:[SPAM]: PDC+LDAP

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

:[SPAM]: PDC+LDAP

Титов Станислав
Уважаемые, помогите решить проблему, настраиваю PDC по следующему
мануалу: http://www.kernel-panic.it/openbsd/pdc/

Проблема следующего характера при добавлении юзера командой:

# smbldap-useradd -a -u 2000 -g 512 -G 513 danix

получаю: /usr/local/sbin/smbldap-useradd: unknown group 512

Команду # smbldap-useradd -a -u 2000 -G 513 danix успешно съедает и
создает пользователя в LDAP.

Принудительно добавить пользователя в группу тоже не даёт:
# smbldap-groupmod -m stans "Domain Admins"
/usr/local/sbin/smbldap-groupmod: group Domain Admins not found!

Хотя такая группа ессно существует:
# smbldap-groupshow Domain\ Admins
dn: cn=Domain Admins,ou=Groups,dc=irk,dc=helios-net,dc=ru
objectClass: top,posixGroup,sambaGroupMapping
gidNumber: 512
cn: Domain Admins
memberUid: root
description: Netbios Domain Administrators
sambaSID: S-1-5-21-1264152437-3322950381-424648354-512
sambaGroupType: 2
displayName: Domain Admins


Почему smbldap-tools так странно себя ведет, где я недоглядел, есть идеи?

PS1: LDAP сконфигурирован без TLS/SSL
PS2: smbldap-populate выполнилось без ошибок, т.е. конфиг скорее всего
верный.

--
С уважением,
Станислав


szh
Reply | Threaded
Open this post in threaded view
|

Re: :[SPAM]: PDC+LDAP

szh
Титов Станислав wrote
Уважаемые, помогите решить проблему, настраиваю PDC по следующему
мануалу: http://www.kernel-panic.it/openbsd/pdc/

Проблема следующего характера при добавлении юзера командой:

# smbldap-useradd -a -u 2000 -g 512 -G 513 danix

получаю: /usr/local/sbin/smbldap-useradd: unknown group 512

Команду # smbldap-useradd -a -u 2000 -G 513 danix успешно съедает и
создает пользователя в LDAP.

Принудительно добавить пользователя в группу тоже не даёт:
# smbldap-groupmod -m stans "Domain Admins"
/usr/local/sbin/smbldap-groupmod: group Domain Admins not found!

Хотя такая группа ессно существует:
# smbldap-groupshow Domain\ Admins
dn: cn=Domain Admins,ou=Groups,dc=irk,dc=helios-net,dc=ru
objectClass: top,posixGroup,sambaGroupMapping
gidNumber: 512
cn: Domain Admins
memberUid: root
description: Netbios Domain Administrators
sambaSID: S-1-5-21-1264152437-3322950381-424648354-512
sambaGroupType: 2
displayName: Domain Admins


Почему smbldap-tools так странно себя ведет, где я недоглядел, есть идеи?

PS1: LDAP сконфигурирован без TLS/SSL
PS2: smbldap-populate выполнилось без ошибок, т.е. конфиг скорее всего
верный.

--
С уважением,
Станислав