SOFTRAID PROBLEM

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

SOFTRAID PROBLEM

laboratory
Hi,
after using some hard-drive with softraid in raid5,
I can no longer reset them. All disks the same problem...
When I try to delete raid partition disklabel reports:
With the command:
disklabel -E wd1, after any changes [ after q option ], return:

disklabel: ioctl DIOCWDINFO open partition would move or shrink
disklabel: unable to write label

--------------------------------------------------------------------------------------

The disks works fine with other operating system [ex. linux[ext4], windows[ntfs]].

The problem is only with OpenBSD [5.3 amd64].

I tried with:
- fdisk -iy wd1;
- dd if=/dev/zero of=/dev/rwd1c bs=1m count=1

but when I launch the command: disklabel wd1
I always find the [a] RAID partition and
and do not remove it and do not delete!!
---------------------------------------------------------------------------------------

How can I delete this partition?

Help me please. Thanks for the help,
Ernest.

[In internet no solution find!]

Reply | Threaded
Open this post in threaded view
|

Re: SOFTRAID PROBLEM

Otto Moerbeek
On Sat, Jun 15, 2013 at 11:46:27PM +0200, [hidden email] wrote:

Please do not post to multiple mailing lists.

        -Otto

> Hi,
> after using some hard-drive with softraid in raid5,
> I can no longer reset them. All disks the same problem...
> When I try to delete raid partition disklabel reports:
> With the command:
> disklabel -E wd1, after any changes [ after q option ], return:
>
> disklabel: ioctl DIOCWDINFO open partition would move or shrink
> disklabel: unable to write label
>
> --------------------------------------------------------------------------------------
>
> The disks works fine with other operating system [ex. linux[ext4], windows[ntfs]].
>
> The problem is only with OpenBSD [5.3 amd64].
>
> I tried with:
> - fdisk -iy wd1;
> - dd if=/dev/zero of=/dev/rwd1c bs=1m count=1
>
> but when I launch the command: disklabel wd1
> I always find the [a] RAID partition and
> and do not remove it and do not delete!!
> ---------------------------------------------------------------------------------------
>
> How can I delete this partition?
>
> Help me please. Thanks for the help,
> Ernest.
>
> [In internet no solution find!]