Retired 4.4-beta

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Retired 4.4-beta

Clint Pachl
I just wanted to share my story ...

I finally retired my old AOpen desktop router which was running 4.4-beta
from July 2008 until now. I originally set it up to test pf and routing
for my company's network. It seemed to work fine so I put it into
production. Then I just kind of forgot about it.

I originally installed an old WD Caviar 3.4 GB drive, which I bought in
bulk, used on Ebay (like 20 drives for $10).

During those 6 years of commission, I only had two hardware failures. I
replaced the old spinning disk, which died a couple years ago, with a
compact flash drive. The power supply fan was also replaced.

Other than taking the machine down for those repairs, it ran 365/24/7.
No crashing. No problems. Just routing/filtering traffic and offering
DHCP leases. Talk about "set it, and for get it!" And that was on a BETA
version.

This machine was replaced with the much smaller, more efficient, and
quieter Lanner FW-7541 with a dual core Atom D525 1.8GHz, 4GB DDR3, and
8GB Transcend SSD. Unlike its predecessor, I plan to upgrade this
machine with every release.

Anyway, I just wanted to share. I also wanted to thank the devs for a
solid OS, time and time again.


OpenBSD 4.4-beta (GENERIC) #979: Wed Jul 16 09:40:32 MDT 2008
     [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel Pentium II ("GenuineIntel" 686-class, 512KB L2 cache) 401 MHz
cpu0:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR
real mem  = 268005376 (255MB)
avail mem = 250929152 (239MB)
mainbus0 at root
bios0 at mainbus0: AT/286+ BIOS, date 07/24/00, BIOS32 rev. 0 @ 0xfb280,
SMBIOS rev. 2.2 @ 0xf0800 (29 entries)
bios0: vendor Award Software International, Inc. version "4.60 PGMA"
date 07/24/00
apm0 at bios0: Power Management spec V1.2 (slowidle)
apm0: AC on, battery charge unknown
acpi at bios0 function 0x0 not configured
pcibios0 at bios0: rev 2.1 @ 0xf0000/0xb6f8
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfdd90/144 (7 entries)
pcibios0: PCI Exclusive IRQs: 10 11 12
pcibios0: PCI Interrupt Router at 000:07:0 ("Intel 82371SB ISA" rev 0x00)
pcibios0: PCI bus #1 is the last bus
bios0: ROM list: 0xc0000/0xc000
cpu0 at mainbus0
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "Intel 82443BX AGP" rev 0x02
ppb0 at pci0 dev 1 function 0 "Intel 82443BX AGP" rev 0x02
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 "Trident 3DImage 9850" rev 0xf3
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
agp0 at vga1: aperture at 0xe5000000, size 0x400000
piixpcib0 at pci0 dev 7 function 0 "Intel 82371AB PIIX4 ISA" rev 0x02
pciide0 at pci0 dev 7 function 1 "Intel 82371AB IDE" rev 0x01: DMA,
channel 0 wired to compatibility, channel 1 wired to compatibility
atapiscsi0 at pciide0 channel 0 drive 1
scsibus0 at atapiscsi0: 2 targets, initiator 7
cd0 at scsibus0 targ 0 lun 0: <ATAPI, CD-ROM DRIVE-36X, 36FP> ATAPI
5/cdrom removable
cd0(pciide0:0:1): using PIO mode 4, Ultra-DMA mode 2
wd0 at pciide0 channel 1 drive 0: <TRANSCEND>
wd0: 1-sector PIO, LBA, 1983MB, 4061232 sectors
wd0(pciide0:1:0): using PIO mode 4, DMA mode 2
uhci0 at pci0 dev 7 function 2 "Intel 82371AB USB" rev 0x01: irq 10
piixpm0 at pci0 dev 7 function 3 "Intel 82371AB Power" rev 0x02: SMI
iic0 at piixpm0
dc0 at pci0 dev 9 function 0 "ADMtek AN983" rev 0x11: irq 10, address
00:04:5a:81:8f:44
ukphy0 at dc0 phy 1: Generic IEEE 802.3u media interface, rev. 1: OUI
0x000749, model 0x0001
dc1 at pci0 dev 10 function 0 "ADMtek AN983" rev 0x11: irq 12, address
00:12:17:52:7a:33
ukphy1 at dc1 phy 1: Generic IEEE 802.3u media interface, rev. 1: OUI
0x000749, model 0x0001
dc2 at pci0 dev 13 function 0 "ADMtek AN983" rev 0x11: irq 10, address
00:03:6d:18:72:e8
acphy0 at dc2 phy 1: AC_UNKNOWN 10/100 PHY, rev. 0
isa0 at piixpcib0
isadma0 at isa0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
com1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
usb0 at uhci0: USB revision 1.0
uhub0 at usb0 "Intel UHCI root hub" rev 1.00/1.00 addr 1
biomask ef65 netmask ff65 ttymask ffff
mtrr: Pentium Pro MTRR support
softraid0 at root
wd0(pciide0:1:0): timeout
        type: ata
        c_bcount: 512
        c_skip: 0
pciide0:1:0: bus-master DMA error: missing interrupt, status=0x21
wd0c: device timeout reading fsbn 0 (wd0 bn 0; cn 0 tn 0 sn 0), retrying
wd0(pciide0:1:0): timeout
        type: ata
        c_bcount: 512
        c_skip: 0
pciide0:1:0: bus-master DMA error: missing interrupt, status=0x21
wd0: transfer error, downgrading to PIO mode 4
wd0(pciide0:1:0): using PIO mode 4
wd0c: device timeout reading fsbn 0 (wd0 bn 0; cn 0 tn 0 sn 0), retrying
wd0: soft error (corrected)
root on wd0a swap on wd0b dump on wd0b
dc2: watchdog timeout
hw.machine=i386
hw.model=Intel Pentium II ("GenuineIntel" 686-class, 512KB L2 cache)
hw.ncpu=1
hw.byteorder=1234
hw.pagesize=4096
hw.disknames=cd0,wd0,fd0
hw.diskcount=3
hw.cpuspeed=401
hw.product=AX6BC
hw.physmem=268005376
hw.usermem=267993088

Reply | Threaded
Open this post in threaded view
|

Re: Retired 4.4-beta

François Chambaud-2
Clint Pachl <[hidden email]> writes:

> I just wanted to share my story ...
>
> I finally retired my old AOpen desktop router which was running
> 4.4-beta from July 2008 until now. I originally set it up to test pf
> and routing for my company's network. It seemed to work fine so I put
> it into production. Then I just kind of forgot about it.
>
> I originally installed an old WD Caviar 3.4 GB drive, which I bought
> in bulk, used on Ebay (like 20 drives for $10).
>
> During those 6 years of commission, I only had two hardware
> failures. I replaced the old spinning disk, which died a couple years
> ago, with a compact flash drive. The power supply fan was also
> replaced.
>
> Other than taking the machine down for those repairs, it ran
> 365/24/7. No crashing. No problems. Just routing/filtering traffic and
> offering DHCP leases. Talk about "set it, and for get it!" And that
> was on a BETA version.
>
> This machine was replaced with the much smaller, more efficient, and
> quieter Lanner FW-7541 with a dual core Atom D525 1.8GHz, 4GB DDR3,
> and 8GB Transcend SSD. Unlike its predecessor, I plan to upgrade this
> machine with every release.
>
> Anyway, I just wanted to share. I also wanted to thank the devs for a
> solid OS, time and time again.
>
>
> OpenBSD 4.4-beta (GENERIC) #979: Wed Jul 16 09:40:32 MDT 2008
>     [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC
> cpu0: Intel Pentium II ("GenuineIntel" 686-class, 512KB L2 cache) 401 MHz
> cpu0:
> FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR
> real mem  = 268005376 (255MB)
> avail mem = 250929152 (239MB)
> mainbus0 at root
> bios0 at mainbus0: AT/286+ BIOS, date 07/24/00, BIOS32 rev. 0 @
> 0xfb280, SMBIOS rev. 2.2 @ 0xf0800 (29 entries)
> bios0: vendor Award Software International, Inc. version "4.60 PGMA"
> date 07/24/00
> apm0 at bios0: Power Management spec V1.2 (slowidle)
> apm0: AC on, battery charge unknown
> acpi at bios0 function 0x0 not configured
> pcibios0 at bios0: rev 2.1 @ 0xf0000/0xb6f8
> pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfdd90/144 (7 entries)
> pcibios0: PCI Exclusive IRQs: 10 11 12
> pcibios0: PCI Interrupt Router at 000:07:0 ("Intel 82371SB ISA" rev 0x00)
> pcibios0: PCI bus #1 is the last bus
> bios0: ROM list: 0xc0000/0xc000
> cpu0 at mainbus0
> pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
> pchb0 at pci0 dev 0 function 0 "Intel 82443BX AGP" rev 0x02
> ppb0 at pci0 dev 1 function 0 "Intel 82443BX AGP" rev 0x02
> pci1 at ppb0 bus 1
> vga1 at pci1 dev 0 function 0 "Trident 3DImage 9850" rev 0xf3
> wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
> wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
> agp0 at vga1: aperture at 0xe5000000, size 0x400000
> piixpcib0 at pci0 dev 7 function 0 "Intel 82371AB PIIX4 ISA" rev 0x02
> pciide0 at pci0 dev 7 function 1 "Intel 82371AB IDE" rev 0x01: DMA,
> channel 0 wired to compatibility, channel 1 wired to compatibility
> atapiscsi0 at pciide0 channel 0 drive 1
> scsibus0 at atapiscsi0: 2 targets, initiator 7
> cd0 at scsibus0 targ 0 lun 0: <ATAPI, CD-ROM DRIVE-36X, 36FP> ATAPI
> 5/cdrom removable
> cd0(pciide0:0:1): using PIO mode 4, Ultra-DMA mode 2
> wd0 at pciide0 channel 1 drive 0: <TRANSCEND>
> wd0: 1-sector PIO, LBA, 1983MB, 4061232 sectors
> wd0(pciide0:1:0): using PIO mode 4, DMA mode 2
> uhci0 at pci0 dev 7 function 2 "Intel 82371AB USB" rev 0x01: irq 10
> piixpm0 at pci0 dev 7 function 3 "Intel 82371AB Power" rev 0x02: SMI
> iic0 at piixpm0
> dc0 at pci0 dev 9 function 0 "ADMtek AN983" rev 0x11: irq 10, address
> 00:04:5a:81:8f:44
> ukphy0 at dc0 phy 1: Generic IEEE 802.3u media interface, rev. 1: OUI
> 0x000749, model 0x0001
> dc1 at pci0 dev 10 function 0 "ADMtek AN983" rev 0x11: irq 12, address
> 00:12:17:52:7a:33
> ukphy1 at dc1 phy 1: Generic IEEE 802.3u media interface, rev. 1: OUI
> 0x000749, model 0x0001
> dc2 at pci0 dev 13 function 0 "ADMtek AN983" rev 0x11: irq 10, address
> 00:03:6d:18:72:e8
> acphy0 at dc2 phy 1: AC_UNKNOWN 10/100 PHY, rev. 0
> isa0 at piixpcib0
> isadma0 at isa0
> com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
> com1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
> pckbc0 at isa0 port 0x60/5
> pckbd0 at pckbc0 (kbd slot)
> pckbc0: using irq 1 for kbd slot
> wskbd0 at pckbd0: console keyboard, using wsdisplay0
> pcppi0 at isa0 port 0x61
> midi0 at pcppi0: <PC speaker>
> spkr0 at pcppi0
> lpt0 at isa0 port 0x378/4 irq 7
> npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
> fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
> fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
> usb0 at uhci0: USB revision 1.0
> uhub0 at usb0 "Intel UHCI root hub" rev 1.00/1.00 addr 1
> biomask ef65 netmask ff65 ttymask ffff
> mtrr: Pentium Pro MTRR support
> softraid0 at root
> wd0(pciide0:1:0): timeout
> type: ata
> c_bcount: 512
> c_skip: 0
> pciide0:1:0: bus-master DMA error: missing interrupt, status=0x21
> wd0c: device timeout reading fsbn 0 (wd0 bn 0; cn 0 tn 0 sn 0), retrying
> wd0(pciide0:1:0): timeout
> type: ata
> c_bcount: 512
> c_skip: 0
> pciide0:1:0: bus-master DMA error: missing interrupt, status=0x21
> wd0: transfer error, downgrading to PIO mode 4
> wd0(pciide0:1:0): using PIO mode 4
> wd0c: device timeout reading fsbn 0 (wd0 bn 0; cn 0 tn 0 sn 0), retrying
> wd0: soft error (corrected)
> root on wd0a swap on wd0b dump on wd0b
> dc2: watchdog timeout
> hw.machine=i386
> hw.model=Intel Pentium II ("GenuineIntel" 686-class, 512KB L2 cache)
> hw.ncpu=1
> hw.byteorder=1234
> hw.pagesize=4096
> hw.disknames=cd0,wd0,fd0
> hw.diskcount=3
> hw.cpuspeed=401
> hw.product=AX6BC
> hw.physmem=268005376
> hw.usermem=267993088
>
>
>

Clint, can you please send to the list a dmesg and sysctl hw of your
Lanner FW-7541?

Thank you in advance.

--
Francois Chambaud
www.chambaud.org