Report - Orange Pi One on -current wrong amount of RAM detected

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Report - Orange Pi One on -current wrong amount of RAM detected

Bodie-3
Hi all,

created image in amd64 -current guest via vnd with:

$ pkg_info -I dtb
dtb-5.7p0           Device Tree Blobs
$

$ ls -l /usr/local/share/dtb/arm/sun8i-h3-orangepi-one.dtb
-rw-r--r--  1 root  bin  22113 Nov 19 01:44
/usr/local/share/dtb/arm/sun8i-h3-orangepi-one.dtb
$

$ pkg_info -I u-boot-arm
u-boot-arm-2020.10  U-Boot firmware
$

$ ls -l /usr/local/share/u-boot/orangepi_one/u-boot-sunxi-with-spl.bin
-rw-r--r--  1 root  bin  487973 Nov 19 01:20
/usr/local/share/u-boot/orangepi_one/u-boot-sunxi-with-spl.bin
$


Device is having 512MB RAM and eg. NetBSD 9.1 -stable was showing about
491MB in dmesg output (however does not have it currently at hand). Is
there anything I can try to see why lower amount of memory is detected?

$ more /var/run/dmesg.boot
OpenBSD 6.8-current (GENERIC) #348: Thu Nov 19 10:21:20 MST 2020
     [hidden email]:/usr/src/sys/arch/armv7/compile/GENERIC
real mem  = 410443776 (391MB)
avail mem = 391720960 (373MB)
random: good seed from bootblocks
mainbus0 at root: Xunlong Orange Pi One
cpu0 at mainbus0 mpidr 0: ARM Cortex-A7 r0p5
cpu0: 32KB 32b/line 2-way L1 VIPT I-cache, 32KB 64b/line 4-way L1
D-cache
cpu0: 512KB 64b/line 8-way L2 cache
cortex0 at mainbus0
psci0 at mainbus0: PSCI 0.0
sxiccmu0 at mainbus0
simplebus0 at mainbus0: "soc"
sxisid0 at simplebus0
sxiccmu1 at simplebus0
sxipio0 at simplebus0: 94 pins
ampintc0 at simplebus0 nirq 160, ncpu 4: "interrupt-controller"
sxirtc0 at simplebus0
sxiccmu2 at simplebus0
sxipio1 at simplebus0: 12 pins
sxisyscon0 at simplebus0
"clock" at simplebus0 not configured
"mixer" at simplebus0 not configured
"dma-controller" at simplebus0 not configured
"lcd-controller" at simplebus0 not configured
sximmc0 at simplebus0
sdmmc0 at sximmc0: 4-bit, sd high-speed, mmc high-speed, dma
"usb" at simplebus0 not configured
"phy" at simplebus0 not configured
ehci0 at simplebus0
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 configuration 1 interface 0 "Generic EHCI root hub" rev
2.00/1.00 addr 1
ohci0 at simplebus0: version 1.0
ehci1 at simplebus0
usb1 at ehci1: USB revision 2.0
uhub1 at usb1 configuration 1 interface 0 "Generic EHCI root hub" rev
2.00/1.00 addr 1
ohci1 at simplebus0: version 1.0
"timer" at simplebus0 not configured
dwxe0 at simplebus0: address XX:XX:XX:XX:XX:XX
ukphy0 at dwxe0 phy 1: Generic IEEE 802.3u media interface, rev. 0: OUI
0x001105, model 0x0000
"dram-controller" at simplebus0 not configured
sxidog0 at simplebus0
com0 at simplebus0: ns16550, no working fifo
com0: console
"hdmi" at simplebus0 not configured
"hdmi-phy" at simplebus0 not configured
"codec-analog" at simplebus0 not configured
"deinterlace" at simplebus0 not configured
"video-codec" at simplebus0 not configured
"crypto" at simplebus0 not configured
"gpu" at simplebus0 not configured
sxitemp0 at simplebus0
gpio0 at sxipio0: 32 pins
gpio1 at sxipio0: 32 pins
gpio2 at sxipio0: 32 pins
gpio3 at sxipio0: 32 pins
gpio4 at sxipio0: 32 pins
gpio5 at sxipio0: 32 pins
gpio6 at sxipio0: 32 pins
gpio7 at sxipio1: 32 pins
usb2 at ohci0: USB revision 1.0
uhub2 at usb2 configuration 1 interface 0 "Generic OHCI root hub" rev
1.00/1.00 addr 1
usb3 at ohci1: USB revision 1.0
uhub3 at usb3 configuration 1 interface 0 "Generic OHCI root hub" rev
1.00/1.00 addr 1
agtimer0 at mainbus0: tick rate 24000 KHz
scsibus0 at sdmmc0: 2 targets, initiator 0
sd0 at scsibus0 targ 1 lun 0: <SD/MMC, SD16G, 0020> removable
sd0: 30510MB, 512 bytes/sector, 62484480 sectors
vscsi0 at root
scsibus1 at vscsi0: 256 targets
softraid0 at root
scsibus2 at softraid0: 256 targets
bootfile: sd0a:/bsd
boot device: sd0
root on sd0a (dc5360811690d318.a) swap on sd0b dump on sd0b
cpu0: DVFS failed
$