Remove utop port -- let opam handle it

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Remove utop port -- let opam handle it

kwesterback
utop is the enhanced command line for ocaml. It is used to develop
ocaml programs and maintaining a port is both effortful and likely to be
little used once people encounter opam, where it is actively maintained
with all of its dependencies and the many nifty libraries ocaml
programmers might want to use while hacking ocaml.

So remove our separate port and use the efforts of the opam maintainers
instead.

When I look at ocaml ports that *only* appear as dependencies of utop I
find

devel/utop 1.19.1/1.19.3/1.19.3
devel/ocaml-lambda-term 1.9/1.10.1/1.10.1
        devel/ocaml-lwt 2.5.2/2.7.0/2.7.0
                devel/ocaml-react 1.2.0/1.2.0/1.2.0
                textproc/ocaml-text 0.6/0.8.0/0.8.0
                security/ocaml-ssl 0.5.2/0.5.3/0.5.3
                devel/ocaml-ppx-tools 4.03.0/4.03.0/4.03.0
        devel/ocaml-zed 1.4/1.4/1.4

i.e. only ocaml-lambda-term. In its dependency list lwt and zed appear
only there and no where else in the ports tree. And drilling down one
more, react, text, ssl and ppx-tools appear only in the dependency
list of lwt.

The numbers represent our port version/the latest upstream/version in
opam.

So I propose to delete the 8 ports. As also suggested by chrisz@ and
avsm@.

Thoughts? OK?

.... Ken