Remove Puppet 4

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Remove Puppet 4

Klemens Nanni-2
Long past EOL according to upstream[0], Puppet 5 is in the tree and
should be used while Puppet 6 out long already but only now about to hit
around our tree.

Anyone still using Puppet 4?  Why?
Upgrading will require manual work for the Puppet configuration, so I
see no sensible way in providing an upgrade path.

0: https://puppet.com/docs/pe/2017.3/component_versions_in_recent_pe_releases.html

Feedback? OK?

Reply | Threaded
Open this post in threaded view
|

Re: Remove Puppet 4

Klemens Nanni-2
On Sun, May 17, 2020 at 03:16:05PM +0200, Klemens Nanni wrote:

> Long past EOL according to upstream[0], Puppet 5 is in the tree and
> should be used while Puppet 6 out long already but only now about to hit
> around our tree.
>
> Anyone still using Puppet 4?  Why?
> Upgrading will require manual work for the Puppet configuration, so I
> see no sensible way in providing an upgrade path.
>
> 0: https://puppet.com/docs/pe/2017.3/component_versions_in_recent_pe_releases.html
>
> Feedback? OK?
Anyone?

Now that Puppet 6 is in the tree and working fine so far, version 4 has
no real reason to be packaged and/or used.