Re: SMP on Proliant 800

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: SMP on Proliant 800

Steven Shockley
(Redirecting to misc@, since I think the smp@ list is mostly dead.)

Marco Derix wrote:
> I'm running the latest bios from HP/Compaq available for my system
> (Compaq Proliant 800 (P2) V4.08a dated 4/19/2000). I also tried the
> system configuration utility, but there was nothing I could configure
> regarding SMP.

If there's an option in the configuration utility, try changing the
"installed OS" option.  I haven't used a Proliant 800 (or a PPro
machine, for that matter) but I've had the best luck using "Unix large
disk" or similar.  You may need to download a newer version of the
config utility, the SmartStart 5.5 CD should work on your machine (6.x
and 7.x won't).

Reply | Threaded
Open this post in threaded view
|

Re: SMP on Proliant 800

Marco Derix
On Fri, 31 Mar 2006 22:39:58 -0500, Steve Shockley wrote

> (Redirecting to misc@, since I think the smp@ list is mostly
> dead.)
>
> Marco Derix wrote:
> > I'm running the latest bios from HP/Compaq available for my system
> > (Compaq Proliant 800 (P2) V4.08a dated 4/19/2000). I also tried the
> > system configuration utility, but there was nothing I could configure
> > regarding SMP.
>
> If there's an option in the configuration utility, try
> changing the "installed OS" option.  I haven't used a Proliant
> 800 (or a PPro machine, for that matter) but I've had the best
> luck using "Unix large disk" or similar.  You may need to
> download a newer version of the config utility, the SmartStart
> 5.5 CD should work on your machine (6.x and 7.x won't).

that was it! It had it configured to UNIX (which seemed logical at the
time), but switched it to Windows 2000 (because SMP should work on
Win2K). And indeed, all of a sudden I have 2 CPU's.

Thanks a lot for your time, you've been a great help !

regards

Marco

(updated dmesg)
# dmesg
OpenBSD 3.8 (GENERIC.MP) #298: Sat Sep 10 15:51:54 MDT 2005
    [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC.MP
cpu0: Intel Pentium Pro ("GenuineIntel" 686-class, 256KB L2 cache) 199 MHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV
real mem  = 200908800 (196200K)
avail mem = 176398336 (172264K)
using 2478 buffers containing 10149888 bytes (9912K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(00) BIOS, date 12/31/99, BIOS32 rev. 0 @ 0xf0000
pcibios0 at bios0: rev 2.1 @ 0xf0000/0x2000
pcibios0: PCI BIOS has 7 Interrupt Routing table entries
pcibios0: PCI Interrupt Router at 000:20:0 ("Intel 82371SB ISA" rev 0x00)
pcibios0: PCI bus #1 is the last bus
bios0: ROM list: 0xc0000/0x8000 0xe8000/0x6000 0xee000/0x2000!
mainbus0: Intel MP Specification (Version 1.4) (COMPAQ   PROLIANT    )
cpu0 at mainbus0: apid 1 (boot processor)
cpu0: apic clock running at 66 MHz
cpu1 at mainbus0: apid 0 (application processor)
cpu1: Intel Pentium Pro ("GenuineIntel" 686-class, 256KB L2 cache) 199 MHz
cpu1: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV
mainbus0: bus 0 is type PCI
mainbus0: bus 1 is type PCI
mainbus0: bus 9 is type ISA
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 11, 24 pins
ioapic0: misconfigured as apic 0, remapped to apic 2
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "Intel 82441FX" rev 0x02
ppb0 at pci0 dev 8 function 0 "IBM 82351 PCI-PCI" rev 0x01
pci1 at ppb0 bus 1
siop0 at pci1 dev 4 function 0 "Symbios Logic 53c875" rev 0x04: apic 2
int 17 (i                                                              
                                                       rq 9), using 4K
of on-board RAM
scsibus0 at siop0: 16 targets
sd0 at scsibus0 targ 0 lun 0: <QUANTUM, XP39100W, LYK8> SCSI2 0/direct fixed
sd0: 8682MB, 5899 cyl, 20 head, 150 sec, 512 bytes/sec, 17781520 sec total
st0 at scsibus0 targ 2 lun 0: <ARCHIVE, 4326XX 27871-XXX, 0324> SCSI2
1/sequenti                                                            
                                                        al removable
st0: drive empty or not ready
tl0 at pci1 dev 8 function 0 "Compaq Netelligent 10/100TX" rev 0x10:
apic 2 int                                                            
                                                         17 (irq 9)
address 00:08:c7:1e:12:a9
nsphy0 at tl0 phy 1: DP83840 10/100 PHY, rev. 1
ukphy0 at tl0 phy 31: Generic IEEE 802.3u media interface
ukphy0: OUI 0x100014, model 0x0001, rev. 5
vga1 at pci1 dev 9 function 0 "Cirrus Logic CL-GD5446" rev 0x00
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
tl1 at pci0 dev 16 function 0 "Compaq Integrated NetFlex 3/P" rev 0x10:
apic 2 i                                                              
                                                      nt 16 (irq 5)
address 00:80:5f:ad:e3:ce
ukphy1 at tl1 phy 31: Generic IEEE 802.3u media interface
ukphy1: OUI 0x100014, model 0x0001, rev. 5
pcib0 at pci0 dev 20 function 0 "Intel 82371SB ISA" rev 0x01
pciide0 at pci0 dev 20 function 1 "Intel 82371SB IDE" rev 0x00: DMA,
channel 0 w                                                            
                                                         ired to
compatibility, channel 1 wired to compatibility
wd0 at pciide0 channel 0 drive 0: <WDC WD2000JB-55GVA0>
wd0: 16-sector PIO, LBA48, 190782MB, 390721968 sectors
wd0(pciide0:0:0): using PIO mode 4, DMA mode 2
pciide0: channel 1 ignored (disabled)
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
sysbeep0 at pcppi0
lpt2 at isa0 port 0x3bc/4: polled
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask 0 netmask 0 ttymask 0
ioapic0: pin 17 shares different IPL interrupts (40..50), degraded
performance
pctr: 686-class user-level performance counters enabled
mtrr: Pentium Pro MTRR support
siop0: target 0 now using tagged 16 bit 20.0 MHz 16 REQ/ACK offset xfers
root on sd0a
rootdev=0x400 rrootdev=0xd00 rawdev=0xd02
------- End of Forwarded Message -------