Re: OpenBSD: problem with installing XFCE

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: OpenBSD: problem with installing XFCE

Landry Breuil-5
On Wed, Mar 27, 2019 at 01:17:40PM +0000, Brian Kelk wrote:
> Hi.
>
> This is about OpenBSD 6.4 on powerpc. When I try to install xfce it all proceeds
> ok except that it says it can't find xfce-terminal and tumbler.

vte3 (a dependency of xfce4-terminal) is broken on macppc since a whilei (cf
http://build-failures.rhaalovely.net/powerpc/2019-02-04/devel/vte3.log)
and nobody was bothered enough to look. Will probably be the same in
6.5.

Landry

Reply | Threaded
Open this post in threaded view
|

Re: OpenBSD: problem with installing XFCE

George Koehler-2
Cc maintainers of devel/vte3.  I attach a diff that allows amd64 to
build and package vte3 with COMPILER=ports-gcc.

On Thu, 28 Mar 2019 08:08:12 +0100
Landry Breuil <[hidden email]> wrote:

> vte3 (a dependency of xfce4-terminal) is broken on macppc since a whilei (cf
> http://build-failures.rhaalovely.net/powerpc/2019-02-04/devel/vte3.log)
> and nobody was bothered enough to look. Will probably be the same in
> 6.5.

vte3-0.54.3 in OpenBSD-current requires a C++14 compiler.  macppc
doesn't have base-clang and uses ports-gcc 4.9, but 4.9 is too old
and fails the C++14 check.

My macppc machine (a PowerBook G4) is using ports-gcc 8.3 instead of
the default 4.9.  This machine built vte3 with gcc 8.3 and now has a
working xfce4-terminal; but gcc 8.3 conflicts with gcc 4.9, and
snapshot packages need 4.9, so you can't build vte3 with 8.3 while
you are using snapshot packages.  (I would like OpenBSD to move the
default to ports-gcc>=8, but gcc 8 breaks some packages.)

I now attach a diff to build vte3 with 4.9.  This diff is for
OpenBSD-current, not for OpenBSD 6.4.  This diff disables the C++14
check and changes some C++ code to prevent errors from gcc.  I have
only built this patch in my amd64 vm (using COMPILER=ports-gcc to
switch away from the default base-clang), and I didn't try to run it,
because this vm has packages built with base-clang, and programs tend
to crash when they use libc++ from base-clang and libestdc++ from
ports-gcc at the same time.

--
George Koehler <[hidden email]>

vte3-gcc49.diff (12K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: OpenBSD: problem with installing XFCE

Stuart Henderson
On 2019/03/31 00:51, George Koehler wrote:
>                                   (I would like OpenBSD to move the
> default to ports-gcc>=8, but gcc 8 breaks some packages.)

Do you have a list?

General thinking is to move to newer ports-gcc after unlock.

Reply | Threaded
Open this post in threaded view
|

Re: OpenBSD: problem with installing XFCE

Jeremie Courreges-Anglas-2
In reply to this post by George Koehler-2
On Sun, Mar 31 2019, George Koehler <[hidden email]> wrote:

> Cc maintainers of devel/vte3.  I attach a diff that allows amd64 to
> build and package vte3 with COMPILER=ports-gcc.
>
> On Thu, 28 Mar 2019 08:08:12 +0100
> Landry Breuil <[hidden email]> wrote:
>
>> vte3 (a dependency of xfce4-terminal) is broken on macppc since a whilei (cf
>> http://build-failures.rhaalovely.net/powerpc/2019-02-04/devel/vte3.log)
>> and nobody was bothered enough to look. Will probably be the same in
>> 6.5.
>
> vte3-0.54.3 in OpenBSD-current requires a C++14 compiler.  macppc
> doesn't have base-clang and uses ports-gcc 4.9, but 4.9 is too old
> and fails the C++14 check.
>
> My macppc machine (a PowerBook G4) is using ports-gcc 8.3 instead of
> the default 4.9.  This machine built vte3 with gcc 8.3 and now has a
> working xfce4-terminal; but gcc 8.3 conflicts with gcc 4.9, and
> snapshot packages need 4.9, so you can't build vte3 with 8.3 while
> you are using snapshot packages.  (I would like OpenBSD to move the
> default to ports-gcc>=8, but gcc 8 breaks some packages.)
>
> I now attach a diff to build vte3 with 4.9.  This diff is for
> OpenBSD-current, not for OpenBSD 6.4.  This diff disables the C++14
> check and changes some C++ code to prevent errors from gcc.  I have
> only built this patch in my amd64 vm (using COMPILER=ports-gcc to
> switch away from the default base-clang), and I didn't try to run it,
> because this vm has packages built with base-clang, and programs tend
> to crash when they use libc++ from base-clang and libestdc++ from
> ports-gcc at the same time.

Thanks for your work on this.  No strong objection, but I feel like the
resulting diff is too intrusive for my taste.

My two cents,
--
jca | PGP : 0x1524E7EE / 5135 92C1 AD36 5293 2BDF  DDCC 0DFA 74AE 1524 E7EE

Reply | Threaded
Open this post in threaded view
|

Re: OpenBSD: problem with installing XFCE

George Koehler-2
In reply to this post by Stuart Henderson
On Sun, 31 Mar 2019 11:02:50 +0100
Stuart Henderson <[hidden email]> wrote:

> On 2019/03/31 00:51, George Koehler wrote:
> >                                   (I would like OpenBSD to move the
> > default to ports-gcc>=8, but gcc 8 breaks some packages.)
>
> Do you have a list?

I only know that gcc 8 breaks 2 ports: x11/qt4, games/stone-soup

My diff at https://marc.info/?l=openbsd-ports&m=154887662015606&w=2
allows gcc 8 to build and package qt4.  This unblocks math/eigen3.

I don't have a fix for stone-soup, but it is an old version, so an
update might fix it.  I haven't tried to update stone-soup.

I know that gcc 8 unbreaks devel/vte3, and suspect that it might
unbreak games/supertux.  I haven't tried to build supertux.

--
George Koehler <[hidden email]>

Reply | Threaded
Open this post in threaded view
|

Re: OpenBSD: problem with installing XFCE

Stuart Henderson
On 2019/04/02 14:41, George Koehler wrote:

> On Sun, 31 Mar 2019 11:02:50 +0100
> Stuart Henderson <[hidden email]> wrote:
>
> > On 2019/03/31 00:51, George Koehler wrote:
> > >                                   (I would like OpenBSD to move the
> > > default to ports-gcc>=8, but gcc 8 breaks some packages.)
> >
> > Do you have a list?
>
> I only know that gcc 8 breaks 2 ports: x11/qt4, games/stone-soup
>
> My diff at https://marc.info/?l=openbsd-ports&m=154887662015606&w=2
> allows gcc 8 to build and package qt4.  This unblocks math/eigen3.

Thanks, seen that - also cwen@ has an alternative diff for qt4 (using
c++11 only for the file/s that need it, not saying that yours is wrong
but hers is simpler).

> I don't have a fix for stone-soup, but it is an old version, so an
> update might fix it.  I haven't tried to update stone-soup.
>
> I know that gcc 8 unbreaks devel/vte3, and suspect that it might
> unbreak games/supertux.  I haven't tried to build supertux.

I've seen enough reasons to want to switch to gcc 8, mostly trying to
ascertain how much carnage it will cause for packages on !clang arches
now :)