Re: Affichage de pages web avec caracteres accentués

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: Affichage de pages web avec caracteres accentués

Mik J
> De : Remi Pointel <[hidden email]>

> À : [hidden email]
>
> Le 2012-09-24 16:45, Mik J a écrit :
>>  Bonjour à tous,
>>
>>  J'ai installé une application codée en php mais les mots avec accents
>>  s'affichent mal: fenêtre => fen^etre, schémas => sch'emas
>>
>>  Dans ma configuration Apache j'ai
>>  AddDefaultCharset ISO-8859-15
>>
>>  Quelqu'un m'a suggéré de vérifier que la locale fr_FR.UTF-8 est
> bien
>>  disponible pour Apache, mais je n'ai pas vraiment compris comment
>>  vérifier ca même après avoir consulté les moteurs de recherche.
>>
>>
>>  Par contre j'ai d'autres pages qui sont bien accentuées.
>>
>>  Est-ce que quelqu'un aurait une idée sur la question ?
>>
>>  Bonne journée
>
> Salut,
>
> il faut que tu remplaces ton AddDefaultCharset par celui-ci :
>
> AddDefaultCharset utf-8

Merci Remi,
J'avais bien essayé cela mais ca ne fonctionne pas non plus.
J'ai activé le mode debug sur cette application php et elle affiche " Setting language to: 'fr_FR.UTF-8' " suite à cet modification mais les caractères accentués posent toujours problème.
> Tu redémarres Apache et ça devrait être bon.
>
> Bonne journée,
>
> Rémi.
>

________________________________
French OpenBSD mailing list
[hidden email]
http://www.openbsd-france.org/communaute.php

Reply | Threaded
Open this post in threaded view
|

Re: Affichage de pages web avec caracteres accentués

michael chlon
Bonjour,

Personnellement, je redirigerai le flux que ton apli sort dans un
fichier, et
je l'éditerai, histoire de voir s'il n'y pas de caractères "à la con" et
qui
serai donc mal interprétés par ton navigateur.
Si ça marche uniquement avec ton appli, je crois
qu'il faut plutôt regardé le code de l'appli et non pas les
options de configuration su système ou de php.

Rgds,
Bon courage,
Michaël C.



Le 24/09/2012 16:57, Mik J a écrit :

>> De : Remi Pointel <[hidden email]>
>> À : [hidden email]
>>
>> Le 2012-09-24 16:45, Mik J a écrit :
>>>  Bonjour à tous,
>>>
>>>  J'ai installé une application codée en php mais les mots avec accents
>>>  s'affichent mal: fenêtre => fen^etre, schémas => sch'emas
>>>
>>>  Dans ma configuration Apache j'ai
>>>  AddDefaultCharset ISO-8859-15
>>>
>>>  Quelqu'un m'a suggéré de vérifier que la locale fr_FR.UTF-8 est
>> bien
>>>  disponible pour Apache, mais je n'ai pas vraiment compris comment
>>>  vérifier ca même après avoir consulté les moteurs de recherche.
>>>
>>>
>>>  Par contre j'ai d'autres pages qui sont bien accentuées.
>>>
>>>  Est-ce que quelqu'un aurait une idée sur la question ?
>>>
>>>  Bonne journée
>> Salut,
>>
>> il faut que tu remplaces ton AddDefaultCharset par celui-ci :
>>
>> AddDefaultCharset utf-8
> Merci Remi,
> J'avais bien essayé cela mais ca ne fonctionne pas non plus.
> J'ai activé le mode debug sur cette application php et elle affiche " Setting language to: 'fr_FR.UTF-8' " suite à cet modification mais les caractères accentués posent toujours problème.
>> Tu redémarres Apache et ça devrait être bon.
>>
>> Bonne journée,
>>
>> Rémi.
>>
> ________________________________
> French OpenBSD mailing list
> [hidden email]
> http://www.openbsd-france.org/communaute.php
>


*Michaël Chlon* |/[hidden email]/

My profiles: LinkedIn
<http://Type%20your%20personal%20details%20here.%20Click%20on%20Templates%20for%20a%20quick%20start%21>
Want a signature like mine?
<http://r1.wisestamp.com/r/landing?promo=22&dest=http%3A%2F%2Fwww.wisestamp.com%2Femail-install%3Futm_source%3Dextension%26utm_medium%3Demail%26utm_campaign%3Dpromo_22>
Click here.
<http://r1.wisestamp.com/r/landing?promo=22&dest=http%3A%2F%2Fwww.wisestamp.com%2Femail-install%3Futm_source%3Dextension%26utm_medium%3Demail%26utm_campaign%3Dpromo_22>