Question to anyone with bwi(4)

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Question to anyone with bwi(4)

Ivan Arsenyev
Hi there. Is here anyone with Apple AirPort Extreme Card (integrated
with iBooks/PowerBooks) using bwi driver? I want to listen user's
experience point.
Because for me it's work badly, i mean it's works normally only while
very close to
AP (nor more than 2-3 meters). If it's far, than it isn't connect to any
IP's (including
internal). AP is ok, it's works good with other machines at hall.
AirPort Card work
well with this AP in Mac OS X.
And if can't connect to any IP nearly point, only re-running of DHCP
help. Manual
assigning of machine's adress works pretty bad.
There is nothing interesting with debug option i think, just no DS/OFDM
tssi from
time to time.

Anyone with problems? I'm interesting is this problem of driver or
problem on
specific machine.

Reply | Threaded
Open this post in threaded view
|

Re: Question to anyone with bwi(4)

Jonathan Gray
On Thu, Sep 11, 2008 at 12:09:41AM +0400, Ivan Arsenyev wrote:

> Hi there. Is here anyone with Apple AirPort Extreme Card (integrated
> with iBooks/PowerBooks) using bwi driver? I want to listen user's  
> experience point.
> Because for me it's work badly, i mean it's works normally only while  
> very close to
> AP (nor more than 2-3 meters). If it's far, than it isn't connect to any  
> IP's (including
> internal). AP is ok, it's works good with other machines at hall.  
> AirPort Card work
> well with this AP in Mac OS X.
> And if can't connect to any IP nearly point, only re-running of DHCP  
> help. Manual
> assigning of machine's adress works pretty bad.
> There is nothing interesting with debug option i think, just no DS/OFDM  
> tssi from
> time to time.
>
> Anyone with problems? I'm interesting is this problem of driver or  
> problem on
> specific machine.

It is some kind of driver problem that a lot of people seem
to be hitting.  Likely something isn't callibrated/setup properly.

Reply | Threaded
Open this post in threaded view
|

Re: Question to anyone with bwi(4)

patrick keshishian
In reply to this post by Ivan Arsenyev
On Wed, Sep 10, 2008 at 1:09 PM, Ivan Arsenyev
<[hidden email]> wrote:

> Hi there. Is here anyone with Apple AirPort Extreme Card (integrated
> with iBooks/PowerBooks) using bwi driver? I want to listen user's experience
> point.
> Because for me it's work badly, i mean it's works normally only while very
> close to
> AP (nor more than 2-3 meters). If it's far, than it isn't connect to any
> IP's (including
> internal). AP is ok, it's works good with other machines at hall. AirPort
> Card work
> well with this AP in Mac OS X.
> And if can't connect to any IP nearly point, only re-running of DHCP help.
> Manual
> assigning of machine's adress works pretty bad.
> There is nothing interesting with debug option i think, just no DS/OFDM tssi
> from
> time to time.
>
> Anyone with problems? I'm interesting is this problem of driver or problem
> on
> specific machine.


I use it w/my ibook g4. It had been OK for me with a May 2008
snapshot. The snapshot I have on there now is from Aug 24 and
its performance has been pretty bad. I've not diagnosed it much
so I can't comment on it nor post a problem report. I do seem
to experience quite a bit of packet loss with it though.

I plan to update to a more recent snapshot soon.

--patrick

Reply | Threaded
Open this post in threaded view
|

Re: Question to anyone with bwi(4)

Vitaliy Kulchevych
In reply to this post by Ivan Arsenyev
On Wed, Sep 10, 2008 at 8:09 PM, Ivan Arsenyev
<[hidden email]> wrote:

> Hi there. Is here anyone with Apple AirPort Extreme Card (integrated
> with iBooks/PowerBooks) using bwi driver? I want to listen user's experience
> point.
> Because for me it's work badly, i mean it's works normally only while very
> close to
> AP (nor more than 2-3 meters). If it's far, than it isn't connect to any
> IP's (including
> internal). AP is ok, it's works good with other machines at hall. AirPort
> Card work
> well with this AP in Mac OS X.
> And if can't connect to any IP nearly point, only re-running of DHCP help.
> Manual
> assigning of machine's adress works pretty bad.
> There is nothing interesting with debug option i think, just no DS/OFDM tssi
> from
> time to time.
>
> Anyone with problems? I'm interesting is this problem of driver or problem
> on
> specific machine.

I have some problem on my IBMT30 with pcmcia linksys wpc54g. This
adapter has bwi driver also.
This problem has appeared on a 4.4-snapshots. (june-july)

Speed of communication in the beginning of downloading ~ 30Kb/s,
during 20 seconds falls up to several bytes a second and absolutely
stops

Now I live on kernel from 4.3 and userland from 4.4-snapshots.
I do not have other choice.

P.S. Ivan, do you speak russian?


--
Yours faithfully,
Vitaliy Kulchevych

Reply | Threaded
Open this post in threaded view
|

Re: Question to anyone with bwi(4)

Ivan Arsenyev
> I have some problem on my IBMT30 with pcmcia linksys wpc54g. This
> adapter has bwi driver also.
> This problem has appeared on a 4.4-snapshots. (june-july)
>
> Speed of communication in the beginning of downloading ~ 30Kb/s,
> during 20 seconds falls up to several bytes a second and absolutely
> stops
>
> Now I live on kernel from 4.3 and userland from 4.4-snapshots.
> I do not have other choice.

If it's driver-specific problem only, than it's better to ident revision
of bwi.c,
that works for most people, maybe it's just a bogus commit. As i remember
on my machine it was broken since first appeared.
That's not only problem of bwi, such things usually happend with other
undocumented or badly documented proprietary things.
For PPC, i saw few times things that worked on most of supported hardware
and didn't work on separately taken model.
For x86 situation is much better due availability of hardware.