Problème de débutant avec pf.conf pour le NAT

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Problème de débutant avec pf.conf pour le NAT

Julien Cabillot
Bonsoir,
j'ai un petit soucis avec ma configuration de pf.conf, j'ai un réseau
qui ressemble à ça (je sais c'est tordu :)):

(internet) | (192.168.0.254) ---------- (192.168.0.3) | (192.168.1.1)
--------------- (192.168.1.0/24)
En premier se trouve un modem routeur (Freebox) puis viens la machine
sous OpenBSD puis mon réseau.
J'ai configuré mes machines du reseau 192.168.1.0 pour qu'elles
passent par la passerelle 192.168.1.1 et j'ai configuré
mon pf.conf comme telle:
<vide>
nat on rl0 from 192.168.1.0/24 to any -> rl0
<vide>
(rl0 a pour ip 192.168.0.3)
Et pourtant impossible ensuite d'arriver à passer la passerelle à
partir du dernier réseau:
ping 192.168.1.1 ne passe plus comme tout les ip qui se trouvent avant.

Voila, je n'arrive pas à voir d'où viens le problème,
si vous avez une idée je suis preneur....

merci

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Problème de débutant avec pf.conf pour le NAT

Christophe Lucas-2
Julien Cabillot ([hidden email]) wrote:

> Bonsoir,
> j'ai un petit soucis avec ma configuration de pf.conf, j'ai un réseau
> qui ressemble à ça (je sais c'est tordu :)):
>
> (internet) | (192.168.0.254) ---------- (192.168.0.3) | (192.168.1.1)
> --------------- (192.168.1.0/24)
> En premier se trouve un modem routeur (Freebox) puis viens la machine
> sous OpenBSD puis mon réseau.
> J'ai configuré mes machines du reseau 192.168.1.0 pour qu'elles
> passent par la passerelle 192.168.1.1 et j'ai configuré
> mon pf.conf comme telle:
> <vide>
> nat on rl0 from 192.168.1.0/24 to any -> rl0
> <vide>
> (rl0 a pour ip 192.168.0.3)
> Et pourtant impossible ensuite d'arriver à passer la passerelle à
> partir du dernier réseau:
> ping 192.168.1.1 ne passe plus comme tout les ip qui se trouvent avant.
>
> Voila, je n'arrive pas à voir d'où viens le problème,
> si vous avez une idée je suis preneur....
>
> merci

Tu trouveras sans doute ton bonheur dans :

        http://www.openbsd-france.org/documentations/OpenBSD-passerelle.html

Pourquoi un problème de sysctl ;)

        net.inet.ip.forwarding=1 dans /etc/sysctl.conf

qui est de base commenté.
 
                        ~Christophe


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Problème de débutant avec pf.conf pour le NAT

Julien Cabillot
Malheuresement non j'avais déja modifié ceci.
Par contre je me rends compte que j'avais oublié de préciser qque
chose avant mon routeur OpenBSD il y a ma freebox elle aussi en
routeur avec comme ip 192.168.0.254 mais j'ai bien spécifié sur
OpenBSD dans mygateway d'utiliser cette gateway (pas de soucis pour se
connecter au web à partir de ce pc d'ailleurs).

On 1/16/06, Christophe Lucas <[hidden email]> wrote:

> Julien Cabillot ([hidden email]) wrote:
> > Bonsoir,
> > j'ai un petit soucis avec ma configuration de pf.conf, j'ai un réseau
> > qui ressemble à ça (je sais c'est tordu :)):
> >
> > (internet) | (192.168.0.254) ---------- (192.168.0.3) | (192.168.1.1)
> > --------------- (192.168.1.0/24)
> > En premier se trouve un modem routeur (Freebox) puis viens la machine
> > sous OpenBSD puis mon réseau.
> > J'ai configuré mes machines du reseau 192.168.1.0 pour qu'elles
> > passent par la passerelle 192.168.1.1 et j'ai configuré
> > mon pf.conf comme telle:
> > <vide>
> > nat on rl0 from 192.168.1.0/24 to any -> rl0
> > <vide>
> > (rl0 a pour ip 192.168.0.3)
> > Et pourtant impossible ensuite d'arriver à passer la passerelle à
> > partir du dernier réseau:
> > ping 192.168.1.1 ne passe plus comme tout les ip qui se trouvent avant.
> >
> > Voila, je n'arrive pas à voir d'où viens le problème,
> > si vous avez une idée je suis preneur....
> >
> > merci
>
> Tu trouveras sans doute ton bonheur dans :
>
>         http://www.openbsd-france.org/documentations/OpenBSD-passerelle.html
>
> Pourquoi un problème de sysctl ;)
>
>         net.inet.ip.forwarding=1 dans /etc/sysctl.conf
>
> qui est de base commenté.
>
>                         ~Christophe
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Problème de débutant avec pf.conf pour le NAT

Julien Cabillot
In reply to this post by Christophe Lucas-2
Je viens de me rendre compte de quelque chose d'étrange:
en mettant uniquement pass all dans /etc/pf.conf
je n'arrive plus à pinguer OpenBSD sur son interface vers le reseau
interne alors que de l'autre coté il n'y a pas de soucis ...

On 1/16/06, Christophe Lucas <[hidden email]> wrote:

> Julien Cabillot ([hidden email]) wrote:
> > Bonsoir,
> > j'ai un petit soucis avec ma configuration de pf.conf, j'ai un réseau
> > qui ressemble à ça (je sais c'est tordu :)):
> >
> > (internet) | (192.168.0.254) ---------- (192.168.0.3) | (192.168.1.1)
> > --------------- (192.168.1.0/24)
> > En premier se trouve un modem routeur (Freebox) puis viens la machine
> > sous OpenBSD puis mon réseau.
> > J'ai configuré mes machines du reseau 192.168.1.0 pour qu'elles
> > passent par la passerelle 192.168.1.1 et j'ai configuré
> > mon pf.conf comme telle:
> > <vide>
> > nat on rl0 from 192.168.1.0/24 to any -> rl0
> > <vide>
> > (rl0 a pour ip 192.168.0.3)
> > Et pourtant impossible ensuite d'arriver à passer la passerelle à
> > partir du dernier réseau:
> > ping 192.168.1.1 ne passe plus comme tout les ip qui se trouvent avant.
> >
> > Voila, je n'arrive pas à voir d'où viens le problème,
> > si vous avez une idée je suis preneur....
> >
> > merci
>
> Tu trouveras sans doute ton bonheur dans :
>
>         http://www.openbsd-france.org/documentations/OpenBSD-passerelle.html
>
> Pourquoi un problème de sysctl ;)
>
>         net.inet.ip.forwarding=1 dans /etc/sysctl.conf
>
> qui est de base commenté.
>
>                         ~Christophe
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Problème de débutant avec pf.conf pour le NAT

Julien Cabillot
In reply to this post by Christophe Lucas-2
Désolé ça va ressembler à du spam:
je vais donc recommencer depuis le debut pour voir d'ou proviens le
soucis et donner une meilleure explication de mon problème.

On 1/16/06, Christophe Lucas <[hidden email]> wrote:

> Julien Cabillot ([hidden email]) wrote:
> > Bonsoir,
> > j'ai un petit soucis avec ma configuration de pf.conf, j'ai un réseau
> > qui ressemble à ça (je sais c'est tordu :)):
> >
> > (internet) | (192.168.0.254) ---------- (192.168.0.3) | (192.168.1.1)
> > --------------- (192.168.1.0/24)
> > En premier se trouve un modem routeur (Freebox) puis viens la machine
> > sous OpenBSD puis mon réseau.
> > J'ai configuré mes machines du reseau 192.168.1.0 pour qu'elles
> > passent par la passerelle 192.168.1.1 et j'ai configuré
> > mon pf.conf comme telle:
> > <vide>
> > nat on rl0 from 192.168.1.0/24 to any -> rl0
> > <vide>
> > (rl0 a pour ip 192.168.0.3)
> > Et pourtant impossible ensuite d'arriver à passer la passerelle à
> > partir du dernier réseau:
> > ping 192.168.1.1 ne passe plus comme tout les ip qui se trouvent avant.
> >
> > Voila, je n'arrive pas à voir d'où viens le problème,
> > si vous avez une idée je suis preneur....
> >
> > merci
>
> Tu trouveras sans doute ton bonheur dans :
>
>         http://www.openbsd-france.org/documentations/OpenBSD-passerelle.html
>
> Pourquoi un problème de sysctl ;)
>
>         net.inet.ip.forwarding=1 dans /etc/sysctl.conf
>
> qui est de base commenté.
>
>                         ~Christophe
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Problème de débutant avec pf.conf pour le NAT

Christophe Lucas-2
In reply to this post by Julien Cabillot
Julien Cabillot ([hidden email]) wrote:
> Malheuresement non j'avais déja modifié ceci.
> Par contre je me rends compte que j'avais oublié de préciser qque
> chose avant mon routeur OpenBSD il y a ma freebox elle aussi en
> routeur avec comme ip 192.168.0.254 mais j'ai bien spécifié sur
> OpenBSD dans mygateway d'utiliser cette gateway (pas de soucis pour se
> connecter au web à partir de ce pc d'ailleurs).
 
Quelle utilité de faire un routeur OpenBSD et d'utiliser le mode routeur
de la freebox ? l'utiliser en bridge(freebox) serait plus simple, non ?
                        ~Christophe


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Problème de débutant avec pf.conf pour le NAT

Julien Cabillot
Finalement un reboot a résolu mon soucis.
Pour le double routeur: c'est pour me permettre d'utiliser l'interface wifi
(je sais pas si en me mettant en bridge cela marche) pour pouvoir surfer et
poser mes questions :) (mais c'est temporaire)

On 1/16/06, Christophe Lucas <[hidden email]> wrote:

>
> Julien Cabillot ([hidden email]) wrote:
> > Malheuresement non j'avais déja modifié ceci.
> > Par contre je me rends compte que j'avais oublié de préciser qque
> > chose avant mon routeur OpenBSD il y a ma freebox elle aussi en
> > routeur avec comme ip 192.168.0.254 mais j'ai bien spécifié sur
> > OpenBSD dans mygateway d'utiliser cette gateway (pas de soucis pour se
> > connecter au web à partir de ce pc d'ailleurs).
>
> Quelle utilité de faire un routeur OpenBSD et d'utiliser le mode routeur
> de la freebox ? l'utiliser en bridge(freebox) serait plus simple, non ?
>                         ~Christophe
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail:
> [hidden email]
>
>