Problem building jdk1.4

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem building jdk1.4

William Gibb-2
Due to the grace of a reader of ports, I was able to obtain the bsd
patchs for java that I needed,  and now that I've got all the files
that need to be manually fetched (as outlined in the makefile), I'm
still getting an error about missing files when I try to make jdk 1.4.
 The enumerated files in the error message are located in
/usr/ports/distfiles, and match the md5, sha1 and size signatures
listed in /usr/ports/devel/jdk/1.4/distinfo.  Does anyone have any
input on the matter?

# make
===>  jdk-1.4.2p7 depends on: gtar-* - found
===>  jdk-1.4.2p7 depends on: zip-* - found
===>  jdk-1.4.2p7 depends on: jdk-linux->=1.3.1_10 - found
===>  jdk-1.4.2p7 depends on: nspr-* - found
===>  jdk-1.4.2p7 depends on: gmake-3.80p1 - found
===>  jdk-1.4.2p7 depends on: unzip-* - found
===>  jdk-1.4.2p7 depends on: iodbc-* - found
===>  jdk-1.4.2p7 depends on: openmotif-* - found
===>  Verifying specs: iodbc.2 Xm.2 X11 Xext Xi Xm Xmu Xp Xt Xtst c m
ossaudio pthread
===>  found iodbc.2.50 Xm.3.0 X11.9.0 Xext.9.0 Xi.9.0 Xm.3.0 Xmu.9.0
Xp.9.0 Xt.9.0 Xtst.9.0 c.39.0 m.2.1 ossaudio.3.0 pthread.6.2
===>  Checking files for jdk-1.4.2p7
*** You must manually fetch the distribution files, place
*** them in /usr/ports/distfiles and then run make again.
*** Get the SCSL source & binary files:
***  j2sdk-1_4_2-src-scsl.zip
***  j2sdk-1_4_2-bin-scsl.zip
*** from http://wwws.sun.com/software/communitysource/j2se/java2/download.html
*** Get the BSD patchset file:
***  bsd-jdk14-patches-7.tar.gz
*** from http://www.eyesbeyond.com/freebsddom/java/jdk14.html
*** Get the linux binary sdk file:
***  j2sdk-1_4_2-linux-i586.bin
*** from http://java.sun.com/products/archive/j2se/1.4.2/
*** Error code 1

Stop in /usr/ports/devel/jdk/1.4 (line 2102 of
/usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/devel/jdk/1.4 (line 1561 of
/usr/ports/infrastructure/mk/bsd.port.mk).
*** Error code 1

Stop in /usr/ports/devel/jdk/1.4 (line 1750 of
/usr/ports/infrastructure/mk/bsd.port.mk).


--
William Gibb
GWU ISS CIMS Intern
SEAS SPAN Mentor
GWU Engineers Council DH House Manager
Scribe of Theta Tau Professional Engineering Fraternity, Gamma
Beta Chapter

Reply | Threaded
Open this post in threaded view
|

Re: Problem building jdk1.4

Bachman Kharazmi
Sounds very strange if all versions are correct.

Make "sure" that both patch and javafiles have correct versionNbrs.

If it still doesn't work out I suggest java 5. You don't have any
reason to play with earlier more than maybe lack of diskspace. You
will get lots of generic fancy stuff with 5.0 also :)

GL
/bkw

On 07/06/06, William Gibb <[hidden email]> wrote:

> Due to the grace of a reader of ports, I was able to obtain the bsd
> patchs for java that I needed,  and now that I've got all the files
> that need to be manually fetched (as outlined in the makefile), I'm
> still getting an error about missing files when I try to make jdk 1.4.
>  The enumerated files in the error message are located in
> /usr/ports/distfiles, and match the md5, sha1 and size signatures
> listed in /usr/ports/devel/jdk/1.4/distinfo.  Does anyone have any
> input on the matter?
>
> # make
> ===>  jdk-1.4.2p7 depends on: gtar-* - found
> ===>  jdk-1.4.2p7 depends on: zip-* - found
> ===>  jdk-1.4.2p7 depends on: jdk-linux->=1.3.1_10 - found
> ===>  jdk-1.4.2p7 depends on: nspr-* - found
> ===>  jdk-1.4.2p7 depends on: gmake-3.80p1 - found
> ===>  jdk-1.4.2p7 depends on: unzip-* - found
> ===>  jdk-1.4.2p7 depends on: iodbc-* - found
> ===>  jdk-1.4.2p7 depends on: openmotif-* - found
> ===>  Verifying specs: iodbc.2 Xm.2 X11 Xext Xi Xm Xmu Xp Xt Xtst c m
> ossaudio pthread
> ===>  found iodbc.2.50 Xm.3.0 X11.9.0 Xext.9.0 Xi.9.0 Xm.3.0 Xmu.9.0
> Xp.9.0 Xt.9.0 Xtst.9.0 c.39.0 m.2.1 ossaudio.3.0 pthread.6.2
> ===>  Checking files for jdk-1.4.2p7
> *** You must manually fetch the distribution files, place
> *** them in /usr/ports/distfiles and then run make again.
> *** Get the SCSL source & binary files:
> ***  j2sdk-1_4_2-src-scsl.zip
> ***  j2sdk-1_4_2-bin-scsl.zip
> *** from http://wwws.sun.com/software/communitysource/j2se/java2/download.html
> *** Get the BSD patchset file:
> ***  bsd-jdk14-patches-7.tar.gz
> *** from http://www.eyesbeyond.com/freebsddom/java/jdk14.html
> *** Get the linux binary sdk file:
> ***  j2sdk-1_4_2-linux-i586.bin
> *** from http://java.sun.com/products/archive/j2se/1.4.2/
> *** Error code 1
>
> Stop in /usr/ports/devel/jdk/1.4 (line 2102 of
> /usr/ports/infrastructure/mk/bsd.port.mk).
> *** Error code 1
>
> Stop in /usr/ports/devel/jdk/1.4 (line 1561 of
> /usr/ports/infrastructure/mk/bsd.port.mk).
> *** Error code 1
>
> Stop in /usr/ports/devel/jdk/1.4 (line 1750 of
> /usr/ports/infrastructure/mk/bsd.port.mk).
>
>
> --
> William Gibb
> GWU ISS CIMS Intern
> SEAS SPAN Mentor
> GWU Engineers Council DH House Manager
> Scribe of Theta Tau Professional Engineering Fraternity, Gamma
> Beta Chapter
>
>


--
/Bachman

Reply | Threaded
Open this post in threaded view
|

Re: Problem building jdk1.4

William Gibb-2
Ian Darwin pointed out my problem.  I was using a font were the 1(one)
and i(eye) were nearly identical, so it wasn't evident until i
resolved that issue that the
> > ***  j2sdk-1_4_2-src-scsl.zip
> > ***  j2sdk-1_4_2-bin-scsl.zip
were actually scs1, not scsi.  Renaming them solved the problem.

On 6/9/06, Bachman Kharazmi <[hidden email]> wrote:

> Sounds very strange if all versions are correct.
>
> Make "sure" that both patch and javafiles have correct versionNbrs.
>
> If it still doesn't work out I suggest java 5. You don't have any
> reason to play with earlier more than maybe lack of diskspace. You
> will get lots of generic fancy stuff with 5.0 also :)
>
> GL
> /bkw
> --
> /Bachman
>


--
William Gibb
GWU ISS CIMS Intern
SEAS SPAN Mentor
GWU Engineers Council DH House Manager
Scribe of Theta Tau Professional Engineering Fraternity, Gamma
Beta Chapter

Reply | Threaded
Open this post in threaded view
|

Re: Problem building jdk1.4

Ian Darwin
In reply to this post by Bachman Kharazmi
Bachman Kharazmi wrote:
> Sounds very strange if all versions are correct.
>
> Make "sure" that both patch and javafiles have correct versionNbrs.
>
> If it still doesn't work out I suggest java 5. You don't have any
> reason to play with earlier more than maybe lack of diskspace. You
> will get lots of generic fancy stuff with 5.0 also :)

The original user didn't respond publicly, but I was able to show him
that there was a subtle error in a distfile name on his system. The port
built correctly after the file was given its correct name.

Reply | Threaded
Open this post in threaded view
|

Re: Problem building jdk1.4

Ian Darwin
In reply to this post by William Gibb-2
Oh, sorry William, you did respond a bit before me :-)