Probelm when building QGIS

classic Classic list List threaded Threaded
9 messages Options
tao
Reply | Threaded
Open this post in threaded view
|

Probelm when building QGIS

tao
Hello,

I am in OpenBSD6.3. QGIS 2.18.17 in packages can not render style just like
things in
http://openbsd-archive.7691.n7.nabble.com/qgis-bug-since-last-security-update-under-stable-td339707.html

So, I am trying to build QGIS 2.18.17 from source.
Succeeded to ccmake the source. But get error when make.
Here is the message:

tao$ make
[  0%] Built target version
make: don't know how to make
/home/tao/Software/qgis/qgis-2.18.22/resources/function_help/json/rea
(prerequisite of: src/core/qgsexpression_texts.cpp)
Stop in .
*** Error 2 in . (CMakeFiles/Makefile2:1165
'src/core/CMakeFiles/qgis_core.dir/all')
*** Error 1 in /home/tao/Software/qgis/build-2.18.22 (Makefile:163 'all')


Tried to find the file mentioned above
"/home/tao/Software/qgis/qgis-2.18.22/resources/function_help/json/rea ",
but could not find anything.

Anyone has an idea?




--
Sent from: http://openbsd-archive.7691.n7.nabble.com/openbsd-user-misc-f3.html

tao
Reply | Threaded
Open this post in threaded view
|

Re: Probelm when building QGIS

tao
If there is any alternatives of QGIS I can use in OpenBSD, please tell me.

Thanks in advance.

Tao  



--
Sent from: http://openbsd-archive.7691.n7.nabble.com/openbsd-user-misc-f3.html

Reply | Threaded
Open this post in threaded view
|

Re: Probelm when building QGIS

Solene Rapenne
In reply to this post by tao
tao <[hidden email]> wrote:

> Hello,
>
> I am in OpenBSD6.3. QGIS 2.18.17 in packages can not render style just like
> things in
> http://openbsd-archive.7691.n7.nabble.com/qgis-bug-since-last-security-update-under-stable-td339707.html
>
> So, I am trying to build QGIS 2.18.17 from source.
> Succeeded to ccmake the source. But get error when make.
> Here is the message:
>
> tao$ make
> [  0%] Built target version
> make: don't know how to make
> /home/tao/Software/qgis/qgis-2.18.22/resources/function_help/json/rea
> (prerequisite of: src/core/qgsexpression_texts.cpp)
> Stop in .
> *** Error 2 in . (CMakeFiles/Makefile2:1165
> 'src/core/CMakeFiles/qgis_core.dir/all')
> *** Error 1 in /home/tao/Software/qgis/build-2.18.22 (Makefile:163 'all')
>
>
> Tried to find the file mentioned above
> "/home/tao/Software/qgis/qgis-2.18.22/resources/function_help/json/rea ",
> but could not find anything.
>
> Anyone has an idea?
>
>
>
>
> --
> Sent from: http://openbsd-archive.7691.n7.nabble.com/openbsd-user-misc-f3.html

qgis uses cmake

tao
Reply | Threaded
Open this post in threaded view
|

Re: Probelm when building QGIS

tao
Hi, Solene

Thank you for your reply.

I followed the instructions in QGIS github to build it.
https://github.com/qgis/QGIS/blob/master/INSTALL

Steps:
  1. $ cd $QGIS_SOURCE
  2. $ mkdir build
  3. $ cd build
  4. $ ccmake ..
        (make WITH_QWTPOLAR=OFF  and  leave others default)

The error mentioned in the earliest post occurred during Step 4.
"/home/tao/Software/qgis/qgis-2.18.22/resources/function_help/json/rea "
I could not find the above file in source folder or build folder.

If I could build from source, I have to find alternatives of QGIS.
But there seems no other GIS desktops in OpenBSD packages.

PS:I re-posted this message because I forget to quote in my last reply.
     Forgive my mistake.




Solene Rapenne wrote
> tao &lt;

> uponmyword@

> &gt; wrote:
>> Hello,
>>
>> I am in OpenBSD6.3. QGIS 2.18.17 in packages can not render style just
>> like
>> things in
>> http://openbsd-archive.7691.n7.nabble.com/qgis-bug-since-last-security-update-under-stable-td339707.html
>>
>> So, I am trying to build QGIS 2.18.17 from source.
>> Succeeded to ccmake the source. But get error when make.
>> Here is the message:
>>
>> tao$ make
>> [  0%] Built target version
>> make: don't know how to make
>> /home/tao/Software/qgis/qgis-2.18.22/resources/function_help/json/rea
>> (prerequisite of: src/core/qgsexpression_texts.cpp)
>> Stop in .
>> *** Error 2 in . (CMakeFiles/Makefile2:1165
>> 'src/core/CMakeFiles/qgis_core.dir/all')
>> *** Error 1 in /home/tao/Software/qgis/build-2.18.22 (Makefile:163 'all')
>>
>>
>> Tried to find the file mentioned above
>> "/home/tao/Software/qgis/qgis-2.18.22/resources/function_help/json/rea ",
>> but could not find anything.
>>
>> Anyone has an idea?
>>
>>
>>
>>
>> --
>> Sent from:
>> http://openbsd-archive.7691.n7.nabble.com/openbsd-user-misc-f3.html
>
> qgis uses cmake





--
Sent from: http://openbsd-archive.7691.n7.nabble.com/openbsd-user-misc-f3.html

Reply | Threaded
Open this post in threaded view
|

Re: Probelm when building QGIS

Rashad Kanavath
In reply to this post by tao
On Thu, Jul 26, 2018 at 12:36 AM tao <[hidden email]> wrote:

> Hello,
>
> I am in OpenBSD6.3. QGIS 2.18.17 in packages can not render style just like
> things in
>
> http://openbsd-archive.7691.n7.nabble.com/qgis-bug-since-last-security-update-under-stable-td339707.html
>
> So, I am trying to build QGIS 2.18.17 from source.
> Succeeded to ccmake the source. But get error when make.
> Here is the message:
>
> tao$ make
> [  0%] Built target version
> make: don't know how to make
> /home/tao/Software/qgis/qgis-2.18.22/resources/function_help/json/rea
> (prerequisite of: src/core/qgsexpression_texts.cpp)
> Stop in .
> *** Error 2 in . (CMakeFiles/Makefile2:1165
> 'src/core/CMakeFiles/qgis_core.dir/all')
> *** Error 1 in /home/tao/Software/qgis/build-2.18.22 (Makefile:163 'all')
>
>
> Tried to find the file mentioned above
> "/home/tao/Software/qgis/qgis-2.18.22/resources/function_help/json/rea ",
> but could not find anything.
>
> Anyone has an idea?
>

could you try gmake instead of make?
make != gmake (unless you simlink or alias it)

>
>
>
>
> --
> Sent from:
> http://openbsd-archive.7691.n7.nabble.com/openbsd-user-misc-f3.html
>
>

--
Regards,
   Rashad
tao
Reply | Threaded
Open this post in threaded view
|

Re: Probelm when building QGIS

tao
Rashad Kanavath wrote
> On Thu, Jul 26, 2018 at 12:36 AM tao &lt;

> uponmyword@

> &gt; wrote:
>
>> Hello,
>>
>> I am in OpenBSD6.3. QGIS 2.18.17 in packages can not render style just
>> like
>> things in
>>
>> http://openbsd-archive.7691.n7.nabble.com/qgis-bug-since-last-security-update-under-stable-td339707.html
>>
>> So, I am trying to build QGIS 2.18.17 from source.
>> Succeeded to ccmake the source. But get error when make.
>> Here is the message:
>>
>> tao$ make
>> [  0%] Built target version
>> make: don't know how to make
>> /home/tao/Software/qgis/qgis-2.18.22/resources/function_help/json/rea
>> (prerequisite of: src/core/qgsexpression_texts.cpp)
>> Stop in .
>> *** Error 2 in . (CMakeFiles/Makefile2:1165
>> 'src/core/CMakeFiles/qgis_core.dir/all')
>> *** Error 1 in /home/tao/Software/qgis/build-2.18.22 (Makefile:163 'all')
>>
>>
>> Tried to find the file mentioned above
>> "/home/tao/Software/qgis/qgis-2.18.22/resources/function_help/json/rea ",
>> but could not find anything.
>>
>> Anyone has an idea?
>>
>
> could you try gmake instead of make?
> make != gmake (unless you simlink or alias it)

That sounds make sense, I will check and try that tonight.
Report later.

Thanks!
Tao


Rashad Kanavath wrote

>>
>>
>>
>>
>> --
>> Sent from:
>> http://openbsd-archive.7691.n7.nabble.com/openbsd-user-misc-f3.html
>>
>>
>
> --
> Regards,
>    Rashad





--
Sent from: http://openbsd-archive.7691.n7.nabble.com/openbsd-user-misc-f3.html

tao
Reply | Threaded
Open this post in threaded view
|

Re: Probelm when building QGIS

tao
In reply to this post by Rashad Kanavath
Rashad Kanavath wrote
> On Thu, Jul 26, 2018 at 12:36 AM tao &lt;

> uponmyword@

> &gt; wrote:
>
>> Hello,
>>
>> I am in OpenBSD6.3. QGIS 2.18.17 in packages can not render style just
>> like
>> things in
>>
>> http://openbsd-archive.7691.n7.nabble.com/qgis-bug-since-last-security-update-under-stable-td339707.html
>>
>> So, I am trying to build QGIS 2.18.17 from source.
>> Succeeded to ccmake the source. But get error when make.
>> Here is the message:
>>
>> tao$ make
>> [  0%] Built target version
>> make: don't know how to make
>> /home/tao/Software/qgis/qgis-2.18.22/resources/function_help/json/rea
>> (prerequisite of: src/core/qgsexpression_texts.cpp)
>> Stop in .
>> *** Error 2 in . (CMakeFiles/Makefile2:1165
>> 'src/core/CMakeFiles/qgis_core.dir/all')
>> *** Error 1 in /home/tao/Software/qgis/build-2.18.22 (Makefile:163 'all')
>>
>>
>> Tried to find the file mentioned above
>> "/home/tao/Software/qgis/qgis-2.18.22/resources/function_help/json/rea ",
>> but could not find anything.
>>
>> Anyone has an idea?
>>
>
> could you try gmake instead of make?
> make != gmake (unless you simlink or alias it)

Could not find gmake. And also could not use cmake to build it.
I think make is the right one.

I have to give up ^ \^


Rashad Kanavath wrote

>>
>>
>>
>>
>> --
>> Sent from:
>> http://openbsd-archive.7691.n7.nabble.com/openbsd-user-misc-f3.html
>>
>>
>
> --
> Regards,
>    Rashad





--
Sent from: http://openbsd-archive.7691.n7.nabble.com/openbsd-user-misc-f3.html

Reply | Threaded
Open this post in threaded view
|

Re: Probelm when building QGIS

Mark Prins-2
On 27-07-18 14:03, tao wrote:

> Rashad Kanavath wrote
>> On Thu, Jul 26, 2018 at 12:36 AM tao &lt;
>
>> uponmyword@
>
>> &gt; wrote:
>>
>>> Hello,
>>>
>>> I am in OpenBSD6.3. QGIS 2.18.17 in packages can not render style just
>>> like
>>> things in
>>>
>>> http://openbsd-archive.7691.n7.nabble.com/qgis-bug-since-last-security-update-under-stable-td339707.html
>>>
>>> So, I am trying to build QGIS 2.18.17 from source.
>>> Succeeded to ccmake the source. But get error when make.
>>> Here is the message:
>>>
>>> tao$ make
>>> [  0%] Built target version
>>> make: don't know how to make
>>> /home/tao/Software/qgis/qgis-2.18.22/resources/function_help/json/rea
>>> (prerequisite of: src/core/qgsexpression_texts.cpp)
>>> Stop in .
>>> *** Error 2 in . (CMakeFiles/Makefile2:1165
>>> 'src/core/CMakeFiles/qgis_core.dir/all')
>>> *** Error 1 in /home/tao/Software/qgis/build-2.18.22 (Makefile:163 'all')
>>>
>>>
>>> Tried to find the file mentioned above
>>> "/home/tao/Software/qgis/qgis-2.18.22/resources/function_help/json/rea ",
>>> but could not find anything.
>>>
>>> Anyone has an idea?
>>>
>>
>> could you try gmake instead of make?
>> make != gmake (unless you simlink or alias it)
>
> Could not find gmake. And also could not use cmake to build it.
> I think make is the right one.
>
> I have to give up ^ \^

snapshots already have qgis 3, so you can upgrade to current to get all
the latest.

since there is a port, you should start from there (eg. upgrade the qgis
source version and start with that)
-m

tao
Reply | Threaded
Open this post in threaded view
|

Re: Probelm when building QGIS

tao
Mark Prins-2 wrote

> On 27-07-18 14:03, tao wrote:
>> Rashad Kanavath wrote
>>> On Thu, Jul 26, 2018 at 12:36 AM tao &lt;
>>
>>> uponmyword@
>>
>>> &gt; wrote:
>>>
>>>> Hello,
>>>>
>>>> I am in OpenBSD6.3. QGIS 2.18.17 in packages can not render style just
>>>> like
>>>> things in
>>>>
>>>> http://openbsd-archive.7691.n7.nabble.com/qgis-bug-since-last-security-update-under-stable-td339707.html
>>>>
>>>> So, I am trying to build QGIS 2.18.17 from source.
>>>> Succeeded to ccmake the source. But get error when make.
>>>> Here is the message:
>>>>
>>>> tao$ make
>>>> [  0%] Built target version
>>>> make: don't know how to make
>>>> /home/tao/Software/qgis/qgis-2.18.22/resources/function_help/json/rea
>>>> (prerequisite of: src/core/qgsexpression_texts.cpp)
>>>> Stop in .
>>>> *** Error 2 in . (CMakeFiles/Makefile2:1165
>>>> 'src/core/CMakeFiles/qgis_core.dir/all')
>>>> *** Error 1 in /home/tao/Software/qgis/build-2.18.22 (Makefile:163
>>>> 'all')
>>>>
>>>>
>>>> Tried to find the file mentioned above
>>>> "/home/tao/Software/qgis/qgis-2.18.22/resources/function_help/json/rea
>>>> ",
>>>> but could not find anything.
>>>>
>>>> Anyone has an idea?
>>>>
>>>
>>> could you try gmake instead of make?
>>> make != gmake (unless you simlink or alias it)
>>
>> Could not find gmake. And also could not use cmake to build it.
>> I think make is the right one.
>>
>> I have to give up ^ \^
>
> snapshots already have qgis 3, so you can upgrade to current to get all
> the latest.
>
> since there is a port, you should start from there (eg. upgrade the qgis
> source version and start with that)
> -m


Thanks for your advice.

I have a a lot program which are build from source, so it is hard to upgrade
to current.
So I continued trying to build from source for several weeks.

FINDING:
Cmake can not treat file names with '(', ')', ' ', '$', so I replace them to
'_'.
And that made the build continued.

3 trials were made during the several weeks.
Trial 1. Build qgis from ports
Trial 2. Build qgis 2.18.22 from source file
Trial 3. Build qgis 3.2 from source file

All these trials failed with the same error:
[ 37%] Built target mdalprovider
/bin/sh: ../../output/bin/crssync: Permission denied
*** Error 1 in . (src/crssync/CMakeFiles/synccrsdb.dir/build.make:57
'src/crssync/CMakeFiles/synccrsdb': cd /home/tao/Software/qgis/build-3....)
*** Error 2 in . (CMakeFiles/Makefile2:2841
'src/crssync/CMakeFiles/synccrsdb.dir/all')
*** Error 2 in /home/tao/Software/qgis/build-3.2.1 (Makefile:163 'all')

I totally did this under user mode, and permission right is okay like:

tao$ ./crssync                                                                
ksh: ./crssync: Permission denied
tao$ ls -l ./crssync                                                          
-rwxr-xr-x  1 tao  tao  23149 Aug  9 14:18 ./crssync

This really beat me.
I also post in QGIS forum
http://osgeo-org.1560.x6.nabble.com/QGIS-Developer-Build-error-output-bin-crssync-Permission-denied-td5373914.html
<http://osgeo-org.1560.x6.nabble.com/QGIS-Developer-Build-error-output-bin-crssync-Permission-denied-td5373914.html>  

Anyone can help?
Thanks god!




--
Sent from: http://openbsd-archive.7691.n7.nabble.com/openbsd-user-misc-f3.html