PowerMac G5 7,2 root problem

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

PowerMac G5 7,2 root problem

The Mouse
Hello list,

I have a PowerMac7,2 (Dual 2.0Ghz PPC970 stock hardware) unit that works
perfectly fine on OpenBSD until I try to use the MP kernel.

The MP kernel right to the end and detects the root and swap partitions
then it hangs indefinately. (The SP kernel works perfectly, but only uses
one cpu.)

I've tried 5.5 and the current snapshot from yesterday. I see the same issue.

Has anyone else seen this before? Does anyone know what might be causing
this?

Thanks in advance.



Reply | Threaded
Open this post in threaded view
|

Re: PowerMac G5 7,2 root problem

Justin Haynes-2
The Mouse -

Can you configure /etc/sysctl.conf to enable ddb and then drop to ddb prompt when this happens to capture some output:

http://www.openbsd.org/report.html  and
http://www.openbsd.org/cgi-bin/man.cgi/OpenBSD-current/man5/sysctl.conf.5?query=sysctl%2econf&sec=5

Also, perhaps an MP bsd.rd (isn't bsd.rd MP?) would allow you to get a dmesg as the hang happens when root and swap are mounted.  This might be enough to allow you to report a problem as described in the report.html link above and may help developers.

If I knew more about macppc I'd probably have more suggestions.  Good luck!

-Justin

On Sep 30, 2014, at 11:26 PM, The Mouse wrote:

> Hello list,
>
> I have a PowerMac7,2 (Dual 2.0Ghz PPC970 stock hardware) unit that works
> perfectly fine on OpenBSD until I try to use the MP kernel.
>
> The MP kernel right to the end and detects the root and swap partitions
> then it hangs indefinately. (The SP kernel works perfectly, but only uses
> one cpu.)
>
> I've tried 5.5 and the current snapshot from yesterday. I see the same issue.
>
> Has anyone else seen this before? Does anyone know what might be causing
> this?
>
> Thanks in advance.
>
>
>

Reply | Threaded
Open this post in threaded view
|

Re: PowerMac G5 7,2 root problem

Martin Pieuchot-2
In reply to this post by The Mouse
On 01/10/14(Wed) 04:26, The Mouse wrote:

> Hello list,
>
> I have a PowerMac7,2 (Dual 2.0Ghz PPC970 stock hardware) unit that works
> perfectly fine on OpenBSD until I try to use the MP kernel.
>
> The MP kernel right to the end and detects the root and swap partitions
> then it hangs indefinately. (The SP kernel works perfectly, but only uses
> one cpu.)
>
> I've tried 5.5 and the current snapshot from yesterday. I see the same issue.
>
> Has anyone else seen this before? Does anyone know what might be causing
> this?

The MP support for G5 is actually not really working.  I have a set of
diffs to improve it, at least make it boot, that I'll try to commit
shortly.

I'll suggest you to stick to a SP kernel for the moment.