PPTP + PPPoE ?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

PPTP + PPPoE ?

Abel Talaverón Estevez
Hi all,

I'm running OpenBSD 3.7. I use my OpenBSD machine as a firewall, including a
PPTP server and it runs ok. But...

I want to connect to my ISP with PPPoE and configure my router as bridge and
I've achieve it!! But now my PPTP server is not running, I cannot connect
from a Windows client as before. Does anybody know why? Can I use ppp.conf
with two different applications? Or the problem is with the tun devices?

Thanks a lot.


My ppp.conf:

pptp:
 #set ifaddr 172.16.1.100 172.16.1.10-172.16.1.20
 enable proxy
 set timeout 0
 enable MSChapV2
 disable ipv6cp
 disable ipv6

default:
 set log Phase Chat LCP IPCP CCP tun command
 set device /dev/cua01
 set speed 115200
# set dial "ABORT BUSY ABORT NO\\sCARRIER TIMEOUT 5 \"\" AT OK-AT-OK ATE1Q0 OK
\\dATDT\\T TIMEOUT 40 CONNECT"


CHAPserver:
 enable chap
 enable proxy
 set ifaddr 192.244.176.44 292.244.184.31
 accept dns

pppoe:
 set device "!/usr/sbin/pppoe -i rl0"
 set mtu max 1492
 set mru max 1492
 set speed sync
 disable acfcomp protocomp
 deny acfcomp
 set authname "adslppp@telefonicanetpa"
 set authkey "adslppp"
 add default HISADDR
 enable dns
 enable mssfixup


--
Abel Talaversn Estevez
Ingeniero Superior de Telecomunicaciones
Analista de Proyectos

OpenWired
Caballero 87 - Bajos
08029 - Barcelona
Tel. 93 495 0990
Fax. 93 419 4591

Openwired
Alejandro Villegas,29
28043 - MADRID - ESPAQA
Telifono: 91 300 51 09
Fax:  91 300 28 13
http://www.openwired.com

Reply | Threaded
Open this post in threaded view
|

Re: PPTP + PPPoE ?

Maxim Bourmistrov
The problem is GRE.
Take a look at http://sourceforge.net/projects/frickin


On Monday 05 December 2005 18:58, Abel Talaversn Estevez wrote:

> Hi all,
>
> I'm running OpenBSD 3.7. I use my OpenBSD machine as a firewall, including a
> PPTP server and it runs ok. But...
>
> I want to connect to my ISP with PPPoE and configure my router as bridge and
> I've achieve it!! But now my PPTP server is not running, I cannot connect
> from a Windows client as before. Does anybody know why? Can I use ppp.conf
> with two different applications? Or the problem is with the tun devices?
>
> Thanks a lot.
>
>
> My ppp.conf:
>
> pptp:
>  #set ifaddr 172.16.1.100 172.16.1.10-172.16.1.20
>  enable proxy
>  set timeout 0
>  enable MSChapV2
>  disable ipv6cp
>  disable ipv6
>
> default:
>  set log Phase Chat LCP IPCP CCP tun command
>  set device /dev/cua01
>  set speed 115200
> # set dial "ABORT BUSY ABORT NO\\sCARRIER TIMEOUT 5 \"\" AT OK-AT-OK ATE1Q0 OK
> \\dATDT\\T TIMEOUT 40 CONNECT"
>
>
> CHAPserver:
>  enable chap
>  enable proxy
>  set ifaddr 192.244.176.44 292.244.184.31
>  accept dns
>
> pppoe:
>  set device "!/usr/sbin/pppoe -i rl0"
>  set mtu max 1492
>  set mru max 1492
>  set speed sync
>  disable acfcomp protocomp
>  deny acfcomp
>  set authname "adslppp@telefonicanetpa"
>  set authkey "adslppp"
>  add default HISADDR
>  enable dns
>  enable mssfixup
>
>

--
Best regards
Maxim Bourmistrov

Reply | Threaded
Open this post in threaded view
|

Re: PPTP + PPPoE ?

David Coppa
Alternatively, you can use in-kernel pppoe for adsl to your ISP and
user-space ppp for pptp.
Look at the man pages.

Regards,
David

On 12/5/05, Maxim Bourmistrov <[hidden email]> wrote:

> The problem is GRE.
> Take a look at http://sourceforge.net/projects/frickin
>
>
> On Monday 05 December 2005 18:58, Abel Talaversn Estevez wrote:
> > Hi all,
> >
> > I'm running OpenBSD 3.7. I use my OpenBSD machine as a firewall, including a
> > PPTP server and it runs ok. But...
> >
> > I want to connect to my ISP with PPPoE and configure my router as bridge and
> > I've achieve it!! But now my PPTP server is not running, I cannot connect
> > from a Windows client as before. Does anybody know why? Can I use ppp.conf
> > with two different applications? Or the problem is with the tun devices?
> >
> > Thanks a lot.
> >
> >
> > My ppp.conf:
> >
> > pptp:
> >  #set ifaddr 172.16.1.100 172.16.1.10-172.16.1.20
> >  enable proxy
> >  set timeout 0
> >  enable MSChapV2
> >  disable ipv6cp
> >  disable ipv6
> >
> > default:
> >  set log Phase Chat LCP IPCP CCP tun command
> >  set device /dev/cua01
> >  set speed 115200
> > # set dial "ABORT BUSY ABORT NO\\sCARRIER TIMEOUT 5 \"\" AT OK-AT-OK ATE1Q0 OK
> > \\dATDT\\T TIMEOUT 40 CONNECT"
> >
> >
> > CHAPserver:
> >  enable chap
> >  enable proxy
> >  set ifaddr 192.244.176.44 292.244.184.31
> >  accept dns
> >
> > pppoe:
> >  set device "!/usr/sbin/pppoe -i rl0"
> >  set mtu max 1492
> >  set mru max 1492
> >  set speed sync
> >  disable acfcomp protocomp
> >  deny acfcomp
> >  set authname "adslppp@telefonicanetpa"
> >  set authkey "adslppp"
> >  add default HISADDR
> >  enable dns
> >  enable mssfixup
> >
> >
>
> --
> Best regards
> Maxim Bourmistrov