Openbsd 6.3 + VirtualBox + Vagrant

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Openbsd 6.3 + VirtualBox + Vagrant

Alceu R. de Freitas Jr.
Hello folks,

I just tried a combination of OpenBSD, Vagrant and Virtualbox that's been working since OpenBSD version 6.0 and the provisioning fails quite soon after I hit "vagrant up".

Initially I thought was something regarding my own scripts, but after some testing, I realized that anything execute over the shell (doesn't matter if "shell" or "inline" from config.vm.provision), even I simple "echo" returns a non-zero exit code.

Following the non-zero return message from Vagrant, I got absolutely nothing from STDOUT or STDERR from the executed commands. Even running:

vb.customize ["modifyvm", :id, "--natdnspassdomain1", "off"]

From the Vagrantfile I got the same behavior.

I tried connecting right after the provisioning failed and was able to find the same scripts ("inline") inside /tmp... running them over there didn't generated any error.

Here the Vagranfile being used to test this:

https://github.com/glasswalk3r/cpan-openbsd-smoker/blob/master/vagrant/Vagrantfile

By any change anybody experimented such problem?

Thanks!

Alceu