OpenSSH and Android

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

OpenSSH and Android

Kevin Chadwick-4
So I found this

https://github.com/nathan-osman/AndroX/blob/master/README.md

but after updating it to use the latest sources and building LibreSSL
and OpenSSL:

I got a configure error for LibreSSL.

"OpenSSL headers missing"

Adding --with-cppflags=-I/home/kc/AndroX/install/include to the below

I got "Can't find recent OpenSSL libcrypto"

/usr/bin/env PATH=$PATH:/home/kc/lib/andtool/bin ./configure
--prefix=/home/kc/AndroX/install --host=arm-linux-androideabi
--with-ssl-dir=/home/kc/AndroX/install


I got the same issue as here for trying to cross build OpenSSH with
OpenSSL

http://w3facility.org/question/error-compiling-openssh-with-android-ndk/



So nevermind, connectbot will have to do for now unless someone has a
cluestick to hand.

Reply | Threaded
Open this post in threaded view
|

Re: OpenSSH and Android

Darren Tucker
On Thu, May 7, 2015 at 11:19 PM, Kevin Chadwick <[hidden email]> wrote:

> So nevermind, connectbot will have to do for now unless someone has a
> cluestick to hand.
>

What gcc version was that?  Anyway...

openbsd-compat/openbsd-compat.h:217:22:
error: expected identifier or '(' before numeric constant
# define mblen(x, y) 1

The obvious thing to try would be to change that to:

# define mblen(x, y) (1)

(BTW [hidden email] is the best place to get help with
portable OpenSSH.  See http://www.openssh.com/report.html for details.)

--
Darren Tucker (dtucker at zip.com.au)
GPG key 8FF4FA69 / D9A3 86E9 7EEE AF4B B2D4  37C9 C982 80C7 8FF4 FA69
    Good judgement comes with experience. Unfortunately, the experience
usually comes from bad judgement.

Reply | Threaded
Open this post in threaded view
|

Re: OpenSSH and Android

Kevin Chadwick-4
On Fri, 8 May 2015 11:02:25 +1000
Darren Tucker wrote:

> What gcc version was that?  Anyway...
>

Using built-in specs.
COLLECT_GCC=/home/kc/lib/andtool/bin/arm-linux-androideabi-gcc
COLLECT_LTO_WRAPPER=/home/kc/lib/andtool/bin/../libexec/gcc/arm-linux-androideabi/4.8/lto-wrapper
Target: arm-linux-androideabi
Configured with: /s/ndk-toolchain/src/build/../gcc/gcc-4.8/configure
--prefix=/tmp/ndk-andrewhsieh/build/toolchain/prefix
--target=arm-linux-androideabi --host=x86_64-linux-gnu
--build=x86_64-linux-gnu --with-gnu-as --with-gnu-ld
--enable-languages=c,c++
--with-gmp=/tmp/ndk-andrewhsieh/build/toolchain/temp-install
--with-mpfr=/tmp/ndk-andrewhsieh/build/toolchain/temp-install
--with-mpc=/tmp/ndk-andrewhsieh/build/toolchain/temp-install
--with-cloog=/tmp/ndk-andrewhsieh/build/toolchain/temp-install
--with-isl=/tmp/ndk-andrewhsieh/build/toolchain/temp-install
--with-ppl=/tmp/ndk-andrewhsieh/build/toolchain/temp-install
--disable-ppl-version-check --disable-cloog-version-check
--disable-isl-version-check --enable-cloog-backend=isl
--with-host-libstdcxx='-static-libgcc -Wl,-Bstatic,-lstdc++,-Bdynamic
-lm' --disable-libssp --enable-threads --disable-nls
--disable-libmudflap --disable-libgomp --disable-libstdc__-v3
--disable-sjlj-exceptions --disable-shared --disable-tls
--disable-libitm --with-float=soft --with-fpu=vfp --with-arch=armv5te
--enable-target-optspace --enable-initfini-array --disable-nls
--prefix=/tmp/ndk-andrewhsieh/build/toolchain/prefix
--with-sysroot=/tmp/ndk-andrewhsieh/build/toolchain/prefix/sysroot
--with-binutils-version=2.24 --with-mpfr-version=3.1.1
--with-mpc-version=1.0.1 --with-gmp-version=5.0.5
--with-gcc-version=4.8 --with-gdb-version=7.6
--with-python=/usr/local/google/home/andrewhsieh/mydroid/ndk/prebuilt/linux-x86_64/bin/python-config.sh
--with-gxx-include-dir=/tmp/ndk-andrewhsieh/build/toolchain/prefix/include/c++/4.8
--with-bugurl=http://source.android.com/source/report-bugs.html
--enable-languages=c,c++ --disable-bootstrap --enable-plugins
--enable-libgomp --disable-libsanitizer --enable-gold
--enable-graphite=yes --with-cloog-version=0.18.0
--with-isl-version=0.11.1 --enable-eh-frame-hdr-for-static
--with-arch=armv5te
--program-transform-name='s&^&arm-linux-androideabi-&'
--enable-gold=default Thread model: posix gcc version 4.8 (GCC)

> openbsd-compat/openbsd-compat.h:217:22:
> error: expected identifier or '(' before numeric constant
> # define mblen(x, y) 1
>
> The obvious thing to try would be to change that to:
>
> # define mblen(x, y) (1)
>

Didn't change the output at all

In case your interested, I've attached the config.logs for the openssh
compile fail with openssl and openssh configure fail with libressl.

> (BTW [hidden email] is the best place to get help with
> portable OpenSSH.  See http://www.openssh.com/report.html for details.)

Ok

[demime 1.01d removed an attachment of type text/x-log]

[demime 1.01d removed an attachment of type text/x-log]