OpenBSD5.3-beta, kernel panic : pf.conf with once option

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

OpenBSD5.3-beta, kernel panic : pf.conf with once option

Wesley MOUEDINE ASSABY
Hi,

I'm running :
kern.version=OpenBSD 5.3-beta (GENERIC) #33: Fri Feb 15 17:03:34 MST
2013
     [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC

2 network cards : bge0 and axe0

"pfctl -vf /etc/pf.conf" load the ruleset, but just after i do "telnet
hostname.on.internet 110" this on a workstation, i have a kernel panic
on my OpenBSD gateway :

uvm_fault(0xd0a51660,0x0, 0, 1) -> e
Kernel: page fault trap, code=0
Stopped at pf_purge_rule +0x11: mov 0x10(%ebx),%eax


my pf.conf :
------------
ports_tcp="{80 25 443 587 995 21}"
set skip on lo
match out on egress inet from bge0:network to any nat-to egress
block log all
pass out
pass in on bge0 inet proto icmp icmp-type echoreq
pass in on bge0 inet proto tcp from bge0:network to any port $ports_tcp
pass in on bge0 inet proto tcp from bge0:network to any port 110 once
pass in on bge0 inet proto udp from bge0:network to any port domain
pass in on bge0 inet proto tcp from bge0:network to any port 22

my dmesg :
-----------
OpenBSD 5.3-beta (GENERIC) #33: Fri Feb 15 17:03:34 MST 2013
     [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel(R) Pentium(R) M processor 1.73GHz ("GenuineIntel"
686-class) 1.73 GHz
cpu0:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,TM,PBE,NXE,EST,TM2,PERF
real mem  = 2137059328 (2038MB)
avail mem = 2091167744 (1994MB)
mainbus0 at root
bios0 at mainbus0: AT/286+ BIOS, date 05/30/05, BIOS32 rev. 0 @
0xfd5f0, SMBIOS rev. 2.3 @ 0xe71e0 (61 entries)
bios0: vendor FUJITSU // Phoenix Technologies Ltd. version "Version
1.05" date 05/30/2005
bios0: FUJITSU SIEMENS LIFEBOOK S7020
acpi0 at bios0: rev 0
acpi0: sleep states S0 S3 S4 S5
acpi0: tables DSDT FACP APIC SSDT SSDT SSDT SSDT MCFG BOOT
acpi0: wakeup devices PCIB(S4) UAR1(S3) MODM(S3) AZAL(S3) EXP1(S4)
EXP2(S4) LID_(S4)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: apic clock running at 133MHz
ioapic0 at mainbus0: apid 1 pa 0xfec00000, version 20, 24 pins
ioapic0: misconfigured as apic 0, remapped to apid 1
acpimcfg0 at acpi0 addr 0xe0000000, bus 0-6
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 6 (PCIB)
acpiprt2 at acpi0: bus 2 (EXP1)
acpiprt3 at acpi0: bus 3 (EXP2)
acpicpu0 at acpi0: C3, C2, PSS
acpibtn0 at acpi0: LID_
acpibtn1 at acpi0: PWRB
acpiac0 at acpi0: AC unit online
acpibat0 at acpi0: CMB1 model "CP191240 / CP191241" serial 1 type LION
oem "Fujitsu"
acpibat1 at acpi0: CMB2 not present
acpidock0 at acpi0: REPL not docked (0)
acpivideo0 at acpi0: GFX0
bios0: ROM list: 0xc0000/0xf200! 0xcf800/0x1000 0xd0800/0x1600
0xdc000/0x4000!
cpu0: Enhanced SpeedStep 1730 MHz: speeds: 1733, 1333, 1067, 800 MHz
pci0 at mainbus0 bus 0: configuration mode 1 (bios)
pchb0 at pci0 dev 0 function 0 "Intel 82915GM Host" rev 0x03
vga1 at pci0 dev 2 function 0 "Intel 82915GM Video" rev 0x03
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
intagp0 at vga1
agp0 at intagp0: aperture at 0xc0000000, size 0x10000000
inteldrm0 at vga1: apic 1 int 16
drm0 at inteldrm0
"Intel 82915GM Video" rev 0x03 at pci0 dev 2 function 1 not configured
azalia0 at pci0 dev 27 function 0 "Intel 82801FB HD Audio" rev 0x04:
msi
azalia0: codecs: Realtek ALC260, AT&T/Lucent/0x3026, using Realtek
ALC260
audio0 at azalia0
ppb0 at pci0 dev 28 function 0 "Intel 82801FB PCIE" rev 0x04: apic 1
int 17
pci1 at ppb0 bus 2
bge0 at pci1 dev 0 function 0 "Broadcom BCM5751M" rev 0x11, BCM5750 B1
(0x4101): apic 1 int 16, address 00:0b:5d:94:e3:23
brgphy0 at bge0 phy 1: BCM5750 10/100/1000baseT PHY, rev. 0
ppb1 at pci0 dev 28 function 1 "Intel 82801FB PCIE" rev 0x04: apic 1
int 16
pci2 at ppb1 bus 3
uhci0 at pci0 dev 29 function 0 "Intel 82801FB USB" rev 0x04: apic 1
int 23
uhci1 at pci0 dev 29 function 1 "Intel 82801FB USB" rev 0x04: apic 1
int 19
uhci2 at pci0 dev 29 function 2 "Intel 82801FB USB" rev 0x04: apic 1
int 18
uhci3 at pci0 dev 29 function 3 "Intel 82801FB USB" rev 0x04: apic 1
int 16
ehci0 at pci0 dev 29 function 7 "Intel 82801FB USB" rev 0x04: apic 1
int 23
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
ppb2 at pci0 dev 30 function 0 "Intel 82801BAM Hub-to-PCI" rev 0xd4
pci3 at ppb2 bus 6
cbb0 at pci3 dev 3 function 0 "O2 Micro OZ711MP1 CardBus" rev 0x20:
apic 1 int 16
iwi0 at pci3 dev 5 function 0 "Intel PRO/Wireless 2200BG" rev 0x05:
apic 1 int 18, address 00:13:ce:60:16:17
"TI TSB43AB21 FireWire" rev 0x00 at pci3 dev 6 function 0 not
configured
cardslot0 at cbb0 slot 0 flags 0
cardbus0 at cardslot0: bus 7 device 0 cacheline 0x0, lattimer 0x20
pcmcia0 at cardslot0
ichpcib0 at pci0 dev 31 function 0 "Intel 82801FBM LPC" rev 0x04: PM
disabled
pciide0 at pci0 dev 31 function 1 "Intel 82801FB IDE" rev 0x04: DMA,
channel 0 configured to compatibility, channel 1 configured to
compatibility
pciide0: channel 0 disabled (no drives)
pciide0: channel 1 ignored (disabled)
pciide1 at pci0 dev 31 function 2 "Intel 82801FBM SATA" rev 0x04: DMA,
channel 0 configured to native-PCI, channel 1 configured to native-PCI
pciide1: using apic 1 int 19 for native-PCI interrupt
wd0 at pciide1 channel 0 drive 0: <FUJITSU MHT2060BH>
wd0: 16-sector PIO, LBA48, 57231MB, 117210240 sectors
wd0(pciide1:0:0): using PIO mode 4, Ultra-DMA mode 5
ichiic0 at pci0 dev 31 function 3 "Intel 82801FB SMBus" rev 0x04: apic
1 int 19
iic0 at ichiic0
iic0: addr 0x19 00=00 01=00 02=00 03=00 04=00 05=00 06=00 07=00 08=00
09=00 0a=00 0b=00 0c=00 0d=00 0e=00 0f=00 10=00 11=20 24=00 b9=00 ba=00
words 00=0000 01=0000 02=0000 03=0000 04=0040 05=0000 06=0000 07=0000
usb1 at uhci0: USB revision 1.0
uhub1 at usb1 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb2 at uhci1: USB revision 1.0
uhub2 at usb2 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb3 at uhci2: USB revision 1.0
uhub3 at usb3 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb4 at uhci3: USB revision 1.0
uhub4 at usb4 "Intel UHCI root hub" rev 1.00/1.00 addr 1
isa0 at ichpcib0
isadma0 at isa0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
wsmouse1 at pms0 mux 0
pms0: Synaptics touchpad, firmware 5.9
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
mtrr: Pentium Pro MTRR support
axe0 at uhub0 port 1 configuration 1 interface 0 "ASIX Electronics
AX88772" rev 2.00/0.01 addr 2
axe0: AX88772, address 00:50:b6:0b:e2:61
ukphy0 at axe0 phy 16: Generic IEEE 802.3u media interface, rev. 1: OUI
0x000ec6, model 0x0006
uhidev0 at uhub2 port 1 configuration 1 interface 0 "LITEON Technology
USB Multimedia Keyboard" rev 1.10/1.01 addr 2
uhidev0: iclass 3/1
ukbd0 at uhidev0: 8 variable keys, 6 key codes
wskbd1 at ukbd0 mux 1
wskbd1: connecting to wsdisplay0
vscsi0 at root
scsibus0 at vscsi0: 256 targets
softraid0 at root
scsibus1 at softraid0: 256 targets
root on wd0a (39789e927a770239.a) swap on wd0b dump on wd0b

Thank you very much.

Cheers,

Wesley

Reply | Threaded
Open this post in threaded view
|

Re: OpenBSD5.3-beta, kernel panic : pf.conf with once option

Mike Belopuhov-5
On 22 February 2013 14:02, Wesley M.A. <[hidden email]> wrote:

> Hi,
>
> I'm running :
> kern.version=OpenBSD 5.3-beta (GENERIC) #33: Fri Feb 15 17:03:34 MST 2013
>     [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC
>
> 2 network cards : bge0 and axe0
>
> "pfctl -vf /etc/pf.conf" load the ruleset, but just after i do "telnet
> hostname.on.internet 110" this on a workstation, i have a kernel panic on my
> OpenBSD gateway :
>
> uvm_fault(0xd0a51660,0x0, 0, 1) -> e
> Kernel: page fault trap, code=0
> Stopped at pf_purge_rule +0x11: mov 0x10(%ebx),%eax
>
>
> my pf.conf :
> ------------
> ports_tcp="{80 25 443 587 995 21}"
> set skip on lo
> match out on egress inet from bge0:network to any nat-to egress
> block log all
> pass out
> pass in on bge0 inet proto icmp icmp-type echoreq
> pass in on bge0 inet proto tcp from bge0:network to any port $ports_tcp
> pass in on bge0 inet proto tcp from bge0:network to any port 110 once
> pass in on bge0 inet proto udp from bge0:network to any port domain
> pass in on bge0 inet proto tcp from bge0:network to any port 22
>

short answer: don't do that.  you have to use an anchor.

regarding the actual crash -- i'll look at it asap.

Reply | Threaded
Open this post in threaded view
|

Re: OpenBSD5.3-beta, kernel panic : pf.conf with once option

Wesley MOUEDINE ASSABY
Le 2013-02-22 21:41, Mike Belopuhov a écrit :

> short answer: don't do that.  you have to use an anchor.
>
> regarding the actual crash -- i'll look at it asap.


Thank you very much for your reply, your advice.

Wesley