OpenBSD 4.1 X.org and locale problem

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

OpenBSD 4.1 X.org and locale problem

Szymon Nowak
In last week I checked OpenBSD 4.1 from snapshot ane when I run xterm
   
  xterm -ls -fn -*-fixed-medium-*-*-*-*-130-*-*-*-*-iso8859-2
   
  I have in .profile
   
  LANG=pl_PL.ISO8859-2
  export=LANG
  LC_ALL=pl_PL.ISO8859-2
  export LC_ALL
   
  xterm tell me
   
  Locale not supported by Xlib locale set to C  
   
  What it is ?
   
  In OpenBSD 3.9/4.0 i have not this messages and polish keyboard works fine

 
---------------------------------
Need Mail bonding?
Go to the Yahoo! Mail Q&A for great tips from Yahoo! Answers users.

Reply | Threaded
Open this post in threaded view
|

Re: OpenBSD 4.1 X.org and locale problem

Christian Weisgerber
Szymon Nowak <[hidden email]> wrote:

> In last week I checked OpenBSD 4.1 from snapshot ane when I run xterm
>    
>   xterm -ls -fn -*-fixed-medium-*-*-*-*-130-*-*-*-*-iso8859-2
>    
>   I have in .profile
>    
>   LANG=pl_PL.ISO8859-2
>   export=LANG
>   LC_ALL=pl_PL.ISO8859-2
>   export LC_ALL
>    
>   xterm tell me
>    
>   Locale not supported by Xlib locale set to C  

I cannot reproduce this.

In fact, an xterm started this way certainly runs in ISO8859-2 mode
because it interprets the corresponding compose sequences (e.g. l-,
c', s' for certain Polish letters).

--
Christian "naddy" Weisgerber                          [hidden email]