OpenBSD 3.8+Mysql 5.0.16

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

OpenBSD 3.8+Mysql 5.0.16

Monah Baki
Hi all,

I'm installing mysql from source. I know this is an error that has been posted
several times:

# /usr/local/mysql/bin/mysql -V
/usr/local/mysql/bin/mysql: can't load library
'../libmysql/.libs/libmysqlclient.so.15.0'

# cd /usr/local/mysql/bin
# ./mysql -V
# ./mysql  Ver 14.12 Distrib 5.0.16, for unknown-openbsd3.8 (i386) using
EditLine wrapper


If I vi the mysql file in /usr/local/mysql/bin:

....SNIP.....
@_GLOBAL_OFFSET_TABLE_^@_ctype_^@strchr^@tgetstr^@tcsetattr^@vfprintf^@
sigprocmask^@../libmysql/.libs/libmysqlclient.so.15.0^@strcpy^@mysql_field_count
....SNIP.....


Does this mean libmysqlclient.so.15.0 is hardcoded and won't work unless
you're in the /usr/local/mysql/bin directory.
It works fine as long as long as you start the commands in the
/usr/local/mysql/bin directory, if you change directory then you get the error.



Thank you

Reply | Threaded
Open this post in threaded view
|

Re: OpenBSD 3.8+Mysql 5.0.16

Joe Barnett-2
Monah Baki wrote:

> Hi all,
>
> I'm installing mysql from source. I know this is an error that has been posted
> several times:
>
> # /usr/local/mysql/bin/mysql -V
> /usr/local/mysql/bin/mysql: can't load library
> '../libmysql/.libs/libmysqlclient.so.15.0'
>
> # cd /usr/local/mysql/bin
> # ./mysql -V
> # ./mysql  Ver 14.12 Distrib 5.0.16, for unknown-openbsd3.8 (i386) using
> EditLine wrapper
>
>
> If I vi the mysql file in /usr/local/mysql/bin:
>
> ....SNIP.....
> @_GLOBAL_OFFSET_TABLE_^@_ctype_^@strchr^@tgetstr^@tcsetattr^@vfprintf^@
> sigprocmask^@../libmysql/.libs/libmysqlclient.so.15.0^@strcpy^@mysql_field_count
> ....SNIP.....
>
>
> Does this mean libmysqlclient.so.15.0 is hardcoded and won't work unless
> you're in the /usr/local/mysql/bin directory.
> It works fine as long as long as you start the commands in the
> /usr/local/mysql/bin directory, if you change directory then you get the error.
>
>
>
> Thank you
>
>

I went ahead and did the same (installed 5.0.16 from source) and had
similar results, with the exception that even within the mysql/bin
directory I still receive that same error.

The daemon, however, runs well.

I have had good luck, however, with the 5.0.16 build available at
mysql.com.  It is labeled for OpenBSD 3.7, but runs well on my 3.8
box without modification.  Just a thought.

Good luck,

Joe