Odd wget --timeout behaviour

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Odd wget --timeout behaviour

Fabio Martins
Hi misc,

Playing with wget I am getting an odd behaviour related to --timeout

It takes about 7 minutes for the process to die inside a 6.9 VM (vmd)
and 2 minutes in real hardware running 6.8, both with internet down but
DNS resolving ok.

to reproduce (with internet not connected):

$ time wget --timeout=5 -q -O - https://www.url.com/test.php

my scenario is wget being called inside a script in a while loop, but
can be reproduced in the prompt as well:

---
inside vmd:
OpenBSD p2p69.my.domain 6.9 GENERIC#328 amd64


Every 2.0s: ps wwaxu | grep wget | egrep -v grep                        
                                                          Thu Feb 18
13:22:04 2021

support  61283  0.0  2.3  1800  5724 p1  S+      1:17PM    0:00.07 wget
--timeout=5 -q -O - https://www.bitstreet.com.br/ip.php

.. timeout expires after about 7 minutes (1:17 - 1:24) for new process
to appear (script)

Every 2.0s: ps wwaxu | grep wget | egrep -v grep                        
                                                          Thu Feb 18
13:24:19 2021

support  44021  0.0  2.3  1812  5764 p1  S+      1:24PM    0:00.07 wget
--timeout=5 -q -O - https://www.bitstreet.com.br/ip.php

real hardware:
OpenBSD laptop.my.domain 6.8 GENERIC.MP#4 amd64

laptop$ time wget --timeout=5 -q -O -
https://www.bitstreet.com.br/ip.php

     2m25.46s real     0m00.03s user     0m00.03s system
---
--
Fabio Martins
GPG: 0xCC59C123
Fingerprint: D06E 24DE 2A72 1BB3 A1A0  C790 E51E 33C4 CC59 C123