Missing Skylake i915 firmware and broken eMMC on HP Chromebook 13 G1

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Missing Skylake i915 firmware and broken eMMC on HP Chromebook 13 G1

Ben Pye
Hi,

I have been trying to get OpenBSD running on my HP Chromebook 13 G1. I
have been running -current from the latest snapshot and a custom built
GENERIC.MP kernel from the tip of cvs.

It seems most hardware is supported however critically the eMMC is not
working. The eMMC controller is detected and initially communicates with
the eMMC device however at some point during negotiation, after changing
the bus power level, all requests time out. In the dmesg output below I
have enabled SDHC_DEBUG and SDMMC_DEBUG in an attempt to identify the
issue. For reference, Linux and FreeBSD work fine with the eMMC
controller however both NetBSD and OpenBSD have the same issue - which
makes sense as they seem to share most of their mmc stacks.

Secondly fw_update does not seem to get the firmware required for the
i915 driver on this device. It uses a Skylake CPU and so requires the
Skylake firmware from
https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/tree/i915
, without this firmware attempting to start X will result in a black
screen.

Lastly I am running this device with a build of Coreboot + Tianocore.
This is functional from some point during boot however immediately after
boot the video output seems to be broken, I needed to set "machine gop
6" before booting the installer to get anything usable for it.

Thanks,
Ben

dmesg:
OpenBSD 6.4-current (GENERIC.MP) #14: Wed Nov  7 00:39:34 GMT 2018
    [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
real mem = 4171194368 (3977MB)
avail mem = 4035493888 (3848MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.7 @ 0x7ab46020 (14 entries)
bios0: vendor coreboot version "MrChromebox" date 08/27/2018
bios0: Google Chell
acpi0 at bios0: rev 2
acpi0: sleep states S0 S3 S5
acpi0: tables DSDT FACP SSDT MCFG TCPA APIC NHLT DMAR HPET BGRT
acpi0: wakeup devices LID0(S5) CREC(S5) WIFI(S3) D015(S3) XHCI(S3)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpimcfg0 at acpi0
acpimcfg0: addr 0xe0000000, bus 0-63
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel(R) Core(TM) m3-6Y30 CPU @ 0.90GHz, 898.23 MHz, 06-4e-03
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,3DNOWP,PERF,ITSC,FSGSBASE,SGX,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,MPX,RDSEED,ADX,SMAP,CLFLUSHOPT,PT,IBRS,IBPB,STIBP,L1DF,SSBD,SENSOR,ARAT,XSAVEOPT,XSAVEC,XGETBV1,XSAVES,MELTDOWN
cpu0: 256KB 64b/line 8-way L2 cache
cpu0: smt 0, core 0, package 0
mtrr: Pentium Pro MTRR support, 10 var ranges, 88 fixed ranges
cpu0: apic clock running at 23MHz
cpu0: mwait min=64, max=64, C-substates=0.2.1.2.4.1.1.1, IBE
cpu1 at mainbus0: apid 1 (application processor)
cpu1: Intel(R) Core(TM) m3-6Y30 CPU @ 0.90GHz, 997.67 MHz, 06-4e-03
cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,3DNOWP,PERF,ITSC,FSGSBASE,SGX,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,MPX,RDSEED,ADX,SMAP,CLFLUSHOPT,PT,IBRS,IBPB,STIBP,L1DF,SSBD,SENSOR,ARAT,XSAVEOPT,XSAVEC,XGETBV1,XSAVES,MELTDOWN
cpu1: 256KB 64b/line 8-way L2 cache
cpu1: smt 1, core 0, package 0
cpu2 at mainbus0: apid 3 (application processor)
cpu2: Intel(R) Core(TM) m3-6Y30 CPU @ 0.90GHz, 901.92 MHz, 06-4e-03
cpu2: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,3DNOWP,PERF,ITSC,FSGSBASE,SGX,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,MPX,RDSEED,ADX,SMAP,CLFLUSHOPT,PT,IBRS,IBPB,STIBP,L1DF,SSBD,SENSOR,ARAT,XSAVEOPT,XSAVEC,XGETBV1,XSAVES,MELTDOWN
cpu2: 256KB 64b/line 8-way L2 cache
cpu2: smt 1, core 1, package 0
cpu3 at mainbus0: apid 2 (application processor)
cpu3: Intel(R) Core(TM) m3-6Y30 CPU @ 0.90GHz, 897.90 MHz, 06-4e-03
cpu3: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,3DNOWP,PERF,ITSC,FSGSBASE,SGX,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,MPX,RDSEED,ADX,SMAP,CLFLUSHOPT,PT,IBRS,IBPB,STIBP,L1DF,SSBD,SENSOR,ARAT,XSAVEOPT,XSAVEC,XGETBV1,XSAVES,MELTDOWN
cpu3: 256KB 64b/line 8-way L2 cache
cpu3: smt 0, core 1, package 0
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 120 pins
acpihpet0 at acpi0: 23999999 Hz
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 1 (RP01)
acpiprt2 at acpi0: bus -1 (RP02)
acpiprt3 at acpi0: bus -1 (RP03)
acpiprt4 at acpi0: bus -1 (RP04)
acpiprt5 at acpi0: bus -1 (RP05)
acpiprt6 at acpi0: bus -1 (RP06)
acpiprt7 at acpi0: bus -1 (RP07)
acpiprt8 at acpi0: bus -1 (RP08)
acpiprt9 at acpi0: bus -1 (RP09)
acpiprt10 at acpi0: bus -1 (RP10)
acpiprt11 at acpi0: bus -1 (RP11)
acpiprt12 at acpi0: bus -1 (RP12)
acpiec0 at acpi0
acpicpu0 at acpi0: C3(200@151 mwait.1@0x33), C2(500@79 mwait.1@0x10), C1(1000@0 mwait.1@0x1)
acpicpu1 at acpi0: C3(200@151 mwait.1@0x33), C2(500@79 mwait.1@0x10), C1(1000@0 mwait.1@0x1)
acpicpu2 at acpi0: C3(200@151 mwait.1@0x33), C2(500@79 mwait.1@0x10), C1(1000@0 mwait.1@0x1)
acpicpu3 at acpi0: C3(200@151 mwait.1@0x33), C2(500@79 mwait.1@0x10), C1(1000@0 mwait.1@0x1)
acpipci0 at acpi0 PCI0: 0x00000000 0x00000011 0x00000001
"INT344B" at acpi0 not configured
acpicmos0 at acpi0
acpibtn0 at acpi0: LID0
acpiac0 at acpi0: AC unit online
acpibat0 at acpi0: BAT0 model "SD03045" serial 02C1 type LION oem "333-1C-"
"GOOG0004" at acpi0 not configured
"GOOG0003" at acpi0 not configured
"PNP0A05" at acpi0 not configured
tpm0 at acpi0: TPM_ addr 0xfed40000/0x5000: device 0x001b15d1 rev 0x10
"ELAN0000" at acpi0 not configured
"10508825" at acpi0 not configured
"INT343B" at acpi0 not configured
"INT343B" at acpi0 not configured
acpicbkbd0 at acpi0: KBLT
"INT3400" at acpi0 not configured
"INT3403" at acpi0 not configured
"INT3403" at acpi0 not configured
"INT3403" at acpi0 not configured
"INT3403" at acpi0 not configured
"INT3403" at acpi0 not configured
"BOOT0000" at acpi0 not configured
acpivideo0 at acpi0: GFX0
acpivout0 at acpivideo0: LCD_
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "Intel Core 6G Host" rev 0x08
inteldrm0 at pci0 dev 2 function 0 "Intel HD Graphics 515" rev 0x07
drm0 at inteldrm0
inteldrm0: msi
error: [drm:pid0:i915_firmware_load_error_print] *ERROR* failed to load firmware i915/skl_dmc_ver1.bin (-22)
error: [drm:pid0:i915_gem_init_hw] *ERROR* Failed to initialize GuC, error -8 (ignored)
inteldrm0: 3200x1800, 32bpp
wsdisplay0 at inteldrm0 mux 1: console (std, vt100 emulation)
wsdisplay0: screen 1-5 added (std, vt100 emulation)
"Intel Core 6G Thermal" rev 0x08 at pci0 dev 4 function 0 not configured
vendor "Intel", unknown product 0x1919 (class multimedia subclass miscellaneous, rev 0x01) at pci0 dev 5 function 0 not configured
"Intel Core GMM" rev 0x00 at pci0 dev 8 function 0 not configured
xhci0 at pci0 dev 20 function 0 "Intel 100 Series xHCI" rev 0x21: msi, xHCI 1.0
usb0 at xhci0: USB revision 3.0
uhub0 at usb0 configuration 1 interface 0 "Intel xHCI root hub" rev 3.00/1.00 addr 1
pchtemp0 at pci0 dev 20 function 2 "Intel 100 Series Thermal" rev 0x21
dwiic0 at pci0 dev 21 function 0 "Intel 100 Series I2C" rev 0x21: apic 2 int 16
iic0 at dwiic0
dwiic1 at pci0 dev 21 function 1 "Intel 100 Series I2C" rev 0x21: apic 2 int 17
iic1 at dwiic1
"ELAN0000" at iic1 addr 0x15 not configured
"Intel 100 Series I2C" rev 0x21 at pci0 dev 25 function 0 not configured
"Intel 100 Series I2C" rev 0x21 at pci0 dev 25 function 2 not configured
ppb0 at pci0 dev 28 function 0 "Intel 100 Series PCIE" rev 0xf1: msi
pci1 at ppb0 bus 1
iwm0 at pci1 dev 0 function 0 "Intel Dual Band Wireless AC 7265" rev 0x59, msi
vendor "Intel", unknown product 0x9d27 (class DASP subclass miscellaneous, rev 0x21) at pci0 dev 30 function 0 not configured
sdhc0 at pci0 dev 30 function 4 vendor "Intel", unknown product 0x9d2b rev 0x21: apic 2 int 21
sdhc0: SD Host Specification/Vendor Version >1.0/16
sdhc0: software reset reg=0x1
sdhc0: SDHC 3.0, 200 MHz base clock
sdmmc0 at sdhc0: 8-bit, sd high-speed, mmc high-speed, dma
0x24 PRESENT_STATE:    1fff0000<CL,D3L,D2L,D1L,D0L,WPS,CD,CSS,CI>
0x29 POWER_CTL:        0
0x30 NINTR_STATUS:     0
0x32 EINTR_STATUS:     0
0x34 NINTR_STATUS_EN:  ff
0x36 EINTR_STATUS_EN:  3ff
0x38 NINTR_SIGNAL_EN:  ff
0x3a EINTR_SIGNAL_EN:  3ff
0x40 CAPABILITIES:     546ec881
0x48 MAX_CAPABILITIES: 0
pcib0 at pci0 dev 31 function 0 "Intel 100 Series LPC" rev 0x21
"Intel 100 Series PMC" rev 0x21 at pci0 dev 31 function 2 not configured
"Intel 100 Series HD Audio" rev 0x21 at pci0 dev 31 function 3 not configured
ichiic0 at pci0 dev 31 function 4 "Intel 100 Series SMBus" rev 0x21: apic 2 int 16
iic2 at ichiic0
iic2: addr 0x24 03=04 09=38 0a=57 0c=04 0d=07 0e=11 0f=18 words 00=00ff 01=00ff 02=00ff 03=04ff 04=00ff 05=00ff 06=00ff 07=00ff
"Intel 100 Series SPI" rev 0x21 at pci0 dev 31 function 5 not configured
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5 irq 1 irq 12
pckbd0 at pckbc0 (kbd slot)
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
vmm0 at mainbus0: VMX/EPT
efifb at mainbus0 not configured
sdmmc0: attach card
0x24 PRESENT_STATE:    1fff0000<CL,D3L,D2L,D1L,D0L,WPS,CD,CSS,CI>
0x29 POWER_CTL:        b
0x30 NINTR_STATUS:     0
0x32 EINTR_STATUS:     0
0x34 NINTR_STATUS_EN:  ff
0x36 EINTR_STATUS_EN:  3ff
0x38 NINTR_SIGNAL_EN:  ff
0x3a EINTR_SIGNAL_EN:  3ff
0x40 CAPABILITIES:     546ec881
0x48 MAX_CAPABILITIES: 0
sdhc0: start cmd 52 arg=0x80000c08 data=0x0 dlen=0 flags=0x1c00 proc="sdmmc0"
sdhc0: cmd=0x341a mode=0 blksize=0 blkcount=0
sdhc0: interrupt status=8000<ERROR>
sdhc0: error interrupt, status=1<CT>
sdhc0: intr status 0x8000 error 0x1
sdhc0: software reset reg=0x6
sdmmc0: cmd 52 arg=0x80000c08 data=0x0 dlen=0 flags=0x1c01 proc="sdmmc0" (error 60)
sdhc0: start cmd 5 arg=0 data=0x0 dlen=0 flags=0x1030 proc="sdmmc0"
sdhc0: cmd=0x502 mode=0 blksize=0 blkcount=0
sdhc0: interrupt status=8000<ERROR>
sdhc0: error interrupt, status=1<CT>
sdhc0: intr status 0x8000 error 0x1
sdhc0: software reset reg=0x6
sdmmc0: cmd 5 arg=0 data=0x0 dlen=0 flags=0x1031 proc="sdmmc0" (error 60)
sdhc0: start cmd 0 arg=0 data=0x0 dlen=0 flags=0x20 proc="sdmmc0"
sdhc0: cmd=0 mode=0 blksize=0 blkcount=0
sdhc0: interrupt status=1<CMD>
sdhc0: intr status 0x1 error 0
sdhc0: cmd 0 done (flags=0x20 error=0)
sdmmc0: cmd 0 arg=0 data=0x0 dlen=0 flags=0x21 proc="sdmmc0" (error 0)
sdmmc0: resp=
sdhc0: start cmd 55 arg=0 data=0x0 dlen=0 flags=0x1c00 proc="sdmmc0"
sdhc0: cmd=0x371a mode=0 blksize=0 blkcount=0
sdhc0: interrupt status=8000<ERROR>
sdhc0: error interrupt, status=1<CT>
sdhc0: intr status 0x8000 error 0x1
sdhc0: software reset reg=0x6
sdmmc0: cmd 55 arg=0 data=0x0 dlen=0 flags=0x1c01 proc="sdmmc0" (error 60)
sdhc0: start cmd 1 arg=0x40000000 data=0x0 dlen=0 flags=0x1030 proc="sdmmc0"
sdhc0: cmd=0x102 mode=0 blksize=0 blkcount=0
sdhc0: interrupt status=1<CMD>
sdhc0: intr status 0x1 error 0
sdhc0: cmd 1 done (flags=0x1030 error=0)
sdmmc0: cmd 1 arg=0x40000000 data=0x0 dlen=0 flags=0x1031 proc="sdmmc0" (error 0)
sdmmc0: resp=80 80 ff 40
sdmmc0: host_ocr=80 card_ocr=40ff8080 new_ocr=80
0x24 PRESENT_STATE:    1fff0000<CL,D3L,D2L,D1L,D0L,WPS,CD,CSS,CI>
0x29 POWER_CTL:        b
0x30 NINTR_STATUS:     0
0x32 EINTR_STATUS:     0
0x34 NINTR_STATUS_EN:  ff
0x36 EINTR_STATUS_EN:  3ff
0x38 NINTR_SIGNAL_EN:  ff
0x3a EINTR_SIGNAL_EN:  3ff
0x40 CAPABILITIES:     546ec881
0x48 MAX_CAPABILITIES: 0
sdhc0: start cmd 0 arg=0 data=0x0 dlen=0 flags=0x20 proc="sdmmc0"
sdhc0: cmd=0 mode=0 blksize=0 blkcount=0
ugen0 at uhub0 port 3 "Intel Bluetooth" rev 2.00/0.03 addr 2
uhub1 at uhub0 port 5 configuration 1 interface 0 "VIA Labs, Inc. USB2.0 Hub" rev 2.10/b.e0 addr 3
sdhc0: intr status 0x8000 error 0
sdhc0: software reset reg=0x6
sdmmc0: cmd 0 arg=0 data=0x0 dlen=0 flags=0x21 proc="sdmmc0" (error 60)
sdhc0: start cmd 8 arg=0x123 data=0x0 dlen=0 flags=0x1c30 proc="sdmmc0"
sdhc0: cmd=0x81a mode=0 blksize=0 blkcount=0
uvideo0 at uhub0 port 7 configuration 1 interface 0 "Generic HP Truevision HD" rev 2.00/0.06 addr 4
video0 at uvideo0
sdhc0: intr status 0x8000 error 0
sdhc0: software reset reg=0x6
sdmmc0: cmd 8 arg=0x123 data=0x0 dlen=0 flags=0x1c31 proc="sdmmc0" (error 60)
sdhc0: start cmd 1 arg=0x40000080 data=0x0 dlen=0 flags=0x1030 proc="sdmmc0"
sdhc0: cmd=0x102 mode=0 blksize=0 blkcount=0
uhub2 at uhub0 port 15 configuration 1 interface 0 "VIA Labs, Inc. USB3.0 Hub" rev 3.00/b.e1 addr 5
sdhc0: intr status 0x8000 error 0
sdhc0: software reset reg=0x6
sdmmc0: cmd 1 arg=0x40000080 data=0x0 dlen=0 flags=0x1031 proc="sdmmc0" (error 60)
sdmmc0: can't send memory OCR
sdhc0: software reset reg=0x1
sdmmc0: can't enable card
sdmmc0: detach card
sdhc0: software reset reg=0x1
ure0 at uhub2 port 4 configuration 1 interface 0 "Realtek USB 10/100/1000 LAN" rev 3.00/30.00 addr 6
ure0: ver 5c10, address f0:1e:34:1f:f7:6c
rgephy0 at ure0 phy 0: RTL8251 PHY, rev. 0
umass0 at uhub0 port 16 configuration 1 interface 0 "Generic USB Storage" rev 3.00/8.19 addr 7
umass0: using SCSI over Bulk-Only
scsibus1 at umass0: 2 targets, initiator 0
sd0 at scsibus1 targ 1 lun 0: <Generic, STORAGE DEVICE, 0819> SCSI4 0/direct removable serial.05e30747000000000819
sd0: 29476MB, 512 bytes/sector, 60367872 sectors
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
root on sd0a (18be884962bd458c.a) swap on sd0b dump on sd0b
iwm0: hw rev 0x210, fw ver 16.242414.0, address 4c:80:93:ba:52:98

Reply | Threaded
Open this post in threaded view
|

Re: Missing Skylake i915 firmware and broken eMMC on HP Chromebook 13 G1

Ben Pye
> Lastly I am running this device with a build of Coreboot + Tianocore.
> This is functional from some point during boot however immediately after
> boot the video output seems to be broken, I needed to set "machine gop
> 6" before booting the installer to get anything usable for it.

I forgot to mention, with regard to the framebuffer issue it seems to be a
regression between OpenBSD 5.9 and OpenBSD 6.0 as I attempted to
bisect the issue. I haven't managed to narrow it down any further than
that though.

Ben.

Reply | Threaded
Open this post in threaded view
|

Re: Missing Skylake i915 firmware and broken eMMC on HP Chromebook 13 G1

Jonathan Gray-11
In reply to this post by Ben Pye
On Wed, Nov 07, 2018 at 01:13:54AM +0000, Ben Pye wrote:

> Hi,
>
> I have been trying to get OpenBSD running on my HP Chromebook 13 G1. I
> have been running -current from the latest snapshot and a custom built
> GENERIC.MP kernel from the tip of cvs.
>
> It seems most hardware is supported however critically the eMMC is not
> working. The eMMC controller is detected and initially communicates with
> the eMMC device however at some point during negotiation, after changing
> the bus power level, all requests time out. In the dmesg output below I
> have enabled SDHC_DEBUG and SDMMC_DEBUG in an attempt to identify the
> issue. For reference, Linux and FreeBSD work fine with the eMMC
> controller however both NetBSD and OpenBSD have the same issue - which
> makes sense as they seem to share most of their mmc stacks.
>
> Secondly fw_update does not seem to get the firmware required for the
> i915 driver on this device. It uses a Skylake CPU and so requires the
> Skylake firmware from
> https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/tree/i915
> , without this firmware attempting to start X will result in a black
> screen.

The i915 firmware is not packaged and inteldrm does not try to load it if
it is present.  As you are using a replacement firmware it seems likely
it does not provide vbt and opregion properly.

>
> Lastly I am running this device with a build of Coreboot + Tianocore.
> This is functional from some point during boot however immediately after
> boot the video output seems to be broken, I needed to set "machine gop
> 6" before booting the installer to get anything usable for it.
>
> Thanks,
> Ben
>
> dmesg:
> OpenBSD 6.4-current (GENERIC.MP) #14: Wed Nov  7 00:39:34 GMT 2018
>     [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
> real mem = 4171194368 (3977MB)
> avail mem = 4035493888 (3848MB)
> mpath0 at root
> scsibus0 at mpath0: 256 targets
> mainbus0 at root
> bios0 at mainbus0: SMBIOS rev. 2.7 @ 0x7ab46020 (14 entries)
> bios0: vendor coreboot version "MrChromebox" date 08/27/2018
> bios0: Google Chell
> acpi0 at bios0: rev 2
> acpi0: sleep states S0 S3 S5
> acpi0: tables DSDT FACP SSDT MCFG TCPA APIC NHLT DMAR HPET BGRT
> acpi0: wakeup devices LID0(S5) CREC(S5) WIFI(S3) D015(S3) XHCI(S3)
> acpitimer0 at acpi0: 3579545 Hz, 24 bits
> acpimcfg0 at acpi0
> acpimcfg0: addr 0xe0000000, bus 0-63
> acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
> cpu0 at mainbus0: apid 0 (boot processor)
> cpu0: Intel(R) Core(TM) m3-6Y30 CPU @ 0.90GHz, 898.23 MHz, 06-4e-03
> cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,3DNOWP,PERF,ITSC,FSGSBASE,SGX,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,MPX,RDSEED,ADX,SMAP,CLFLUSHOPT,PT,IBRS,IBPB,STIBP,L1DF,SSBD,SENSOR,ARAT,XSAVEOPT,XSAVEC,XGETBV1,XSAVES,MELTDOWN
> cpu0: 256KB 64b/line 8-way L2 cache
> cpu0: smt 0, core 0, package 0
> mtrr: Pentium Pro MTRR support, 10 var ranges, 88 fixed ranges
> cpu0: apic clock running at 23MHz
> cpu0: mwait min=64, max=64, C-substates=0.2.1.2.4.1.1.1, IBE
> cpu1 at mainbus0: apid 1 (application processor)
> cpu1: Intel(R) Core(TM) m3-6Y30 CPU @ 0.90GHz, 997.67 MHz, 06-4e-03
> cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,3DNOWP,PERF,ITSC,FSGSBASE,SGX,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,MPX,RDSEED,ADX,SMAP,CLFLUSHOPT,PT,IBRS,IBPB,STIBP,L1DF,SSBD,SENSOR,ARAT,XSAVEOPT,XSAVEC,XGETBV1,XSAVES,MELTDOWN
> cpu1: 256KB 64b/line 8-way L2 cache
> cpu1: smt 1, core 0, package 0
> cpu2 at mainbus0: apid 3 (application processor)
> cpu2: Intel(R) Core(TM) m3-6Y30 CPU @ 0.90GHz, 901.92 MHz, 06-4e-03
> cpu2: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,3DNOWP,PERF,ITSC,FSGSBASE,SGX,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,MPX,RDSEED,ADX,SMAP,CLFLUSHOPT,PT,IBRS,IBPB,STIBP,L1DF,SSBD,SENSOR,ARAT,XSAVEOPT,XSAVEC,XGETBV1,XSAVES,MELTDOWN
> cpu2: 256KB 64b/line 8-way L2 cache
> cpu2: smt 1, core 1, package 0
> cpu3 at mainbus0: apid 2 (application processor)
> cpu3: Intel(R) Core(TM) m3-6Y30 CPU @ 0.90GHz, 897.90 MHz, 06-4e-03
> cpu3: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,3DNOWP,PERF,ITSC,FSGSBASE,SGX,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,MPX,RDSEED,ADX,SMAP,CLFLUSHOPT,PT,IBRS,IBPB,STIBP,L1DF,SSBD,SENSOR,ARAT,XSAVEOPT,XSAVEC,XGETBV1,XSAVES,MELTDOWN
> cpu3: 256KB 64b/line 8-way L2 cache
> cpu3: smt 0, core 1, package 0
> ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 120 pins
> acpihpet0 at acpi0: 23999999 Hz
> acpiprt0 at acpi0: bus 0 (PCI0)
> acpiprt1 at acpi0: bus 1 (RP01)
> acpiprt2 at acpi0: bus -1 (RP02)
> acpiprt3 at acpi0: bus -1 (RP03)
> acpiprt4 at acpi0: bus -1 (RP04)
> acpiprt5 at acpi0: bus -1 (RP05)
> acpiprt6 at acpi0: bus -1 (RP06)
> acpiprt7 at acpi0: bus -1 (RP07)
> acpiprt8 at acpi0: bus -1 (RP08)
> acpiprt9 at acpi0: bus -1 (RP09)
> acpiprt10 at acpi0: bus -1 (RP10)
> acpiprt11 at acpi0: bus -1 (RP11)
> acpiprt12 at acpi0: bus -1 (RP12)
> acpiec0 at acpi0
> acpicpu0 at acpi0: C3(200@151 mwait.1@0x33), C2(500@79 mwait.1@0x10), C1(1000@0 mwait.1@0x1)
> acpicpu1 at acpi0: C3(200@151 mwait.1@0x33), C2(500@79 mwait.1@0x10), C1(1000@0 mwait.1@0x1)
> acpicpu2 at acpi0: C3(200@151 mwait.1@0x33), C2(500@79 mwait.1@0x10), C1(1000@0 mwait.1@0x1)
> acpicpu3 at acpi0: C3(200@151 mwait.1@0x33), C2(500@79 mwait.1@0x10), C1(1000@0 mwait.1@0x1)
> acpipci0 at acpi0 PCI0: 0x00000000 0x00000011 0x00000001
> "INT344B" at acpi0 not configured
> acpicmos0 at acpi0
> acpibtn0 at acpi0: LID0
> acpiac0 at acpi0: AC unit online
> acpibat0 at acpi0: BAT0 model "SD03045" serial 02C1 type LION oem "333-1C-"
> "GOOG0004" at acpi0 not configured
> "GOOG0003" at acpi0 not configured
> "PNP0A05" at acpi0 not configured
> tpm0 at acpi0: TPM_ addr 0xfed40000/0x5000: device 0x001b15d1 rev 0x10
> "ELAN0000" at acpi0 not configured
> "10508825" at acpi0 not configured
> "INT343B" at acpi0 not configured
> "INT343B" at acpi0 not configured
> acpicbkbd0 at acpi0: KBLT
> "INT3400" at acpi0 not configured
> "INT3403" at acpi0 not configured
> "INT3403" at acpi0 not configured
> "INT3403" at acpi0 not configured
> "INT3403" at acpi0 not configured
> "INT3403" at acpi0 not configured
> "BOOT0000" at acpi0 not configured
> acpivideo0 at acpi0: GFX0
> acpivout0 at acpivideo0: LCD_
> pci0 at mainbus0 bus 0
> pchb0 at pci0 dev 0 function 0 "Intel Core 6G Host" rev 0x08
> inteldrm0 at pci0 dev 2 function 0 "Intel HD Graphics 515" rev 0x07
> drm0 at inteldrm0
> inteldrm0: msi
> error: [drm:pid0:i915_firmware_load_error_print] *ERROR* failed to load firmware i915/skl_dmc_ver1.bin (-22)
> error: [drm:pid0:i915_gem_init_hw] *ERROR* Failed to initialize GuC, error -8 (ignored)
> inteldrm0: 3200x1800, 32bpp
> wsdisplay0 at inteldrm0 mux 1: console (std, vt100 emulation)
> wsdisplay0: screen 1-5 added (std, vt100 emulation)
> "Intel Core 6G Thermal" rev 0x08 at pci0 dev 4 function 0 not configured
> vendor "Intel", unknown product 0x1919 (class multimedia subclass miscellaneous, rev 0x01) at pci0 dev 5 function 0 not configured
> "Intel Core GMM" rev 0x00 at pci0 dev 8 function 0 not configured
> xhci0 at pci0 dev 20 function 0 "Intel 100 Series xHCI" rev 0x21: msi, xHCI 1.0
> usb0 at xhci0: USB revision 3.0
> uhub0 at usb0 configuration 1 interface 0 "Intel xHCI root hub" rev 3.00/1.00 addr 1
> pchtemp0 at pci0 dev 20 function 2 "Intel 100 Series Thermal" rev 0x21
> dwiic0 at pci0 dev 21 function 0 "Intel 100 Series I2C" rev 0x21: apic 2 int 16
> iic0 at dwiic0
> dwiic1 at pci0 dev 21 function 1 "Intel 100 Series I2C" rev 0x21: apic 2 int 17
> iic1 at dwiic1
> "ELAN0000" at iic1 addr 0x15 not configured
> "Intel 100 Series I2C" rev 0x21 at pci0 dev 25 function 0 not configured
> "Intel 100 Series I2C" rev 0x21 at pci0 dev 25 function 2 not configured
> ppb0 at pci0 dev 28 function 0 "Intel 100 Series PCIE" rev 0xf1: msi
> pci1 at ppb0 bus 1
> iwm0 at pci1 dev 0 function 0 "Intel Dual Band Wireless AC 7265" rev 0x59, msi
> vendor "Intel", unknown product 0x9d27 (class DASP subclass miscellaneous, rev 0x21) at pci0 dev 30 function 0 not configured
> sdhc0 at pci0 dev 30 function 4 vendor "Intel", unknown product 0x9d2b rev 0x21: apic 2 int 21
> sdhc0: SD Host Specification/Vendor Version >1.0/16
> sdhc0: software reset reg=0x1
> sdhc0: SDHC 3.0, 200 MHz base clock
> sdmmc0 at sdhc0: 8-bit, sd high-speed, mmc high-speed, dma
> 0x24 PRESENT_STATE:    1fff0000<CL,D3L,D2L,D1L,D0L,WPS,CD,CSS,CI>
> 0x29 POWER_CTL:        0
> 0x30 NINTR_STATUS:     0
> 0x32 EINTR_STATUS:     0
> 0x34 NINTR_STATUS_EN:  ff
> 0x36 EINTR_STATUS_EN:  3ff
> 0x38 NINTR_SIGNAL_EN:  ff
> 0x3a EINTR_SIGNAL_EN:  3ff
> 0x40 CAPABILITIES:     546ec881
> 0x48 MAX_CAPABILITIES: 0
> pcib0 at pci0 dev 31 function 0 "Intel 100 Series LPC" rev 0x21
> "Intel 100 Series PMC" rev 0x21 at pci0 dev 31 function 2 not configured
> "Intel 100 Series HD Audio" rev 0x21 at pci0 dev 31 function 3 not configured
> ichiic0 at pci0 dev 31 function 4 "Intel 100 Series SMBus" rev 0x21: apic 2 int 16
> iic2 at ichiic0
> iic2: addr 0x24 03=04 09=38 0a=57 0c=04 0d=07 0e=11 0f=18 words 00=00ff 01=00ff 02=00ff 03=04ff 04=00ff 05=00ff 06=00ff 07=00ff
> "Intel 100 Series SPI" rev 0x21 at pci0 dev 31 function 5 not configured
> isa0 at pcib0
> isadma0 at isa0
> pckbc0 at isa0 port 0x60/5 irq 1 irq 12
> pckbd0 at pckbc0 (kbd slot)
> wskbd0 at pckbd0: console keyboard, using wsdisplay0
> pcppi0 at isa0 port 0x61
> spkr0 at pcppi0
> vmm0 at mainbus0: VMX/EPT
> efifb at mainbus0 not configured
> sdmmc0: attach card
> 0x24 PRESENT_STATE:    1fff0000<CL,D3L,D2L,D1L,D0L,WPS,CD,CSS,CI>
> 0x29 POWER_CTL:        b
> 0x30 NINTR_STATUS:     0
> 0x32 EINTR_STATUS:     0
> 0x34 NINTR_STATUS_EN:  ff
> 0x36 EINTR_STATUS_EN:  3ff
> 0x38 NINTR_SIGNAL_EN:  ff
> 0x3a EINTR_SIGNAL_EN:  3ff
> 0x40 CAPABILITIES:     546ec881
> 0x48 MAX_CAPABILITIES: 0
> sdhc0: start cmd 52 arg=0x80000c08 data=0x0 dlen=0 flags=0x1c00 proc="sdmmc0"
> sdhc0: cmd=0x341a mode=0 blksize=0 blkcount=0
> sdhc0: interrupt status=8000<ERROR>
> sdhc0: error interrupt, status=1<CT>
> sdhc0: intr status 0x8000 error 0x1
> sdhc0: software reset reg=0x6
> sdmmc0: cmd 52 arg=0x80000c08 data=0x0 dlen=0 flags=0x1c01 proc="sdmmc0" (error 60)
> sdhc0: start cmd 5 arg=0 data=0x0 dlen=0 flags=0x1030 proc="sdmmc0"
> sdhc0: cmd=0x502 mode=0 blksize=0 blkcount=0
> sdhc0: interrupt status=8000<ERROR>
> sdhc0: error interrupt, status=1<CT>
> sdhc0: intr status 0x8000 error 0x1
> sdhc0: software reset reg=0x6
> sdmmc0: cmd 5 arg=0 data=0x0 dlen=0 flags=0x1031 proc="sdmmc0" (error 60)
> sdhc0: start cmd 0 arg=0 data=0x0 dlen=0 flags=0x20 proc="sdmmc0"
> sdhc0: cmd=0 mode=0 blksize=0 blkcount=0
> sdhc0: interrupt status=1<CMD>
> sdhc0: intr status 0x1 error 0
> sdhc0: cmd 0 done (flags=0x20 error=0)
> sdmmc0: cmd 0 arg=0 data=0x0 dlen=0 flags=0x21 proc="sdmmc0" (error 0)
> sdmmc0: resp=
> sdhc0: start cmd 55 arg=0 data=0x0 dlen=0 flags=0x1c00 proc="sdmmc0"
> sdhc0: cmd=0x371a mode=0 blksize=0 blkcount=0
> sdhc0: interrupt status=8000<ERROR>
> sdhc0: error interrupt, status=1<CT>
> sdhc0: intr status 0x8000 error 0x1
> sdhc0: software reset reg=0x6
> sdmmc0: cmd 55 arg=0 data=0x0 dlen=0 flags=0x1c01 proc="sdmmc0" (error 60)
> sdhc0: start cmd 1 arg=0x40000000 data=0x0 dlen=0 flags=0x1030 proc="sdmmc0"
> sdhc0: cmd=0x102 mode=0 blksize=0 blkcount=0
> sdhc0: interrupt status=1<CMD>
> sdhc0: intr status 0x1 error 0
> sdhc0: cmd 1 done (flags=0x1030 error=0)
> sdmmc0: cmd 1 arg=0x40000000 data=0x0 dlen=0 flags=0x1031 proc="sdmmc0" (error 0)
> sdmmc0: resp=80 80 ff 40
> sdmmc0: host_ocr=80 card_ocr=40ff8080 new_ocr=80
> 0x24 PRESENT_STATE:    1fff0000<CL,D3L,D2L,D1L,D0L,WPS,CD,CSS,CI>
> 0x29 POWER_CTL:        b
> 0x30 NINTR_STATUS:     0
> 0x32 EINTR_STATUS:     0
> 0x34 NINTR_STATUS_EN:  ff
> 0x36 EINTR_STATUS_EN:  3ff
> 0x38 NINTR_SIGNAL_EN:  ff
> 0x3a EINTR_SIGNAL_EN:  3ff
> 0x40 CAPABILITIES:     546ec881
> 0x48 MAX_CAPABILITIES: 0
> sdhc0: start cmd 0 arg=0 data=0x0 dlen=0 flags=0x20 proc="sdmmc0"
> sdhc0: cmd=0 mode=0 blksize=0 blkcount=0
> ugen0 at uhub0 port 3 "Intel Bluetooth" rev 2.00/0.03 addr 2
> uhub1 at uhub0 port 5 configuration 1 interface 0 "VIA Labs, Inc. USB2.0 Hub" rev 2.10/b.e0 addr 3
> sdhc0: intr status 0x8000 error 0
> sdhc0: software reset reg=0x6
> sdmmc0: cmd 0 arg=0 data=0x0 dlen=0 flags=0x21 proc="sdmmc0" (error 60)
> sdhc0: start cmd 8 arg=0x123 data=0x0 dlen=0 flags=0x1c30 proc="sdmmc0"
> sdhc0: cmd=0x81a mode=0 blksize=0 blkcount=0
> uvideo0 at uhub0 port 7 configuration 1 interface 0 "Generic HP Truevision HD" rev 2.00/0.06 addr 4
> video0 at uvideo0
> sdhc0: intr status 0x8000 error 0
> sdhc0: software reset reg=0x6
> sdmmc0: cmd 8 arg=0x123 data=0x0 dlen=0 flags=0x1c31 proc="sdmmc0" (error 60)
> sdhc0: start cmd 1 arg=0x40000080 data=0x0 dlen=0 flags=0x1030 proc="sdmmc0"
> sdhc0: cmd=0x102 mode=0 blksize=0 blkcount=0
> uhub2 at uhub0 port 15 configuration 1 interface 0 "VIA Labs, Inc. USB3.0 Hub" rev 3.00/b.e1 addr 5
> sdhc0: intr status 0x8000 error 0
> sdhc0: software reset reg=0x6
> sdmmc0: cmd 1 arg=0x40000080 data=0x0 dlen=0 flags=0x1031 proc="sdmmc0" (error 60)
> sdmmc0: can't send memory OCR
> sdhc0: software reset reg=0x1
> sdmmc0: can't enable card
> sdmmc0: detach card
> sdhc0: software reset reg=0x1
> ure0 at uhub2 port 4 configuration 1 interface 0 "Realtek USB 10/100/1000 LAN" rev 3.00/30.00 addr 6
> ure0: ver 5c10, address f0:1e:34:1f:f7:6c
> rgephy0 at ure0 phy 0: RTL8251 PHY, rev. 0
> umass0 at uhub0 port 16 configuration 1 interface 0 "Generic USB Storage" rev 3.00/8.19 addr 7
> umass0: using SCSI over Bulk-Only
> scsibus1 at umass0: 2 targets, initiator 0
> sd0 at scsibus1 targ 1 lun 0: <Generic, STORAGE DEVICE, 0819> SCSI4 0/direct removable serial.05e30747000000000819
> sd0: 29476MB, 512 bytes/sector, 60367872 sectors
> vscsi0 at root
> scsibus2 at vscsi0: 256 targets
> softraid0 at root
> scsibus3 at softraid0: 256 targets
> root on sd0a (18be884962bd458c.a) swap on sd0b dump on sd0b
> iwm0: hw rev 0x210, fw ver 16.242414.0, address 4c:80:93:ba:52:98
>

Reply | Threaded
Open this post in threaded view
|

Re: Missing Skylake i915 firmware and broken eMMC on HP Chromebook 13 G1

Ben Pye


>The i915 firmware is not packaged and inteldrm does not try to load it
>if
>it is present.  As you are using a replacement firmware it seems likely
>it does not provide vbt and opregion properly.

Ah okay, I will have to investigate that further. To be specific the screen goes black and the backlight actually turns off, upon killing xenodm it comes back. It seems odd as again Linux appears to work fine and supposedly Windows will run happily as well though I haven't tried that myself.

Reply | Threaded
Open this post in threaded view
|

Re: Missing Skylake i915 firmware and broken eMMC on HP Chromebook 13 G1

Jonathan Gray-11
On Wed, Nov 07, 2018 at 02:29:25AM +0000, Ben Pye wrote:
>
>
> >The i915 firmware is not packaged and inteldrm does not try to load it
> >if
> >it is present.  As you are using a replacement firmware it seems likely
> >it does not provide vbt and opregion properly.
>
> Ah okay, I will have to investigate that further. To be specific the screen goes black and the backlight actually turns off, upon killing xenodm it comes back. It seems odd as again Linux appears to work fine and supposedly Windows will run happily as well though I haven't tried that myself.
>

If you can go back to the firmware it came with that would be an
interesting comparison.

Reply | Threaded
Open this post in threaded view
|

Re: Missing Skylake i915 firmware and broken eMMC on HP Chromebook 13 G1

Ben Pye
>> Ah okay, I will have to investigate that further. To be specific the screen goes black and the backlight actually turns off, upon killing xenodm it comes back. It seems odd as again Linux appears to work fine and supposedly Windows will run happily as well though I haven't tried that myself.
>>
>
> If you can go back to the firmware it came with that would be an
> interesting comparison.
>

As it turns out this was user error. My backlight brightness defaulted
to 0% and so it appeared that the display wasn't working, increasing the
brightness with wsconsctl display.brightness=xx fixed it.