Midori (= Xfce's lightweight Webkit web browser) unstable in 6.4, anyone more test?

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Midori (= Xfce's lightweight Webkit web browser) unstable in 6.4, anyone more test?

Joseph Mayer
Hi,

Can anyone install and surf the web for 5 minutes with Midori and
confirm if they see any unstability in OpenBSD 6.4 AMD64?

Mine quickly crashes with:

"** (midori4:46726): CRITICAL **: 06:45:29.139: gboolean
webkit_web_view_get_tls_info(WebKitWebView *, GTlsCertificate **,
GTlsCertificateFlags *): assertion 'wkCertificateInfo' failed"

Midori is a lightweight WebKit-based web browser.

Joseph

Reply | Threaded
Open this post in threaded view
|

Re: Midori (= Xfce's lightweight Webkit web browser) unstable in 6.4, anyone more test?

Jim Anderson
‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Saturday, November 3, 2018 12:50 AM, Joseph Mayer <[hidden email]> wrote:

> Hi,
>
> Can anyone install and surf the web for 5 minutes with Midori and
> confirm if they see any unstability in OpenBSD 6.4 AMD64?
>
> Mine quickly crashes with:
>
> "** (midori4:46726): CRITICAL **: 06:45:29.139: gboolean
> webkit_web_view_get_tls_info(WebKitWebView *, GTlsCertificate **,
> GTlsCertificateFlags *): assertion 'wkCertificateInfo' failed"
>
> Midori is a lightweight WebKit-based web browser.
>
> Joseph


Joseph,

I am running OpenBSD 6.4 GENERIC#349 amd64 and saw the same issue. The
browser always opened if I ran it a second time but the third time it
may or may not crash. Once opened everything worked fine for 10+
minutes.

Jim

Reply | Threaded
Open this post in threaded view
|

Re: Midori (= Xfce's lightweight Webkit web browser) unstable in 6.4, anyone more test?

Joseph Mayer
On Sunday, November 4, 2018 6:19 AM, Jim Anderson <[hidden email]> wrote:

> On Saturday, November 3, 2018 12:50 AM, Joseph Mayer [hidden email] wrote:
> > Hi,
> > Can anyone install and surf the web for 5 minutes with Midori and
> > confirm if they see any unstability in OpenBSD 6.4 AMD64?
> > Mine quickly crashes with:
> > "** (midori4:46726): CRITICAL **: 06:45:29.139: gboolean
> > webkit_web_view_get_tls_info(WebKitWebView *, GTlsCertificate **,
> > GTlsCertificateFlags *): assertion 'wkCertificateInfo' failed"
> > Midori is a lightweight WebKit-based web browser.
> > Joseph
>
> Joseph,
>
> I am running OpenBSD 6.4 GENERIC#349 amd64 and saw the same issue. The
> browser always opened if I ran it a second time but the third time it
> may or may not crash. Once opened everything worked fine for 10+
> minutes.
>
> Jim

Jim,

Thanks for confirming.

Can you paste us the crash log please?

In particular I like to see if you get the same crash as I quoted
above.

What happens for me is it crashes on pretty much the first web page
visit.

Joseph

Reply | Threaded
Open this post in threaded view
|

Re: Midori (= Xfce's lightweight Webkit web browser) unstable in 6.4, anyone more test?

Jim Anderson



Sent with ProtonMail Secure Email.

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Sunday, November 4, 2018 7:58 PM, Joseph Mayer <[hidden email]> wrote:

> On Sunday, November 4, 2018 6:19 AM, Jim Anderson [hidden email] wrote:
>
> > On Saturday, November 3, 2018 12:50 AM, Joseph Mayer [hidden email] wrote:
> >
> > > Hi,
> > > Can anyone install and surf the web for 5 minutes with Midori and
> > > confirm if they see any unstability in OpenBSD 6.4 AMD64?
> > > Mine quickly crashes with:
> > > "** (midori4:46726): CRITICAL **: 06:45:29.139: gboolean
> > > webkit_web_view_get_tls_info(WebKitWebView *, GTlsCertificate **,
> > > GTlsCertificateFlags *): assertion 'wkCertificateInfo' failed"
> > > Midori is a lightweight WebKit-based web browser.
> > > Joseph
> >
> > Joseph,
> > I am running OpenBSD 6.4 GENERIC#349 amd64 and saw the same issue. The
> > browser always opened if I ran it a second time but the third time it
> > may or may not crash. Once opened everything worked fine for 10+
> > minutes.
> > Jim
>
> Jim,
>
> Thanks for confirming.
>
> Can you paste us the crash log please?
>
> In particular I like to see if you get the same crash as I quoted
> above.
>
> What happens for me is it crashes on pretty much the first web page
> visit.
>
> Joseph


Joseph,

I did not click anything in the midori GUI, I simply ran it from the
terminal. For reference I am using dwm as my wm and st for the terminal.
This is all from a fresh install on a new user profile.


galgvidr$ midori
The configuration couldn't be loaded: No such file or directory

(midori4:84848): Gtk-WARNING **: 20:32:20.868: Theme parsing error: gtk3.css:2:31: The style property GtkButton:default-border is deprecated and shouldn't be used anymore. It will be removed in a future version

(midori4:84848): Gtk-WARNING **: 20:32:20.923: Theme parsing error: gtk3.css:3:39: The style property GtkButton:default-outside-border is deprecated and shouldn't be used anymore. It will be removed in a future version

(midori4:84848): Gtk-WARNING **: 20:32:20.927: Theme parsing error: gtk3.css:4:29: The style property GtkButton:inner-border is deprecated and shouldn't be used anymore. It will be removed in a future version

(midori4:84848): Gtk-WARNING **: 20:32:20.927: Theme parsing error: gtk3.css:5:33: The style property GtkWidget:focus-line-width is deprecated and shouldn't be used anymore. It will
be removed in a future version

(midori4:84848): Gtk-WARNING **: 20:32:20.927: Theme parsing error: gtk3.css:6:30: The style property GtkWidget:focus-padding is deprecated and shouldn't be used anymore. It will be
removed in a future version

(midori4:84848): Gtk-WARNING **: 20:32:20.927: Theme parsing error: gtk3.css:26:20: The :insensitive pseudo-class is deprecated. Use :disabled instead.

** (midori4:84848): CRITICAL **: 20:32:23.344: gboolean webkit_web_view_get_tls_info(WebKitWebView *, GTlsCertificate **, GTlsCertificateFlags *): assertion 'wkCertificateInfo' failed
Segmentation fault (core dumped)
galgvidr$


Jim

Reply | Threaded
Open this post in threaded view
|

Re: Midori (= Xfce's lightweight Webkit web browser) unstable in 6.4, anyone more test?

Joseph Mayer
On Monday, November 5, 2018 11:35 AM, Jim Anderson <[hidden email]> wrote:
..
> > > > "** (midori4:46726): CRITICAL **: 06:45:29.139: gboolean
> > > > webkit_web_view_get_tls_info(WebKitWebView *, GTlsCertificate **,
> > > > GTlsCertificateFlags *): assertion 'wkCertificateInfo' failed"
> > > > Midori is a lightweight WebKit-based web browser.
..
> ** (midori4:84848): CRITICAL **: 20:32:23.344: gboolean webkit_web_view_get_tls_info(WebKitWebView *, GTlsCertificate **, GTlsCertificateFlags *): assertion 'wkCertificateInfo' failed

Thank you for that you confirmed the bug and sharing the crash log.

I wonder, is there an attempt to visit a HTTPS URL here, would need to
check also.

You and me got the same error, and on different code locations.

Next step now is recompile midori with debugging symbols and run it
using egdb, to then catch the backtrace using the "bt" command.

I think this is pretty much

     cd /usr/ports/web/midori
     CC_FLAGS="-g -Og" make
     make install
     pkg_install gdb
     egdb midori
     run
     bt

The fix for this problem may be obvious and simple to solve.

If you can do it feel free to, i should have the right environment for
it next weeks.

Joseph