Metasploit on OpenBSD 5.1 (ppc)

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Metasploit on OpenBSD 5.1 (ppc)

Andrew Barnes-7
Hello,

I just recently installed OpenBSD 5.1 on a old PowerMac G4. So far I'm really enjoying it. The install went smoothly, all is well.

What I would like to do is have a running copy of Metasploit on this box and I'm running into a problem. I know Metasploit exists as a OpenBSD port, when I go to the port under /security/metasploit and do a "make install", everything has installed thus far except for 'nasm'. I get the error:

# make install
===> metasploit-3.5.0p0 depends on: ruby-iconv->=1.8,<1.9 -> ruby-iconv-1.8.7.357
===> metasploit-3.5.0p0 depends on: ruby-gems-* -> ruby-gems-1.8.10
===> metasploit-3.5.0p0 depends on: nasm-* - not found
===>  Verifying install for nasm-* in devel/nasm
===>  nasm-2.08.01   is only for i386 amd64, not powerpc (macppc) .

Ok, that's fine, there is no *compiled* version of nasm for ppc. So I obtained the source code for nasm and compiled it with no issues. Now as you see, I have nasm installed:

# nasm -version
NASM version 2.10.01 compiled on Jun 10 2012
# uname -prsv
OpenBSD 5.1 GENERIC#150 powerpc

And returning back to the Metasploit port tree I run 'make install' again only to get the same error indicating that nasm is not installed.

So... how do I inform OpenBSD that I have this installed version and where it is?

Any help is appreciated.


Thanks,
Andrew

Reply | Threaded
Open this post in threaded view
|

Re: Metasploit on OpenBSD 5.1 (ppc)

David Diggles-2
While NASM can run on non Intel arch, it can not compile binaries that will run on
non-Intel arch.  If metasploit expects run NASM generated code, then it is not
compatible with powerpc.

On Sun, Jun 10, 2012 at 08:45:26PM -0400, Andrew Barnes wrote:

> Hello,
>
> I just recently installed OpenBSD 5.1 on a old PowerMac G4. So far I'm really enjoying it. The install went smoothly, all is well.
>
> What I would like to do is have a running copy of Metasploit on this box and I'm running into a problem. I know Metasploit exists as a OpenBSD port, when I go to the port under /security/metasploit and do a "make install", everything has installed thus far except for 'nasm'. I get the error:
>
> # make install
> ===> metasploit-3.5.0p0 depends on: ruby-iconv->=1.8,<1.9 -> ruby-iconv-1.8.7.357
> ===> metasploit-3.5.0p0 depends on: ruby-gems-* -> ruby-gems-1.8.10
> ===> metasploit-3.5.0p0 depends on: nasm-* - not found
> ===>  Verifying install for nasm-* in devel/nasm
> ===>  nasm-2.08.01   is only for i386 amd64, not powerpc (macppc) .
>
> Ok, that's fine, there is no *compiled* version of nasm for ppc. So I obtained the source code for nasm and compiled it with no issues. Now as you see, I have nasm installed:
>
> # nasm -version
> NASM version 2.10.01 compiled on Jun 10 2012
> # uname -prsv
> OpenBSD 5.1 GENERIC#150 powerpc
>
> And returning back to the Metasploit port tree I run 'make install' again only to get the same error indicating that nasm is not installed.
>
> So... how do I inform OpenBSD that I have this installed version and where it is?
>
> Any help is appreciated.
>
>
> Thanks,
> Andrew

Reply | Threaded
Open this post in threaded view
|

Re: Metasploit on OpenBSD 5.1 (ppc)

Andrew Barnes-7
That makes sense,

Thanks for taking the time to reply.

On Jun 10, 2012, at 10:06 PM, David Diggles wrote:

> While NASM can run on non Intel arch, it can not compile binaries that will run on
> non-Intel arch.  If metasploit expects run NASM generated code, then it is not
> compatible with powerpc.
>
> On Sun, Jun 10, 2012 at 08:45:26PM -0400, Andrew Barnes wrote:
>> Hello,
>>
>> I just recently installed OpenBSD 5.1 on a old PowerMac G4. So far I'm really enjoying it. The install went smoothly, all is well.
>>
>> What I would like to do is have a running copy of Metasploit on this box and I'm running into a problem. I know Metasploit exists as a OpenBSD port, when I go to the port under /security/metasploit and do a "make install", everything has installed thus far except for 'nasm'. I get the error:
>>
>> # make install
>> ===> metasploit-3.5.0p0 depends on: ruby-iconv->=1.8,<1.9 -> ruby-iconv-1.8.7.357
>> ===> metasploit-3.5.0p0 depends on: ruby-gems-* -> ruby-gems-1.8.10
>> ===> metasploit-3.5.0p0 depends on: nasm-* - not found
>> ===>  Verifying install for nasm-* in devel/nasm
>> ===>  nasm-2.08.01   is only for i386 amd64, not powerpc (macppc) .
>>
>> Ok, that's fine, there is no *compiled* version of nasm for ppc. So I obtained the source code for nasm and compiled it with no issues. Now as you see, I have nasm installed:
>>
>> # nasm -version
>> NASM version 2.10.01 compiled on Jun 10 2012
>> # uname -prsv
>> OpenBSD 5.1 GENERIC#150 powerpc
>>
>> And returning back to the Metasploit port tree I run 'make install' again only to get the same error indicating that nasm is not installed.
>>
>> So... how do I inform OpenBSD that I have this installed version and where it is?
>>
>> Any help is appreciated.
>>
>>
>> Thanks,
>> Andrew