Marvell Yukon 88E8053

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Marvell Yukon 88E8053

info-1230
Hello. First of all congratulations for your nice work ! I'm really

enjoying OpenBSD. I've built a server with it and it's really great.

I'm so addicted that i want to use it on my laptop as well, but i

encountered some problems :



ATI Radeon X700 (PCI-Express) with 1920x1200 wasn't working properly i

solved it with xorg.conf. If there is any place to publish it, please

ask me for my xorg.conf.



Marvell Yukon 88E8053 (should be PCI-Express) is recognized but not

working : here is a partial dmesg.

# dmesg | grep skc

skc0 at pci2 dev 0 function 0 "Marvell Yukon 88E8053" rev 0x19, Marvell

Yukon-2EC rev. A3 (0x2): irq 7

sk port A at skc0 not configured



Seems the material is properly recognized (except in ifconfig -a) and

everything is fine, just this annoying message : port A not configured.

What does it mean ? i think i should get the MAC address somewhere.



Is there any way to solve it ? I'm willing to help, for the moment i

know how to run a custom bsd/bsd.rd kernel but not compile it...



i can do tests if needed :) thank you for your help.



Maybe you should get some hints on :

http://cvsweb.netbsd.org/bsdweb.cgi/src/sys/dev/pci/if_sk.c



seems their driver is working, but so far i didn't tested it...

If they have a livecd i could :)



I guess the file you should edit is

http://www.openbsd.org/cgi-bin/cvsweb/src/sys/dev/pci/if_sk.c



Thanks for your great os :D



Thierry C.

Reply | Threaded
Open this post in threaded view
|

Re: Marvell Yukon 88E8053

Jonathan Gray
On Sat, Jun 10, 2006 at 06:12:16PM -0000, [hidden email] wrote:

> Hello. First of all congratulations for your nice work ! I'm really
> enjoying OpenBSD. I've built a server with it and it's really great.
> I'm so addicted that i want to use it on my laptop as well, but i
> encountered some problems :
>
> ATI Radeon X700 (PCI-Express) with 1920x1200 wasn't working properly i
> solved it with xorg.conf. If there is any place to publish it, please
> ask me for my xorg.conf.
>
> Marvell Yukon 88E8053 (should be PCI-Express) is recognized but not
> working : here is a partial dmesg.
> # dmesg | grep skc
> skc0 at pci2 dev 0 function 0 "Marvell Yukon 88E8053" rev 0x19, Marvell
> Yukon-2EC rev. A3 (0x2): irq 7
> sk port A at skc0 not configured
>
> Seems the material is properly recognized (except in ifconfig -a) and
> everything is fine, just this annoying message : port A not configured.
> What does it mean ? i think i should get the MAC address somewhere.
>
> Is there any way to solve it ? I'm willing to help, for the moment i
> know how to run a custom bsd/bsd.rd kernel but not compile it...
>
> i can do tests if needed :) thank you for your help.
>
> Maybe you should get some hints on :
> http://cvsweb.netbsd.org/bsdweb.cgi/src/sys/dev/pci/if_sk.c
>
> seems their driver is working, but so far i didn't tested it...
> If they have a livecd i could :)
>
> I guess the file you should edit is
> http://www.openbsd.org/cgi-bin/cvsweb/src/sys/dev/pci/if_sk.c
>
> Thanks for your great os :D
>
> Thierry C.

Their driver can not possibly work with what is there.
Several new PCI-X/PCIE based Yukon chips don't work
and they are fundamentally different from the older generation
chips in several areas.  As such a new driver will have
to be written.  This is hindered by Marvell not releasing
documentation and Linux developers getting their documentation
under NDA from Marvell.