Maintainer update: py-aiodns dependency change

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Maintainer update: py-aiodns dependency change

Kurt Mosiejczuk-9
Since I've discovered that py-typing does nothing for Python 3.6+,
there is no need to have it as a RUN_DEPENDS for py-aiodns.

So this is a quick revision bump to remove py-typing from its
DEPENDENCIES. All regression tests still pass.

--Kurt

Index: Makefile
===================================================================
RCS file: /cvs/ports/net/py-aiodns/Makefile,v
retrieving revision 1.5
diff -u -p -r1.5 Makefile
--- Makefile 19 Jan 2019 14:26:34 -0000 1.5
+++ Makefile 18 Feb 2019 06:40:22 -0000
@@ -6,6 +6,7 @@ MODPY_EGG_VERSION = 1.2.0
 DISTNAME = aiodns-${MODPY_EGG_VERSION}
 PKGNAME = py-${DISTNAME}
 CATEGORIES = net
+REVISION = 0
 
 MAINTAINER = Kurt Mosiejczuk <[hidden email]>
 
@@ -20,10 +21,10 @@ MODPY_SETUPTOOLS = Yes
 FLAVORS = python3
 FLAVOR ?=
 
-RUN_DEPENDS = devel/py-typing${MODPY_FLAVOR} \
- net/py-cares${MODPY_FLAVOR}
+RUN_DEPENDS = net/py-cares${MODPY_FLAVOR}
 .if !${FLAVOR:Mpython3}
-RUN_DEPENDS += devel/py-trollius
+RUN_DEPENDS += devel/py-trollius \
+ devel/py-typing
 .endif
 
 TEST_DEPENDS = ${RUN_DEPENDS}