MAJ de package sous OpenBSD 3.9

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

MAJ de package sous OpenBSD 3.9

Gil Andre

Bonjour/Bonsoir...

J'ai un petit problème pour mettre à jour un paquetage sur une station
de travail sous OpenBSD 3.9.

Quand je veux mettre à jour Firefox vers la dernière version disponible
pour OpenBSD 3.9, rien ne marche, et j'obtiens les erreurs suivantes :

# pkg_add -vvv ./mozilla-firefox-1.5.0.4.tgz  
parsing mozilla-firefox-1.5.0.4
Can't install mozilla-firefox-1.5.0.4 because of conflicts (.libs-mozilla-firefox-1.0.6p3)
/usr/sbin/pkg_add: ./mozilla-firefox-1.5.0.4.tgz:Fatal error

Plus bizarre encore, si j'essaye de forcer la mise à jour de manière
"sauvage", j'obtiens les mêmes erreurs :

# pkg_add -F update -u -r -vvv ./mozilla-firefox-1.5.0.4.tgz  
parsing mozilla-firefox-1.5.0.4
Can't install mozilla-firefox-1.5.0.4 because of conflicts (.libs-mozilla-firefox-1.0.6p3)
/usr/sbin/pkg_add: ./mozilla-firefox-1.5.0.4.tgz:Fatal error

Est-ce que quelqu'un a déjà rencontré ce problème ?

Et, surtout, est-ce quelqu'un connaît une solution ?   :-)

Merci d'avance !

--
  __  Gil ANDRE  gil [at] panix   [dot] com
 (oO) andre [dot] g [at] wanadoo [dot] fr
 /||\ Relax to the soothing madness of the ancient ones: 66.6FM KTLU

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: MAJ de package sous OpenBSD 3.9

Antoine Jacoutot
On Sat, 10 Jun 2006, Gil Andre wrote:
> # pkg_add -vvv ./mozilla-firefox-1.5.0.4.tgz
> parsing mozilla-firefox-1.5.0.4
> Can't install mozilla-firefox-1.5.0.4 because of conflicts (.libs-mozilla-firefox-1.0.6p3)
> /usr/sbin/pkg_add: ./mozilla-firefox-1.5.0.4.tgz:Fatal error

Il suffit de lire le message d'erreur :
"Can't install mozilla-firefox-1.5.0.4 because of conflicts
(.libs-mozilla-firefox-1.0.6p3)"

Donc :
# pkg_delete .libs-mozilla-firefox-1.0.6p3

++

--
Antoine

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: MAJ de package sous OpenBSD 3.9

Bastien Mourlon
In reply to this post by Gil Andre
Bonjour ...

Pour ma part j'utilise juste pkg_add -u -i
et je n'ai pas eu de souci pour le moment, neanmoins, je n'ai pas
encore upgradé firefox en 1.5.0.4 ( mon mirroir est en retard ... ) mais
juste en 1.5.0.3.
 
( -i pour interactif )

Je ne sais pas si ca aidera ...

--
Bastien

PS : mozilla-firefox-1.0.6p3 date d'open 3.8 il me semble ...
Attention aux upgrade !

On Sat, Jun 10, 2006 at 02:12:19AM +0200, Gil Andre wrote:

>
> Bonjour/Bonsoir...
>
> J'ai un petit problème pour mettre à jour un paquetage sur une station
> de travail sous OpenBSD 3.9.
>
> Quand je veux mettre à jour Firefox vers la dernière version disponible
> pour OpenBSD 3.9, rien ne marche, et j'obtiens les erreurs suivantes :
>
> # pkg_add -vvv ./mozilla-firefox-1.5.0.4.tgz  
> parsing mozilla-firefox-1.5.0.4
> Can't install mozilla-firefox-1.5.0.4 because of conflicts (.libs-mozilla-firefox-1.0.6p3)
> /usr/sbin/pkg_add: ./mozilla-firefox-1.5.0.4.tgz:Fatal error
>
> Plus bizarre encore, si j'essaye de forcer la mise à jour de manière
> "sauvage", j'obtiens les mêmes erreurs :
>
> # pkg_add -F update -u -r -vvv ./mozilla-firefox-1.5.0.4.tgz  
> parsing mozilla-firefox-1.5.0.4
> Can't install mozilla-firefox-1.5.0.4 because of conflicts (.libs-mozilla-firefox-1.0.6p3)
> /usr/sbin/pkg_add: ./mozilla-firefox-1.5.0.4.tgz:Fatal error
>
> Est-ce que quelqu'un a déjà rencontré ce problème ?
>
> Et, surtout, est-ce quelqu'un connaît une solution ?   :-)
>
> Merci d'avance !
>
> --
>   __  Gil ANDRE  gil [at] panix   [dot] com
>  (oO) andre [dot] g [at] wanadoo [dot] fr
>  /||\ Relax to the soothing madness of the ancient ones: 66.6FM KTLU
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

RE : [obsdfr-misc] MAJ de package sous OpenBSD 3.9

Franck Bednarski
In reply to this post by Gil Andre
salut,

pour ma part, je te propose de sauvegarder ton bookmark, faire la liste
de tes plugins firefox, de supprimer firefox puis d'installer la dernière version pour OpenBSD3.9
:)

c'est bête mais ce sera plus rapide que de chercher pour la mise à jour ne fonctionne pas.
C'est toi qui décide.

a+

--- Gil Andre <[hidden email]> a écrit :

>
> Bonjour/Bonsoir...
>
> J'ai un petit problème pour mettre à jour un paquetage sur une station
> de travail sous OpenBSD 3.9.
>
> Quand je veux mettre à jour Firefox vers la dernière version disponible
> pour OpenBSD 3.9, rien ne marche, et j'obtiens les erreurs suivantes :
>
> # pkg_add -vvv ./mozilla-firefox-1.5.0.4.tgz  
> parsing mozilla-firefox-1.5.0.4
> Can't install mozilla-firefox-1.5.0.4 because of conflicts (.libs-mozilla-firefox-1.0.6p3)
> /usr/sbin/pkg_add: ./mozilla-firefox-1.5.0.4.tgz:Fatal error
>
> Plus bizarre encore, si j'essaye de forcer la mise à jour de manière
> "sauvage", j'obtiens les mêmes erreurs :
>
> # pkg_add -F update -u -r -vvv ./mozilla-firefox-1.5.0.4.tgz  
> parsing mozilla-firefox-1.5.0.4
> Can't install mozilla-firefox-1.5.0.4 because of conflicts (.libs-mozilla-firefox-1.0.6p3)
> /usr/sbin/pkg_add: ./mozilla-firefox-1.5.0.4.tgz:Fatal error
>
> Est-ce que quelqu'un a déjà rencontré ce problème ?
>
> Et, surtout, est-ce quelqu'un connaît une solution ?   :-)
>
> Merci d'avance !
>
> --
>   __  Gil ANDRE  gil [at] panix   [dot] com
>  (oO) andre [dot] g [at] wanadoo [dot] fr
>  /||\ Relax to the soothing madness of the ancient ones: 66.6FM KTLU
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


__________________________________________________
Do You Yahoo!?
En finir avec le spam? Yahoo! Mail vous offre la meilleure protection possible contre les messages non sollicités
http://mail.yahoo.fr Yahoo! Mail

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: MAJ de package sous OpenBSD 3.9

jean.lorget
In reply to this post by Gil Andre
as tu essayé d'enlever le paquet qui fait probleme et de rajouter ensuite
ton package?

Le 10/06/06, Gil Andre <[hidden email]> a écrit :

>
>
> Bonjour/Bonsoir...
>
> J'ai un petit problème pour mettre à jour un paquetage sur une station
> de travail sous OpenBSD 3.9.
>
> Quand je veux mettre à jour Firefox vers la dernière version disponible
> pour OpenBSD 3.9, rien ne marche, et j'obtiens les erreurs suivantes :
>
> # pkg_add -vvv ./mozilla-firefox-1.5.0.4.tgz
> parsing mozilla-firefox-1.5.0.4
> Can't install mozilla-firefox-1.5.0.4 because of conflicts (.libs-
> mozilla-firefox-1.0.6p3)
> /usr/sbin/pkg_add: ./mozilla-firefox-1.5.0.4.tgz:Fatal error
>
> Plus bizarre encore, si j'essaye de forcer la mise à jour de manière
> "sauvage", j'obtiens les mêmes erreurs :
>
> # pkg_add -F update -u -r -vvv ./mozilla-firefox-1.5.0.4.tgz
> parsing mozilla-firefox-1.5.0.4
> Can't install mozilla-firefox-1.5.0.4 because of conflicts (.libs-
> mozilla-firefox-1.0.6p3)
> /usr/sbin/pkg_add: ./mozilla-firefox-1.5.0.4.tgz:Fatal error
>
> Est-ce que quelqu'un a déjà rencontré ce problème ?
>
> Et, surtout, est-ce quelqu'un connaît une solution ?   :-)
>
> Merci d'avance !
>
> --
>   __  Gil ANDRE                           gil [at] panix   [dot] com
> (oO)                           andre [dot] g [at] wanadoo [dot] fr
> /||\ Relax to the soothing madness of the ancient ones: 66.6FM KTLU
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail:
> [hidden email]
>
>
Reply | Threaded
Open this post in threaded view
|

Re: MAJ de package sous OpenBSD 3.9

Gil Andre
In reply to this post by Bastien Mourlon

Bonjour Bastien,

On Sat, 10 Jun 2006 09:41:28 +0200 Bastien Mourlon <[hidden email]> wrote:
> Pour ma part j'utilise juste pkg_add -u -i

Bonne idée, je vais essayer le "-i"...

Euh, en fait non, ça marche pas non plus :

-bash-3.1$ sudo pkg_add -u -i -vvv mozilla-firefox-1.5.0.4.tgz
parsing mozilla-firefox-1.5.0.4
Can't install mozilla-firefox-1.5.0.4 because of conflicts (.libs-mozilla-firefox-1.0.6p3)
/usr/sbin/pkg_add: ./mozilla-firefox-1.5.0.4.tgz:Fatal error

> PS : mozilla-firefox-1.0.6p3 date d'open 3.8 il me semble ...
> Attention aux upgrade !

Oui, la machine tournait sous OpenBSD 3.8, elle a été mise à jour en 3.9.
Mais, chose intéressante, la mise à jour vers firefox 1.5.0.3, en partant
de la version 1.0.6p3, n'entraînait pas de problèmes...

Je serais assez curieux de savoir si tu as aussi des problèmes lors de ta
mise à jour vers la version 1.5.0.4 de firefox. Si ça se trouve, je suis
tombé sur un paquetage mal fichu ? OpenBSD prendrait-il la direction de
Debian ? (Horreur !)    ;-)

Egalement important : le paquetage firefox 1.0.6p3 a été effacé depuis
bien longtemps (lors du passage de 3.8 vers 3.9), ainsi que firefox
1.5.0.3. Merci à tout ceux qui ont suggéré de l'effacer, mais c'est
l'une des premières choses que j'ai essayé pour corriger les conflits
(quand même !)   ;-)

Si quelqu'un a d'autres idées, je suis preneur. Je tourne sous Mozilla
pour le moment. Mozilla, c'est bien... Mais firefox, c'est mieux !

Cordialement,

--
  __  Gil ANDRE  gil [at] panix   [dot] com
 (oO) andre [dot] g [at] wanadoo [dot] fr
 /||\ Relax to the soothing madness of the ancient ones: 66.6FM KTLU

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: MAJ de package sous OpenBSD 3.9

Pascal Filipovicz
In reply to this post by Gil Andre
Le samedi 10 juin 2006 02:12, Gil Andre a écrit :
> Bonjour/Bonsoir...

Bonjour,

>
> J'ai un petit problème pour mettre à jour un paquetage sur une station
> de travail sous OpenBSD 3.9.
>
> Quand je veux mettre à jour Firefox vers la dernière version disponible
> pour OpenBSD 3.9, rien ne marche, et j'obtiens les erreurs suivantes :
>
> # pkg_add -vvv ./mozilla-firefox-1.5.0.4.tgz
> parsing mozilla-firefox-1.5.0.4
> Can't install mozilla-firefox-1.5.0.4 because of conflicts
> (.libs-mozilla-firefox-1.0.6p3) /usr/sbin/pkg_add:
> ./mozilla-firefox-1.5.0.4.tgz:Fatal error
>

Supprime le fichier ou dossier /var/db/pkg/.libs-mozilla-firefox-1.0.6p3 (s'il
existe) et ça devrait fonctionner.

--
Pascal

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: MAJ de package sous OpenBSD 3.9

Gil Andre

Bonjour,

On Sat, 10 Jun 2006 16:05:28 +0200 Pascal Filipovicz <[hidden email]> wrote:
> > # pkg_add -vvv ./mozilla-firefox-1.5.0.4.tgz
> > parsing mozilla-firefox-1.5.0.4
> > Can't install mozilla-firefox-1.5.0.4 because of conflicts
> > (.libs-mozilla-firefox-1.0.6p3) /usr/sbin/pkg_add:
> > ./mozilla-firefox-1.5.0.4.tgz:Fatal error
> Supprime le fichier ou dossier /var/db/pkg/.libs-mozilla-firefox-1.0.6p3 (s'il
> existe) et ça devrait fonctionner.

Bonne réponse !

Il y avait effectivement un répertoire :
        /var/db/pkg/.libs-mozilla-firefox-1.0.6p3/

Une fois supprimé, l'installation de firefox 1.5.0.4 s'est passé sans
problèmes... Merci pour ta réponse !

Cordialement,

--
  __  Gil ANDRE  gil [at] panix   [dot] com
 (oO) andre [dot] g [at] wanadoo [dot] fr
 /||\ Relax to the soothing madness of the ancient ones: 66.6FM KTLU

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: MAJ de package sous OpenBSD 3.9

Antoine Jacoutot
On Sat, 10 Jun 2006, Gil Andre wrote:
> Bonne réponse !
>
> Il y avait effectivement un répertoire :
> /var/db/pkg/.libs-mozilla-firefox-1.0.6p3/
>
> Une fois supprimé, l'installation de firefox 1.5.0.4 s'est passé sans
> problèmes... Merci pour ta réponse !

Non, mauvaise réponse, il fallait faire :
pkg_delete .libs-mozilla-firefox-1.0.6p3

--
Antoine

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: MAJ de package sous OpenBSD 3.9

Gil Andre
In reply to this post by Antoine Jacoutot

Bonsoir Antoine,

On Sat, 10 Jun 2006 09:16:21 +0200 (CEST) Antoine Jacoutot <[hidden email]> wrote:

> > # pkg_add -vvv ./mozilla-firefox-1.5.0.4.tgz
> > parsing mozilla-firefox-1.5.0.4
> > Can't install mozilla-firefox-1.5.0.4 because of conflicts (.libs-mozilla-firefox-1.0.6p3)
> > /usr/sbin/pkg_add: ./mozilla-firefox-1.5.0.4.tgz:Fatal error
> Il suffit de lire le message d'erreur :
> "Can't install mozilla-firefox-1.5.0.4 because of conflicts
> (.libs-mozilla-firefox-1.0.6p3)"
>
> Donc :
> # pkg_delete .libs-mozilla-firefox-1.0.6p3

J'avais bien compris qu'il y avait un problème avec les
".libs-mozilla-firefox-1.0.6p3".

Mais ce que je n'avais pas compris c'est :

-1- Que les libs de la v1.0.6p3 soient encore sur mon système
    alors que j'avais fait une mise à jour vers Firefox 1.5.0.x
    en passant d'OpenBSD 3.8 à OpenBSD 3.9.

-2- Qu'il était possible d'enlever ces libs en faisant un pkg_delete.
    (ou en faisant un 'rm' sur /var/db/pkg/.libs-mozilla-firefox-1.0.6p3
    ce que j'ai fini par faire).

J'ai bien cherché dans le FAQ et dans les pages de man, mais je n'ai
rien trouvé... Est-ce que tu sais où cela est documenté ? Le simple
fait de devoir effacer des "restes" d'anciens packages pour pouvoir
faire des mises à jour ne semble pas une procédure très "standard"...

Cordialement,

--
  __  Gil ANDRE  gil [at] panix   [dot] com
 (oO) andre [dot] g [at] wanadoo [dot] fr
 /||\ Relax to the soothing madness of the ancient ones: 66.6FM KTLU

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: MAJ de package sous OpenBSD 3.9

Antoine Jacoutot
Gil Andre wrote:
> J'avais bien compris qu'il y avait un problème avec les
> ".libs-mozilla-firefox-1.0.6p3".
>
> Mais ce que je n'avais pas compris c'est :
>
> -1- Que les libs de la v1.0.6p3 soient encore sur mon système
>     alors que j'avais fait une mise à jour vers Firefox 1.5.0.x
>     en passant d'OpenBSD 3.8 à OpenBSD 3.9.

Certaines bibliothèques ont été gardées car d'autre paquets pouvaient en
dépendre.

> -2- Qu'il était possible d'enlever ces libs en faisant un pkg_delete.
>     (ou en faisant un 'rm' sur /var/db/pkg/.libs-mozilla-firefox-1.0.6p3
>     ce que j'ai fini par faire).

man pkg_info => regarde l'option "-A"
Et la faq15 sur le site d'OpenBSD.

> J'ai bien cherché dans le FAQ et dans les pages de man, mais je n'ai
> rien trouvé... Est-ce que tu sais où cela est documenté ? Le simple
> fait de devoir effacer des "restes" d'anciens packages pour pouvoir
> faire des mises à jour ne semble pas une procédure très "standard"...

Parce qu'il s'agit d'un mise à jour de mozilla-firefox et pas de
.libs-mozilla-firefox.
  Généralement, après une grosse mise à jour de paquets (genre entre
releases), un petit coup de "pkg_info -A | grep libs" permet de voir si
de vieilles bibliothèques ont été gardées.

++

--
Antoine

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]