Lenovo Notebook Core Duo SMP Trouble

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Lenovo Notebook Core Duo SMP Trouble

Sam Fourman Jr.
Hello OpenBSD Developers,

I have a odd problem with my Lenovo 3000 N100 768-DKU Notebook with a
Intel Core Duo 2
it seems my network adapters(Both wpi0 and rl0) get timeout errors
when attempting to obtain dhcp on boot up

this only happens when trying to boot bsd.mp from the boot prompt.

please note that on kernel bsd everything works just fine.

on bsd.mp I can seem to do anything i want to Except use any network adapter

I have recent dmesg's (10-22-06) in this post

http://www.mail-archive.com/misc@.../msg31661.html

I also Just downloaded - current (GENERIC.MP #1051) and the trouble still exists


Thank you again for all of your work on OpenBSD

Sam Fourman Jr.

Reply | Threaded
Open this post in threaded view
|

Re: Lenovo Notebook Core Duo SMP Trouble

Sam Fourman Jr.
Just a side note,

if it is any help I noticed that when starting kismet (From -current
ports) with kernel bsd wpi0 reports Device Timed out  as well.

the wpi wireless device works fine in ! bsd.mp.

Sam Fourman Jr.

On 11/13/06, Sam Fourman Jr. <[hidden email]> wrote:

> Hello OpenBSD Developers,
>
> I have a odd problem with my Lenovo 3000 N100 768-DKU Notebook with a
> Intel Core Duo 2
> it seems my network adapters(Both wpi0 and rl0) get timeout errors
> when attempting to obtain dhcp on boot up
>
> this only happens when trying to boot bsd.mp from the boot prompt.
>
> please note that on kernel bsd everything works just fine.
>
> on bsd.mp I can seem to do anything i want to Except use any network adapter
>
> I have recent dmesg's (10-22-06) in this post
>
> http://www.mail-archive.com/misc@.../msg31661.html
>
> I also Just downloaded - current (GENERIC.MP #1051) and the trouble still exists
>
>
> Thank you again for all of your work on OpenBSD
>
> Sam Fourman Jr.

Reply | Threaded
Open this post in threaded view
|

Re: Lenovo Notebook Core Duo SMP Trouble

Mark Kettenis
In reply to this post by Sam Fourman Jr.
You might want to try the diff at

   http://www.xs4all.nl/~sibelius/acpi-apic.diff

and use GENERIC.ACPI to build your kernel.

Reply | Threaded
Open this post in threaded view
|

Re: Lenovo Notebook Core Duo SMP Trouble

Sam Fourman Jr.
hello misc@
here is a updated dmesg for my lenovo notebook with todays -current
the pcmica slot is atleast returning a error

Sam Fourman Jr.


OpenBSD 4.0-current (GENERIC) #1263: Tue Dec 12 19:56:25 MST 2006
    [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel(R) Core(TM)2 CPU T5500 @ 1.66GHz ("GenuineIntel" 686-class) 1.67 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,MWAIT,DS-CPL,EST,TM2,CX16
real mem  = 526544896 (514204K)
avail mem = 472215552 (461148K)
using 4256 buffers containing 26451968 bytes (25832K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(e5) BIOS, date 02/17/09, BIOS32 rev. 0 @
0xfd610, SMBIOS rev. 2.4 @ 0xdc010 (42 entries)
bios0: LENOVO 0768DKU
pcibios0 at bios0: rev 2.1 @ 0xfd610/0x9f0
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfdee0/256 (14 entries)
pcibios0: PCI Interrupt Router at 000:31:0 ("Intel 82371FB ISA" rev 0x00)
pcibios0: PCI bus #4 is the last bus
bios0: ROM list: 0xc0000/0xe600! 0xce800/0x1000 0xdc000/0x4000! 0xe0000/0x1800!
acpi at mainbus0 not configured
cpu0 at mainbus0
cpu0: unknown Enhanced SpeedStep CPU, msr 0x06130a2506000613
cpu0: using only highest and lowest power states
cpu0: Enhanced SpeedStep 1000 MHz (1004 mV): speeds: 1667, 1000 MHz
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "Intel 82945GM MCH" rev 0x03
vga1 at pci0 dev 2 function 0 "Intel 82945GM Video" rev 0x03: aperture
at 0xd0200000, size 0x10000000
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
"Intel 82945GM Video" rev 0x03 at pci0 dev 2 function 1 not configured
azalia0 at pci0 dev 27 function 0 "Intel 82801GB HD Audio" rev 0x02: irq 11
azalia0: host: High Definition Audio rev. 1.0
azalia0: codec: 0x04x/0x11d4 (rev. 5.0), HDA version 1.0
azalia0: codec: 0x04x/0x11c1 (rev. 2.0), HDA version 1.0
azalia0: codec[1]: No support for modem function groups
azalia0: codec[1]: No audio function groups
audio0 at azalia0
ppb0 at pci0 dev 28 function 0 "Intel 82801GB PCIE" rev 0x02
pci1 at ppb0 bus 1
ppb1 at pci0 dev 28 function 1 "Intel 82801GB PCIE" rev 0x02
pci2 at ppb1 bus 2
wpi0 at pci2 dev 0 function 0 "Intel PRO/Wireless 3945ABG" rev 0x02:
irq 7, address 00:18:de:2c:a8:a3
uhci0 at pci0 dev 29 function 0 "Intel 82801GB USB" rev 0x02: irq 5
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1 at pci0 dev 29 function 1 "Intel 82801GB USB" rev 0x02: irq 10
usb1 at uhci1: USB revision 1.0
uhub1 at usb1
uhub1: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2 at pci0 dev 29 function 2 "Intel 82801GB USB" rev 0x02: irq 11
usb2 at uhci2: USB revision 1.0
uhub2 at usb2
uhub2: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
uhci3 at pci0 dev 29 function 3 "Intel 82801GB USB" rev 0x02: irq 10
usb3 at uhci3: USB revision 1.0
uhub3 at usb3
uhub3: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub3: 2 ports with 2 removable, self powered
ehci0 at pci0 dev 29 function 7 "Intel 82801GB USB" rev 0x02: irq 5
ehci0: timed out waiting for BIOS
usb4 at ehci0: USB revision 2.0
uhub4 at usb4
uhub4: Intel EHCI root hub, rev 2.00/1.00, addr 1
uhub4: 8 ports with 8 removable, self powered
ppb2 at pci0 dev 30 function 0 "Intel 82801BAM Hub-to-PCI" rev 0xe2
pci3 at ppb2 bus 3
rl0 at pci3 dev 1 function 0 "Realtek 8139" rev 0x10: irq 10, address
00:0f:b0:cc:44:41
rlphy0 at rl0 phy 0: RTL internal PHY
cbb0 at pci3 dev 4 function 0 "ENE CB-1410 CardBus" rev
0x01pci_intr_map: no mapping for pin A
: couldn't map interrupt
"Ricoh 5C832 Firewire" rev 0x00 at pci3 dev 6 function 0 not configured
sdhc0 at pci3 dev 6 function 1 "Ricoh 5C822 SD/MMC" rev 0x19: irq 5
sdmmc0 at sdhc0
"Ricoh 5C843" rev 0x01 at pci3 dev 6 function 2 not configured
"Ricoh 5C592 Memory Stick" rev 0x0a at pci3 dev 6 function 3 not configured
"Ricoh 5C852 xD" rev 0x05 at pci3 dev 6 function 4 not configured
ichpcib0 at pci0 dev 31 function 0 "Intel 82801GBM LPC" rev 0x02: PM disabled
pciide0 at pci0 dev 31 function 2 "Intel 82801GBM SATA" rev 0x02: DMA,
channel 0 wired to compatibility, channel 1 wired to compatibility
wd0 at pciide0 channel 0 drive 0: <HTS541080G9SA00>
wd0: 16-sector PIO, LBA48, 76319MB, 156301488 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 5
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <HL-DT-ST, DVDRAM GMA-4082N, HA01> SCSI0
5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
ichiic0 at pci0 dev 31 function 3 "Intel 82801GB SMBus" rev 0x02: irq 10
iic0 at ichiic0
isa0 at ichpcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
pcic0 at isa0 port 0x3e0/2 iomem 0xd0000/16384
pcic0 controller 0: <Intel 82365SL rev 2> has socket A only
pcmcia0 at pcic0 controller 0 socket 0
pcic_chip_socket_enable: status c
pcic_wait_ready: ready never happened, status = 0c
pccom3 at pcmcia0 function 0: can't allocate i/o space
pcic0: irq 3, polling enabled
biomask ef75 netmask eff5 ttymask ffff
pctr: 686-class user-level performance counters enabled
mtrr: Pentium Pro MTRR support
dkcsum: wd0 matches BIOS drive 0x80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302
WARNING: / was not properly unmounted


On 11/14/06, Mark Kettenis <[hidden email]> wrote:
> You might want to try the diff at
>
>    http://www.xs4all.nl/~sibelius/acpi-apic.diff
>
> and use GENERIC.ACPI to build your kernel.

Reply | Threaded
Open this post in threaded view
|

Re: Lenovo Notebook Core Duo SMP Trouble

Mark Kettenis
>  hello misc@
>  here is a updated dmesg for my lenovo notebook with todays -current
>  the pcmica slot is atleast returning a error
>
>  Sam Fourman Jr.

Try enabling acpi.  That is, boot with "boot -c" and type "enable acpi"
at the UKC> prompt.