LSI Logic MegaRAID SAS 9240-8i Panic

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

LSI Logic MegaRAID SAS 9240-8i Panic

Shane Harbour
Hello,
I'm running into the following panic when trying to boot the OpenBSD 6.2
release install disc (as well as the latest snapshot) with an LSI Logic
MegaRAID SAS 9240-8i (mfi driver) card installed in the machine.  I take
the card out and it boots just fine from the disc, but the following
panic happens with the RAID card in:

-------------------------------
boot>
cannot open cd0a:/etc/random.see: No such file or directory
booting cd0a:/6.2/amd64/bsd.rd: 3371132+1459200+3873512+0+598016
[373741+82+427200+282103]=0x9e99c0
entry point at 0x1000158
panic: init_x86_64: can't find end of memory

The operating system has halted.
Please press any key to reboot.
-------------------------------

The system is in an Intel Core 2 Quad system with 8GB of RAM. The RAID
is setup in two logical drives, one in RAID5 and the other in RAID1.

If you need any other information, just let me know.

Thanks,
Shane

Reply | Threaded
Open this post in threaded view
|

Re: LSI Logic MegaRAID SAS 9240-8i Panic

Mike Larkin
On Sun, Jan 07, 2018 at 04:57:22PM -0700, Shane Harbour wrote:

> Hello,
> I'm running into the following panic when trying to boot the OpenBSD 6.2
> release install disc (as well as the latest snapshot) with an LSI Logic
> MegaRAID SAS 9240-8i (mfi driver) card installed in the machine.  I take the
> card out and it boots just fine from the disc, but the following panic
> happens with the RAID card in:
>
> -------------------------------
> boot>
> cannot open cd0a:/etc/random.see: No such file or directory
> booting cd0a:/6.2/amd64/bsd.rd: 3371132+1459200+3873512+0+598016
> [373741+82+427200+282103]=0x9e99c0
> entry point at 0x1000158
> panic: init_x86_64: can't find end of memory
>
> The operating system has halted.
> Please press any key to reboot.
> -------------------------------
>
> The system is in an Intel Core 2 Quad system with 8GB of RAM. The RAID is
> setup in two logical drives, one in RAID5 and the other in RAID1.
>
> If you need any other information, just let me know.
>
> Thanks,
> Shane
>

sendbug from the working boot please

also please send output of "machine memory" from the boot> prompt, while
the card is plugged in.

-ml