Issues with the Thunderbolt/USB-C port on my ThinkPad T480

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Issues with the Thunderbolt/USB-C port on my ThinkPad T480

Jeffrey Abbinante
Hello all,

I am a relatively new OpenBSD user and an ex-Arch and Gentoo user and I'm
liking the experience so far. Everything feels lighter than GNU/Linux but
there is one huge issue. My USB-C ports don't really work. Sometimes they
work and sometimes they don't. When they do the performance of the system
degrades and the only way to fix it is to suspend the laptop. I kinda need
the USB-C ports to work but I don't know where to start. Any suggestions?

Thank you,

Jeffrey Abbinante
Reply | Threaded
Open this post in threaded view
|

Re: Issues with the Thunderbolt/USB-C port on my ThinkPad T480

Anatoli
Hi Jeffrey,

You should start by sending your complete dmesg (with the problematic
devices attached) so we all see what's your hardware.

Then, USB-C is a connector [1], it doesn't imply anything in particular.
What is important is the USB protocol version of your devices (on both
ends). It would help if you describe in detail some particular scenario
that you say doesn't work.

Regards,
Anatoli

[1] https://en.wikipedia.org/wiki/USB-C

On 8/10/19 15:14, Jeffrey Abbinante wrote:

> Hello all,
>
> I am a relatively new OpenBSD user and an ex-Arch and Gentoo user and I'm
> liking the experience so far. Everything feels lighter than GNU/Linux but
> there is one huge issue. My USB-C ports don't really work. Sometimes they
> work and sometimes they don't. When they do the performance of the system
> degrades and the only way to fix it is to suspend the laptop. I kinda need
> the USB-C ports to work but I don't know where to start. Any suggestions?
>
> Thank you,
>
> Jeffrey Abbinante
>