IBM xServer 336/346 - OpenBSD 4.9

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

IBM xServer 336/346 - OpenBSD 4.9

Lévai, Dániel
Hi!


(Just for the record)
Regarding PR#6523, OpenBSD 4.9 works with pci.c 1.88 (from OPENBSD_4_9),
patched with kettenis@'s pci.c patch 1.72 [1].
I was afraid it won't apply, or there will be incompatibilities with
other parts, but so far so good.
(It's unfortuane it broke other systems :( )


Anyway, thanks!


[1]:
http://www.openbsd.org/cgi-bin/cvsweb/src/sys/dev/pci/pci.c.diff?r1=1.71;r2=1.72



Daniel

--
LIVAI Daniel
PGP key ID = 0x83B63A8F
Key fingerprint = DBEC C66B A47A DFA2 792D  650C C69B BE4C 83B6 3A8F

Reply | Threaded
Open this post in threaded view
|

Re: IBM xServer 336/346 - OpenBSD 4.9

FRLinux-2
On Fri, May 20, 2011 at 7:43 AM, LEVAI Daniel <[hidden email]> wrote:
> (Just for the record)
> Regarding PR#6523, OpenBSD 4.9 works with pci.c 1.88 (from OPENBSD_4_9),
> patched with kettenis@'s pci.c patch 1.72 [1].
> I was afraid it won't apply, or there will be incompatibilities with
> other parts, but so far so good.
> (It's unfortuane it broke other systems :( )

Thanks for confirming this, I am no longer using OpenBSD with IBM x336
series for that very reason.

Cheers,
Steph

Reply | Threaded
Open this post in threaded view
|

Re: IBM xServer 336/346 - OpenBSD 4.9

Marcos Laufer - Ipv4networks.com
In reply to this post by Lévai, Dániel
Daniel,

What i did to make my x336 servers work with OpenBSD 4.9 was to replace
pci.c from the source with pci.c 1.72 .
Is this somehow wrong? Should i apply this patch instead?

Regards,
Marcos




LEVAI Daniel wrote:

> Hi!
>
>
> (Just for the record)
> Regarding PR#6523, OpenBSD 4.9 works with pci.c 1.88 (from OPENBSD_4_9),
> patched with kettenis@'s pci.c patch 1.72 [1].
> I was afraid it won't apply, or there will be incompatibilities with
> other parts, but so far so good.
> (It's unfortuane it broke other systems :( )
>
>
> Anyway, thanks!
>
>
> [1]:
> http://www.openbsd.org/cgi-bin/cvsweb/src/sys/dev/pci/pci.c.diff?r1=1.71;r2=1.72
>
>
>
> Daniel

Reply | Threaded
Open this post in threaded view
|

Re: IBM xServer 336/346 - OpenBSD 4.9

Lévai, Dániel
On sze, jzn 01, 2011 at 15:28:36 -0300, Marcos Laufer wrote:
> Daniel,
>
> What i did to make my x336 servers work with OpenBSD 4.9 was to replace
> pci.c from the source with pci.c 1.72 .
> Is this somehow wrong? Should i apply this patch instead?

That I don't know. I just simply wanted to make sure that my upgrade
path is clear next time, when I'll try to upgrade to the following
release. This way I can use this hardware longer with OpenBSD-stable.


Daniel

--
LIVAI Daniel
PGP key ID = 0x83B63A8F
Key fingerprint = DBEC C66B A47A DFA2 792D  650C C69B BE4C 83B6 3A8F