How to invoke gm4 from autoconf-2.59 in a port?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

How to invoke gm4 from autoconf-2.59 in a port?

Vortechz
I need to invoke /usr/local/bin/gm4 to get a configure.ac script processed by autoconf.

NOTE:    Don't point me to the -g option of /usr/bin/m4 , that does not work.

This is in my port Makefile, of course...
BUILD_DEPENDS= :m4->=1.4:devel/m4

I have tried these things in my port Makefile:

1.
M4=/usr/local/bin/gm4

2.
CONFIGURE_ARGS+= M4=/usr/local/bin/gm4

3.
CONFIGURE_ENV+= M4=/usr/local/bin/gm4

4.
post-patch:
export M4=/usr/local/bin/gm4

Outside ports, nr. 4 works, but when building a port, I can't get away from autoconf
invoking /usr/bin/m4 -g and it is very annoying.

// V.A.



Reply | Threaded
Open this post in threaded view
|

Re: How to invoke gm4 from autoconf-2.59 in a port?

Mikolaj Kucharski-3
On Wed, Jun 13, 2007 at 03:00:27AM -0700, Vortechz wrote:
>
> I need to invoke /usr/local/bin/gm4 to get a configure.ac script processed by
> autoconf.

Some GNOME ports have trick like below. Maybe this will help.

post-patch:
        @ln -s ${LOCALBASE}/bin/gm4 ${WRKDIR}/bin/m4

--
best regards
q#

Reply | Threaded
Open this post in threaded view
|

Re: How to invoke gm4 from autoconf-2.59 in a port?

Marc Espie-2
In reply to this post by Vortechz
On Wed, Jun 13, 2007 at 03:00:27AM -0700, Vortechz wrote:
>
> I need to invoke /usr/local/bin/gm4 to get a configure.ac script processed by
> autoconf.
>
> NOTE:    Don't point me to the -g option of /usr/bin/m4 , that does not
> work.

I will point out to that option. If you have some configure.ac that does
not work with m4 -g, then I want to know why it does not work.

I won't provide you with any work-around unless you give me that info.

Reply | Threaded
Open this post in threaded view
|

Re: How to invoke gm4 from autoconf-2.59 in a port?

j4nKy
In reply to this post by Vortechz
On Wed, Jun 13, 2007 at 03:00:27AM -0700, Vortechz wrote:

>
> I need to invoke /usr/local/bin/gm4 to get a configure.ac script processed by
> autoconf.
>
> NOTE:    Don't point me to the -g option of /usr/bin/m4 , that does not
> work.
>
> This is in my port Makefile, of course...
> BUILD_DEPENDS= :m4->=1.4:devel/m4
>
> I have tried these things in my port Makefile:
>
> 1.
> M4=/usr/local/bin/gm4
>
> 2.
> CONFIGURE_ARGS+= M4=/usr/local/bin/gm4
>
> 3.
> CONFIGURE_ENV+= M4=/usr/local/bin/gm4
>
> 4.
> post-patch:
> export M4=/usr/local/bin/gm4
>
> Outside ports, nr. 4 works, but when building a port, I can't get away from
> autoconf
> invoking /usr/bin/m4 -g and it is very annoying.

bad hack, not sure if it works, but maybe try something like

AUTOCONF_VERSION= 2.59 M4=/usr/local/bin/gm4

anyway, it would be better to fix the m4.  no ports in the tree
need GNU m4, and quite a few use autoconf.  I don't know why the
port you're working on should be different.  quite unlikely
the above hack would get committed to the ports tree.

--
[hidden email]
SDF Public Access UNIX System - http://sdf.lonestar.org