Hints on understanding/solving strange behavior in OBSD@QEmu

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Hints on understanding/solving strange behavior in OBSD@QEmu

Guillaume Muller-2
Hi,

I installed OBSD 6.5 (or upgraded from 6.4, I'm not sure...) in a
qcow2 image in QEmu 3.1.0 (Xubuntu 19.04 host). I selected to run ssh
& start X with xenodm.

Everything went fine with the basic install.

Then I installed a few packages (emacs, python, spyder3, etc) and
updated everything with pkg_add -ui and (sysmerge)/syspatch.

Everything still worked fine after this step too.

Then I discovered about Slim and decided to install Slim+XFCE4 following:
https://medium.com/@005/openbsd-6-4-installing-a-seriously-underrated-os-in-a-virtual-machine-f5848ee5a25a
and:
https://sohcahtoa.org.uk/openbsd.html

Thus I installed a few more packages:
pkg_add -ui dbus consolekit2 polkit xfce xfce-extras slim slim-themes
1) set Slim as the display manager in /etc/rc.local
/etc/rc.d/slim start
2) started the required daemons in /etc/rc.conf.local
pkg_scripts="dbus_daemon avahi_daemon messagebus"
dbus_enable
3) set XFCE as the in .xinitrc:
exec startxfce4 --with-ck-launch

And then the problem occurred: I could not login (graphically)
anymore. The display manager would simply restart. I tried various
modifications of 2) (removing some/all the pkg_scripts, adding =YES to
dbus_enable) and 3) (removing exec, removing --withxxx, replacing by
dbus-launch xxx).
It did not work.

After investigation, I discovered that dbus was not running, and that
running dbus-daemon manually led to a coredump due to a floating point
exception (thus XFCE would not start neither with Slim nor with
xenodm, but restoring fvwm, by renaming .xinitrc, would work).

I ffsck'ed the disk, then reinstalled dbus with pkg_add -D installed -r dbus.
It did not work.

I ran pkg_checked and discovered a few errors, particularly "checksum
for /usr/local/bin/dbus-daemon does not match".
I manually deleted all the files marked as errors by pkg_checked and
reinstalled the concerned packages with pkg_add -D installed -r xxx
(FYI: avahi, curl, dbus, ffcall, gettext, gnutls, harfbuzz, icu4c,
libffi, libpaper, p11-kit, pcre, pcre2, png, sqlite, tiff).
It did not work.

I installed & ran sysclean, rerun pkg_check/pkg_add -D xxx -r yyy
multiple times.
Some errors disappeared, but not the dbus-daemon checksum & floating
point exception problem.

I know I could probably solve the problem quickly by reinstalling
properly the whole system, but I'm really curious about HOW I could
have reached such a situation, WHY this situation still holds after
multiple pkg reinstalls and IF there's a clean/simple solution.

So if anymore has any idea, I'd love to learn more, just in case this
happens in a more dramatic situation and I have to find a cleaner
solution than just reinstalling...

Thanks in advance

Guillaume