GENERIC.MP cold reboot at savecore

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

GENERIC.MP cold reboot at savecore

Kapetanakis Giannis

I've tested a while ago the GENERIC.MP kernel of 4.8-stable and the system
cold reboots. GENERIC runs fine.

Trying to regenerate the problem I went into single user more and found out
that it reboots when it executes /sbin/savecore /var/crash

I tried ktrace but the dump was empty.
I also tried disabling apm without luck.

Any way to debug this?

Attaching the dmesg.

Thanx

Giannis

Reply | Threaded
Open this post in threaded view
|

Re: GENERIC.MP cold reboot at savecore

iridaoc iribag
Hello same problem  here on DELL PowerEdge R210.


Starting with OpenBSD 4.8 Release was Ok.

Applying patchs one by one until patch 006_cbc.patch

System cold reboots with this patch.

Back to kernel GENERIC.MP 4.8 release + patchs : 001_bgpd.patch,
002_pci.patch,  003_vr.patch, 004_openssl.patch 005_pf.patch, is Ok.



2011/3/24 Kapetanakis Giannis <[hidden email]>

>
> I've tested a while ago the GENERIC.MP kernel of 4.8-stable and the system
> cold reboots. GENERIC runs fine.
>
> Trying to regenerate the problem I went into single user more and found out
> that it reboots when it executes /sbin/savecore /var/crash
>
> I tried ktrace but the dump was empty.
> I also tried disabling apm without luck.
>
> Any way to debug this?
>
> Attaching the dmesg.
>
> Thanx
>
> Giannis

Reply | Threaded
Open this post in threaded view
|

Re: GENERIC.MP cold reboot at savecore

Ivo Chutkin-2
On 25.3.2011 P3. 11:00 Q., iridaoc iribag wrote:

> Hello same problem  here on DELL PowerEdge R210.
>
>
> Starting with OpenBSD 4.8 Release was Ok.
>
> Applying patchs one by one until patch 006_cbc.patch
>
> System cold reboots with this patch.
>
> Back to kernel GENERIC.MP 4.8 release + patchs : 001_bgpd.patch,
> 002_pci.patch,  003_vr.patch, 004_openssl.patch 005_pf.patch, is Ok.
>
>
>
> 2011/3/24 Kapetanakis Giannis<[hidden email]>
>
>>
>> I've tested a while ago the GENERIC.MP kernel of 4.8-stable and the system
>> cold reboots. GENERIC runs fine.
>>
>> Trying to regenerate the problem I went into single user more and found out
>> that it reboots when it executes /sbin/savecore /var/crash
>>
>> I tried ktrace but the dump was empty.
>> I also tried disabling apm without luck.
>>
>> Any way to debug this?
>>
>> Attaching the dmesg.
>>
>> Thanx
>>
>> Giannis
>
>
Hello,
Also, problem installing 4.8 -stable as of March 06 by PXE on DELL
1655MC. The server just reboots after it gets ip address.
Installing 4.8 Release without problem.

Regards,
Ivo

Reply | Threaded
Open this post in threaded view
|

Re: GENERIC.MP cold reboot at savecore

Miod Vallat
In reply to this post by Kapetanakis Giannis
> I've tested a while ago the GENERIC.MP kernel of 4.8-stable and the system
> cold reboots. GENERIC runs fine.
>
> Trying to regenerate the problem I went into single user more and found out
> that it reboots when it executes /sbin/savecore /var/crash

This has very likely been fixed early december; can you try a snapshot
kernel on your machine?

Miod

Reply | Threaded
Open this post in threaded view
|

Re: GENERIC.MP cold reboot at savecore

Kapetanakis Giannis
On 26/03/11 22:40, Miod Vallat wrote:
>> I've tested a while ago the GENERIC.MP kernel of 4.8-stable and the system
>> cold reboots. GENERIC runs fine.
>>
>> Trying to regenerate the problem I went into single user more and found out
>> that it reboots when it executes /sbin/savecore /var/crash
> This has very likely been fixed early december; can you try a snapshot
> kernel on your machine?
>
> Miod

Kernel from -current works fine.
Do you know the exact patch?

Giannis

Reply | Threaded
Open this post in threaded view
|

Re: GENERIC.MP cold reboot at savecore

Mitja Muženič
sthen@ just commited a backported fix for this to 4.8-stable for i386 and
amd64, it fixed my Dell PE T110 that experienced the same symptoms. Update
your 4.8-stable source tree and try again.