G4 Cube

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

G4 Cube

Daniel Boyd-2
I posted this to misc, but figured probably more relevant here:

I'm into week 2 of trying to get OpenBSD installed on my G4 Cube.

I first tried installing via CD, but the CD-ROM drive is broken.

I then tried DHCP/TFTP/NFS booting but couldn't get that working.

I then tried attaching another IDE CD-ROM drive to the Cube, but I
couldn't get the CD to boot (tried install62.iso and cd62.iso).  

boot cd:,ofwboot /6.2/macppc/bsd.rd DISK-LABEL: read of block 0 failed
ATAPI-DISK: open of DISK-LABEL failed can't OPEN: cd:,ofwboot

I guess maybe the IDE drive is having issues reading the CD?  I have no
idea.

Abandoning that idea, I am now attempting to boot the installer from
the internal hard drive.  I read in INSTALL.macppc that the bootloader
has to be on a DOS partition (or HFS if dual booting which I'm not), so
I looked at the macppc install.md for clues as to how this works.
Here's what I've done so far:

1) Installed OpenBSD 6.2 on old spare Dell with IDE hard drive/CD-ROM
2) Bought Torx T10 screw driver off Amazon
3) unscrewed some things to get to the IDE connector and then hooked
the Cube hard drive up to the Dell as IDE secondary master
4) copied /usr/mdec/mbr from macppc base62.tgz
5) reading from macppc install.md:
   5a) dd if=/dev/zero of=/dev/rwd1c bs=1M count=1  #assume this is
wiping out the old MBR
   5b) fdisk -f mbr -iy wd1 #write default macppc mbr to disk
6) newfs -t msdos wd1i
7) newfs all the openbsd partitions
8) mount dos partition and wd1a ffs partition
9) copy ofwboot to dos partition
10) copy bsd.rd and installation tgz files to ffs partition

11) Hooked the hard drive back into the Cube, powered it on and then
typed this into OpenFirmware

0 > boot hd:,ofwboot /bsd.rd

the system added things to the end of that line after I pressed enter:
0 > boot hd:,ofwboot /bsd.rd load-size=fcbc adler32=c626975c

and...

Loading ELF
>> OpenBSD/macppc BOOT 1.6
/pci@f2000000/mac-io@17/ata-4@1f000/disk@0:/etc/boot.conf: line too
long
boot >
booting /pci@f2000000/mac-io@17/ata-4@1f000/disk@0:/bsd.rd /pci@f200000
0/mac-io@17/ata-4@1f000/disk@0:/bsd.rd: Inappropriate file type or
format
failed(12304). will try /bsd

So...what am I doing wrong?  It's finding ofwboot, but not the kernel.
Where is ofwboot looking for bsd.rd??  I assume it shouldn't go in the
DOS partition since it's only recommended to be 1MB.
Reply | Threaded
Open this post in threaded view
|

Re: G4 Cube

Joe Nosay
You could do the dual booting from an apm (apple partition map) setup with
another BSD or Linux.

On Tue, Oct 24, 2017 at 10:52 PM, Daniel Boyd <[hidden email]>
wrote:

> I posted this to misc, but figured probably more relevant here:
>
> I'm into week 2 of trying to get OpenBSD installed on my G4 Cube.
>
> I first tried installing via CD, but the CD-ROM drive is broken.
>
> I then tried DHCP/TFTP/NFS booting but couldn't get that working.
>
> I then tried attaching another IDE CD-ROM drive to the Cube, but I
> couldn't get the CD to boot (tried install62.iso and cd62.iso).
>
> boot cd:,ofwboot /6.2/macppc/bsd.rd DISK-LABEL: read of block 0 failed
> ATAPI-DISK: open of DISK-LABEL failed can't OPEN: cd:,ofwboot
>
> I guess maybe the IDE drive is having issues reading the CD?  I have no
> idea.
>
> Abandoning that idea, I am now attempting to boot the installer from
> the internal hard drive.  I read in INSTALL.macppc that the bootloader
> has to be on a DOS partition (or HFS if dual booting which I'm not), so
> I looked at the macppc install.md for clues as to how this works.
> Here's what I've done so far:
>
> 1) Installed OpenBSD 6.2 on old spare Dell with IDE hard drive/CD-ROM
> 2) Bought Torx T10 screw driver off Amazon
> 3) unscrewed some things to get to the IDE connector and then hooked
> the Cube hard drive up to the Dell as IDE secondary master
> 4) copied /usr/mdec/mbr from macppc base62.tgz
> 5) reading from macppc install.md:
>    5a) dd if=/dev/zero of=/dev/rwd1c bs=1M count=1  #assume this is
> wiping out the old MBR
>    5b) fdisk -f mbr -iy wd1 #write default macppc mbr to disk
> 6) newfs -t msdos wd1i
> 7) newfs all the openbsd partitions
> 8) mount dos partition and wd1a ffs partition
> 9) copy ofwboot to dos partition
> 10) copy bsd.rd and installation tgz files to ffs partition
>
> 11) Hooked the hard drive back into the Cube, powered it on and then
> typed this into OpenFirmware
>
> 0 > boot hd:,ofwboot /bsd.rd
>
> the system added things to the end of that line after I pressed enter:
> 0 > boot hd:,ofwboot /bsd.rd load-size=fcbc adler32=c626975c
>
> and...
>
> Loading ELF
> >> OpenBSD/macppc BOOT 1.6
> /pci@f2000000/mac-io@17/ata-4@1f000/disk@0:/etc/boot.conf: line too
> long
> boot >
> booting /pci@f2000000/mac-io@17/ata-4@1f000/disk@0:/bsd.rd /pci@f200000
> 0/mac-io@17/ata-4@1f000/disk@0:/bsd.rd: Inappropriate file type or
> format
> failed(12304). will try /bsd
>
> So...what am I doing wrong?  It's finding ofwboot, but not the kernel.
> Where is ofwboot looking for bsd.rd??  I assume it shouldn't go in the
> DOS partition since it's only recommended to be 1MB.
>