Focusrite Scarlett 2i2 and uaudio error 4 "audio descriptors make no sense"

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Focusrite Scarlett 2i2 and uaudio error 4 "audio descriptors make no sense"

gjones5555
The Focusrite Scarlett 2i2 gives me an uaudio error=4 "audio descriptors make no
sense"

Googling, there was a patch made to Freebsd's uaudio last April,

"http://freebsd.1045724.n5.nabble.com/snd-uaudio-2-0-class-support-for-24-bit-samples-with-bSubslotSize-4-td5806141.html"

but I am unable to figure out how to translate this into a patch for OpenBSD's
uaudio.c.

Can anyone point me in the right direction?

Greg
______________________

$ usbdevs -a 3 -d -v
Controller /dev/usb0:
addr 3: high speed, power 500 mA, config 1, Scarlett 2i2 USB(0x8006),
Focusrite(0x1235), rev 0.cc
   uaudio0
   ugen0
_________________

from dmesg:

ehci0 at pci0 dev 26 function 0 "Intel 7 Series USB" rev 0x04: apic 2 int 16
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
.
.
.
.
uhub2 at uhub0 port 1 "Intel Rate Matching Hub" rev 2.00/0.00 addr 2
uaudio0 at uhub2 port 1 configuration 1 interface 0 "Focusrite Scarlett 2i2 USB"
rev 2.00/0.cc addr 3
uaudio0: audio descriptors make no sense, error=4
ugen0 at uhub2 port 1 configuration 1 "Focusrite Scarlett 2i2 USB" rev 2.00/0.cc
addr 3

Reply | Threaded
Open this post in threaded view
|

Re: Focusrite Scarlett 2i2 and uaudio error 4 "audio descriptors make no sense"

Remco-2
gjones wrote:

> The Focusrite Scarlett 2i2 gives me an uaudio error=4 "audio descriptors
> make no sense"
>
> Googling, there was a patch made to Freebsd's uaudio last April,
>
> "http://freebsd.1045724.n5.nabble.com/snd-uaudio-2-0-class-support-for-24-bit-samples-with-bSubslotSize-4-td5806141.html"
>
> but I am unable to figure out how to translate this into a patch for
> OpenBSD's uaudio.c.

I don't think this is the problem.

>
> Can anyone point me in the right direction?
>
> Greg
> ______________________
>
> $ usbdevs -a 3 -d -v
> Controller /dev/usb0:
> addr 3: high speed, power 500 mA, config 1, Scarlett 2i2 USB(0x8006),
> Focusrite(0x1235), rev 0.cc
>    uaudio0
>    ugen0
> _________________
>
> from dmesg:
>
> ehci0 at pci0 dev 26 function 0 "Intel 7 Series USB" rev 0x04: apic 2 int
> 16 usb0 at ehci0: USB revision 2.0
> uhub0 at usb0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
> .
> .
> .
> .
> uhub2 at uhub0 port 1 "Intel Rate Matching Hub" rev 2.00/0.00 addr 2
> uaudio0 at uhub2 port 1 configuration 1 interface 0 "Focusrite Scarlett
> 2i2 USB" rev 2.00/0.cc addr 3
> uaudio0: audio descriptors make no sense, error=4
> ugen0 at uhub2 port 1 configuration 1 "Focusrite Scarlett 2i2 USB" rev
> 2.00/0.cc addr 3

AFAICT this fails during detection of the device, the uaudio driver isn't able
to interpret your device's USB descriptors.

Looking at the FreeBSD post, your device seems to adhere to the USB Audio 2.0
specification. I don't think OpenBSD has support for USB Audio 2.0 and that's
the reason it fails to detect your device. (note that USB Audio 2.0 is NOT
the same as USB 2.0, for which OpenBSD DOES have support)