Firefox pegging my CPU

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Firefox pegging my CPU

Nick Guenther
I installed firefox35 on 4.6 and used it happily until yesterday when
it went crazy. It will still load pages but extremely slowly--to the
point of being unusable. I deleted my .mozilla directory--no luck. I
reinstalled it--no luck. I got rid of swfdec--no luck. Here's top(1):

load averages:  3.57,  3.41,  3.02    03:01:56
62 processes:  60 idle, 2 on processor
CPU0 states: 24.1% user,  0.0% nice,  4.3% system,  5.9% interrupt, 65.7% idle
CPU1 states: 35.9% user,  0.0% nice,  6.4% system,  0.1% interrupt, 57.6% idle
Memory: Real: 170M/496M act/tot  Free: 1000M  Swap: 0K/2910M used/tot

  PID USERNAME PRI NICE  SIZE   RES STATE     WAIT      TIME    CPU COMMAND
 5413 kousu     63    0   52M   80M onproc/0  -         3:13 78.76%
firefox35-bin
 9499 _x11       2    0   20M   39M sleep/1   select    8:04 29.98% Xorg
 5556 kousu      2    0 2468K 3812K sleep/1   select    2:11 10.84% ssh
24095 kousu      2    0 9600K   18M sleep/1   poll      1:07  7.18% Terminal
15752 kousu      2    0  844K 1456K sleep/1   netio     0:16  0.98% sftp
 3515 kousu      2    0  920K 2152K sleep/1   select    0:04  0.05% wmii
17588 kousu      2    0   19M   43M sleep/0   poll      0:07  0.00% liferea-bin
24351 kousu     18    0  592K  408K sleep/1   pause     0:09  0.00% sh
16769 kousu      2    0  544K 2088K sleep/1   poll      0:01  0.00% autocutsel
11276 kousu      2    0 1808K 4188K sleep/1   poll      0:00  0.00% gconfd-2
13162 kousu     -6    0  636K  488K idle      piperd    0:00  0.00% sh
28545 kousu      2    0 2168K 4600K sleep/0   poll      0:00  0.00% gconfd-2
25080 kousu      2    0  600K 1528K sleep/0   poll      0:00  0.00% top
28316 root       2    0  476K 1168K idle      select    0:00  0.00% famd
11756 _pflogd    4    0  604K  332K sleep/1   bpf       0:00  0.00% pflogd
 1948 kousu      3    0 1652K 3172K idle      ttyin     0:00  0.00% lynx
30910 kousu      2    0  484K  780K sleep/0   select    0:00  0.00% ifstat
 6337 kousu      3    0  716K  580K idle      ttyin     0:00  0.00% ksh

Is anyone else seeing this? Any tips on how to debug it? Clearly
something has changed on my system because it was fine for a good
month until just now.

Thanks,
-Nick

Reply | Threaded
Open this post in threaded view
|

Re: Firefox pegging my CPU

Jacek Masiulaniec-2
Did you ktrace it?

On Mon, Nov 30, 2009 at 03:08:43AM -0500, Nick Guenther wrote:

> I installed firefox35 on 4.6 and used it happily until yesterday when
> it went crazy. It will still load pages but extremely slowly--to the
> point of being unusable. I deleted my .mozilla directory--no luck. I
> reinstalled it--no luck. I got rid of swfdec--no luck. Here's top(1):
>
> load averages:  3.57,  3.41,  3.02    03:01:56
> 62 processes:  60 idle, 2 on processor
> CPU0 states: 24.1% user,  0.0% nice,  4.3% system,  5.9% interrupt, 65.7% idle
> CPU1 states: 35.9% user,  0.0% nice,  6.4% system,  0.1% interrupt, 57.6% idle
> Memory: Real: 170M/496M act/tot  Free: 1000M  Swap: 0K/2910M used/tot
>
>   PID USERNAME PRI NICE  SIZE   RES STATE     WAIT      TIME    CPU COMMAND
>  5413 kousu     63    0   52M   80M onproc/0  -         3:13 78.76%
> firefox35-bin
>  9499 _x11       2    0   20M   39M sleep/1   select    8:04 29.98% Xorg
>  5556 kousu      2    0 2468K 3812K sleep/1   select    2:11 10.84% ssh
> 24095 kousu      2    0 9600K   18M sleep/1   poll      1:07  7.18% Terminal
> 15752 kousu      2    0  844K 1456K sleep/1   netio     0:16  0.98% sftp
>  3515 kousu      2    0  920K 2152K sleep/1   select    0:04  0.05% wmii
> 17588 kousu      2    0   19M   43M sleep/0   poll      0:07  0.00% liferea-bin
> 24351 kousu     18    0  592K  408K sleep/1   pause     0:09  0.00% sh
> 16769 kousu      2    0  544K 2088K sleep/1   poll      0:01  0.00% autocutsel
> 11276 kousu      2    0 1808K 4188K sleep/1   poll      0:00  0.00% gconfd-2
> 13162 kousu     -6    0  636K  488K idle      piperd    0:00  0.00% sh
> 28545 kousu      2    0 2168K 4600K sleep/0   poll      0:00  0.00% gconfd-2
> 25080 kousu      2    0  600K 1528K sleep/0   poll      0:00  0.00% top
> 28316 root       2    0  476K 1168K idle      select    0:00  0.00% famd
> 11756 _pflogd    4    0  604K  332K sleep/1   bpf       0:00  0.00% pflogd
>  1948 kousu      3    0 1652K 3172K idle      ttyin     0:00  0.00% lynx
> 30910 kousu      2    0  484K  780K sleep/0   select    0:00  0.00% ifstat
>  6337 kousu      3    0  716K  580K idle      ttyin     0:00  0.00% ksh
>
> Is anyone else seeing this? Any tips on how to debug it? Clearly
> something has changed on my system because it was fine for a good
> month until just now.
>
> Thanks,
> -Nick

Reply | Threaded
Open this post in threaded view
|

Re: Firefox pegging my CPU

Nick Guenther
On Mon, Nov 30, 2009 at 5:02 AM, Jacek Masiulaniec
<[hidden email]> wrote:

>
> On Mon, Nov 30, 2009 at 03:08:43AM -0500, Nick Guenther wrote:
>> I installed firefox35 on 4.6 and used it happily until yesterday when
>> it went crazy. It will still load pages but extremely slowly--to the
>> point of being unusable. I deleted my .mozilla directory--no luck. I
>> reinstalled it--no luck. I got rid of swfdec--no luck. Here's top(1):
>>
>> load averages:  3.57,  3.41,  3.02    03:01:56
>> 62 processes:  60 idle, 2 on processor
>> CPU0 states: 24.1% user,  0.0% nice,  4.3% system,  5.9% interrupt, 65.7%
idle
>> CPU1 states: 35.9% user,  0.0% nice,  6.4% system,  0.1% interrupt, 57.6%
idle
>> Memory: Real: 170M/496M act/tot  Free: 1000M  Swap: 0K/2910M used/tot
>>
>>   PID USERNAME PRI NICE  SIZE   RES STATE     WAIT      TIME    CPU
COMMAND
>>  5413 kousu     63    0   52M   80M onproc/0  -         3:13 78.76%
>> firefox35-bin
>>
>
> Did you ktrace it?

Nope (though I was considering it) but it's gotten better
mysteriously. Sorry for the noise.

-Nick