Firefox package update problem due to libraries

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

Firefox package update problem due to libraries

James Griffin-2
Hi

Updated my packages this morning, came to update Firefox-22 and some errors were spat out:

Can't install firefox-22.0 because of libraries
|library nss3.33.3 not found
| /usr/local/lib/libnss3.so.33.2 (nss-3.15): minor is too small
|library nssutil3.33.3 not found
| /usr/local/lib/libnssutil3.so.33.2 (nss-3.15): minor is too small
|library smime3.33.3 not found
| /usr/local/lib/libsmime3.so.33.2 (nss-3.15): minor is too small
|library ssl3.33.3 not found
| /usr/local/lib/libssl3.so.33.2 (nss-3.15): minor is too small
Direct dependencies for firefox-22.0->22.0 resolve to gstreamer-plugins-good-0.10.31p7v0 nss-3.15 desktop-file-utils-0.21p0 libiconv-1.14p0 gtk+2-2.24.19p1 gettext-0.18.2p2 gstreamer-plugins-base-0.10.36p6 nspr-4.10
Full dependency tree is graphite2-1.2.1 libsecret-0.14p0 lzo2-2.06p0 gsettings-desktop-schemas-3.8.2 cairo-1.12.14p0 libcroco-0.6.8p0 jasper-1.900.1p2 taglib-1.8p5 gstreamer-plugins-good-0.10.31p7v0 cups-libs-1.6.2p1 gdbm-1.10 libgpg-error-1.11 libogg-1.3.1 libgcrypt-1.5.2 png-1.6.2p0 libdaemon-0.14 libtasn1-3.3 flac-1.3.0 shared-mime-info-1.1 gvfs-1.16.3 tiff-4.0.3p2 libnettle-2.7.1 orc-0.4.16p2 libelf-0.8.13p1 gtk+2-2.24.19p1 gstreamer-plugins-base-0.10.36p6 atk-2.8.0 libidn-1.27 libshout-2.2.2p1 libtheora-1.1.1p2 nss-3.15 libsoup-gnome-2.42.2 gstreamer-0.10.36p5 pango-1.34.1p1 desktop-file-utils-0.21p0 avahi-0.6.31p10 gettext-0.18.2p2 bzip2-1.0.6p0 python-2.7.5 at-spi2-atk-2.8.1 dbus-glib-0.100.2v0 p11-kit-0.18.3p0 gtk+3-3.8.2p2 at-spi2-core-2.8.0 libffi-3.0.9p3 cdparanoia-3.a9.8p0 xz-5.0.4p0 hicolor-icon-theme-0.12p2 gnutls-3.2.1 dconf-0.16.0p0 librsvg-2.36.4p3 gmp-5.0.2p2 libvorbis-1.3.3p0 gnome-icon-theme-3.8.2 libsoup-2.42.2 libarchive-3.0.4p0 gconf2-3.2.6p0 libxml-2.!
 9.0p0 gtk-update-icon-cache-2.24.19p1 wavpack-4.60.1p0 dbus-1.6.12v0 pcre-8.33 glib2-2.36.3 speex-1.2rc1p0 libproxy-0.4.11p1 gnome-icon-theme-symbolic-3.8.3 libiconv-1.14p0 harfbuzz-0.9.18 gdk-pixbuf-2.28.2p1 nspr-4.10 glib2-networking-2.36.2 tremor-20120410p0 jpeg-9p0


Not really sure what this problem is due to, never had this before. Running OpenBSD -current snapshot:

        OpenBSD 5.3-current (GENERIC.MP) #14: Thu Jul  4 11:58:08 MDT 2013

Also, at the end of update process, some more update failure messgaes:

Couldn't find updates for uvideo-firmware-1.2p0, nss-3.15, tk-8.5.14, tcl-8.6.0p0, libotr-3.2.1, firefox-22.0, latex-mk-1.9.1p0, p5-MP3-Tag-1.13, re2c-0.13.5, tcl-8.5.14, tk-8.6.0, p5-IO-Socket-SSL-1.94, xz-5.0.4p0, p5-IO-Socket-INET6-2.70, libxslt-1.1.28, openjpeg-1.5.0p4, libmng-1.0.10p1, msttcorefonts-2.0p0, vlc-2.0.7, libshout-2.2.2p1

Had a similar issue yesterday, just not so many errors.

Could anyone help to explain what's gone wrong?

Many thanks, Jamie.

Reply | Threaded
Open this post in threaded view
|

Re: Firefox package update problem due to libraries

dmitry.sensei
You must include PKG_PATH value.
09.07.2013 13:40 пользователь "James Griffin" <[hidden email]>
написал:

> Hi
>
> Updated my packages this morning, came to update Firefox-22 and some
> errors were spat out:
>
> Can't install firefox-22.0 because of libraries
> |library nss3.33.3 not found
> | /usr/local/lib/libnss3.so.33.2 (nss-3.15): minor is too small
> |library nssutil3.33.3 not found
> | /usr/local/lib/libnssutil3.so.33.2 (nss-3.15): minor is too small
> |library smime3.33.3 not found
> | /usr/local/lib/libsmime3.so.33.2 (nss-3.15): minor is too small
> |library ssl3.33.3 not found
> | /usr/local/lib/libssl3.so.33.2 (nss-3.15): minor is too small
> Direct dependencies for firefox-22.0->22.0 resolve to
> gstreamer-plugins-good-0.10.31p7v0 nss-3.15 desktop-file-utils-0.21p0
> libiconv-1.14p0 gtk+2-2.24.19p1 gettext-0.18.2p2
> gstreamer-plugins-base-0.10.36p6 nspr-4.10
> Full dependency tree is graphite2-1.2.1 libsecret-0.14p0 lzo2-2.06p0
> gsettings-desktop-schemas-3.8.2 cairo-1.12.14p0 libcroco-0.6.8p0
> jasper-1.900.1p2 taglib-1.8p5 gstreamer-plugins-good-0.10.31p7v0
> cups-libs-1.6.2p1 gdbm-1.10 libgpg-error-1.11 libogg-1.3.1 libgcrypt-1.5.2
> png-1.6.2p0 libdaemon-0.14 libtasn1-3.3 flac-1.3.0 shared-mime-info-1.1
> gvfs-1.16.3 tiff-4.0.3p2 libnettle-2.7.1 orc-0.4.16p2 libelf-0.8.13p1
> gtk+2-2.24.19p1 gstreamer-plugins-base-0.10.36p6 atk-2.8.0 libidn-1.27
> libshout-2.2.2p1 libtheora-1.1.1p2 nss-3.15 libsoup-gnome-2.42.2
> gstreamer-0.10.36p5 pango-1.34.1p1 desktop-file-utils-0.21p0
> avahi-0.6.31p10 gettext-0.18.2p2 bzip2-1.0.6p0 python-2.7.5
> at-spi2-atk-2.8.1 dbus-glib-0.100.2v0 p11-kit-0.18.3p0 gtk+3-3.8.2p2
> at-spi2-core-2.8.0 libffi-3.0.9p3 cdparanoia-3.a9.8p0 xz-5.0.4p0
> hicolor-icon-theme-0.12p2 gnutls-3.2.1 dconf-0.16.0p0 librsvg-2.36.4p3
> gmp-5.0.2p2 libvorbis-1.3.3p0 gnome-icon-theme-3.8.2 libsoup-2.42.2
> libarchive-3.0.4p0 gconf2-3.2.6p0 libxml-2.!
>  9.0p0 gtk-update-icon-cache-2.24.19p1 wavpack-4.60.1p0 dbus-1.6.12v0
> pcre-8.33 glib2-2.36.3 speex-1.2rc1p0 libproxy-0.4.11p1
> gnome-icon-theme-symbolic-3.8.3 libiconv-1.14p0 harfbuzz-0.9.18
> gdk-pixbuf-2.28.2p1 nspr-4.10 glib2-networking-2.36.2 tremor-20120410p0
> jpeg-9p0
>
>
> Not really sure what this problem is due to, never had this before.
> Running OpenBSD -current snapshot:
>
>         OpenBSD 5.3-current (GENERIC.MP) #14: Thu Jul  4 11:58:08 MDT 2013
>
> Also, at the end of update process, some more update failure messgaes:
>
> Couldn't find updates for uvideo-firmware-1.2p0, nss-3.15, tk-8.5.14,
> tcl-8.6.0p0, libotr-3.2.1, firefox-22.0, latex-mk-1.9.1p0, p5-MP3-Tag-1.13,
> re2c-0.13.5, tcl-8.5.14, tk-8.6.0, p5-IO-Socket-SSL-1.94, xz-5.0.4p0,
> p5-IO-Socket-INET6-2.70, libxslt-1.1.28, openjpeg-1.5.0p4, libmng-1.0.10p1,
> msttcorefonts-2.0p0, vlc-2.0.7, libshout-2.2.2p1
>
> Had a similar issue yesterday, just not so many errors.
>
> Could anyone help to explain what's gone wrong?
>
> Many thanks, Jamie.
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Firefox package update problem due to libraries

Landry Breuil-6
In reply to this post by James Griffin-2
On Tue, Jul 09, 2013 at 09:39:04AM +0100, James Griffin wrote:

> Hi
>
> Updated my packages this morning, came to update Firefox-22 and some errors were spat out:
>
> Can't install firefox-22.0 because of libraries
> |library nss3.33.3 not found
> | /usr/local/lib/libnss3.so.33.2 (nss-3.15): minor is too small
> |library nssutil3.33.3 not found
> | /usr/local/lib/libnssutil3.so.33.2 (nss-3.15): minor is too small
> |library smime3.33.3 not found
> | /usr/local/lib/libsmime3.so.33.2 (nss-3.15): minor is too small
> |library ssl3.33.3 not found
> | /usr/local/lib/libssl3.so.33.2 (nss-3.15): minor is too small
> Direct dependencies for firefox-22.0->22.0 resolve to gstreamer-plugins-good-0.10.31p7v0 nss-3.15 desktop-file-utils-0.21p0 libiconv-1.14p0 gtk+2-2.24.19p1 gettext-0.18.2p2 gstreamer-plugins-base-0.10.36p6 nspr-4.10
> Full dependency tree is graphite2-1.2.1 libsecret-0.14p0 lzo2-2.06p0 gsettings-desktop-schemas-3.8.2 cairo-1.12.14p0 libcroco-0.6.8p0 jasper-1.900.1p2 taglib-1.8p5 gstreamer-plugins-good-0.10.31p7v0 cups-libs-1.6.2p1 gdbm-1.10 libgpg-error-1.11 libogg-1.3.1 libgcrypt-1.5.2 png-1.6.2p0 libdaemon-0.14 libtasn1-3.3 flac-1.3.0 shared-mime-info-1.1 gvfs-1.16.3 tiff-4.0.3p2 libnettle-2.7.1 orc-0.4.16p2 libelf-0.8.13p1 gtk+2-2.24.19p1 gstreamer-plugins-base-0.10.36p6 atk-2.8.0 libidn-1.27 libshout-2.2.2p1 libtheora-1.1.1p2 nss-3.15 libsoup-gnome-2.42.2 gstreamer-0.10.36p5 pango-1.34.1p1 desktop-file-utils-0.21p0 avahi-0.6.31p10 gettext-0.18.2p2 bzip2-1.0.6p0 python-2.7.5 at-spi2-atk-2.8.1 dbus-glib-0.100.2v0 p11-kit-0.18.3p0 gtk+3-3.8.2p2 at-spi2-core-2.8.0 libffi-3.0.9p3 cdparanoia-3.a9.8p0 xz-5.0.4p0 hicolor-icon-theme-0.12p2 gnutls-3.2.1 dconf-0.16.0p0 librsvg-2.36.4p3 gmp-5.0.2p2 libvorbis-1.3.3p0 gnome-icon-theme-3.8.2 libsoup-2.42.2 libarchive-3.0.4p0 gconf2-3.2.6p0 libxml-!
 2.!

>  9.0p0 gtk-update-icon-cache-2.24.19p1 wavpack-4.60.1p0 dbus-1.6.12v0 pcre-8.33 glib2-2.36.3 speex-1.2rc1p0 libproxy-0.4.11p1 gnome-icon-theme-symbolic-3.8.3 libiconv-1.14p0 harfbuzz-0.9.18 gdk-pixbuf-2.28.2p1 nspr-4.10 glib2-networking-2.36.2 tremor-20120410p0 jpeg-9p0
>
>
> Not really sure what this problem is due to, never had this before. Running OpenBSD -current snapshot:
>
> OpenBSD 5.3-current (GENERIC.MP) #14: Thu Jul  4 11:58:08 MDT 2013
>
> Also, at the end of update process, some more update failure messgaes:
>
> Couldn't find updates for uvideo-firmware-1.2p0, nss-3.15, tk-8.5.14, tcl-8.6.0p0, libotr-3.2.1, firefox-22.0, latex-mk-1.9.1p0, p5-MP3-Tag-1.13, re2c-0.13.5, tcl-8.5.14, tk-8.6.0, p5-IO-Socket-SSL-1.94, xz-5.0.4p0, p5-IO-Socket-INET6-2.70, libxslt-1.1.28, openjpeg-1.5.0p4, libmng-1.0.10p1, msttcorefonts-2.0p0, vlc-2.0.7, libshout-2.2.2p1
>
> Had a similar issue yesterday, just not so many errors.
>
> Could anyone help to explain what's gone wrong?

Somehow the ffx package was built against nss 3.15.1, but the latter
wasnt on the mirrors. Maybe you were using a half-synched pkg snapshots.

Update nss to fix the issue.

Landry

Reply | Threaded
Open this post in threaded view
|

Re: Firefox package update problem due to libraries

James Griffin-2
In reply to this post by dmitry.sensei
................Tue  9.Jul'13 at 13:43:38 +0500, dmitry.sensei................
> You must include PKG_PATH value.

Sure, $PKG_PATH is set a local mirror:

ftp://mirror.ox.ac.uk/pub/OpenBSD/snapshots/packages/amd64/

Thanks, Jamie

Reply | Threaded
Open this post in threaded view
|

Re: Firefox package update problem due to libraries

Stuart Henderson-6
In reply to this post by James Griffin-2
On 2013/07/09 09:39, James Griffin wrote:
> Hi
>
> Updated my packages this morning, came to update Firefox-22 and some errors were spat out:

Look at the file directory listing in the mirror and check that dates on
packages are consistent; during updates it's possible to end up with a
mismatched set.

If this was the problem, it might have been fixed by now already.
If not, please say which mirror you use, and which arch (sparc64? i386?
amd64? macppc? etc).

Reply | Threaded
Open this post in threaded view
|

Re: Firefox package update problem due to libraries

Stuart Henderson-6
In reply to this post by James Griffin-2
On 2013/07/09 09:48, James Griffin wrote:
> ................Tue  9.Jul'13 at 13:43:38 +0500, dmitry.sensei................
> > You must include PKG_PATH value.
>
> Sure, $PKG_PATH is set a local mirror:
>
> ftp://mirror.ox.ac.uk/pub/OpenBSD/snapshots/packages/amd64/
>
> Thanks, Jamie
>

Yes this is half of one set, half of another, same for most of the EU mirrors.
If you need it today then use ftp5.eu.openbsd.org, otherwise try again this
evening or tomorrow.



Reply | Threaded
Open this post in threaded view
|

Re: Firefox package update problem due to libraries

James Griffin-2
In reply to this post by Stuart Henderson-6
................Tue  9.Jul'13 at  9:51:10 +0100, Stuart Henderson................

> On 2013/07/09 09:39, James Griffin wrote:
> > Hi
> >
> > Updated my packages this morning, came to update Firefox-22 and some errors were spat out:
>
> Look at the file directory listing in the mirror and check that dates on
> packages are consistent; during updates it's possible to end up with a
> mismatched set.
>
> If this was the problem, it might have been fixed by now already.
> If not, please say which mirror you use, and which arch (sparc64? i386?
> amd64? macppc? etc).
>

Firefox was updated to 22.x last week. It pulled in the libraries it needed  then and was fine. I've update a couple of times since then, and it's been fine. Just today i've seen this. The browser works ok so it's no major issue. If it's a case of waiting a while for the mirror to be updated then i'll just wait.

I specified the system arch in my first message. AMD64 OpenBSD -current Jul 04 snapshot.

Reply | Threaded
Open this post in threaded view
|

Re: Firefox package update problem due to libraries

Stuart Henderson-6
On 2013/07/09 10:04, James Griffin wrote:

> ................Tue  9.Jul'13 at  9:51:10 +0100, Stuart Henderson................
> > On 2013/07/09 09:39, James Griffin wrote:
> > > Hi
> > >
> > > Updated my packages this morning, came to update Firefox-22 and some errors were spat out:
> >
> > Look at the file directory listing in the mirror and check that dates on
> > packages are consistent; during updates it's possible to end up with a
> > mismatched set.
> >
> > If this was the problem, it might have been fixed by now already.
> > If not, please say which mirror you use, and which arch (sparc64? i386?
> > amd64? macppc? etc).
> >
>
> Firefox was updated to 22.x last week. It pulled in the libraries it
> needed then and was fine. I've update a couple of times since then, and
> it's been fine. Just today i've seen this. The browser works ok so it's
> no major issue. If it's a case of waiting a while for the mirror to be
> updated then i'll just wait.

Note that when running -current, all packages should be updated together.
Depending on library updates you can run into various dependency problems
if you just update some packages.

> I specified the system arch in my first message. AMD64 OpenBSD -current Jul 04 snapshot.

You trimmed the arch,
http://marc.info/?l=openbsd-ports&m=137335917003298


Reply | Threaded
Open this post in threaded view
|

Re: Firefox package update problem due to libraries

James Griffin-2
................Tue  9.Jul'13 at 10:21:37 +0100, Stuart Henderson................

> On 2013/07/09 10:04, James Griffin wrote:
> > ................Tue  9.Jul'13 at  9:51:10 +0100, Stuart Henderson................
> > > On 2013/07/09 09:39, James Griffin wrote:
> > > > Hi
> > > >
> > > > Updated my packages this morning, came to update Firefox-22 and some errors were spat out:
> > >
> > > Look at the file directory listing in the mirror and check that dates on
> > > packages are consistent; during updates it's possible to end up with a
> > > mismatched set.
> > >
> > > If this was the problem, it might have been fixed by now already.
> > > If not, please say which mirror you use, and which arch (sparc64? i386?
> > > amd64? macppc? etc).
> > >
> >
> > Firefox was updated to 22.x last week. It pulled in the libraries it
> > needed then and was fine. I've update a couple of times since then, and
> > it's been fine. Just today i've seen this. The browser works ok so it's
> > no major issue. If it's a case of waiting a while for the mirror to be
> > updated then i'll just wait.
>
> Note that when running -current, all packages should be updated together.
> Depending on library updates you can run into various dependency problems
> if you just update some packages.
>
> > I specified the system arch in my first message. AMD64 OpenBSD -current Jul 04 snapshot.
>
> You trimmed the arch,
> http://marc.info/?l=openbsd-ports&m=137335917003298

Sorry, didn't realise. Yes, I always update my packages when I upgrade to a newer snapshot. I do my best to keep things in sync. I've never seen this before. I'm sure it's just a temporary issue, I'll try to update them later using the same mirror.

Thanks to all for the info and advice.

Jamie.

Reply | Threaded
Open this post in threaded view
|

Re: Firefox package update problem due to libraries

James Griffin-2
In reply to this post by Stuart Henderson-6
................Tue  9.Jul'13 at  9:59:17 +0100, Stuart Henderson................

> On 2013/07/09 09:48, James Griffin wrote:
> > ................Tue  9.Jul'13 at 13:43:38 +0500, dmitry.sensei................
> > > You must include PKG_PATH value.
> >
> > Sure, $PKG_PATH is set a local mirror:
> >
> > ftp://mirror.ox.ac.uk/pub/OpenBSD/snapshots/packages/amd64/
> >
> > Thanks, Jamie
> >
>
> Yes this is half of one set, half of another, same for most of the EU mirrors.
> If you need it today then use ftp5.eu.openbsd.org, otherwise try again this
> evening or tomorrow.

I tried this mirror and loads of packages got updated. I also used it to upgrade to a newer snapshot 5.4-beta. All sorted now.

Thanks again for the help.

Jamie.