Does mldonkey require Objective-Caml 3.12.0?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Does mldonkey require Objective-Caml 3.12.0?

Brett Mahar-2
Hi ports,

I'm trying to build mldonkey on i386 current. The build pauses and asks me [see output below]. If I say no it errors out. I couldn't see anything in the makefile that says it needs ocaml-3.12.0, and the build process has already installed ocaml-4.00.0p1 prior to reaching this question.

Is this port just a special case where I will need ocaml-3.12.0 as well, or has something gone wrong? I know we push packages over ports, but if this is supposed to happen, should I send in something to add to the DESCR for future reference?

Cheers,
Brett.





checking host system type... i386-unknown-openbsd5.2

--------------------------------
     Checking system tools.
--------------------------------
checking for ranlib... (cached) ranlib
checking for gmake... gmake
checking for make... (cached) gmake
checking if gmake is GNU make ... yes
checking for bzip2... bzip2
checking for gzip... (cached) bzip2
checking for perl... /usr/bin/perl
checking for rpmbuild... (cached) no
checking for rpm... (cached) no
checking for wget... (cached) no
/tmp//ccIv57OX.o(.text+0x2d): In function `parse_url':
: warning: strcpy() is almost always misused, please use strlcpy()
/tmp//ccIv57OX.o(.text+0x3ff): In function `main':
: warning: sprintf() is often misused, please use snprintf()
checking for wget... /usr/ports/pobj/mldonkey-3.1.2/mldonkey-3.1.2/config/wget
----------------------------------------
     Checking system tools finished.
----------------------------------------

--------------------------------
     Checking Ocaml compiler.
--------------------------------
checking for ocamlc.opt... /usr/local/bin/ocamlc.opt
checking for ocamlc... /usr/local/bin/ocamlc.opt
checking for camlp4... /usr/local/bin/camlp4
Need build
********  Objective-Caml 3.12.0 is required  *********
*******  Check http://caml.inria.fr/  ********
Do you want this script to try to download and install ocaml
LOCALLY in mldonkey directory ?
yes
Downloading ...


Reply | Threaded
Open this post in threaded view
|

Re: Does mldonkey require Objective-Caml 3.12.0?

David Coppa-4
On Mon, Aug 20, 2012 at 11:12:36AM +1000, Brett wrote:
> Hi ports,
>
> I'm trying to build mldonkey on i386 current. The build pauses and asks me [see output below]. If I say no it errors out. I couldn't see anything in the makefile that says it needs ocaml-3.12.0, and the build process has already installed ocaml-4.00.0p1 prior to reaching this question.
>
> Is this port just a special case where I will need ocaml-3.12.0 as well, or has something gone wrong? I know we push packages over ports, but if this is supposed to happen, should I send in something to add to the DESCR for future reference?
>
> Cheers,
> Brett.

What version of mldonkey are you trying to compile?
mldonkey has been updated too (alongside the switch to ocaml4). You need mldonkey-3.1.3 to go with ocaml 4.0.

Ciao,
David

>
>
>
> checking host system type... i386-unknown-openbsd5.2
>
> --------------------------------
>      Checking system tools.
> --------------------------------
> checking for ranlib... (cached) ranlib
> checking for gmake... gmake
> checking for make... (cached) gmake
> checking if gmake is GNU make ... yes
> checking for bzip2... bzip2
> checking for gzip... (cached) bzip2
> checking for perl... /usr/bin/perl
> checking for rpmbuild... (cached) no
> checking for rpm... (cached) no
> checking for wget... (cached) no
> /tmp//ccIv57OX.o(.text+0x2d): In function `parse_url':
> : warning: strcpy() is almost always misused, please use strlcpy()
> /tmp//ccIv57OX.o(.text+0x3ff): In function `main':
> : warning: sprintf() is often misused, please use snprintf()
> checking for wget... /usr/ports/pobj/mldonkey-3.1.2/mldonkey-3.1.2/config/wget
> ----------------------------------------
>      Checking system tools finished.
> ----------------------------------------
>
> --------------------------------
>      Checking Ocaml compiler.
> --------------------------------
> checking for ocamlc.opt... /usr/local/bin/ocamlc.opt
> checking for ocamlc... /usr/local/bin/ocamlc.opt
> checking for camlp4... /usr/local/bin/camlp4
> Need build
> ********  Objective-Caml 3.12.0 is required  *********
> *******  Check http://caml.inria.fr/  ********
> Do you want this script to try to download and install ocaml
> LOCALLY in mldonkey directory ?
> yes
> Downloading ...
>
>

Reply | Threaded
Open this post in threaded view
|

Re: Does mldonkey require Objective-Caml 3.12.0?

Brett Mahar-2
> >
> > I'm trying to build mldonkey on i386 current. The build pauses and asks me [see output below]. If I say no it errors out. I couldn't see anything in the makefile that says it needs ocaml-3.12.0, and the build process has already installed ocaml-4.00.0p1 prior to reaching this question.
> >


>
> What version of mldonkey are you trying to compile?
> mldonkey has been updated too (alongside the switch to ocaml4). You need mldonkey-3.1.3 to go with ocaml 4.0.
>
> Ciao,
> David
>

Sorry about the noise, I cvsync'd yesterday and must have just missed that update, and didn't notice it on the ports-cvs mailing list.

Thanks,
Brett.