Does intel(4) support Iris Xe Graphics?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Does intel(4) support Iris Xe Graphics?

Michel von Behr
Hi - (not a dev, just trying to use OpenBSD snapshot) whenever I try to
launch Xorg, either via xenodm or startx, I'm getting a kernel panic,
like "pool_do_get:
drmobj : page empty" (I already sent an e-mail [1] to [hidden email] with
dmesg and all).

I'm wondering if the problem could be with my video card, Intel Iris Xe?
Even though dmesg shows that is was detected and should (?) be working. But
I can't find a reason why my laptop would not run Xorg.

inteldrm0 at pci0 dev 2 function 0 "Intel Xe Graphics" rev 0x01
drm0 at inteldrm0
inteldrm0: msi, TIGERLAKE, gen 12


Any pointing to the right direction would be appreciated. (If this problem
relates to Xorg specifically and not to OpenBSD please let me know).

[1] https://marc.info/?l=openbsd-bugs&m=161754767328009&w=2

Regards,

Michel
Reply | Threaded
Open this post in threaded view
|

Re: Does intel(4) support Iris Xe Graphics?

Jonathan Gray-11
On Tue, Apr 06, 2021 at 11:09:07AM +0400, Michel von Behr wrote:
> Hi - (not a dev, just trying to use OpenBSD snapshot) whenever I try to
> launch Xorg, either via xenodm or startx, I'm getting a kernel panic,
> like "pool_do_get:
> drmobj : page empty" (I already sent an e-mail [1] to [hidden email] with
> dmesg and all).

The pool should already be initialised via
i915_global_objects_init()
i915_globals_init()
inteldrm_attachhook()

>
> I'm wondering if the problem could be with my video card, Intel Iris Xe?
> Even though dmesg shows that is was detected and should (?) be working. But
> I can't find a reason why my laptop would not run Xorg.
>
> inteldrm0 at pci0 dev 2 function 0 "Intel Xe Graphics" rev 0x01
> drm0 at inteldrm0
> inteldrm0: msi, TIGERLAKE, gen 12
>

jcs@ has/had a tiger lake machine which could run Xorg with the
linux 5.7 based drm in -current.  I'm not sure what is different here.

>
> Any pointing to the right direction would be appreciated. (If this problem
> relates to Xorg specifically and not to OpenBSD please let me know).
>
> [1] https://marc.info/?l=openbsd-bugs&m=161754767328009&w=2
>
> Regards,
>
> Michel
>

Reply | Threaded
Open this post in threaded view
|

Re: Does intel(4) support Iris Xe Graphics?

Michel von Behr
Thank you for the reply, Jonathan - FWIW I was able to run Ubuntu on the
machine just now. I still would like to try and install OpenBSD, if anyone
can help me diagnose/fix the problem I’m willing to try.

Regards,

Michel

On Wed, 7 Apr 2021 at 2:33 AM Jonathan Gray <[hidden email]> wrote:

> On Tue, Apr 06, 2021 at 11:09:07AM +0400, Michel von Behr wrote:
> > Hi - (not a dev, just trying to use OpenBSD snapshot) whenever I try to
> > launch Xorg, either via xenodm or startx, I'm getting a kernel panic,
> > like "pool_do_get:
> > drmobj : page empty" (I already sent an e-mail [1] to [hidden email]
> with
> > dmesg and all).
>
> The pool should already be initialised via
> i915_global_objects_init()
> i915_globals_init()
> inteldrm_attachhook()
>
> >
> > I'm wondering if the problem could be with my video card, Intel Iris Xe?
> > Even though dmesg shows that is was detected and should (?) be working.
> But
> > I can't find a reason why my laptop would not run Xorg.
> >
> > inteldrm0 at pci0 dev 2 function 0 "Intel Xe Graphics" rev 0x01
> > drm0 at inteldrm0
> > inteldrm0: msi, TIGERLAKE, gen 12
> >
>
> jcs@ has/had a tiger lake machine which could run Xorg with the
> linux 5.7 based drm in -current.  I'm not sure what is different here.
>
> >
> > Any pointing to the right direction would be appreciated. (If this
> problem
> > relates to Xorg specifically and not to OpenBSD please let me know).
> >
> > [1] https://marc.info/?l=openbsd-bugs&m=161754767328009&w=2
> >
> > Regards,
> >
> > Michel
> >
>
Reply | Threaded
Open this post in threaded view
|

Re: Does intel(4) support Iris Xe Graphics?

Tom Smyth
Hi Michel,
if you send the dmesg  from OpenBSD when it is installed and Ubuntu
it would help alot
see the hardware that your box is running (and the hardware as
detected by OpenBSD / Ubuntu


On Wed, 7 Apr 2021 at 05:21, Michel von Behr <[hidden email]> wrote:

>
> Thank you for the reply, Jonathan - FWIW I was able to run Ubuntu on the
> machine just now. I still would like to try and install OpenBSD, if anyone
> can help me diagnose/fix the problem I’m willing to try.
>
> Regards,
>
> Michel
>
> On Wed, 7 Apr 2021 at 2:33 AM Jonathan Gray <[hidden email]> wrote:
>
> > On Tue, Apr 06, 2021 at 11:09:07AM +0400, Michel von Behr wrote:
> > > Hi - (not a dev, just trying to use OpenBSD snapshot) whenever I try to
> > > launch Xorg, either via xenodm or startx, I'm getting a kernel panic,
> > > like "pool_do_get:
> > > drmobj : page empty" (I already sent an e-mail [1] to [hidden email]
> > with
> > > dmesg and all).
> >
> > The pool should already be initialised via
> > i915_global_objects_init()
> > i915_globals_init()
> > inteldrm_attachhook()
> >
> > >
> > > I'm wondering if the problem could be with my video card, Intel Iris Xe?
> > > Even though dmesg shows that is was detected and should (?) be working.
> > But
> > > I can't find a reason why my laptop would not run Xorg.
> > >
> > > inteldrm0 at pci0 dev 2 function 0 "Intel Xe Graphics" rev 0x01
> > > drm0 at inteldrm0
> > > inteldrm0: msi, TIGERLAKE, gen 12
> > >
> >
> > jcs@ has/had a tiger lake machine which could run Xorg with the
> > linux 5.7 based drm in -current.  I'm not sure what is different here.
> >
> > >
> > > Any pointing to the right direction would be appreciated. (If this
> > problem
> > > relates to Xorg specifically and not to OpenBSD please let me know).
> > >
> > > [1] https://marc.info/?l=openbsd-bugs&m=161754767328009&w=2
> > >
> > > Regards,
> > >
> > > Michel
> > >
> >



--
Kindest regards,
Tom Smyth.

Reply | Threaded
Open this post in threaded view
|

Re: Does intel(4) support Iris Xe Graphics?

Tom Smyth
Try Current and 6.8  and see if you get a different result in each..
dmesgs are key for getting help on this type of query ...

On Wed, 7 Apr 2021 at 11:33, Tom Smyth <[hidden email]> wrote:

>
> Hi Michel,
> if you send the dmesg  from OpenBSD when it is installed and Ubuntu
> it would help alot
> see the hardware that your box is running (and the hardware as
> detected by OpenBSD / Ubuntu
>
>
> On Wed, 7 Apr 2021 at 05:21, Michel von Behr <[hidden email]> wrote:
> >
> > Thank you for the reply, Jonathan - FWIW I was able to run Ubuntu on the
> > machine just now. I still would like to try and install OpenBSD, if anyone
> > can help me diagnose/fix the problem I’m willing to try.
> >
> > Regards,
> >
> > Michel
> >
> > On Wed, 7 Apr 2021 at 2:33 AM Jonathan Gray <[hidden email]> wrote:
> >
> > > On Tue, Apr 06, 2021 at 11:09:07AM +0400, Michel von Behr wrote:
> > > > Hi - (not a dev, just trying to use OpenBSD snapshot) whenever I try to
> > > > launch Xorg, either via xenodm or startx, I'm getting a kernel panic,
> > > > like "pool_do_get:
> > > > drmobj : page empty" (I already sent an e-mail [1] to [hidden email]
> > > with
> > > > dmesg and all).
> > >
> > > The pool should already be initialised via
> > > i915_global_objects_init()
> > > i915_globals_init()
> > > inteldrm_attachhook()
> > >
> > > >
> > > > I'm wondering if the problem could be with my video card, Intel Iris Xe?
> > > > Even though dmesg shows that is was detected and should (?) be working.
> > > But
> > > > I can't find a reason why my laptop would not run Xorg.
> > > >
> > > > inteldrm0 at pci0 dev 2 function 0 "Intel Xe Graphics" rev 0x01
> > > > drm0 at inteldrm0
> > > > inteldrm0: msi, TIGERLAKE, gen 12
> > > >
> > >
> > > jcs@ has/had a tiger lake machine which could run Xorg with the
> > > linux 5.7 based drm in -current.  I'm not sure what is different here.
> > >
> > > >
> > > > Any pointing to the right direction would be appreciated. (If this
> > > problem
> > > > relates to Xorg specifically and not to OpenBSD please let me know).
> > > >
> > > > [1] https://marc.info/?l=openbsd-bugs&m=161754767328009&w=2
> > > >
> > > > Regards,
> > > >
> > > > Michel
> > > >
> > >
>
>
>
> --
> Kindest regards,
> Tom Smyth.



--
Kindest regards,
Tom Smyth.

Reply | Threaded
Open this post in threaded view
|

Re: Does intel(4) support Iris Xe Graphics?

Jonathan Gray-11
On Wed, Apr 07, 2021 at 11:34:54AM +0100, Tom Smyth wrote:
> Try Current and 6.8  and see if you get a different result in each..
> dmesgs are key for getting help on this type of query ...

There is a snapshot dmesg in the bug report.  I don't see a benefit to
6.8 or linux dmesgs.

Reply | Threaded
Open this post in threaded view
|

Re: Does intel(4) support Iris Xe Graphics?

Tom Smyth
Hi Jonathan,
sorry missed the Bug Report... with the dmesg.
I thought the linux  dnmesg  where the hardware was working  would
have been useful if there was an issue with the hardware detection.
I suggested trying 6.8 incase there was a bug introduced in current
and would give a baseline...
suggested current  as the bug might already be fixed in current as
opposed to release ...


On Wed, 7 Apr 2021 at 11:56, Jonathan Gray <[hidden email]> wrote:
>
> On Wed, Apr 07, 2021 at 11:34:54AM +0100, Tom Smyth wrote:
> > Try Current and 6.8  and see if you get a different result in each..
> > dmesgs are key for getting help on this type of query ...
>
> There is a snapshot dmesg in the bug report.  I don't see a benefit to
> 6.8 or linux dmesgs.



--
Kindest regards,
Tom Smyth.