Disabled USB port

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Disabled USB port

Sketboy 12
To: [hidden email]
Subject: Disabled USB port
From: [hidden email]
Cc: white_glint
Reply-To: [hidden email]

>Synopsis: 1 USB port not working
>Category: <system>
>Environment:
        System      : OpenBSD 6.2
        Details     : OpenBSD 6.2 (GENERIC.MP) #0: Thu Oct 12 19:53:18 CEST 2017
                         [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP

        Architecture: OpenBSD.amd64
        Machine     : amd64
>Description:
        A USB2.0 port on my ASUS X555Y laptop is not functionnal : it detects
no devices. It is not disabled in the BIOS. My two other USB ports
(3.0) are functionnals (at uhub0). This problem already existed with
OpenBSD6.1. The port was functionnal under Windows.
>How-To-Repeat:
  Plugging a USB device on the right port of my laptop
>Fix:

dmesg:
OpenBSD 6.2 (GENERIC.MP) #0: Thu Oct 12 19:53:18 CEST 2017
    [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
real mem = 3660677120 (3491MB)
avail mem = 3542712320 (3378MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.8 @ 0xebf30 (18 entries)
bios0: vendor American Megatrends Inc. version "X555YI.602" date 04/29/2016
bios0: ASUSTeK COMPUTER INC. X555YI
acpi0 at bios0: rev 2
acpi0: sleep states S0 S3 S4 S5
acpi0: tables DSDT FACP APIC FPDT FIDT MCFG HPET WDRT ECDT UEFI BGRT
TPM2 SSDT SSDT SSDT SSDT SSDT SSDT MSDM
acpi0: wakeup devices GLAN(S4) SBAZ(S4) EHC1(S4) EHC2(S4) EHC3(S4)
XHC0(S4) ODD8(S3) SLPB(S4)
acpitimer0 at acpi0: 3579545 Hz, 32 bits
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: AMD A8-7410 APU with AMD Radeon R5 Graphics, 2196.17 MHz
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,PCLMUL,MWAIT,SSSE3,CX16,SSE4.1,SSE4.2,MOVBE,POPCNT,AES,XSAVE,AVX,F16C,RDRAND,NXE,MMXX,FFXSR,PAGE1GB,RDTSCP,LONG,LAHF,CMPLEG,SVM,EAPICSP,AMCR8,ABM,SSE4A,MASSE,3DNOWP,OSVW,IBS,SKINIT,TOPEXT,ITSC,BMI1
cpu0: 32KB 64b/line 2-way I-cache, 32KB 64b/line 8-way D-cache, 2MB
64b/line 16-way L2 cache
cpu0: ITLB 32 4KB entries fully associative, 8 4MB entries fully associative
cpu0: DTLB 40 4KB entries fully associative, 8 4MB entries fully associative
cpu0: TSC frequency 2196172080 Hz
cpu0: smt 0, core 0, package 0
mtrr: Pentium Pro MTRR support, 8 var ranges, 88 fixed ranges
cpu0: apic clock running at 99MHz
cpu0: mwait min=64, max=64, IBE
cpu1 at mainbus0: apid 1 (application processor)
cpu1: AMD A8-7410 APU with AMD Radeon R5 Graphics, 2195.89 MHz
cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,PCLMUL,MWAIT,SSSE3,CX16,SSE4.1,SSE4.2,MOVBE,POPCNT,AES,XSAVE,AVX,F16C,RDRAND,NXE,MMXX,FFXSR,PAGE1GB,RDTSCP,LONG,LAHF,CMPLEG,SVM,EAPICSP,AMCR8,ABM,SSE4A,MASSE,3DNOWP,OSVW,IBS,SKINIT,TOPEXT,ITSC,BMI1
cpu1: 32KB 64b/line 2-way I-cache, 32KB 64b/line 8-way D-cache, 2MB
64b/line 16-way L2 cache
cpu1: ITLB 32 4KB entries fully associative, 8 4MB entries fully associative
cpu1: DTLB 40 4KB entries fully associative, 8 4MB entries fully associative
cpu1: smt 0, core 1, package 0
cpu2 at mainbus0: apid 2 (application processor)
cpu2: AMD A8-7410 APU with AMD Radeon R5 Graphics, 2195.89 MHz
cpu2: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,PCLMUL,MWAIT,SSSE3,CX16,SSE4.1,SSE4.2,MOVBE,POPCNT,AES,XSAVE,AVX,F16C,RDRAND,NXE,MMXX,FFXSR,PAGE1GB,RDTSCP,LONG,LAHF,CMPLEG,SVM,EAPICSP,AMCR8,ABM,SSE4A,MASSE,3DNOWP,OSVW,IBS,SKINIT,TOPEXT,ITSC,BMI1
cpu2: 32KB 64b/line 2-way I-cache, 32KB 64b/line 8-way D-cache, 2MB
64b/line 16-way L2 cache
cpu2: ITLB 32 4KB entries fully associative, 8 4MB entries fully associative
cpu2: DTLB 40 4KB entries fully associative, 8 4MB entries fully associative
cpu2: smt 0, core 2, package 0
cpu3 at mainbus0: apid 3 (application processor)
cpu3: AMD A8-7410 APU with AMD Radeon R5 Graphics, 2195.89 MHz
cpu3: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,PCLMUL,MWAIT,SSSE3,CX16,SSE4.1,SSE4.2,MOVBE,POPCNT,AES,XSAVE,AVX,F16C,RDRAND,NXE,MMXX,FFXSR,PAGE1GB,RDTSCP,LONG,LAHF,CMPLEG,SVM,EAPICSP,AMCR8,ABM,SSE4A,MASSE,3DNOWP,OSVW,IBS,SKINIT,TOPEXT,ITSC,BMI1
cpu3: 32KB 64b/line 2-way I-cache, 32KB 64b/line 8-way D-cache, 2MB
64b/line 16-way L2 cache
cpu3: ITLB 32 4KB entries fully associative, 8 4MB entries fully associative
cpu3: DTLB 40 4KB entries fully associative, 8 4MB entries fully associative
cpu3: smt 0, core 3, package 0
ioapic0 at mainbus0: apid 5 pa 0xfec00000, version 21, 24 pins
ioapic1 at mainbus0: apid 6 pa 0xfec01000, version 21, 32 pins
acpimcfg0 at acpi0 addr 0xf8000000, bus 0-63
acpihpet0 at acpi0: 14318180 Hz
acpiec0 at acpi0
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 1 (GFX_)
acpiprt2 at acpi0: bus 2 (GPP0)
acpiprt3 at acpi0: bus 3 (GPP1)
acpiprt4 at acpi0: bus -1 (GPP2)
acpiprt5 at acpi0: bus -1 (GPP3)
acpicpu0 at acpi0: C2(0@400 io@0x414), C1(@1 halt!), PSS
acpicpu1 at acpi0: C2(0@400 io@0x414), C1(@1 halt!), PSS
acpicpu2 at acpi0: C2(0@400 io@0x414), C1(@1 halt!), PSS
acpicpu3 at acpi0: C2(0@400 io@0x414), C1(@1 halt!), PSS
acpitz0 at acpi0: critical temperature is 103 degC
"ETD0108" at acpi0 not configured
"ATK3001" at acpi0 not configured
acpiac0 at acpi0: AC unit online
acpibat0 at acpi0: BAT0 model "X555-50" serial   type LIon oem "ASUSTeK"
acpibtn0 at acpi0: PWRB
"MSFT0101" at acpi0 not configured
"PNP0C14" at acpi0 not configured
"ATK4002" at acpi0 not configured
acpibtn1 at acpi0: LID_
acpibtn2 at acpi0: SLPB
acpivideo0 at acpi0: VGA_
acpivideo1 at acpi0: VGA_
cpu0: 2196 MHz: speeds: 2200 2000 1800 1600 1300 1000 MHz
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "AMD AMD64 16h Root Complex" rev 0x00
vendor "ATI", unknown product 0x9851 (class display subclass VGA, rev
0x45) at pci0 dev 1 function 0 not configured
azalia0 at pci0 dev 1 function 1 "ATI Radeon HD Audio" rev 0x00: msi
azalia0: no supported codecs
pchb1 at pci0 dev 2 function 0 "AMD AMD64 16h Host" rev 0x00
ppb0 at pci0 dev 2 function 1 "AMD AMD64 16h PCIE" rev 0x00: msi
pci1 at ppb0 bus 1
"ATI Hainan" rev 0x83 at pci1 dev 0 function 0 not configured
ppb1 at pci0 dev 2 function 2 "AMD AMD64 16h PCIE" rev 0x00: msi
pci2 at ppb1 bus 2
"Atheros AR9565" rev 0x01 at pci2 dev 0 function 0 not configured
ppb2 at pci0 dev 2 function 3 "AMD AMD64 16h PCIE" rev 0x00: msi
pci3 at ppb2 bus 3
re0 at pci3 dev 0 function 0 "Realtek 8168" rev 0x10: RTL8168GU/8111GU
(0x5080), msi, address 2c:4d:54:3c:cd:76
rgephy0 at re0 phy 7: RTL8251 PHY, rev. 0
"AMD CCP" rev 0x00 at pci0 dev 8 function 0 not configured
xhci0 at pci0 dev 16 function 0 "AMD Bolton xHCI" rev 0x11: msi
usb0 at xhci0: USB revision 3.0
uhub0 at usb0 configuration 1 interface 0 "AMD xHCI root hub" rev
3.00/1.00 addr 1
ahci0 at pci0 dev 17 function 0 "AMD Hudson-2 SATA" rev 0x39: msi, AHCI 1.3
ahci0: port 0: 6.0Gb/s
ahci0: port 1: 1.5Gb/s
scsibus1 at ahci0: 32 targets
sd0 at scsibus1 targ 0 lun 0: <ATA, TOSHIBA MQ01ABD1, AX0R> SCSI3
0/direct fixed naa.500003976250429e
sd0: 953869MB, 512 bytes/sector, 1953525168 sectors
cd0 at scsibus1 targ 1 lun 0: <TSSTcorp, CDDVDW SU-228HB, AS00> ATAPI
5/cdrom removable
ehci0 at pci0 dev 18 function 0 "AMD Hudson-2 USB2" rev 0x39: apic 5 int 18
usb1 at ehci0: USB revision 2.0
uhub1 at usb1 configuration 1 interface 0 "AMD EHCI root hub" rev
2.00/1.00 addr 1
ehci1 at pci0 dev 19 function 0 "AMD Hudson-2 USB2" rev 0x39: apic 5 int 18
usb2 at ehci1: USB revision 2.0
uhub2 at usb2 configuration 1 interface 0 "AMD EHCI root hub" rev
2.00/1.00 addr 1
piixpm0 at pci0 dev 20 function 0 "AMD Hudson-2 SMBus" rev 0x42: SMBus disabled
azalia1 at pci0 dev 20 function 2 "AMD Hudson-2 HD Audio" rev 0x02:
apic 5 int 16
azalia1: codecs: Conexant/0x510f
audio0 at azalia1
pcib0 at pci0 dev 20 function 3 "AMD Hudson-2 LPC" rev 0x11
pchb2 at pci0 dev 24 function 0 "AMD AMD64 16h Link Cfg" rev 0x00
pchb3 at pci0 dev 24 function 1 "AMD AMD64 16h Address Map" rev 0x00
pchb4 at pci0 dev 24 function 2 "AMD AMD64 16h DRAM Cfg" rev 0x00
km0 at pci0 dev 24 function 3 "AMD AMD64 16h Misc Cfg" rev 0x00
pchb5 at pci0 dev 24 function 4 "AMD AMD64 16h CPU Power" rev 0x00
pchb6 at pci0 dev 24 function 5 "AMD AMD64 16h Misc Cfg" rev 0x00
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5 irq 1 irq 12
pckbd0 at pckbc0 (kbd slot)
wskbd0 at pckbd0: console keyboard
pms0 at pckbc0 (aux slot)
wsmouse0 at pms0 mux 0
pms0: Elantech Clickpad, version 4, firmware 0x381f00
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
vmm0 at mainbus0: SVM/RVI
efifb0 at mainbus0: 1366x768, 32bpp
wsdisplay0 at efifb0 mux 1: console (std, vt100 emulation), using wskbd0
wsdisplay0: screen 1-5 added (std, vt100 emulation)
uhub3 at uhub1 port 1 configuration 1 interface 0 "Advanced Micro
Devices product 0x7900" rev 2.00/0.18 addr 2
ugen0 at uhub3 port 3 "AsureWave product 0x3423" rev 1.10/0.01 addr 3
uvideo0 at uhub3 port 4 configuration 1 interface 0 "Chicony
Electronics Co.,Ltd. USB2.0 VGA UVC WebCam" rev 2.00/95.52 addr 4
video0 at uvideo0
uhub4 at uhub2 port 1 configuration 1 interface 0 "Advanced Micro
Devices product 0x7900" rev 2.00/0.18 addr 2
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
sd1 at scsibus3 targ 1 lun 0: <OPENBSD, SR CRYPTO, 006> SCSI2 0/direct fixed
sd1: 953868MB, 512 bytes/sector, 1953523553 sectors
root on sd1a (cbca681d31ac789e.a) swap on sd1b dump on sd1b

usbdevs:
Controller /dev/usb0:
addr 1: super speed, self powered, config 1, xHCI root hub(0x0000),
AMD(0x1022), rev 1.00
 port 1 disabled
 port 2 disabled
 port 3 disabled
 port 4 disabled
Controller /dev/usb1:
addr 1: high speed, self powered, config 1, EHCI root hub(0x0000),
AMD(0x1022), rev 1.00
 port 1 addr 2: high speed, self powered, config 1, product
0x7900(0x7900), Advanced Micro Devices(0x0438), rev 0.18
  port 1 powered
  port 2 powered
  port 3 addr 3: full speed, self powered, config 1, product
0x3423(0x3423), AsureWave(0x13d3), rev 0.01
  port 4 addr 4: high speed, power 500 mA, config 1, USB2.0 VGA UVC
WebCam(0xb52b), Chicony Electronics Co.,Ltd.(0x04f2), rev 95.52,
iSerialNumber 0x0001
 port 2 powered
Controller /dev/usb2:
addr 1: high speed, self powered, config 1, EHCI root hub(0x0000),
AMD(0x1022), rev 1.00
 port 1 addr 2: high speed, self powered, config 1, product
0x7900(0x7900), Advanced Micro Devices(0x0438), rev 0.18
  port 1 powered
  port 2 powered
 port 2 powered
Reply | Threaded
Open this post in threaded view
|

Re: Disabled USB port

tinkr
..
>>Description:
> A USB2.0 port on my ASUS X555Y laptop is not functionnal : it detects
> no devices. It is not disabled in the BIOS. My two other USB ports
> (3.0) are functionnals (at uhub0). This problem already existed with
> OpenBSD6.1. The port was functionnal under Windows.
>>How-To-Repeat:
>   Plugging a USB device on the right port of my laptop

Sketboy12,

Thanks for your report! Would you mind enabling the XHCI_DEBUG and EHCI_DEBUG settings in your kernel (add those, recompile, install the new kernel, reboot), and provide the dmesg you get then?

The general picture presently is that EHCI  (USB2) is mature and XHCI (USB3) is close to but not quite mature.

Thanks!
Reply | Threaded
Open this post in threaded view
|

Re: Disabled USB port

tinkr
In reply to this post by Sketboy 12
> ..
>>>Description:
>> A USB2.0 port on my ASUS X555Y laptop is not functionnal : it detects
>> no devices. It is not disabled in the BIOS. My two other USB ports
>> (3.0) are functionnals (at uhub0). This problem already existed with
>> OpenBSD6.1. The port was functionnal under Windows.
>>>How-To-Repeat:
>>   Plugging a USB device on the right port of my laptop
>
> Sketboy12,
>
> Thanks for your report! Would you mind enabling the XHCI_DEBUG and EHCI_DEBUG settings in your kernel (add those, recompile, install the new kernel, reboot), and provide the dmesg you get then?
>
> The general picture presently is that EHCI  (USB2) is mature and XHCI (USB3) is close to but not quite mature.
>
> Thanks!

Also please explain

 * Which devices you have plugged in and how they behave.

 * How OpenBSD responds to having the respective USB device plugged in on the USB2/3 port at boot, versus when plugging it in during runtime.

In other words more and more detailed info for both when it works and for when it not works, and which specific things you tested.

Sometimes, USB devices won't show up, because they fail in their negotiation for electricity from the USB hub.