Dell XPS13 9333 Touchpad doesn't work

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Dell XPS13 9333 Touchpad doesn't work

Gabriel Guzman-2
Hello misc@

I have a Dell XPS 13 9333 that I recently installed OpenBSD on.  For the
most part everything runs great.  WiFi, suspend resume, everything.  The
laptop has both a touchscreen and a touchpad.  The touchscreen works
just fine, I can use it as a pointing device w/out problems.  The
touchpad however doesn't seem to be recognized by the system.  I'm not
sure if it's user error or some hardware that's not recognized.  dmesg
and other output included below.  Anyone have any idea what I might be
able to try to get this working?  Plugging in an external mouse also
works just fine.  

Thanks,
gabe.


OpenBSD 5.9-current (GENERIC.MP) #2002: Sun May  1 06:35:58 MDT 2016
    [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
real mem = 8474284032 (8081MB)
avail mem = 8212860928 (7832MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.7 @ 0xe0fc0 (69 entries)
bios0: vendor Dell Inc. version "A06" date 11/07/2014
bios0: Dell Inc. XPS13 9333
acpi0 at bios0: rev 2
acpi0: sleep states S0 S1 S3 S4 S5
acpi0: tables DSDT FACP ASF! HPET LPIT APIC MCFG SSDT SSDT SSDT SSDT SSDT UEFI POAT BATB FPDT SLIC UEFI SSDT BGRT CSRT
acpi0: wakeup devices P0P1(S4) GLAN(S4) EHC1(S4) EHC2(S4) XHC_(S4) HDEF(S4) TPD4(S4) TPD7(S0) TPD8(S0) PXSX(S4) RP01(S4) PXSX(S4) RP02(S4) PXSX(S4) RP03(S4) PXSX(S4) [...]
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpihpet0 at acpi0: 14318179 Hz
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz, 1596.56 MHz
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,LONG,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,SENSOR,ARAT
cpu0: 256KB 64b/line 8-way L2 cache
cpu0: smt 0, core 0, package 0
mtrr: Pentium Pro MTRR support, 10 var ranges, 88 fixed ranges
cpu0: apic clock running at 99MHz
cpu0: mwait min=64, max=64, C-substates=0.2.1.2.4.1.1.1, IBE
cpu1 at mainbus0: apid 1 (application processor)
cpu1: Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz, 1596.31 MHz
cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,LONG,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,SENSOR,ARAT
cpu1: 256KB 64b/line 8-way L2 cache
cpu1: smt 1, core 0, package 0
cpu2 at mainbus0: apid 2 (application processor)
cpu2: Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz, 1596.31 MHz
cpu2: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,LONG,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,SENSOR,ARAT
cpu2: 256KB 64b/line 8-way L2 cache
cpu2: smt 0, core 1, package 0
cpu3 at mainbus0: apid 3 (application processor)
cpu3: Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz, 1596.31 MHz
cpu3: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,LONG,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,SENSOR,ARAT
cpu3: 256KB 64b/line 8-way L2 cache
cpu3: smt 1, core 1, package 0
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 40 pins
acpimcfg0 at acpi0 addr 0xf8000000, bus 0-63
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus -1 (P0P1)
acpiprt2 at acpi0: bus 1 (RP01)
acpiprt3 at acpi0: bus 2 (RP03)
acpiprt4 at acpi0: bus -1 (PEG0)
acpiprt5 at acpi0: bus -1 (PEG1)
acpiprt6 at acpi0: bus -1 (PEG2)
acpiec0 at acpi0
acpicpu0 at acpi0: C3(200@332 mwait.1@0x50), C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
acpicpu1 at acpi0: C3(200@332 mwait.1@0x50), C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
acpicpu2 at acpi0: C3(200@332 mwait.1@0x50), C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
acpicpu3 at acpi0: C3(200@332 mwait.1@0x50), C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
acpitz0 at acpi0: critical temperature is 105 degC
acpitz1 at acpi0: critical temperature is 105 degC
"PNP0C14" at acpi0 not configured
"INT3F0D" at acpi0 not configured
"ACPI0008" at acpi0 not configured
"MSFT0001" at acpi0 not configured
"SYN0608" at acpi0 not configured
dwiic0 at acpi0: I2C1 addr 0xfe105000/0x1000 irq 7
iic0 at dwiic0
ihidev0 at iic0 addr 0x2c irq 39dwiic0: timed out reading remaining 29
, failed fetching initial HID descriptor
"DLL060A" at acpi0 not configured
acpibtn0 at acpi0: PWRB
acpibtn1 at acpi0: LID0
acpiac0 at acpi0: AC unit offline
acpibat0 at acpi0: BAT0 model "Dell" serial 1727 type LION oem "SIMPLO"
"DELLABCE" at acpi0 not configured
"INT340E" at acpi0 not configured
"INT33A0" at acpi0 not configured
acpivideo0 at acpi0: GFX0
acpivout0 at acpivideo0: DD1F
cpu0: Enhanced SpeedStep 1596 MHz: speeds: 2401, 2400, 2300, 2200, 2000, 1900, 1700, 1600, 1500, 1400, 1300, 1200, 1100, 900, 800, 768 MHz
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "Intel Core 4G Host" rev 0x0b
inteldrm0 at pci0 dev 2 function 0 "Intel HD Graphics" rev 0x0b
drm0 at inteldrm0
inteldrm0: msi
inteldrm0: 1920x1080
wsdisplay0 at inteldrm0 mux 1: console (std, vt100 emulation)
wsdisplay0: screen 1-5 added (std, vt100 emulation)
azalia0 at pci0 dev 3 function 0 "Intel Core 4G HD Audio" rev 0x0b: msi
xhci0 at pci0 dev 20 function 0 "Intel 8 Series xHCI" rev 0x04: msi
usb0 at xhci0: USB revision 3.0
uhub0 at usb0 "Intel xHCI root hub" rev 3.00/1.00 addr 1
"Intel 8 Series MEI" rev 0x04 at pci0 dev 22 function 0 not configured
azalia1 at pci0 dev 27 function 0 "Intel 8 Series HD Audio" rev 0x04: msi
azalia1: codecs: Realtek/0x0668
audio0 at azalia1
ppb0 at pci0 dev 28 function 0 "Intel 8 Series PCIE" rev 0xe4
pci1 at ppb0 bus 1
ppb1 at pci0 dev 28 function 2 "Intel 8 Series PCIE" rev 0xe4: msi
pci2 at ppb1 bus 2
iwm0 at pci2 dev 0 function 0 "Intel Dual Band Wireless AC 7260" rev 0x6b, msi
ehci0 at pci0 dev 29 function 0 "Intel 8 Series USB" rev 0x04: apic 2 int 23
usb1 at ehci0: USB revision 2.0
uhub1 at usb1 "Intel EHCI root hub" rev 2.00/1.00 addr 1
pcib0 at pci0 dev 31 function 0 "Intel 8 Series LPC" rev 0x04
ahci0 at pci0 dev 31 function 2 "Intel 8 Series AHCI" rev 0x04: msi, AHCI 1.3
ahci0: port 2: 6.0Gb/s
scsibus1 at ahci0: 32 targets
sd0 at scsibus1 targ 2 lun 0: <ATA, LITEON IT LMT-12, HM71> SCSI3 0/direct fixed t10.ATA_LITEON_IT_LMT-128L9M-11_MSATA_128GB_TW0921PN5508544A1906
sd0: 122104MB, 512 bytes/sector, 250069680 sectors, thin
ichiic0 at pci0 dev 31 function 3 "Intel 8 Series SMBus" rev 0x04: apic 2 int 18
iic1 at ichiic0
iic1: addr 0x29 80=03 81=ad 82=ff 83=ff 8f=02 91=01 92=44 93=11 94=7c 96=64 98=53 9a=4e 9f=14 a0=03 a1=ad a2=ff a3=ff af=02 b1=01 b2=44 b3=11 b4=7c b6=64 b8=53 ba=4e bf=14 c0=03 c1=ad c2=ff c3=ff cf=02 d1=01 d2=44 d3=11 d4=7c d6=64 d8=53 da=4e df=14 e0=14 e1=14 e2=14 e3=14 e4=14 e5=14 e6=14 e7=14 e9=14 ea=14 eb=14 ec=14 ed=14 ee=14 ef=14 f0=14 f1=14 f2=14 f3=14 f4=14 f5=14 f6=14 f7=14 f8=14 f9=14 fa=14 fb=14 fd=14 ff=14 words 00=0000 01=0100 02=0200 03=0300 04=0400 05=0500 06=0600 07=0700
iic1: addr 0x4c 00=2a 01=2f 02=80 04=06 05=55 07=55 0a=06 0b=55 0d=55 10=c0 15=55 19=55 1a=55 1e=5b 20=55 21=0a 22=70 23=28 24=80 25=0f 26=0f 27=12 28=12 29=e0 60=06 70=06 71=07 72=07 a4=6f a5=c0 ac=28 ad=d4 ae=04 af=df b0=20 b1=20 fd=23 fe=5d ff=04 words 00=2aff 01=2fff 02=80ff 03=00ff 04=06ff 05=55ff 06=00ff 07=55ff
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5 irq 1 irq 12
pckbd0 at pckbc0 (kbd slot)
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
wsmouse0 at pms0 mux 0
pms0: disable error
pms0: disable error
pms0: disable error
pms0: disable error
pms0: disable error
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
efifb at mainbus0 not configured
error: [drm:pid0:intel_uncore_check_errors] *ERROR* Unclaimed register before interrupt
uhidev0 at uhub0 port 3 configuration 1 interface 0 "SYNAPTICS Synaptics Large Touch Screen" rev 2.00/0.01 addr 2
uhidev0: iclass 3/0, 15 report ids
ums0 at uhidev0 reportid 1: 1 button, tip
wsmouse1 at ums0 mux 0
ums1 at uhidev0 reportid 2: 2 buttons
wsmouse2 at ums1 mux 0
ums2 at uhidev0 reportid 7
ums2: mouse has no X report
uhid0 at uhidev0 reportid 8: input=0, output=0, feature=1
uhid1 at uhidev0 reportid 9: input=0, output=63, feature=0
uhid2 at uhidev0 reportid 10: input=0, output=5, feature=0
uhid3 at uhidev0 reportid 11: input=61, output=0, feature=0
uhid4 at uhidev0 reportid 12: input=1, output=0, feature=0
uhid5 at uhidev0 reportid 15: input=0, output=0, feature=1
uvideo0 at uhub0 port 5 configuration 1 interface 0 "CN0Y2TKG724873CED0DKA00 Integrated_Webcam_HD" rev 2.01/39.02 addr 3
video0 at uvideo0
ugen0 at uhub0 port 6 "Intel product 0x07dc" rev 2.00/0.01 addr 4
uhub2 at uhub1 port 1 "Intel Rate Matching Hub" rev 2.00/0.04 addr 2
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
root on sd0a (c0be31cb1e50e248.a) swap on sd0b dump on sd0b
iwm0: hw rev 0x140, fw ver 25.228 (API ver 9), address e8:2a:ea:ab:49:24
pckbc: command timeout
pckbc: command timeout
pms0: enable error
pms0: not in sync yet, discard input (state 0)
pckbc: command timeout
pms0: disable error
pckbc: command timeout
pckbc: command timeout
pms0: enable error
pms0: not in sync yet, discard input (state 0)
pckbc: command timeout
pms0: disable error
pckbc: command timeout
pckbc: command timeout
pms0: enable error


-------
# usbdevs                                                                      
addr 1: xHCI root hub, Intel
addr 2: Synaptics Large Touch Screen, SYNAPTICS
addr 3: Integrated_Webcam_HD, CN0Y2TKG724873CED0DKA00
addr 4: product 0x07dc, Intel
addr 1: EHCI root hub, Intel
addr 2: Rate Matching Hub, Intel

Reply | Threaded
Open this post in threaded view
|

Re: Dell XPS13 9333 Touchpad doesn't work

Ulf Brosziewski
Hi, it might be that you are out of luck with your hardware. If
I'm not mistaken, it has a Cypress touchpad, which isn't supported.

On 05/06/2016 05:16 AM, Gabriel Guzman wrote:

> Hello misc@
>
> I have a Dell XPS 13 9333 that I recently installed OpenBSD on.  For the
> most part everything runs great.  WiFi, suspend resume, everything.  The
> laptop has both a touchscreen and a touchpad.  The touchscreen works
> just fine, I can use it as a pointing device w/out problems.  The
> touchpad however doesn't seem to be recognized by the system.  I'm not
> sure if it's user error or some hardware that's not recognized.  dmesg
> and other output included below.  Anyone have any idea what I might be
> able to try to get this working?  Plugging in an external mouse also
> works just fine.  
>
> Thanks,
> gabe.
>
>
> OpenBSD 5.9-current (GENERIC.MP) #2002: Sun May  1 06:35:58 MDT 2016
>     [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
> real mem = 8474284032 (8081MB)
> avail mem = 8212860928 (7832MB)
> mpath0 at root
> scsibus0 at mpath0: 256 targets
> mainbus0 at root
> bios0 at mainbus0: SMBIOS rev. 2.7 @ 0xe0fc0 (69 entries)
> bios0: vendor Dell Inc. version "A06" date 11/07/2014
> bios0: Dell Inc. XPS13 9333
> acpi0 at bios0: rev 2
> acpi0: sleep states S0 S1 S3 S4 S5
> acpi0: tables DSDT FACP ASF! HPET LPIT APIC MCFG SSDT SSDT SSDT SSDT SSDT UEFI POAT BATB FPDT SLIC UEFI SSDT BGRT CSRT
> acpi0: wakeup devices P0P1(S4) GLAN(S4) EHC1(S4) EHC2(S4) XHC_(S4) HDEF(S4) TPD4(S4) TPD7(S0) TPD8(S0) PXSX(S4) RP01(S4) PXSX(S4) RP02(S4) PXSX(S4) RP03(S4) PXSX(S4) [...]
> acpitimer0 at acpi0: 3579545 Hz, 24 bits
> acpihpet0 at acpi0: 14318179 Hz
> acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
> cpu0 at mainbus0: apid 0 (boot processor)
> cpu0: Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz, 1596.56 MHz
> cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,LONG,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,SENSOR,ARAT
> cpu0: 256KB 64b/line 8-way L2 cache
> cpu0: smt 0, core 0, package 0
> mtrr: Pentium Pro MTRR support, 10 var ranges, 88 fixed ranges
> cpu0: apic clock running at 99MHz
> cpu0: mwait min=64, max=64, C-substates=0.2.1.2.4.1.1.1, IBE
> cpu1 at mainbus0: apid 1 (application processor)
> cpu1: Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz, 1596.31 MHz
> cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,LONG,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,SENSOR,ARAT
> cpu1: 256KB 64b/line 8-way L2 cache
> cpu1: smt 1, core 0, package 0
> cpu2 at mainbus0: apid 2 (application processor)
> cpu2: Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz, 1596.31 MHz
> cpu2: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,LONG,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,SENSOR,ARAT
> cpu2: 256KB 64b/line 8-way L2 cache
> cpu2: smt 0, core 1, package 0
> cpu3 at mainbus0: apid 3 (application processor)
> cpu3: Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz, 1596.31 MHz
> cpu3: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,LONG,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,SENSOR,ARAT
> cpu3: 256KB 64b/line 8-way L2 cache
> cpu3: smt 1, core 1, package 0
> ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 40 pins
> acpimcfg0 at acpi0 addr 0xf8000000, bus 0-63
> acpiprt0 at acpi0: bus 0 (PCI0)
> acpiprt1 at acpi0: bus -1 (P0P1)
> acpiprt2 at acpi0: bus 1 (RP01)
> acpiprt3 at acpi0: bus 2 (RP03)
> acpiprt4 at acpi0: bus -1 (PEG0)
> acpiprt5 at acpi0: bus -1 (PEG1)
> acpiprt6 at acpi0: bus -1 (PEG2)
> acpiec0 at acpi0
> acpicpu0 at acpi0: C3(200@332 mwait.1@0x50), C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
> acpicpu1 at acpi0: C3(200@332 mwait.1@0x50), C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
> acpicpu2 at acpi0: C3(200@332 mwait.1@0x50), C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
> acpicpu3 at acpi0: C3(200@332 mwait.1@0x50), C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
> acpitz0 at acpi0: critical temperature is 105 degC
> acpitz1 at acpi0: critical temperature is 105 degC
> "PNP0C14" at acpi0 not configured
> "INT3F0D" at acpi0 not configured
> "ACPI0008" at acpi0 not configured
> "MSFT0001" at acpi0 not configured
> "SYN0608" at acpi0 not configured
> dwiic0 at acpi0: I2C1 addr 0xfe105000/0x1000 irq 7
> iic0 at dwiic0
> ihidev0 at iic0 addr 0x2c irq 39dwiic0: timed out reading remaining 29
> , failed fetching initial HID descriptor
> "DLL060A" at acpi0 not configured
> acpibtn0 at acpi0: PWRB
> acpibtn1 at acpi0: LID0
> acpiac0 at acpi0: AC unit offline
> acpibat0 at acpi0: BAT0 model "Dell" serial 1727 type LION oem "SIMPLO"
> "DELLABCE" at acpi0 not configured
> "INT340E" at acpi0 not configured
> "INT33A0" at acpi0 not configured
> acpivideo0 at acpi0: GFX0
> acpivout0 at acpivideo0: DD1F
> cpu0: Enhanced SpeedStep 1596 MHz: speeds: 2401, 2400, 2300, 2200, 2000, 1900, 1700, 1600, 1500, 1400, 1300, 1200, 1100, 900, 800, 768 MHz
> pci0 at mainbus0 bus 0
> pchb0 at pci0 dev 0 function 0 "Intel Core 4G Host" rev 0x0b
> inteldrm0 at pci0 dev 2 function 0 "Intel HD Graphics" rev 0x0b
> drm0 at inteldrm0
> inteldrm0: msi
> inteldrm0: 1920x1080
> wsdisplay0 at inteldrm0 mux 1: console (std, vt100 emulation)
> wsdisplay0: screen 1-5 added (std, vt100 emulation)
> azalia0 at pci0 dev 3 function 0 "Intel Core 4G HD Audio" rev 0x0b: msi
> xhci0 at pci0 dev 20 function 0 "Intel 8 Series xHCI" rev 0x04: msi
> usb0 at xhci0: USB revision 3.0
> uhub0 at usb0 "Intel xHCI root hub" rev 3.00/1.00 addr 1
> "Intel 8 Series MEI" rev 0x04 at pci0 dev 22 function 0 not configured
> azalia1 at pci0 dev 27 function 0 "Intel 8 Series HD Audio" rev 0x04: msi
> azalia1: codecs: Realtek/0x0668
> audio0 at azalia1
> ppb0 at pci0 dev 28 function 0 "Intel 8 Series PCIE" rev 0xe4
> pci1 at ppb0 bus 1
> ppb1 at pci0 dev 28 function 2 "Intel 8 Series PCIE" rev 0xe4: msi
> pci2 at ppb1 bus 2
> iwm0 at pci2 dev 0 function 0 "Intel Dual Band Wireless AC 7260" rev 0x6b, msi
> ehci0 at pci0 dev 29 function 0 "Intel 8 Series USB" rev 0x04: apic 2 int 23
> usb1 at ehci0: USB revision 2.0
> uhub1 at usb1 "Intel EHCI root hub" rev 2.00/1.00 addr 1
> pcib0 at pci0 dev 31 function 0 "Intel 8 Series LPC" rev 0x04
> ahci0 at pci0 dev 31 function 2 "Intel 8 Series AHCI" rev 0x04: msi, AHCI 1.3
> ahci0: port 2: 6.0Gb/s
> scsibus1 at ahci0: 32 targets
> sd0 at scsibus1 targ 2 lun 0: <ATA, LITEON IT LMT-12, HM71> SCSI3 0/direct fixed t10.ATA_LITEON_IT_LMT-128L9M-11_MSATA_128GB_TW0921PN5508544A1906
> sd0: 122104MB, 512 bytes/sector, 250069680 sectors, thin
> ichiic0 at pci0 dev 31 function 3 "Intel 8 Series SMBus" rev 0x04: apic 2 int 18
> iic1 at ichiic0
> iic1: addr 0x29 80=03 81=ad 82=ff 83=ff 8f=02 91=01 92=44 93=11 94=7c 96=64 98=53 9a=4e 9f=14 a0=03 a1=ad a2=ff a3=ff af=02 b1=01 b2=44 b3=11 b4=7c b6=64 b8=53 ba=4e bf=14 c0=03 c1=ad c2=ff c3=ff cf=02 d1=01 d2=44 d3=11 d4=7c d6=64 d8=53 da=4e df=14 e0=14 e1=14 e2=14 e3=14 e4=14 e5=14 e6=14 e7=14 e9=14 ea=14 eb=14 ec=14 ed=14 ee=14 ef=14 f0=14 f1=14 f2=14 f3=14 f4=14 f5=14 f6=14 f7=14 f8=14 f9=14 fa=14 fb=14 fd=14 ff=14 words 00=0000 01=0100 02=0200 03=0300 04=0400 05=0500 06=0600 07=0700
> iic1: addr 0x4c 00=2a 01=2f 02=80 04=06 05=55 07=55 0a=06 0b=55 0d=55 10=c0 15=55 19=55 1a=55 1e=5b 20=55 21=0a 22=70 23=28 24=80 25=0f 26=0f 27=12 28=12 29=e0 60=06 70=06 71=07 72=07 a4=6f a5=c0 ac=28 ad=d4 ae=04 af=df b0=20 b1=20 fd=23 fe=5d ff=04 words 00=2aff 01=2fff 02=80ff 03=00ff 04=06ff 05=55ff 06=00ff 07=55ff
> isa0 at pcib0
> isadma0 at isa0
> pckbc0 at isa0 port 0x60/5 irq 1 irq 12
> pckbd0 at pckbc0 (kbd slot)
> wskbd0 at pckbd0: console keyboard, using wsdisplay0
> pms0 at pckbc0 (aux slot)
> wsmouse0 at pms0 mux 0
> pms0: disable error
> pms0: disable error
> pms0: disable error
> pms0: disable error
> pms0: disable error
> pcppi0 at isa0 port 0x61
> spkr0 at pcppi0
> efifb at mainbus0 not configured
> error: [drm:pid0:intel_uncore_check_errors] *ERROR* Unclaimed register before interrupt
> uhidev0 at uhub0 port 3 configuration 1 interface 0 "SYNAPTICS Synaptics Large Touch Screen" rev 2.00/0.01 addr 2
> uhidev0: iclass 3/0, 15 report ids
> ums0 at uhidev0 reportid 1: 1 button, tip
> wsmouse1 at ums0 mux 0
> ums1 at uhidev0 reportid 2: 2 buttons
> wsmouse2 at ums1 mux 0
> ums2 at uhidev0 reportid 7
> ums2: mouse has no X report
> uhid0 at uhidev0 reportid 8: input=0, output=0, feature=1
> uhid1 at uhidev0 reportid 9: input=0, output=63, feature=0
> uhid2 at uhidev0 reportid 10: input=0, output=5, feature=0
> uhid3 at uhidev0 reportid 11: input=61, output=0, feature=0
> uhid4 at uhidev0 reportid 12: input=1, output=0, feature=0
> uhid5 at uhidev0 reportid 15: input=0, output=0, feature=1
> uvideo0 at uhub0 port 5 configuration 1 interface 0 "CN0Y2TKG724873CED0DKA00 Integrated_Webcam_HD" rev 2.01/39.02 addr 3
> video0 at uvideo0
> ugen0 at uhub0 port 6 "Intel product 0x07dc" rev 2.00/0.01 addr 4
> uhub2 at uhub1 port 1 "Intel Rate Matching Hub" rev 2.00/0.04 addr 2
> vscsi0 at root
> scsibus2 at vscsi0: 256 targets
> softraid0 at root
> scsibus3 at softraid0: 256 targets
> root on sd0a (c0be31cb1e50e248.a) swap on sd0b dump on sd0b
> iwm0: hw rev 0x140, fw ver 25.228 (API ver 9), address e8:2a:ea:ab:49:24
> pckbc: command timeout
> pckbc: command timeout
> pms0: enable error
> pms0: not in sync yet, discard input (state 0)
> pckbc: command timeout
> pms0: disable error
> pckbc: command timeout
> pckbc: command timeout
> pms0: enable error
> pms0: not in sync yet, discard input (state 0)
> pckbc: command timeout
> pms0: disable error
> pckbc: command timeout
> pckbc: command timeout
> pms0: enable error
>
>
> -------
> # usbdevs                                                                      
> addr 1: xHCI root hub, Intel
> addr 2: Synaptics Large Touch Screen, SYNAPTICS
> addr 3: Integrated_Webcam_HD, CN0Y2TKG724873CED0DKA00
> addr 4: product 0x07dc, Intel
> addr 1: EHCI root hub, Intel
> addr 2: Rate Matching Hub, Intel

Reply | Threaded
Open this post in threaded view
|

Re: Dell XPS13 9333 Touchpad doesn't work

Mark Kettenis
In reply to this post by Gabriel Guzman-2
Please send bug reports to [hidden email].

> dwiic0 at acpi0: I2C1 addr 0xfe105000/0x1000 irq 7
> iic0 at dwiic0
> ihidev0 at iic0 addr 0x2c irq 39dwiic0: timed out reading remaining 29, failed fetching initial HID descriptor
> "DLL060A" at acpi0 not configured

Can you try what happens if you disable dwiic in UKC?  See
boot_config(8) for information on how to do that.

Reply | Threaded
Open this post in threaded view
|

Re: Dell XPS13 9333 Touchpad doesn't work

Gabriel Guzman-2
On 05/07, Mark Kettenis wrote:
> Please send bug reports to [hidden email].
>
> > dwiic0 at acpi0: I2C1 addr 0xfe105000/0x1000 irq 7
> > iic0 at dwiic0
> > ihidev0 at iic0 addr 0x2c irq 39dwiic0: timed out reading remaining 29, failed fetching initial HID descriptor
> > "DLL060A" at acpi0 not configured
>
> Can you try what happens if you disable dwiic in UKC?  See
> boot_config(8) for information on how to do that.

Doesn't seem to make a difference.  Strangely, while in UKC, if I hit
the touchpad I do get gibberish on the screen (see below immediately
after entering UKC I accidentally grazed the touchpad).

Thanks for your help,
gabe.

OpenBSD 5.9-current (GENERIC.MP) #2002: Sun May  1 06:35:58 MDT 2016
    [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
        real mem = 8474284032 (8081MB)
        avail mem = 8212860928 (7832MB)
        User Kernel Config
        UKC> oo'''''''''''''7\^G7\^G7\^G7\^G\^H \^H\^H \^H\^H \^H\^H \^H\^H
        \^H\^H \^H\^H \^H\^H \^H\^H \^H\^H \^H\^H \^H\^H \^H\^H \^H\^H
        \^H\^H \^H\^H \^H\^H \^H\^H \^H\^H
        \^H7\^G717\^G7\^G7\^G7\^G7\^G7\^G7\^G7\^G7\^G7\^G'\^G''''''o''\M-'\M-'\M-'\M^?\M^?\M^?\M^?\M^?\M^?\M^?\M^?\M^?\M^U\M^U\M^U\M^U\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G\^G
        Unknown command, try help
        UKC>
        UKC> DI\^H \^H\^H \^Hdisable \^H \^H\^H \^H\^H \^H\^H \^H\^H \^H\^H
        \^H\^H \^H\^H \^Hfind di\^H \^Hwi
        UKC> disable dwiic0
        UKC> \^Gk\^H \^Hfind dwi*
        UKC> find dwiic*
        396 dwiic* at acpi0 flags 0x0
        UKC> \^Gk\^H \^Hfind dwoi\^H \^H\^H \^Hiic0
        UKC> find dwiic*
        396 dwiic* at acpi0 flags 0x0
        UKC> find dwiic0
        UKC> find dwiic
        396 dwiic* at acpi0 flags 0x0
        UKC> disable dwiic
        396 dwiic* disabled
        UKC> quit
        Continuing...
        mpath0 at root
        scsibus0 at mpath0: 256 targets
        mainbus0 at root
        bios0 at mainbus0: SMBIOS rev. 2.7 @ 0xe0fc0 (69 entries)
        bios0: vendor Dell Inc. version "A06" date 11/07/2014
        bios0: Dell Inc. XPS13 9333
        acpi0 at bios0: rev 2
        acpi0: sleep states S0 S1 S3 S4 S5
        acpi0: tables DSDT FACP ASF! HPET LPIT APIC MCFG SSDT SSDT SSDT SSDT
        SSDT UEFI POAT BATB FPDT SLIC UEFI SSDT BGRT CSRT
        acpi0: wakeup devices P0P1(S4) GLAN(S4) EHC1(S4) EHC2(S4) XHC_(S4)
        HDEF(S4) TPD4(S4) TPD7(S0) TPD8(S0) PXSX(S4) RP01(S4) PXSX(S4)
        RP02(S4) PXSX(S4) RP03(S4) PXSX(S4) [...]
        acpitimer0 at acpi0: 3579545 Hz, 24 bits
        acpihpet0 at acpi0: 14318179 Hz
        acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
        cpu0 at mainbus0: apid 0 (boot processor)
        cpu0: Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz, 1596.58 MHz
        cpu0:
        FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CF
        LUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,LONG,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,SENSOR,ARAT
        cpu0: 256KB 64b/line 8-way L2 cache
        cpu0: smt 0, core 0, package 0
        mtrr: Pentium Pro MTRR support, 10 var ranges, 88 fixed ranges
        cpu0: apic clock running at 99MHz
        cpu0: mwait min=64, max=64, C-substates=0.2.1.2.4.1.1.1, IBE
        cpu1 at mainbus0: apid 1 (application processor)
        cpu1: Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz, 1596.31 MHz
        cpu1:
        FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,LONG,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,SENSOR,ARAT
        cpu1: 256KB 64b/line 8-way L2 cache
        cpu1: smt 1, core 0, package 0
        cpu2 at mainbus0: apid 2 (application processor)
        cpu2: Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz, 1596.31 MHz
        cpu2:
        FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,LONG,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,SENSOR,ARAT
        cpu2: 256KB 64b/line 8-way L2 cache
        cpu2: smt 0, core 1, package 0
        cpu3 at mainbus0: apid 3 (application processor)
        cpu3: Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz, 1596.31 MHz
        cpu3:
        FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,LONG,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,SENSOR,ARAT
        cpu3: 256KB 64b/line 8-way L2 cache
        cpu3: smt 1, core 1, package 0
        ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 40 pins
        acpimcfg0 at acpi0 addr 0xf8000000, bus 0-63
        acpiprt0 at acpi0: bus 0 (PCI0)
        acpiprt1 at acpi0: bus -1 (P0P1)
        acpiprt2 at acpi0: bus 1 (RP01)
        acpiprt3 at acpi0: bus 2 (RP03)
        acpiprt4 at acpi0: bus -1 (PEG0)
        acpiprt5 at acpi0: bus -1 (PEG1)
        acpiprt6 at acpi0: bus -1 (PEG2)
        acpiec0 at acpi0
        acpicpu0 at acpi0: C3(200@332 mwait.1@0x50), C2(200@148
        mwait.1@0x33), C1(1000@1 mwait.1), PSS
        acpicpu1 at acpi0: C3(200@332 mwait.1@0x50), C2(200@148
        mwait.1@0x33), C1(1000@1 mwait.1), PSS
        acpicpu2 at acpi0: C3(200@332 mwait.1@0x50), C2(200@148
        mwait.1@0x33), C1(1000@1 mwait.1), PSS
        acpicpu3 at acpi0: C3(200@332 mwait.1@0x50), C2(200@148
        mwait.1@0x33), C1(1000@1 mwait.1), PSS
        acpitz0 at acpi0: critical temperature is 105 degC
        acpitz1 at acpi0: critical temperature is 105 degC
        "PNP0C14" at acpi0 not configured
        "INT3F0D" at acpi0 not configured
        "ACPI0008" at acpi0 not configured
        "MSFT0001" at acpi0 not configured
        "SYN0608" at acpi0 not configured
        "INT33C3" at acpi0 not configured
        "DLL060A" at acpi0 not configured
        acpibtn0 at acpi0: PWRB
        acpibtn1 at acpi0: LID0
        acpiac0 at acpi0: AC unit offline
        acpibat0 at acpi0: BAT0 model "Dell" serial 1727 type LION oem
        "SIMPLO"
        "DELLABCE" at acpi0 not configured
        "INT340E" at acpi0 not configured
        "INT33A0" at acpi0 not configured
        acpivideo0 at acpi0: GFX0
        acpivout0 at acpivideo0: DD1F
        cpu0: Enhanced SpeedStep 1596 MHz: speeds: 2401, 2400, 2300, 2200,
        2000, 1900, 1700, 1600, 1500, 1400, 1300, 1200, 1100, 900, 800, 768
        MHz
        pci0 at mainbus0 bus 0
        pchb0 at pci0 dev 0 function 0 "Intel Core 4G Host" rev 0x0b
        inteldrm0 at pci0 dev 2 function 0 "Intel HD Graphics" rev 0x0b
        drm0 at inteldrm0
        inteldrm0: msi
        inteldrm0: 1920x1080
        wsdisplay0 at inteldrm0 mux 1: console (std, vt100 emulation)
        wsdisplay0: screen 1-5 added (std, vt100 emulation)
        azalia0 at pci0 dev 3 function 0 "Intel Core 4G HD Audio" rev 0x0b:
        msi
        xhci0 at pci0 dev 20 function 0 "Intel 8 Series xHCI" rev 0x04: msi
        usb0 at xhci0: USB revision 3.0
        uhub0 at usb0 "Intel xHCI root hub" rev 3.00/1.00 addr 1
        "Intel 8 Series MEI" rev 0x04 at pci0 dev 22 function 0 not
        configured
        azalia1 at pci0 dev 27 function 0 "Intel 8 Series HD Audio" rev
        0x04: msi
        azalia1: codecs: Realtek/0x0668
        audio0 at azalia1
        ppb0 at pci0 dev 28 function 0 "Intel 8 Series PCIE" rev 0xe4
        pci1 at ppb0 bus 1
        ppb1 at pci0 dev 28 function 2 "Intel 8 Series PCIE" rev 0xe4: msi
        pci2 at ppb1 bus 2
        iwm0 at pci2 dev 0 function 0 "Intel Dual Band Wireless AC 7260" rev
        0x6b, msi
        ehci0 at pci0 dev 29 function 0 "Intel 8 Series USB" rev 0x04: apic
        2 int 23
        usb1 at ehci0: USB revision 2.0
        uhub1 at usb1 "Intel EHCI root hub" rev 2.00/1.00 addr 1
        pcib0 at pci0 dev 31 function 0 "Intel 8 Series LPC" rev 0x04
        ahci0 at pci0 dev 31 function 2 "Intel 8 Series AHCI" rev 0x04: msi,
        AHCI 1.3
        ahci0: port 2: 6.0Gb/s
        scsibus1 at ahci0: 32 targets
        sd0 at scsibus1 targ 2 lun 0: <ATA, LITEON IT LMT-12, HM71> SCSI3
        0/direct fixed
        t10.ATA_LITEON_IT_LMT-128L9M-11_MSATA_128GB_TW0921PN5508544A1906
        sd0: 122104MB, 512 bytes/sector, 250069680 sectors, thin
        ichiic0 at pci0 dev 31 function 3 "Intel 8 Series SMBus" rev 0x04:
        apic 2 int 18
        iic0 at ichiic0
        iic0: addr 0x29 00=00 01=00 02=00 03=00 04=00 05=00 06=00 07=00
        08=00 09=00 0a=00 0b=00 0c=00 0d=00 0e=00 0f=00 10=3f 11=3f 3e=00
        48=00 4a=00 4e=00 4f=00 80=03 81=ad 82=ff 83=ff 84=00 85=00 86=00
        87=00 88=00 89=00 8a=00 8b=00 8c=00 8d=00 8e=00 8f=02 90=00 91=01
        92=44 93=11 94=7f 95=00 96=3f 97=00 98=36 99=00 9b=00 9c=00 9d=00
        9e=00 9f=14 a0=03 a1=ad a2=ff a3=ff a4=00 a5=00 a6=00 a7=00 a8=00
        a9=00 aa=00 ab=00 ac=00 ad=00 ae=00 af=02 b0=00 b1=01 b2=44 b3=11
        b4=7f b5=00 b6=3f b7=00 b8=36 b9=00 ba=2f bb=00 bc=00 bd=00 be=00
        bf=14 c0=03 c1=ad c2=ff c3=ff c4=00 c5=00 c6=00 c7=00 c8=00 c9=00
        ca=00 cb=00 cc=00 cd=00 ce=00 cf=02 d0=00 d1=01 d2=44 d3=11 d4=7f
        d5=00 d6=3f d7=00 d8=36 d9=00 da=2f db=00 dc=00 dd=00 de=00 df=14
        e0=14 e1=14 e2=14 e3=14 e4=14 e5=14 e6=14 e7=14 e8=00 e9=14 ea=14
        eb=14 ec=14 ed=14 ee=14 ef=14 f0=14 f1=14 f2=14 f3=14 f4=14 f5=14
        f6=14 f7=14 f8=14 f9=14 fa=14 fb=14 fc=00 fd=14 fe=00 ff=14 words
        00=0000 01=0100 02=0200 03=0300 04=0400 05=0500 06=0600 07=0700
        iic0: addr 0x4c 00=31 01=32 02=80 04=06 05=55 07=55 0a=06 0b=55
        0d=55 10=e0 15=55 19=55 1a=55 1e=5b 20=55 21=0a 22=70 23=2f 24=a0
        25=0f 26=0f 27=12 28=12 29=a0 60=06 70=06 71=07 72=07 a4=6f a5=80
        ac=28 ad=d4 ae=04 af=df b0=20 b1=20 fd=23 fe=5d ff=04 words 00=31ff
        01=32ff 02=80ff 03=00ff 04=06ff 05=55ff 06=00ff 07=55ff
        isa0 at pcib0
        isadma0 at isa0
        pckbc0 at isa0 port 0x60/5 irq 1 irq 12
        pckbd0 at pckbc0 (kbd slot)
        wskbd0 at pckbd0: console keyboard, using wsdisplay0
        pms0 at pckbc0 (aux slot)
        wsmouse0 at pms0 mux 0
        pms0: disable error
        pms0: disable error
        pms0: disable error
        pms0: disable error
        pms0: disable error
        pcppi0 at isa0 port 0x61
        spkr0 at pcppi0
        efifb at mainbus0 not configured
        error: [drm:pid0:intel_uncore_check_errors] *ERROR* Unclaimed
        register before interrupt
        uhidev0 at uhub0 port 1 configuration 1 interface 0 "Logitech USB
        Optical Mouse" rev 2.00/63.00 addr 2
        uhidev0: iclass 3/1
        ums0 at uhidev0: 3 buttons, Z dir
        wsmouse1 at ums0 mux 0
        uhidev1 at uhub0 port 3 configuration 1 interface 0 "SYNAPTICS
        Synaptics Large Touch Screen" rev 2.00/0.01 addr 3
        uhidev1: iclass 3/0, 15 report ids
        ums1 at uhidev1 reportid 1: 1 button, tip
        wsmouse2 at ums1 mux 0
        ums2 at uhidev1 reportid 2: 2 buttons
        wsmouse3 at ums2 mux 0
        ums3 at uhidev1 reportid 7
        ums3: mouse has no X report
        uhid0 at uhidev1 reportid 8: input=0, output=0, feature=1
        uhid1 at uhidev1 reportid 9: input=0, output=63, feature=0
        uhid2 at uhidev1 reportid 10: input=0, output=5, feature=0
        uhid3 at uhidev1 reportid 11: input=61, output=0, feature=0
        uhid4 at uhidev1 reportid 12: input=1, output=0, feature=0
        uhid5 at uhidev1 reportid 15: input=0, output=0, feature=1
        uvideo0 at uhub0 port 5 configuration 1 interface 0
        "CN0Y2TKG724873CED0DKA00 Integrated_Webcam_HD" rev 2.01/39.02 addr 4
        video0 at uvideo0
        ugen0 at uhub0 port 6 "Intel product 0x07dc" rev 2.00/0.01 addr 5
        uhub2 at uhub1 port 1 "Intel Rate Matching Hub" rev 2.00/0.04 addr 2
        vscsi0 at root
        scsibus2 at vscsi0: 256 targets
        softraid0 at root
        scsibus3 at softraid0: 256 targets
        root on sd0a (c0be31cb1e50e248.a) swap on sd0b dump on sd0b
        iwm0: hw rev 0x140, fw ver 25.228 (API ver 9), address
        e8:2a:ea:ab:49:24
        pckbc: command timeout
        pckbc: command timeout
        pms0: enable error
        pms0: not in sync yet, discard input (state 0)
        pckbc: command timeout
        pms0: disable error
        pckbc: command timeout
        pckbc: command timeout
        pms0: enable error
        pms0: not in sync yet, discard input (state 0)
        pckbc: command timeout
        pms0: disable error
        pckbc: command timeout
        pckbc: command timeout
        pms0: enable error