Quantcast

Compile failure, Openbsd 6.1, building userland.

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Compile failure, Openbsd 6.1, building userland.

John Watts
Hello Openbsd,

I have been using Openbsd for a couple of years now as a
router/firewall machine.  I access the openbsd machine from one of the
machines behind, via ssh on the lan.  I do the rebuilds of the kernel
and userland discussed below "over the wire".

Whenever the buglist requires, I recompile the kernel and userland
following the procedures in the FAQ.

I have managed to do this procedure, without incident, about 6 or 8
times during the life of Version 5.9, 6.0 and now 6.1.  When I first
installed Version 6.1, shortly after release, I did the procedure just
to make sure all my configurations were working ok - successfully.

After the short list of bugs appeared for Version 6.1 I tried to
rebuild the kernel and userland.  The kernel compilation and
installation works fine but the userland compile halts with an error.
I have attached the part of the compilation output that shows the error.

See attached text file OBSD6_1_compilefail.txt

I was careful to ensure that /usr/obj was owned by build:wobj with
permissions 770.  I also manually deleted everything in the
subdirectory as root using "rm -r eachdir"

I have tried the kernel and userland rebuild several times, and have
erased the source and re-downloaded a couple of times and get the same
result when compiling the new kernel (success!) and rebuilding userland
(failure!).

Any help would be greatly appreciated.

John Watts
Cranbrook, BC




OBSD6_1_compilefail.txt (410 bytes) Download Attachment
Loading...