Clevo W840-SU laptop: suspend / hibernate fails

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Clevo W840-SU laptop: suspend / hibernate fails

finkfox
> Synopsis: Clevo W840-SU Laptop: suspend / hibernate fails
> Category: amd64
> Environment:

System : OpenBSD 6.5
Details : OpenBSD 6.5-beta (GENERIC.MP) #806: Mon Mar 18 23:24:02 MDT 2019
[hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP

Architecture: OpenBSD.amd64
Machine : amd64

> Description:

1) suspend to ram "zzz":
* System seems to suspend to ram, but after a short moment it wakes up again.
* Thereafter there is a kernel thread "acpid0" consuming %50 of cpu0. (see log further below)
* Attempts to kill the process have failed (kill -9)

2) hibernate "ZZZ":
* Monitor goes blank (but not off), but nothing more happens
* No response to keyboard interaction

I tested both cases with xenodem started under X, and with X on plain console
with same result. Hence not attaching /var/log/Xorg.0.log yet.

> How-To-Repeat:

install -current on Clevo W840-SU, rcctl start apmd, execute zzz / ZZZ

> Fix:

unknown

> Logs:

apmd debug during zzz fail (auto resume):
# apmd -d
battery status: high. external power status: connected. estimated battery life
can't disable driver messages, error: Inappropriate ioctl for device
apmevent 0000 index 0
apmevent 0006 index 22
do_etc_file(): cannot access file /etc/apm/powerup
apmevent 0006 index 23
system suspending
battery status: high. external power status: connected. estimated battery life 92%
/etc/apm/suspend exited with status 0
apmevent 0003 index 24
do_etc_file(): cannot access file /etc/apm/resume
system resumed from sleep
battery status: high. external power status: connected. estimated battery life 92%
apmevent 0006 index 30
apmevent 0006 index 33

after zzz "auto" resume:
$ top -SI
load averages: 0.98, 0.54, 0.24 xxx.yyy 19:00:30
57 processes: 1 running, 52 idle, 4 on processor up 0:07
CPU0 states: 0.6% user, 0.0% nice, 32.0% sys, 3.0% spin, 23.2% intr, 41.1% idle
CPU1 states: 0.6% user, 0.0% nice, 2.1% sys, 0.4% spin, 0.0% intr, 96.9% idle
Memory: Real: 22M/645M act/tot Free: 15G Cache: 376M Swap: 0K/16G
PID USERNAME PRI NICE SIZE RES STATE WAIT TIME CPU COMMAND
42368 root 10 0 0K 9516K onproc/0 - 2:25 56.84% acpi0

dmesg:
OpenBSD 6.5-beta (GENERIC.MP) #806: Mon Mar 18 23:24:02 MDT 2019
[hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
real mem = 17045577728 (16255MB)
avail mem = 16518680576 (15753MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.7 @ 0xeb500 (35 entries)
bios0: vendor American Megatrends Inc. version "4.6.5" date 11/21/2013
bios0: Notebook W840SU Series
acpi0 at bios0: rev 2
acpi0: sleep states S0 S3 S4 S5
acpi0: tables DSDT FACP APIC FPDT ASF! SSDT SSDT SSDT MCFG HPET SSDT SSDT DMAR CSRT
acpi0: wakeup devices PXSX(S4) RP01(S4) PXSX(S4) PXSX(S4) RP03(S4) PXSX(S4) RP04(S4) PXSX(S4)
PXSX(S4) PXSX(S4) PXSX(S4) GLAN(S4) EHC1(S3) EHC2(S3) XHC_(S3) HDEF(S4) [...]
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel(R) Core(TM) i7-4510U CPU @ 2.00GHz, 2793.90 MHz, 06-45-01
cpu0:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,
SE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SS
4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,PERF,ITS
,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,IBRS,IBPB,STIBP,L1DF,SSBD,SENSOR,ARAT,XSAVEOPT,MELTDOWN
cpu0: 256KB 64b/line 8-way L2 cache
cpu0: smt 0, core 0, package 0
mtrr: Pentium Pro MTRR support, 10 var ranges, 88 fixed ranges
cpu0: apic clock running at 99MHz
cpu0: mwait min=64, max=64, C-substates=0.2.1.2.4.1.1.1, IBE
cpu1 at mainbus0: apid 2 (application processor)
cpu1: Intel(R) Core(TM) i7-4510U CPU @ 2.00GHz, 2793.54 MHz, 06-45-01
cpu1:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,
SE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SS
4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,PERF,ITS
,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,IBRS,IBPB,STIBP,L1DF,SSBD,SENSOR,ARAT,XSAVEOPT,MELTDOWN
cpu1: 256KB 64b/line 8-way L2 cache
cpu1: smt 0, core 1, package 0
cpu2 at mainbus0: apid 1 (application processor)
cpu2: Intel(R) Core(TM) i7-4510U CPU @ 2.00GHz, 2793.53 MHz, 06-45-01
cpu2:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,
SE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SS
4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,PERF,ITS
,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,IBRS,IBPB,STIBP,L1DF,SSBD,SENSOR,ARAT,XSAVEOPT,MELTDOWN
cpu2: 256KB 64b/line 8-way L2 cache
cpu2: smt 1, core 0, package 0
cpu3 at mainbus0: apid 3 (application processor)
cpu3: Intel(R) Core(TM) i7-4510U CPU @ 2.00GHz, 2793.53 MHz, 06-45-01
cpu3:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,
SE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SS
4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,PERF,ITS
,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,IBRS,IBPB,STIBP,L1DF,SSBD,SENSOR,ARAT,XSAVEOPT,MELTDOWN
cpu3: 256KB 64b/line 8-way L2 cache
cpu3: smt 1, core 1, package 0
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 40 pins
acpimcfg0 at acpi0
acpimcfg0: addr 0xf8000000, bus 0-63
acpihpet0 at acpi0: 14318179 Hz
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 1 (RP01)
acpiprt2 at acpi0: bus 2 (RP03)
acpiprt3 at acpi0: bus 3 (RP04)
acpiprt4 at acpi0: bus -1 (P0P2)
acpiprt5 at acpi0: bus -1 (P0PA)
acpiprt6 at acpi0: bus -1 (P0PB)
acpiprt7 at acpi0: bus -1 (PEG0)
acpiprt8 at acpi0: bus -1 (PEG1)
acpiprt9 at acpi0: bus -1 (PEG2)
acpiec0 at acpi0
acpicpu0 at acpi0: C3(200@506 mwait.1@0x60), C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
acpicpu1 at acpi0: C3(200@506 mwait.1@0x60), C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
acpicpu2 at acpi0: C3(200@506 mwait.1@0x60), C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
acpicpu3 at acpi0: C3(200@506 mwait.1@0x60), C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
acpitz0 at acpi0: critical temperature is 120 degC
acpipci0 at acpi0 PCI0: 0x00000010 0x00000011 0x00000000
acpicmos0 at acpi0
"PNPC000" at acpi0 not configured
acpibtn0 at acpi0: PWRB
acpibtn1 at acpi0: SLPB
acpibtn2 at acpi0: LID0
acpiac0 at acpi0: AC unit online
acpibat0 at acpi0: BAT0 model "BAT" serial 0001 type LION oem "Notebook"
"PNP0C14" at acpi0 not configured
acpivideo0 at acpi0: GFX0
acpivout0 at acpivideo0: DD1F
cpu0: Enhanced SpeedStep 2793 MHz: speeds: 2601, 2600, 2500, 2300, 2200, 2000, 1900, 1800, 1600,
1500, 1400, 1200, 1100, 1000, 800, 754 MHz
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "Intel Core 4G Host" rev 0x0b
inteldrm0 at pci0 dev 2 function 0 "Intel HD Graphics" rev 0x0b
drm0 at inteldrm0
inteldrm0: msi
inteldrm0: 1920x1080, 32bpp
wsdisplay0 at inteldrm0 mux 1: console (std, vt100 emulation)
wsdisplay0: screen 1-5 added (std, vt100 emulation)
azalia0 at pci0 dev 3 function 0 "Intel Core 4G HD Audio" rev 0x0b: msi
xhci0 at pci0 dev 20 function 0 "Intel 8 Series xHCI" rev 0x04: msi, xHCI 1.0
usb0 at xhci0: USB revision 3.0
uhub0 at usb0 configuration 1 interface 0 "Intel xHCI root hub" rev 3.00/1.00 addr 1
"Intel 8 Series MEI" rev 0x04 at pci0 dev 22 function 0 not configured
azalia1 at pci0 dev 27 function 0 "Intel 8 Series HD Audio" rev 0x04: msi
azalia1: codecs: Realtek ALC282
audio0 at azalia1
ppb0 at pci0 dev 28 function 0 "Intel 8 Series PCIE" rev 0xe4: msi
pci1 at ppb0 bus 1
ppb1 at pci0 dev 28 function 2 "Intel 8 Series PCIE" rev 0xe4: msi
pci2 at ppb1 bus 2
athn0 at pci2 dev 0 function 0 "Atheros AR9285" rev 0x01: apic 2 int 18
athn0: AR9285 rev 2 (1T1R), ROM rev 14, address 08:3e:8e:d0:7b:31
ppb2 at pci0 dev 28 function 3 "Intel 8 Series PCIE" rev 0xe4: msi
pci3 at ppb2 bus 3
rtsx0 at pci3 dev 0 function 0 "Realtek RTL8411B Card Reader" rev 0x01: msi
sdmmc0 at rtsx0: 4-bit, dma
re0 at pci3 dev 0 function 1 "Realtek 8168" rev 0x12: RTL8411B (0x5c80), msi, address
80:fa:5b:08:66:84
rgephy0 at re0 phy 7: RTL8251 PHY, rev. 0
ehci0 at pci0 dev 29 function 0 "Intel 8 Series USB" rev 0x04: apic 2 int 23
usb1 at ehci0: USB revision 2.0
uhub1 at usb1 configuration 1 interface 0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
pcib0 at pci0 dev 31 function 0 "Intel 8 Series LPC" rev 0x04
ahci0 at pci0 dev 31 function 2 "Intel 8 Series AHCI" rev 0x04: msi, AHCI 1.3
ahci0: port 0: 6.0Gb/s
scsibus1 at ahci0: 32 targets
sd0 at scsibus1 targ 0 lun 0: <ATA, Samsung SSD 840, DXM0> SCSI3 0/direct fixed
naa.50025385a01ccb8c
sd0: 244198MB, 512 bytes/sector, 500118192 sectors, thin
ichiic0 at pci0 dev 31 function 3 "Intel 8 Series SMBus" rev 0x04: apic 2 int 18
iic0 at ichiic0
spdmem0 at iic0 addr 0x50: 8GB DDR3 SDRAM PC3-12800 SO-DIMM
spdmem1 at iic0 addr 0x52: 8GB DDR3 SDRAM PC3-12800 SO-DIMM
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5 irq 1 irq 12
pckbd0 at pckbc0 (kbd slot)
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
vmm0 at mainbus0: VMX/EPT
ugen0 at uhub0 port 5 "Foxconn product 0xe027" rev 1.10/0.01 addr 2
uhub2 at uhub1 port 1 configuration 1 interface 0 "Intel Rate Matching Hub" rev 2.00/0.04 addr 2
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
sd1 at scsibus3 targ 1 lun 0: <OPENBSD, SR CRYPTO, 006> SCSI2 0/direct fixed
sd1: 244190MB, 512 bytes/sector, 500102858 sectors
root on sd1a (8e1f55d9ac8dbdd8.a) swap on sd1b dump on sd1b

usbdevs:
Controller /dev/usb0:
addr 01: 8086:0000 Intel, xHCI root hub
super speed, self powered, config 1, rev 1.00
driver: uhub0
addr 02: 0489:e027 Foxconn, product 0xe027
full speed, self powered, config 1, rev 0.01
driver: ugen0
Controller /dev/usb1:
addr 01: 8086:0000 Intel, EHCI root hub
high speed, self powered, config 1, rev 1.00
driver: uhub1
addr 02: 8087:8000 Intel, Rate Matching Hub
high speed, self powered, config 1, rev 0.04
driver: uhub2

Reply | Threaded
Open this post in threaded view
|

Re: Clevo W840-SU laptop: suspend / hibernate fails

Mike Larkin-2
On Mon, Mar 25, 2019 at 07:06:37PM +0000, [hidden email] wrote:

> > Synopsis: Clevo W840-SU Laptop: suspend / hibernate fails
> > Category: amd64
> > Environment:
>
> System : OpenBSD 6.5
> Details : OpenBSD 6.5-beta (GENERIC.MP) #806: Mon Mar 18 23:24:02 MDT 2019
> [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
>
> Architecture: OpenBSD.amd64
> Machine : amd64
>
> > Description:
>
> 1) suspend to ram "zzz":
> * System seems to suspend to ram, but after a short moment it wakes up again.
> * Thereafter there is a kernel thread "acpid0" consuming %50 of cpu0. (see log further below)
> * Attempts to kill the process have failed (kill -9)
>
> 2) hibernate "ZZZ":
> * Monitor goes blank (but not off), but nothing more happens
> * No response to keyboard interaction
>
> I tested both cases with xenodem started under X, and with X on plain console
> with same result. Hence not attaching /var/log/Xorg.0.log yet.
>
> > How-To-Repeat:
>
> install -current on Clevo W840-SU, rcctl start apmd, execute zzz / ZZZ
>
> > Fix:
>
> unknown
>
> > Logs:
>

First things first, get a newer bios.

-ml

> apmd debug during zzz fail (auto resume):
> # apmd -d
> battery status: high. external power status: connected. estimated battery life
> can't disable driver messages, error: Inappropriate ioctl for device
> apmevent 0000 index 0
> apmevent 0006 index 22
> do_etc_file(): cannot access file /etc/apm/powerup
> apmevent 0006 index 23
> system suspending
> battery status: high. external power status: connected. estimated battery life 92%
> /etc/apm/suspend exited with status 0
> apmevent 0003 index 24
> do_etc_file(): cannot access file /etc/apm/resume
> system resumed from sleep
> battery status: high. external power status: connected. estimated battery life 92%
> apmevent 0006 index 30
> apmevent 0006 index 33
>
> after zzz "auto" resume:
> $ top -SI
> load averages: 0.98, 0.54, 0.24 xxx.yyy 19:00:30
> 57 processes: 1 running, 52 idle, 4 on processor up 0:07
> CPU0 states: 0.6% user, 0.0% nice, 32.0% sys, 3.0% spin, 23.2% intr, 41.1% idle
> CPU1 states: 0.6% user, 0.0% nice, 2.1% sys, 0.4% spin, 0.0% intr, 96.9% idle
> Memory: Real: 22M/645M act/tot Free: 15G Cache: 376M Swap: 0K/16G
> PID USERNAME PRI NICE SIZE RES STATE WAIT TIME CPU COMMAND
> 42368 root 10 0 0K 9516K onproc/0 - 2:25 56.84% acpi0
>
> dmesg:
> OpenBSD 6.5-beta (GENERIC.MP) #806: Mon Mar 18 23:24:02 MDT 2019
> [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
> real mem = 17045577728 (16255MB)
> avail mem = 16518680576 (15753MB)
> mpath0 at root
> scsibus0 at mpath0: 256 targets
> mainbus0 at root
> bios0 at mainbus0: SMBIOS rev. 2.7 @ 0xeb500 (35 entries)
> bios0: vendor American Megatrends Inc. version "4.6.5" date 11/21/2013
> bios0: Notebook W840SU Series
> acpi0 at bios0: rev 2
> acpi0: sleep states S0 S3 S4 S5
> acpi0: tables DSDT FACP APIC FPDT ASF! SSDT SSDT SSDT MCFG HPET SSDT SSDT DMAR CSRT
> acpi0: wakeup devices PXSX(S4) RP01(S4) PXSX(S4) PXSX(S4) RP03(S4) PXSX(S4) RP04(S4) PXSX(S4)
> PXSX(S4) PXSX(S4) PXSX(S4) GLAN(S4) EHC1(S3) EHC2(S3) XHC_(S3) HDEF(S4) [...]
> acpitimer0 at acpi0: 3579545 Hz, 24 bits
> acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
> cpu0 at mainbus0: apid 0 (boot processor)
> cpu0: Intel(R) Core(TM) i7-4510U CPU @ 2.00GHz, 2793.90 MHz, 06-45-01
> cpu0:
> FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,
> SE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SS
> 4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,PERF,ITS
> ,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,IBRS,IBPB,STIBP,L1DF,SSBD,SENSOR,ARAT,XSAVEOPT,MELTDOWN
> cpu0: 256KB 64b/line 8-way L2 cache
> cpu0: smt 0, core 0, package 0
> mtrr: Pentium Pro MTRR support, 10 var ranges, 88 fixed ranges
> cpu0: apic clock running at 99MHz
> cpu0: mwait min=64, max=64, C-substates=0.2.1.2.4.1.1.1, IBE
> cpu1 at mainbus0: apid 2 (application processor)
> cpu1: Intel(R) Core(TM) i7-4510U CPU @ 2.00GHz, 2793.54 MHz, 06-45-01
> cpu1:
> FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,
> SE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SS
> 4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,PERF,ITS
> ,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,IBRS,IBPB,STIBP,L1DF,SSBD,SENSOR,ARAT,XSAVEOPT,MELTDOWN
> cpu1: 256KB 64b/line 8-way L2 cache
> cpu1: smt 0, core 1, package 0
> cpu2 at mainbus0: apid 1 (application processor)
> cpu2: Intel(R) Core(TM) i7-4510U CPU @ 2.00GHz, 2793.53 MHz, 06-45-01
> cpu2:
> FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,
> SE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SS
> 4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,PERF,ITS
> ,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,IBRS,IBPB,STIBP,L1DF,SSBD,SENSOR,ARAT,XSAVEOPT,MELTDOWN
> cpu2: 256KB 64b/line 8-way L2 cache
> cpu2: smt 1, core 0, package 0
> cpu3 at mainbus0: apid 3 (application processor)
> cpu3: Intel(R) Core(TM) i7-4510U CPU @ 2.00GHz, 2793.53 MHz, 06-45-01
> cpu3:
> FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,
> SE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SS
> 4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,PERF,ITS
> ,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,IBRS,IBPB,STIBP,L1DF,SSBD,SENSOR,ARAT,XSAVEOPT,MELTDOWN
> cpu3: 256KB 64b/line 8-way L2 cache
> cpu3: smt 1, core 1, package 0
> ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 40 pins
> acpimcfg0 at acpi0
> acpimcfg0: addr 0xf8000000, bus 0-63
> acpihpet0 at acpi0: 14318179 Hz
> acpiprt0 at acpi0: bus 0 (PCI0)
> acpiprt1 at acpi0: bus 1 (RP01)
> acpiprt2 at acpi0: bus 2 (RP03)
> acpiprt3 at acpi0: bus 3 (RP04)
> acpiprt4 at acpi0: bus -1 (P0P2)
> acpiprt5 at acpi0: bus -1 (P0PA)
> acpiprt6 at acpi0: bus -1 (P0PB)
> acpiprt7 at acpi0: bus -1 (PEG0)
> acpiprt8 at acpi0: bus -1 (PEG1)
> acpiprt9 at acpi0: bus -1 (PEG2)
> acpiec0 at acpi0
> acpicpu0 at acpi0: C3(200@506 mwait.1@0x60), C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
> acpicpu1 at acpi0: C3(200@506 mwait.1@0x60), C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
> acpicpu2 at acpi0: C3(200@506 mwait.1@0x60), C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
> acpicpu3 at acpi0: C3(200@506 mwait.1@0x60), C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
> acpitz0 at acpi0: critical temperature is 120 degC
> acpipci0 at acpi0 PCI0: 0x00000010 0x00000011 0x00000000
> acpicmos0 at acpi0
> "PNPC000" at acpi0 not configured
> acpibtn0 at acpi0: PWRB
> acpibtn1 at acpi0: SLPB
> acpibtn2 at acpi0: LID0
> acpiac0 at acpi0: AC unit online
> acpibat0 at acpi0: BAT0 model "BAT" serial 0001 type LION oem "Notebook"
> "PNP0C14" at acpi0 not configured
> acpivideo0 at acpi0: GFX0
> acpivout0 at acpivideo0: DD1F
> cpu0: Enhanced SpeedStep 2793 MHz: speeds: 2601, 2600, 2500, 2300, 2200, 2000, 1900, 1800, 1600,
> 1500, 1400, 1200, 1100, 1000, 800, 754 MHz
> pci0 at mainbus0 bus 0
> pchb0 at pci0 dev 0 function 0 "Intel Core 4G Host" rev 0x0b
> inteldrm0 at pci0 dev 2 function 0 "Intel HD Graphics" rev 0x0b
> drm0 at inteldrm0
> inteldrm0: msi
> inteldrm0: 1920x1080, 32bpp
> wsdisplay0 at inteldrm0 mux 1: console (std, vt100 emulation)
> wsdisplay0: screen 1-5 added (std, vt100 emulation)
> azalia0 at pci0 dev 3 function 0 "Intel Core 4G HD Audio" rev 0x0b: msi
> xhci0 at pci0 dev 20 function 0 "Intel 8 Series xHCI" rev 0x04: msi, xHCI 1.0
> usb0 at xhci0: USB revision 3.0
> uhub0 at usb0 configuration 1 interface 0 "Intel xHCI root hub" rev 3.00/1.00 addr 1
> "Intel 8 Series MEI" rev 0x04 at pci0 dev 22 function 0 not configured
> azalia1 at pci0 dev 27 function 0 "Intel 8 Series HD Audio" rev 0x04: msi
> azalia1: codecs: Realtek ALC282
> audio0 at azalia1
> ppb0 at pci0 dev 28 function 0 "Intel 8 Series PCIE" rev 0xe4: msi
> pci1 at ppb0 bus 1
> ppb1 at pci0 dev 28 function 2 "Intel 8 Series PCIE" rev 0xe4: msi
> pci2 at ppb1 bus 2
> athn0 at pci2 dev 0 function 0 "Atheros AR9285" rev 0x01: apic 2 int 18
> athn0: AR9285 rev 2 (1T1R), ROM rev 14, address 08:3e:8e:d0:7b:31
> ppb2 at pci0 dev 28 function 3 "Intel 8 Series PCIE" rev 0xe4: msi
> pci3 at ppb2 bus 3
> rtsx0 at pci3 dev 0 function 0 "Realtek RTL8411B Card Reader" rev 0x01: msi
> sdmmc0 at rtsx0: 4-bit, dma
> re0 at pci3 dev 0 function 1 "Realtek 8168" rev 0x12: RTL8411B (0x5c80), msi, address
> 80:fa:5b:08:66:84
> rgephy0 at re0 phy 7: RTL8251 PHY, rev. 0
> ehci0 at pci0 dev 29 function 0 "Intel 8 Series USB" rev 0x04: apic 2 int 23
> usb1 at ehci0: USB revision 2.0
> uhub1 at usb1 configuration 1 interface 0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
> pcib0 at pci0 dev 31 function 0 "Intel 8 Series LPC" rev 0x04
> ahci0 at pci0 dev 31 function 2 "Intel 8 Series AHCI" rev 0x04: msi, AHCI 1.3
> ahci0: port 0: 6.0Gb/s
> scsibus1 at ahci0: 32 targets
> sd0 at scsibus1 targ 0 lun 0: <ATA, Samsung SSD 840, DXM0> SCSI3 0/direct fixed
> naa.50025385a01ccb8c
> sd0: 244198MB, 512 bytes/sector, 500118192 sectors, thin
> ichiic0 at pci0 dev 31 function 3 "Intel 8 Series SMBus" rev 0x04: apic 2 int 18
> iic0 at ichiic0
> spdmem0 at iic0 addr 0x50: 8GB DDR3 SDRAM PC3-12800 SO-DIMM
> spdmem1 at iic0 addr 0x52: 8GB DDR3 SDRAM PC3-12800 SO-DIMM
> isa0 at pcib0
> isadma0 at isa0
> pckbc0 at isa0 port 0x60/5 irq 1 irq 12
> pckbd0 at pckbc0 (kbd slot)
> wskbd0 at pckbd0: console keyboard, using wsdisplay0
> pms0 at pckbc0 (aux slot)
> wsmouse0 at pms0 mux 0
> pcppi0 at isa0 port 0x61
> spkr0 at pcppi0
> vmm0 at mainbus0: VMX/EPT
> ugen0 at uhub0 port 5 "Foxconn product 0xe027" rev 1.10/0.01 addr 2
> uhub2 at uhub1 port 1 configuration 1 interface 0 "Intel Rate Matching Hub" rev 2.00/0.04 addr 2
> vscsi0 at root
> scsibus2 at vscsi0: 256 targets
> softraid0 at root
> scsibus3 at softraid0: 256 targets
> sd1 at scsibus3 targ 1 lun 0: <OPENBSD, SR CRYPTO, 006> SCSI2 0/direct fixed
> sd1: 244190MB, 512 bytes/sector, 500102858 sectors
> root on sd1a (8e1f55d9ac8dbdd8.a) swap on sd1b dump on sd1b
>
> usbdevs:
> Controller /dev/usb0:
> addr 01: 8086:0000 Intel, xHCI root hub
> super speed, self powered, config 1, rev 1.00
> driver: uhub0
> addr 02: 0489:e027 Foxconn, product 0xe027
> full speed, self powered, config 1, rev 0.01
> driver: ugen0
> Controller /dev/usb1:
> addr 01: 8086:0000 Intel, EHCI root hub
> high speed, self powered, config 1, rev 1.00
> driver: uhub1
> addr 02: 8087:8000 Intel, Rate Matching Hub
> high speed, self powered, config 1, rev 0.04
> driver: uhub2
>

Reply | Threaded
Open this post in threaded view
|

Re: Clevo W840-SU laptop: suspend / hibernate fails

finkfox
Hi Mike and all,

thank you for your reply.

> First things first, get a newer bios.

That's a good idea.
I'm not sure though if a new BIOS for my machine exists
and where I should get it.

In fact I'm still a bit confused about this.

From my BIOS I could extract the following information:

* Clevo W840SU
* American Megatrends Version 2.15.1236 2012
* ME FW Version 9.5.13.1706
* BIOS Version 1.03.02
* KBC/EC Firmware Revision 1.03.02

So as I understand, there is

* American Megatrends which provides BIOS for the industry.
* Clevo, the laptop manufacturer, which provides BIOS (and is based on the American Megatrends one?).
* resellers of Clevo laptops (which may modify/customize the BIOS).

I looked at the American Megatrends homepage [0] but did not understand how I could obtain a BIOS for my machine from them.

On the official Clevo support homepage I only could find a list of drivers [1] but no BIOS updates.

On a German Clevo reseller homepage [2] I could find a BIOS with Version 1.03.02 [3],
the one I'm already using.

So who should I ask for a BIOS update?
American Megatrends, Clevo, some reseller?

How long are these companies "obliged" to maintain and offer BIOS updates?

What if there is no newer BIOS?

Thank you very much,

Fox

----
[0] https://ami.com
[1] https://www.clevo.com.tw/en/e-services/download/ftpOut.asp?Lmodel=W840SU&ltype=9&submit=+GO+
[2] https://clevo-computer.com/support/
[3] https://my.hidrive.com/share/yze8mg-wf8#$/BIOS%20and%20EC%20Firmware/CLEVO/W_Series/W8_Series/W840SU

Reply | Threaded
Open this post in threaded view
|

Re: Clevo W840-SU laptop: suspend / hibernate fails

Mike Larkin-2
On Tue, Mar 26, 2019 at 01:15:35PM +0000, [hidden email] wrote:

> Hi Mike and all,
>
> thank you for your reply.
>
> > First things first, get a newer bios.
>
> That's a good idea.
> I'm not sure though if a new BIOS for my machine exists
> and where I should get it.
>
> In fact I'm still a bit confused about this.
>
> From my BIOS I could extract the following information:
>
> * Clevo W840SU
> * American Megatrends Version 2.15.1236 2012
> * ME FW Version 9.5.13.1706
> * BIOS Version 1.03.02
> * KBC/EC Firmware Revision 1.03.02
>
> So as I understand, there is
>
> * American Megatrends which provides BIOS for the industry.
> * Clevo, the laptop manufacturer, which provides BIOS (and is based on the American Megatrends one?).
> * resellers of Clevo laptops (which may modify/customize the BIOS).
>
> I looked at the American Megatrends homepage [0] but did not understand how I could obtain a BIOS for my machine from them.
>

Not there, they likely sell the bios to Clevo.

> On the official Clevo support homepage I only could find a list of drivers [1] but no BIOS updates.
>

Shrug.

> On a German Clevo reseller homepage [2] I could find a BIOS with Version 1.03.02 [3],
> the one I'm already using.
>
> So who should I ask for a BIOS update?
> American Megatrends, Clevo, some reseller?
>

Clevo likely.

> How long are these companies "obliged" to maintain and offer BIOS updates?
>

There's no set time.

> What if there is no newer BIOS?
>

You're waking up from resume for some reason. You can try disabling devices
(sometimes usb devices wake the machine, as we've seen in the past). Or try ZZZ
instead of zzz and see if hibernate works differently for you.

> Thank you very much,
>
> Fox
>
> ----
> [0] https://ami.com
> [1] https://www.clevo.com.tw/en/e-services/download/ftpOut.asp?Lmodel=W840SU&ltype=9&submit=+GO+
> [2] https://clevo-computer.com/support/
> [3] https://my.hidrive.com/share/yze8mg-wf8#$/BIOS%20and%20EC%20Firmware/CLEVO/W_Series/W8_Series/W840SU

Reply | Threaded
Open this post in threaded view
|

Re: Clevo W840-SU laptop: suspend / hibernate fails

finkfox
> >
> > So who should I ask for a BIOS update?
> > American Megatrends, Clevo, some reseller?
> >
>
> Clevo likely.
>

And what is wrong with my BIOS?
What do they need to fix if I'd ask Clevo for an update?

> > What if there is no newer BIOS?

> You're waking up from resume for some reason. You can try disabling devices
> (sometimes usb devices wake the machine, as we've seen in the past).

Could you give an example how I could do that?

> Or try ZZZ instead of zzz and see if hibernate works differently for you.

Unfortunately ZZZ is failing as well as I described in the bug report.