Carp : perte du trafic réseau

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Carp : perte du trafic réseau

GouNiNi-3
Bonjour,

J'ai un souci avec une installation Carp, deux OpenBSD 4.3 i386.
Ces machines sont la passerelle d'un vlan privé.
La configuration est la suivante :
         +--| carp0:Shared LAN |--+
         |                        |
     bge2|                        |bge2  
      +-----+                  +-----+
      | fw1 |-bge1--------bge1-| fw2 |
      +-----+                  +-----+
     bge0|                        |bge0
         |                        |
         +--| carp1:Private LAN |-+

Cette installation a fonctionnée pendant plusieurs mois,
mais ça fait quelques semaines que mon problème apparait :

- Au bout d'un temps aléatoire d'utilisation, "Private LAN" devient
injoignable sur le master (pas de problème sur le slave)

- carp1 ne ping plus rien et n'est plus pinguable (toujours sur
le master)

- bge0 ne ping plus rien et n'est plus pinguable (même chose)

- ifconfig des interfaces qui "plantent" ne remontent rien de
particulier (pas qui me saute aux yeux en tout cas), les interfaces
sont UP et les IP sont présentes

- carp ne détecte pas de problème, il n'y a pas de bascule

- ifconfig bge0 down && ifconfig bge0 up résout mon problème

- ce problème intervient de manière identique, quelque soit
le master (fw1 ou fw2)

Bien entendu, rien n'a été modifié sur ces deux machines avant
le problème, en revanche, le réseau "Private LAN" évolue
régulièrement. Il semble que le problème vienne de pars là, mais
je n'arrive pas à identifier quoi exactement.
J'avoue être à court de d'idée.

J'ai volontairement pas fait de gros copier/coller de ifconfig
ou autre, ne sachant pas trop ce dont vous avez besoin comme infos.

Pouvez vous m'aiguiller sur ce problème ?

Cordialement

--
Bonnetot Jean-Daniel

________________________________
French OpenBSD mailing list
[hidden email]
http://www.openbsd-france.org/communaute.php

Reply | Threaded
Open this post in threaded view
|

Re: Carp : perte du trafic réseau

GouNiNi-3
----- Mail original -----
> De: "GouNiNi" <[hidden email]>
> À: [hidden email]
> Envoyé: Mercredi 28 Juillet 2010 17:50:40
> Objet: [obsdfr-misc] Carp : perte du trafic réseau

>
> Bien entendu, rien n'a été modifié sur ces deux machines avant
> le problème, en revanche, le réseau "Private LAN" évolue
> régulièrement. Il semble que le problème vienne de pars là, mais
> je n'arrive pas à identifier quoi exactement.
> J'avoue être à court de d'idée.
>
> J'ai volontairement pas fait de gros copier/coller de ifconfig
> ou autre, ne sachant pas trop ce dont vous avez besoin comme infos.
>
> Pouvez vous m'aiguiller sur ce problème ?
>
> Cordialement
>
> -- Bonnetot Jean-Daniel
>
> ________________________________ French OpenBSD mailing list
> [hidden email]
> http://www.openbsd-france.org/communaute.php

Bonjour la liste,

Est ce qu'il manque des infos ?
Peut être que ma description du problème n'est pas claire ?

Merci d'avance

--
Bonnetot Jean-Daniel

________________________________
French OpenBSD mailing list
[hidden email]
http://www.openbsd-france.org/communaute.php

Reply | Threaded
Open this post in threaded view
|

Re: Carp : perte du trafic réseau

Alexis de BRUYN
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Bonjour Jean-Daniel,

Pourrais-tu donner la configuration de toutes tes interfaces réseaux
ainsi que celle de PF (si tu l'as activée).

Merci d'avance,


GouNiNi wrote:

> ----- Mail original -----
>> De: "GouNiNi" <[hidden email]>
>> À: [hidden email]
>> Envoyé: Mercredi 28 Juillet 2010 17:50:40
>> Objet: [obsdfr-misc] Carp : perte du trafic réseau
>
>> Bien entendu, rien n'a été modifié sur ces deux machines avant
>> le problème, en revanche, le réseau "Private LAN" évolue
>> régulièrement. Il semble que le problème vienne de pars là, mais
>> je n'arrive pas à identifier quoi exactement.
>> J'avoue être à court de d'idée.
>>
>> J'ai volontairement pas fait de gros copier/coller de ifconfig
>> ou autre, ne sachant pas trop ce dont vous avez besoin comme infos.
>>
>> Pouvez vous m'aiguiller sur ce problème ?
>>
>> Cordialement
>>
>> -- Bonnetot Jean-Daniel
>>
>> ________________________________ French OpenBSD mailing list
>> [hidden email]
>> http://www.openbsd-france.org/communaute.php
>
> Bonjour la liste,
>
> Est ce qu'il manque des infos ?
> Peut être que ma description du problème n'est pas claire ?
>
> Merci d'avance
>
> --
> Bonnetot Jean-Daniel
>
> ________________________________
> French OpenBSD mailing list
> [hidden email]
> http://www.openbsd-france.org/communaute.php
>

- --
Alexis de BRUYN
email : [hidden email]
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkxUNw8ACgkQPdN4bPTxnXeMmgCfV4HG1OquQXfUNMnaODnSg2lu
n/kAn2PLAnwqSkWdtAXA4+wCk/ttKro8
=XUTt
-----END PGP SIGNATURE-----

________________________________
French OpenBSD mailing list
[hidden email]
http://www.openbsd-france.org/communaute.php