Cant build Apache 2.4.33 in OpenBSD 6.3

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Cant build Apache 2.4.33 in OpenBSD 6.3

Helmut Kiessling BT
Hi,

 

I'm trying to build newest version of Apache 2.4.33 in OpenBSD 6.3 but got
the following errors:

 

ssl_engine_init.c:54:12: error: static declaration of 'DH_set0_pqg' follows
non-static declaration

static int DH_set0_pqg(DH *dh, BIGNUM *p, BIGNUM *q, BIGNUM *g)

           ^

/usr/include/openssl/dh.h:195:5: note: previous declaration is here

int DH_set0_pqg(DH *dh, BIGNUM *p, BIGNUM *q, BIGNUM *g);

    ^

 

No errors when doing the same build in OpenBSD 6.2. Any ideas what's wrong
or is it a bug perhaps?

 

Many Thanks Again,

Helmut Kiessling

 

 

Reply | Threaded
Open this post in threaded view
|

Re: Cant build Apache 2.4.33 in OpenBSD 6.3

Ingo Schwarze
Hi Helmut,

Helmut Kiessling BT wrote on Mon, Apr 16, 2018 at 02:49:23PM +0100:

> I'm trying to build newest version of Apache 2.4.33 in OpenBSD 6.3

No need to try, it's already in -current ports:

   $ grep ^V= /usr/ports/www/apache-httpd/Makefile                
  V=                      2.4.33

sthen@ committed it on 2018/03/29.

> but got the following errors:
>
> ssl_engine_init.c:54:12: error: static declaration of 'DH_set0_pqg'
> follows non-static declaration
> static int DH_set0_pqg(DH *dh, BIGNUM *p, BIGNUM *q, BIGNUM *g)
>            ^
>
> /usr/include/openssl/dh.h:195:5: note: previous declaration is here
> int DH_set0_pqg(DH *dh, BIGNUM *p, BIGNUM *q, BIGNUM *g);
>     ^
> No errors when doing the same build in OpenBSD 6.2.

We added the DH_set0_pqg(3) in 6.3:

   $ man DH_set0_pqg | tail -n 5    
  HISTORY
     These functions first appeared in OpenSSL 1.1.0 and have been available
     since OpenBSD 6.3.

  OpenBSD 6.3                   March 23, 2018                   OpenBSD 6.3

> Any ideas what's wrong or is it a bug perhaps?

The Apache build system attempts to compile a replacement
function, even though it is already available in the base
system, causing a conflict.

Consequently, not a bug.

Backport the -current port to -stable, or run -current.

Yours,
  Ingo

Reply | Threaded
Open this post in threaded view
|

Re: Cant build Apache 2.4.33 in OpenBSD 6.3

Stuart Henderson
In reply to this post by Helmut Kiessling BT
On 2018/04/16 14:49, Helmut Kiessling BT wrote:
>
> I'm trying to build newest version of Apache 2.4.33 in OpenBSD 6.3 but got
> the following errors:

It needs patches which you can find in -current ports.