Can't mount hfs+ partitions

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Can't mount hfs+ partitions

Samad Lotia
Hey everyone,
I am having problems mounting hfs+ partitions. I just installed 3.8  
and apt-get'd the hfsplus utils package. I typed hpmount /dev/wd0i  
but I get an unknown error (-1). Here is my partition map from Mac OS X:
(/dev/rdisk0 is /dev/wd0c for OpenBSD kernel)

Bagh-i-Shalimar:/Users/samad root# pdisk /dev/rdisk0
Edit /dev/rdisk0 -
Command (? for help): p

Partition map (with 512 byte blocks) on '/dev/rdisk0'
#:                type name                   length   base     ( size )
1: Apple_partition_map Apple                      63 @ 1
2:             OpenBSD swap                  4492188 @ 83624000 (  2.1G)
3:           Apple_HFS Apple_HFS_Untitled_1 83361792 @ 262208   ( 39.8G)
4:     Apple_Bootstrap boot                     1954 @ 88116188
5:             OpenBSD root                 29092098 @ 88118142 ( 13.9G)
6:          Apple_Free Extra                  262144 @ 64       (128.0M)

Device block size=512, Number of Blocks=117210240 (55.9G)
DeviceType=0x0, DeviceId=0x0


I also have an external USB drive, and I tried to mount it with  
hpmount /dev/rd0i, but I get the same error message. Here is that  
drive's partition map:
(Again, /dev/rdisk2 is /dev/rd0c for the OpenBSD kernel)
Partition map (with 512 byte blocks) on '/dev/rdisk2'
#:                type name                    length   base      
( size )
1: Apple_partition_map Apple                       63 @ 1
2:          Apple_Free                         262144 @ 64        
(128.0M)
3:           Apple_HFS Apple_HFS_Untitled_1 195550848 @ 262208    
( 93.2G)
4:          Apple_Free                             16 @ 195813056

Device block size=512, Number of Blocks=195813072 (93.4G)
DeviceType=0x0, DeviceId=0x0

Thanks,
Samad

Reply | Threaded
Open this post in threaded view
|

Re: Can't mount hfs+ partitions

OpenBSD-9
Samad Lotia wrote:

> Hey everyone,
> I am having problems mounting hfs+ partitions. I just installed 3.8  and
> apt-get'd the hfsplus utils package. I typed hpmount /dev/wd0i  but I
> get an unknown error (-1). Here is my partition map from Mac OS X:
> (/dev/rdisk0 is /dev/wd0c for OpenBSD kernel)
>
> Bagh-i-Shalimar:/Users/samad root# pdisk /dev/rdisk0
> Edit /dev/rdisk0 -
> Command (? for help): p
>
> Partition map (with 512 byte blocks) on '/dev/rdisk0'
> #:                type name                   length   base     ( size )
> 1: Apple_partition_map Apple                      63 @ 1
> 2:             OpenBSD swap                  4492188 @ 83624000 (  2.1G)
> 3:           Apple_HFS Apple_HFS_Untitled_1 83361792 @ 262208   ( 39.8G)
> 4:     Apple_Bootstrap boot                     1954 @ 88116188
> 5:             OpenBSD root                 29092098 @ 88118142 ( 13.9G)
> 6:          Apple_Free Extra                  262144 @ 64       (128.0M)
>
> Device block size=512, Number of Blocks=117210240 (55.9G)
> DeviceType=0x0, DeviceId=0x0
>
>
> I also have an external USB drive, and I tried to mount it with  hpmount
> /dev/rd0i, but I get the same error message. Here is that  drive's
> partition map:
> (Again, /dev/rdisk2 is /dev/rd0c for the OpenBSD kernel)
> Partition map (with 512 byte blocks) on '/dev/rdisk2'
> #:                type name                    length   base       ( size )
> 1: Apple_partition_map Apple                       63 @ 1
> 2:          Apple_Free                         262144 @ 64         (128.0M)
> 3:           Apple_HFS Apple_HFS_Untitled_1 195550848 @ 262208     ( 93.2G)
> 4:          Apple_Free                             16 @ 195813056
>
> Device block size=512, Number of Blocks=195813072 (93.4G)
> DeviceType=0x0, DeviceId=0x0
>
> Thanks,
> Samad
>
Hi Samad,

What is the output of disklabel wd0 and disklabel rd0?

That might explain the error you are getting.

And dmesg's are always useful.

HTH

Fred