Can't locate OpenBSD/Quirks.pm in @INC

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Can't locate OpenBSD/Quirks.pm in @INC

mymlact@gmx.com
HI,


I downloaded the install66.fs snapshot today, 20200117, and did a fresh
install.  Even though I got the full install set, i used http from
ftp.openbsd.org as the install source.

Installation went fine but when I tried to install packages I get the
above error.

"# pkg_add -vn pftop
quirks-3.216 signed on 2020-01-17T19:15:00Z
quirks-3.216: ok
Can't load quirk: Can't locate OpenBSD/Quirks.pm in @INC (you may need
to install the OpenBSD::Quirks module) (@INC contains:
/usr/local/libdata/perl5/site_perl/amd64-openbsd
/usr/local/libdata/perl5/site_perl /usr/libdata/perl5/amd64-openbsd
/usr/libdata/perl5) at /usr/libdata/perl5/OpenBSD/AddDelete.pm line 350.

pftop-0.7p19: ok
Merging manpages in /usr/local/man: /usr/local/man/man8/pftop.8
Extracted 252817 from 253475"


Any ideas?


Thanks in advance.


system dmesg:


# dmesg
OpenBSD 6.6-current (RAMDISK_CD) #586: Thu Jan 16 14:00:02 MST 2020
[hidden email]:/usr/src/sys/arch/amd64/compile/RAMDISK_CD
real mem = 8487612416 (8094MB)
avail mem = 8226369536 (7845MB)
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 3.0 @ 0x8d318000 (86 entries)
bios0: vendor American Megatrends Inc. version "5.12" date 07/08/2019
bios0: Protectli FW6
acpi0 at bios0: ACPI 6.1
acpi0: tables DSDT FACP APIC FPDT MCFG SSDT FIDT SSDT HPET SSDT SSDT
UEFI SSDT LPIT WSMT SSDT SSDT SSDT SSDT DBGP DBG2 DMAR BGRT ASF!
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz, 2395.13 MHz, 06-8e-09
cpu0:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,3DNOWP,PERF,ITSC,FSGSBASE,TSC_ADJUST,SGX,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,MPX,RDSEED,ADX,SMAP,CLFLUSHOPT,PT,IBRS,IBPB,STIBP,SENSOR,ARAT,XSAVEOPT,XSAVEC,XGETBV1,XSAVES,MELTDOWN
cpu0: 256KB 64b/line 8-way L2 cache
cpu0: apic clock running at 24MHz
cpu0: mwait min=64, max=64, C-substates=0.2.1.2.4.1.1.1, IBE
cpu at mainbus0: not configured
cpu at mainbus0: not configured
cpu at mainbus0: not configured
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 120 pins
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus -1 (PEG0)
acpiprt2 at acpi0: bus -1 (PEG1)
acpiprt3 at acpi0: bus -1 (PEG2)
acpiprt4 at acpi0: bus -1 (RP09)
acpiprt5 at acpi0: bus -1 (RP10)
acpiprt6 at acpi0: bus -1 (RP11)
acpiprt7 at acpi0: bus -1 (RP12)
acpiprt8 at acpi0: bus -1 (RP13)
acpiprt9 at acpi0: bus 1 (RP01)
acpiprt10 at acpi0: bus 2 (RP02)
acpiprt11 at acpi0: bus 3 (RP03)
acpiprt12 at acpi0: bus 4 (RP04)
acpiprt13 at acpi0: bus 5 (RP05)
acpiprt14 at acpi0: bus 6 (RP06)
acpiprt15 at acpi0: bus -1 (RP07)
acpiprt16 at acpi0: bus -1 (RP08)
acpiprt17 at acpi0: bus -1 (RP17)
acpiprt18 at acpi0: bus -1 (RP18)
acpiprt19 at acpi0: bus -1 (RP19)
acpiprt20 at acpi0: bus -1 (RP20)
acpiprt21 at acpi0: bus -1 (RP21)
acpiprt22 at acpi0: bus -1 (RP22)
acpiprt23 at acpi0: bus -1 (RP23)
acpiprt24 at acpi0: bus -1 (RP24)
acpiprt25 at acpi0: bus -1 (RP14)
acpiprt26 at acpi0: bus -1 (RP15)
acpiprt27 at acpi0: bus -1 (RP16)
acpiec0 at acpi0: not present
acpicpu at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpitz at acpi0 not configured
acpitz at acpi0 not configured
acpipci0 at acpi0 PCI0: 0x00000000 0x00000011 0x00000001
acpicmos0 at acpi0
"PNP0C0E" at acpi0 not configured
"INT33A1" at acpi0 not configured
"PNP0C0C" at acpi0 not configured
"PNP0C0B" at acpi0 not configured
"PNP0C0B" at acpi0 not configured
"PNP0C0B" at acpi0 not configured
"PNP0C0B" at acpi0 not configured
"PNP0C0B" at acpi0 not configured
cpu0: using Skylake AVX MDS workaround
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "Intel Core 7G Host" rev 0x02
"Intel HD Graphics 620" rev 0x02 at pci0 dev 2 function 0 not configured
xhci0 at pci0 dev 20 function 0 "Intel 100 Series xHCI" rev 0x21: msi,
xHCI 1.0
usb0 at xhci0: USB revision 3.0
uhub0 at usb0 configuration 1 interface 0 "Intel xHCI root hub" rev
3.00/1.00 addr 1
"Intel 100 Series MEI" rev 0x21 at pci0 dev 22 function 0 not configured
ahci0 at pci0 dev 23 function 0 "Intel 100 Series AHCI" rev 0x21: msi,
AHCI 1.3.1
ahci0: port 0: 6.0Gb/s
ahci0: PHY offline on port 1
ahci0: PHY offline on port 2
scsibus0 at ahci0: 32 targets
sd0 at scsibus0 targ 0 lun 0: <ATA, KINGSTON SUV500M, 0030>
naa.50026b77830e2173
sd0: 114473MB, 512 bytes/sector, 234441648 sectors, thin
ppb0 at pci0 dev 28 function 0 "Intel 100 Series PCIE" rev 0xf1: msi
pci1 at ppb0 bus 1
em0 at pci1 dev 0 function 0 "Intel 82583V" rev 0x00: msi, address
00:e0:67:18:01:ae
ppb1 at pci0 dev 28 function 1 "Intel 100 Series PCIE" rev 0xf1: msi
pci2 at ppb1 bus 2
em1 at pci2 dev 0 function 0 "Intel 82583V" rev 0x00: msi, address
00:e0:67:18:01:af
ppb2 at pci0 dev 28 function 2 "Intel 100 Series PCIE" rev 0xf1: msi
pci3 at ppb2 bus 3
em2 at pci3 dev 0 function 0 "Intel 82583V" rev 0x00: msi, address
00:e0:67:18:01:b0
ppb3 at pci0 dev 28 function 3 "Intel 100 Series PCIE" rev 0xf1: msi
pci4 at ppb3 bus 4
em3 at pci4 dev 0 function 0 "Intel 82583V" rev 0x00: msi, address
00:e0:67:18:01:b1
ppb4 at pci0 dev 28 function 4 "Intel 100 Series PCIE" rev 0xf1: msi
pci5 at ppb4 bus 5
em4 at pci5 dev 0 function 0 "Intel 82583V" rev 0x00: msi, address
00:e0:67:18:01:b2
ppb5 at pci0 dev 28 function 5 "Intel 100 Series PCIE" rev 0xf1: msi
pci6 at ppb5 bus 6
em5 at pci6 dev 0 function 0 "Intel 82583V" rev 0x00: msi, address
00:e0:67:18:01:b3
"Intel 200 Series LPC" rev 0x21 at pci0 dev 31 function 0 not configured
"Intel 100 Series PMC" rev 0x21 at pci0 dev 31 function 2 not configured
"Intel 100 Series SMBus" rev 0x21 at pci0 dev 31 function 4 not configured
isa0 at mainbus0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5 irq 1 irq 12
pckbd0 at pckbc0 (kbd slot)
wskbd0 at pckbd0: console keyboard
efifb0 at mainbus0: 2560x1440, 32bpp
wsdisplay0 at efifb0 mux 1: console (std, vt100 emulation), using wskbd0
uhidev0 at uhub0 port 1 configuration 1 interface 0 "DELL DELL USB
Keyboard" rev 1.10/1.05 addr 2
uhidev0: iclass 3/1
ukbd0 at uhidev0
wskbd1 at ukbd0 mux 1
wskbd1: connecting to wsdisplay0
umass0 at uhub0 port 15 configuration 1 interface 0 "SanDisk Ultra" rev
3.00/1.00 addr 3
umass0: using SCSI over Bulk-Only
scsibus1 at umass0: 2 targets, initiator 0
sd1 at scsibus1 targ 1 lun 0: <SanDisk, Ultra, 1.00> removable
serial.07815581200212119554
sd1: 29328MB, 512 bytes/sector, 60063744 sectors
softraid0 at root
scsibus2 at softraid0: 256 targets
root on rd0a swap on rd0b dump on rd0b
OpenBSD 6.6-current (RAMDISK_CD) #586: Thu Jan 16 14:00:02 MST 2020
[hidden email]:/usr/src/sys/arch/amd64/compile/RAMDISK_CD
real mem = 8487612416 (8094MB)
avail mem = 8226369536 (7845MB)
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 3.0 @ 0x8d318000 (86 entries)
bios0: vendor American Megatrends Inc. version "5.12" date 07/08/2019
bios0: Protectli FW6
acpi0 at bios0: ACPI 6.1
acpi0: tables DSDT FACP APIC FPDT MCFG SSDT FIDT SSDT HPET SSDT SSDT
UEFI SSDT LPIT WSMT SSDT SSDT SSDT SSDT DBGP DBG2 DMAR ASF!
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz, 2395.24 MHz, 06-8e-09
cpu0:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,3DNOWP,PERF,ITSC,FSGSBASE,TSC_ADJUST,SGX,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,MPX,RDSEED,ADX,SMAP,CLFLUSHOPT,PT,IBRS,IBPB,STIBP,SENSOR,ARAT,XSAVEOPT,XSAVEC,XGETBV1,XSAVES,MELTDOWN
cpu0: 256KB 64b/line 8-way L2 cache
cpu0: apic clock running at 24MHz
cpu0: mwait min=64, max=64, C-substates=0.2.1.2.4.1.1.1, IBE
cpu at mainbus0: not configured
cpu at mainbus0: not configured
cpu at mainbus0: not configured
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 120 pins
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus -1 (PEG0)
acpiprt2 at acpi0: bus -1 (PEG1)
acpiprt3 at acpi0: bus -1 (PEG2)
acpiprt4 at acpi0: bus -1 (RP09)
acpiprt5 at acpi0: bus -1 (RP10)
acpiprt6 at acpi0: bus -1 (RP11)
acpiprt7 at acpi0: bus -1 (RP12)
acpiprt8 at acpi0: bus -1 (RP13)
acpiprt9 at acpi0: bus 1 (RP01)
acpiprt10 at acpi0: bus 2 (RP02)
acpiprt11 at acpi0: bus 3 (RP03)
acpiprt12 at acpi0: bus 4 (RP04)
acpiprt13 at acpi0: bus 5 (RP05)
acpiprt14 at acpi0: bus 6 (RP06)
acpiprt15 at acpi0: bus -1 (RP07)
acpiprt16 at acpi0: bus -1 (RP08)
acpiprt17 at acpi0: bus -1 (RP17)
acpiprt18 at acpi0: bus -1 (RP18)
acpiprt19 at acpi0: bus -1 (RP19)
acpiprt20 at acpi0: bus -1 (RP20)
acpiprt21 at acpi0: bus -1 (RP21)
acpiprt22 at acpi0: bus -1 (RP22)
acpiprt23 at acpi0: bus -1 (RP23)
acpiprt24 at acpi0: bus -1 (RP24)
acpiprt25 at acpi0: bus -1 (RP14)
acpiprt26 at acpi0: bus -1 (RP15)
acpiprt27 at acpi0: bus -1 (RP16)
acpiec0 at acpi0: not present
acpicpu at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpipwrres at acpi0 not configured
acpitz at acpi0 not configured
acpitz at acpi0 not configured
acpipci0 at acpi0 PCI0: 0x00000000 0x00000011 0x00000001
acpicmos0 at acpi0
"PNP0C0E" at acpi0 not configured
"INT33A1" at acpi0 not configured
"PNP0C0C" at acpi0 not configured
"PNP0C0B" at acpi0 not configured
"PNP0C0B" at acpi0 not configured
"PNP0C0B" at acpi0 not configured
"PNP0C0B" at acpi0 not configured
"PNP0C0B" at acpi0 not configured
cpu0: using Skylake AVX MDS workaround
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "Intel Core 7G Host" rev 0x02
"Intel HD Graphics 620" rev 0x02 at pci0 dev 2 function 0 not configured
xhci0 at pci0 dev 20 function 0 "Intel 100 Series xHCI" rev 0x21: msi,
xHCI 1.0
usb0 at xhci0: USB revision 3.0
uhub0 at usb0 configuration 1 interface 0 "Intel xHCI root hub" rev
3.00/1.00 addr 1
"Intel 100 Series MEI" rev 0x21 at pci0 dev 22 function 0 not configured
ahci0 at pci0 dev 23 function 0 "Intel 100 Series AHCI" rev 0x21: msi,
AHCI 1.3.1
ahci0: port 0: 6.0Gb/s
ahci0: PHY offline on port 1
ahci0: PHY offline on port 2
scsibus0 at ahci0: 32 targets
sd0 at scsibus0 targ 0 lun 0: <ATA, KINGSTON SUV500M, 0030>
naa.50026b77830e2173
sd0: 114473MB, 512 bytes/sector, 234441648 sectors, thin
ppb0 at pci0 dev 28 function 0 "Intel 100 Series PCIE" rev 0xf1: msi
pci1 at ppb0 bus 1
em0 at pci1 dev 0 function 0 "Intel 82583V" rev 0x00: msi, address
00:e0:67:18:01:ae
ppb1 at pci0 dev 28 function 1 "Intel 100 Series PCIE" rev 0xf1: msi
pci2 at ppb1 bus 2
em1 at pci2 dev 0 function 0 "Intel 82583V" rev 0x00: msi, address
00:e0:67:18:01:af
ppb2 at pci0 dev 28 function 2 "Intel 100 Series PCIE" rev 0xf1: msi
pci3 at ppb2 bus 3
em2 at pci3 dev 0 function 0 "Intel 82583V" rev 0x00: msi, address
00:e0:67:18:01:b0
ppb3 at pci0 dev 28 function 3 "Intel 100 Series PCIE" rev 0xf1: msi
pci4 at ppb3 bus 4
em3 at pci4 dev 0 function 0 "Intel 82583V" rev 0x00: msi, address
00:e0:67:18:01:b1
ppb4 at pci0 dev 28 function 4 "Intel 100 Series PCIE" rev 0xf1: msi
pci5 at ppb4 bus 5
em4 at pci5 dev 0 function 0 "Intel 82583V" rev 0x00: msi, address
00:e0:67:18:01:b2
ppb5 at pci0 dev 28 function 5 "Intel 100 Series PCIE" rev 0xf1: msi
pci6 at ppb5 bus 6
em5 at pci6 dev 0 function 0 "Intel 82583V" rev 0x00: msi, address
00:e0:67:18:01:b3
"Intel 200 Series LPC" rev 0x21 at pci0 dev 31 function 0 not configured
"Intel 100 Series PMC" rev 0x21 at pci0 dev 31 function 2 not configured
"Intel 100 Series SMBus" rev 0x21 at pci0 dev 31 function 4 not configured
isa0 at mainbus0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5 irq 1 irq 12
pckbd0 at pckbc0 (kbd slot)
wskbd0 at pckbd0: console keyboard
efifb0 at mainbus0: 2560x1440, 32bpp
wsdisplay0 at efifb0 mux 1: console (std, vt100 emulation), using wskbd0
uhidev0 at uhub0 port 1 configuration 1 interface 0 "DELL DELL USB
Keyboard" rev 1.10/1.05 addr 2
uhidev0: iclass 3/1
ukbd0 at uhidev0
wskbd1 at ukbd0 mux 1
wskbd1: connecting to wsdisplay0
umass0 at uhub0 port 15 configuration 1 interface 0 "SanDisk Ultra" rev
3.00/1.00 addr 3
umass0: using SCSI over Bulk-Only
scsibus1 at umass0: 2 targets, initiator 0
sd1 at scsibus1 targ 1 lun 0: <SanDisk, Ultra, 1.00> removable
serial.07815581200212119554
sd1: 29328MB, 512 bytes/sector, 60063744 sectors
softraid0 at root
scsibus2 at softraid0: 256 targets
root on rd0a swap on rd0b dump on rd0b
syncing disks...
OpenBSD 6.6-current (GENERIC.MP) #613: Thu Jan 16 13:52:56 MST 2020
[hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
real mem = 8487612416 (8094MB)
avail mem = 8217915392 (7837MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 3.0 @ 0x8d318000 (86 entries)
bios0: vendor American Megatrends Inc. version "5.12" date 07/08/2019
bios0: Protectli FW6
acpi0 at bios0: ACPI 6.1
acpi0: sleep states S0 S5
acpi0: tables DSDT FACP APIC FPDT MCFG SSDT FIDT SSDT HPET SSDT SSDT
UEFI SSDT LPIT WSMT SSDT SSDT SSDT SSDT DBGP DBG2 DMAR ASF!
acpi0: wakeup devices PS2K(S0) PS2M(S0) RP09(S0) PXSX(S0) RP10(S0)
PXSX(S0) RP11(S0) PXSX(S0) RP12(S0) PXSX(S0) RP13(S0) PXSX(S0) RP01(S0)
PXSX(S0) RP02(S0) PXSX(S0) [...]
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz, 2395.21 MHz, 06-8e-09
cpu0:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,3DNOWP,PERF,ITSC,FSGSBASE,TSC_ADJUST,SGX,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,MPX,RDSEED,ADX,SMAP,CLFLUSHOPT,PT,IBRS,IBPB,STIBP,SENSOR,ARAT,XSAVEOPT,XSAVEC,XGETBV1,XSAVES,MELTDOWN
cpu0: 256KB 64b/line 8-way L2 cache
cpu0: smt 0, core 0, package 0
mtrr: Pentium Pro MTRR support, 10 var ranges, 88 fixed ranges
cpu0: apic clock running at 24MHz
cpu0: mwait min=64, max=64, C-substates=0.2.1.2.4.1.1.1, IBE
cpu1 at mainbus0: apid 2 (application processor)
cpu1: Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz, 2394.43 MHz, 06-8e-09
cpu1:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,3DNOWP,PERF,ITSC,FSGSBASE,TSC_ADJUST,SGX,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,MPX,RDSEED,ADX,SMAP,CLFLUSHOPT,PT,IBRS,IBPB,STIBP,SENSOR,ARAT,XSAVEOPT,XSAVEC,XGETBV1,XSAVES,MELTDOWN
cpu1: 256KB 64b/line 8-way L2 cache
cpu1: smt 0, core 1, package 0
cpu2 at mainbus0: apid 1 (application processor)
cpu2: Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz, 2394.43 MHz, 06-8e-09
cpu2:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,3DNOWP,PERF,ITSC,FSGSBASE,TSC_ADJUST,SGX,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,MPX,RDSEED,ADX,SMAP,CLFLUSHOPT,PT,IBRS,IBPB,STIBP,SENSOR,ARAT,XSAVEOPT,XSAVEC,XGETBV1,XSAVES,MELTDOWN
cpu2: 256KB 64b/line 8-way L2 cache
cpu2: smt 1, core 0, package 0
cpu3 at mainbus0: apid 3 (application processor)
cpu3: Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz, 2394.42 MHz, 06-8e-09
cpu3:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,3DNOWP,PERF,ITSC,FSGSBASE,TSC_ADJUST,SGX,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,MPX,RDSEED,ADX,SMAP,CLFLUSHOPT,PT,IBRS,IBPB,STIBP,SENSOR,ARAT,XSAVEOPT,XSAVEC,XGETBV1,XSAVES,MELTDOWN
cpu3: 256KB 64b/line 8-way L2 cache
cpu3: smt 1, core 1, package 0
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 120 pins
acpimcfg0 at acpi0
acpimcfg0: addr 0xe0000000, bus 0-255
acpihpet0 at acpi0: 23999999 Hz
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus -1 (PEG0)
acpiprt2 at acpi0: bus -1 (PEG1)
acpiprt3 at acpi0: bus -1 (PEG2)
acpiprt4 at acpi0: bus -1 (RP09)
acpiprt5 at acpi0: bus -1 (RP10)
acpiprt6 at acpi0: bus -1 (RP11)
acpiprt7 at acpi0: bus -1 (RP12)
acpiprt8 at acpi0: bus -1 (RP13)
acpiprt9 at acpi0: bus 1 (RP01)
acpiprt10 at acpi0: bus 2 (RP02)
acpiprt11 at acpi0: bus 3 (RP03)
acpiprt12 at acpi0: bus 4 (RP04)
acpiprt13 at acpi0: bus 5 (RP05)
acpiprt14 at acpi0: bus 6 (RP06)
acpiprt15 at acpi0: bus -1 (RP07)
acpiprt16 at acpi0: bus -1 (RP08)
acpiprt17 at acpi0: bus -1 (RP17)
acpiprt18 at acpi0: bus -1 (RP18)
acpiprt19 at acpi0: bus -1 (RP19)
acpiprt20 at acpi0: bus -1 (RP20)
acpiprt21 at acpi0: bus -1 (RP21)
acpiprt22 at acpi0: bus -1 (RP22)
acpiprt23 at acpi0: bus -1 (RP23)
acpiprt24 at acpi0: bus -1 (RP24)
acpiprt25 at acpi0: bus -1 (RP14)
acpiprt26 at acpi0: bus -1 (RP15)
acpiprt27 at acpi0: bus -1 (RP16)
acpiec0 at acpi0: not present
acpicpu0 at acpi0: C3(200@1034 mwait.1@0x60), C2(200@151 mwait.1@0x33),
C1(1000@1 mwait.1), PSS
acpicpu1 at acpi0: C3(200@1034 mwait.1@0x60), C2(200@151 mwait.1@0x33),
C1(1000@1 mwait.1), PSS
acpicpu2 at acpi0: C3(200@1034 mwait.1@0x60), C2(200@151 mwait.1@0x33),
C1(1000@1 mwait.1), PSS
acpicpu3 at acpi0: C3(200@1034 mwait.1@0x60), C2(200@151 mwait.1@0x33),
C1(1000@1 mwait.1), PSS
acpipwrres0 at acpi0: WRST
acpipwrres1 at acpi0: WRST
acpipwrres2 at acpi0: WRST
acpipwrres3 at acpi0: WRST
acpipwrres4 at acpi0: WRST
acpipwrres5 at acpi0: WRST
acpipwrres6 at acpi0: WRST
acpipwrres7 at acpi0: WRST
acpipwrres8 at acpi0: WRST
acpipwrres9 at acpi0: WRST
acpipwrres10 at acpi0: WRST
acpipwrres11 at acpi0: WRST
acpipwrres12 at acpi0: WRST
acpipwrres13 at acpi0: WRST
acpipwrres14 at acpi0: WRST
acpipwrres15 at acpi0: WRST
acpipwrres16 at acpi0: WRST
acpipwrres17 at acpi0: WRST
acpipwrres18 at acpi0: WRST
acpipwrres19 at acpi0: WRST
acpipwrres20 at acpi0: FN00, resource for FAN0
acpipwrres21 at acpi0: FN01, resource for FAN1
acpipwrres22 at acpi0: FN02, resource for FAN2
acpipwrres23 at acpi0: FN03, resource for FAN3
acpipwrres24 at acpi0: FN04, resource for FAN4
acpitz0 at acpi0: critical temperature is 119 degC
acpitz1 at acpi0: critical temperature is 119 degC
acpipci0 at acpi0 PCI0: 0x00000000 0x00000011 0x00000001
extent `acpipci0 pcibus' (0x0 - 0xff), flags=0
      0xff - 0xff
extent `acpipci0 pciio' (0x0 - 0xffffffff), flags=0
      0xcf8 - 0xcff
      0x10000 - 0xffffffff
extent `acpipci0 pcimem' (0x0 - 0xffffffffffffffff), flags=0
      0x0 - 0x9ffff
      0xc0000 - 0x8fffffff
      0xe0000000 - 0xfcffffff
      0xfe800000 - 0xffffffffffffffff
acpicmos0 at acpi0
acpibtn0 at acpi0: SLPB
"INT33A1" at acpi0 not configured
acpibtn1 at acpi0: PWRB
"PNP0C0B" at acpi0 not configured
"PNP0C0B" at acpi0 not configured
"PNP0C0B" at acpi0 not configured
"PNP0C0B" at acpi0 not configured
"PNP0C0B" at acpi0 not configured
acpivideo0 at acpi0: GFX0
acpivout0 at acpivideo0: DD1F
cpu0: using Skylake AVX MDS workaround
cpu0: Enhanced SpeedStep 2395 MHz: speeds: 2601, 2600, 2500, 2400, 2200,
2000, 1900, 1700, 1500, 1400, 1200, 1100, 800, 700, 600, 400 MHz
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "Intel Core 7G Host" rev 0x02
inteldrm0 at pci0 dev 2 function 0 "Intel HD Graphics 620" rev 0x02
drm0 at inteldrm0
inteldrm0: msi
xhci0 at pci0 dev 20 function 0 "Intel 100 Series xHCI" rev 0x21: msi,
xHCI 1.0
usb0 at xhci0: USB revision 3.0
uhub0 at usb0 configuration 1 interface 0 "Intel xHCI root hub" rev
3.00/1.00 addr 1
"Intel 100 Series MEI" rev 0x21 at pci0 dev 22 function 0 not configured
ahci0 at pci0 dev 23 function 0 "Intel 100 Series AHCI" rev 0x21: msi,
AHCI 1.3.1
ahci0: port 0: 6.0Gb/s
ahci0: PHY offline on port 1
ahci0: PHY offline on port 2
scsibus1 at ahci0: 32 targets
sd0 at scsibus1 targ 0 lun 0: <ATA, KINGSTON SUV500M, 0030>
naa.50026b77830e2173
sd0: 114473MB, 512 bytes/sector, 234441648 sectors, thin
ppb0 at pci0 dev 28 function 0 "Intel 100 Series PCIE" rev 0xf1: msi
pci1 at ppb0 bus 1
em0 at pci1 dev 0 function 0 "Intel 82583V" rev 0x00: msi, address
00:e0:67:18:01:ae
ppb1 at pci0 dev 28 function 1 "Intel 100 Series PCIE" rev 0xf1: msi
pci2 at ppb1 bus 2
em1 at pci2 dev 0 function 0 "Intel 82583V" rev 0x00: msi, address
00:e0:67:18:01:af
ppb2 at pci0 dev 28 function 2 "Intel 100 Series PCIE" rev 0xf1: msi
pci3 at ppb2 bus 3
em2 at pci3 dev 0 function 0 "Intel 82583V" rev 0x00: msi, address
00:e0:67:18:01:b0
ppb3 at pci0 dev 28 function 3 "Intel 100 Series PCIE" rev 0xf1: msi
pci4 at ppb3 bus 4
em3 at pci4 dev 0 function 0 "Intel 82583V" rev 0x00: msi, address
00:e0:67:18:01:b1
ppb4 at pci0 dev 28 function 4 "Intel 100 Series PCIE" rev 0xf1: msi
pci5 at ppb4 bus 5
em4 at pci5 dev 0 function 0 "Intel 82583V" rev 0x00: msi, address
00:e0:67:18:01:b2
ppb5 at pci0 dev 28 function 5 "Intel 100 Series PCIE" rev 0xf1: msi
pci6 at ppb5 bus 6
em5 at pci6 dev 0 function 0 "Intel 82583V" rev 0x00: msi, address
00:e0:67:18:01:b3
pcib0 at pci0 dev 31 function 0 "Intel 200 Series LPC" rev 0x21
"Intel 100 Series PMC" rev 0x21 at pci0 dev 31 function 2 not configured
ichiic0 at pci0 dev 31 function 4 "Intel 100 Series SMBus" rev 0x21:
apic 2 int 16
iic0 at ichiic0
spdmem0 at iic0 addr 0x50: 4GB DDR4 SDRAM PC4-19200 SO-DIMM
spdmem1 at iic0 addr 0x52: 4GB DDR4 SDRAM PC4-19200 SO-DIMM
isa0 at pcib0
isadma0 at isa0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5 irq 1 irq 12
pckbd0 at pckbc0 (kbd slot)
wskbd0 at pckbd0: console keyboard
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
it0 at isa0 port 0x2e/2: IT8772F rev 1, EC port 0xa40
vmm0 at mainbus0: VMX/EPT (using slow L1TF mitigation)
uhidev0 at uhub0 port 1 configuration 1 interface 0 "DELL DELL USB
Keyboard" rev 1.10/1.05 addr 2
uhidev0: iclass 3/1
ukbd0 at uhidev0: 8 variable keys, 6 key codes
wskbd1 at ukbd0 mux 1
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
root on sd0a (5bec410ae1a4a338.a) swap on sd0b dump on sd0b
inteldrm0: 2560x1440, 32bpp
drm:pid35471:csr_load_work_fn *NOTICE* Failed to load DMC firmware
i915/kbl_dmc_ver1_04.bin. Disabling runtime power management.
drm:pid35471:csr_load_work_fn *NOTICE* DMC firmware homepage:
https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/tree/i915wsdisplay0
at inteldrm0 mux 1: console (std, vt100 emulation), using wskbd0
wskbd1: connecting to wsdisplay0
wsdisplay0: screen 1-5 added (std, vt100 emulation)
umass0 at uhub0 port 3 configuration 1 interface 0 "SMI Corporation USB
DISK" rev 2.00/11.00 addr 3
umass0: using SCSI over Bulk-Only
scsibus4 at umass0: 2 targets, initiator 0
sd1 at scsibus4 targ 1 lun 0: <FLASH, Drive SM_USB20, 1100> removable
serial.090c1000012700007502
sd1: 1912MB, 512 bytes/sector, 3915776 sectors
fw01#


Reply | Threaded
Open this post in threaded view
|

Re: Can't locate OpenBSD/Quirks.pm in @INC

Jordan Geoghegan-3


On 2020-01-17 18:10, [hidden email] wrote:

> HI,
>
>
> I downloaded the install66.fs snapshot today, 20200117, and did a fresh
> install.  Even though I got the full install set, i used http from
> ftp.openbsd.org as the install source.
>
> Installation went fine but when I tried to install packages I get the
> above error.
>
> "# pkg_add -vn pftop
> quirks-3.216 signed on 2020-01-17T19:15:00Z
> quirks-3.216: ok
> Can't load quirk: Can't locate OpenBSD/Quirks.pm in @INC (you may need
> to install the OpenBSD::Quirks module) (@INC contains:
> /usr/local/libdata/perl5/site_perl/amd64-openbsd
> /usr/local/libdata/perl5/site_perl /usr/libdata/perl5/amd64-openbsd
> /usr/libdata/perl5) at /usr/libdata/perl5/OpenBSD/AddDelete.pm line 350.
>
> pftop-0.7p19: ok
> Merging manpages in /usr/local/man: /usr/local/man/man8/pftop.8
> Extracted 252817 from 253475"
>
[snip]

I believe quirks gets automatically installed when you install your
first package.

Reply | Threaded
Open this post in threaded view
|

Re: Can't locate OpenBSD/Quirks.pm in @INC

mymlact@gmx.com

On 1/17/20 7:25 PM, Jordan Geoghegan wrote:

>
>
> On 2020-01-17 18:10, [hidden email] wrote:
>> HI,
>>
>>
>> I downloaded the install66.fs snapshot today, 20200117, and did a fresh
>> install.  Even though I got the full install set, i used http from
>> ftp.openbsd.org as the install source.
>>
>> Installation went fine but when I tried to install packages I get the
>> above error.
>>
>> "# pkg_add -vn pftop
>> quirks-3.216 signed on 2020-01-17T19:15:00Z
>> quirks-3.216: ok
>> Can't load quirk: Can't locate OpenBSD/Quirks.pm in @INC (you may need
>> to install the OpenBSD::Quirks module) (@INC contains:
>> /usr/local/libdata/perl5/site_perl/amd64-openbsd
>> /usr/local/libdata/perl5/site_perl /usr/libdata/perl5/amd64-openbsd
>> /usr/libdata/perl5) at /usr/libdata/perl5/OpenBSD/AddDelete.pm line 350.
>>
>> pftop-0.7p19: ok
>> Merging manpages in /usr/local/man: /usr/local/man/man8/pftop.8
>> Extracted 252817 from 253475"
>>
> [snip]
>
> I believe quirks gets automatically installed when you install your
> first package.


AH HA, that seems to be the case.

  pkg_add -v pftop
quirks-3.216 signed on 2020-01-17T19:15:00Z
quirks-3.216: ok
pftop-0.7p19: ok
Extracted 252817 from 253475


I was just initially trying to see what would be installed without
actually installing.  I've run into issues before where the base system
packages and the userland stuff, if they aren't labeled the same date
have library issues.  I was trying to make sure i'd avoid that.


Thanks for the quick answer!

Reply | Threaded
Open this post in threaded view
|

Re: Can't locate OpenBSD/Quirks.pm in @INC

Antoine Jacoutot-7
On Fri, Jan 17, 2020 at 07:46:23PM -0700, [hidden email] wrote:

>
> On 1/17/20 7:25 PM, Jordan Geoghegan wrote:
> >
> >
> > On 2020-01-17 18:10, [hidden email] wrote:
> > > HI,
> > >
> > >
> > > I downloaded the install66.fs snapshot today, 20200117, and did a fresh
> > > install.  Even though I got the full install set, i used http from
> > > ftp.openbsd.org as the install source.
> > >
> > > Installation went fine but when I tried to install packages I get the
> > > above error.
> > >
> > > "# pkg_add -vn pftop
> > > quirks-3.216 signed on 2020-01-17T19:15:00Z
> > > quirks-3.216: ok
> > > Can't load quirk: Can't locate OpenBSD/Quirks.pm in @INC (you may need
> > > to install the OpenBSD::Quirks module) (@INC contains:
> > > /usr/local/libdata/perl5/site_perl/amd64-openbsd
> > > /usr/local/libdata/perl5/site_perl /usr/libdata/perl5/amd64-openbsd
> > > /usr/libdata/perl5) at /usr/libdata/perl5/OpenBSD/AddDelete.pm line 350.
> > >
> > > pftop-0.7p19: ok
> > > Merging manpages in /usr/local/man: /usr/local/man/man8/pftop.8
> > > Extracted 252817 from 253475"
> > >
> > [snip]
> >
> > I believe quirks gets automatically installed when you install your
> > first package.
>
>
> AH HA, that seems to be the case.
>
>  pkg_add -v pftop
> quirks-3.216 signed on 2020-01-17T19:15:00Z
> quirks-3.216: ok
> pftop-0.7p19: ok
> Extracted 252817 from 253475
>
>
> I was just initially trying to see what would be installed without
> actually installing.  I've run into issues before where the base system
> packages and the userland stuff, if they aren't labeled the same date
> have library issues.  I was trying to make sure i'd avoid that.
>
>
> Thanks for the quick answer!
 
That is still a pkg_add bug though...

--
Antoine

Reply | Threaded
Open this post in threaded view
|

Re: Can't locate OpenBSD/Quirks.pm in @INC

Marc Espie-2
On Sat, Jan 18, 2020 at 01:41:20PM +0100, Antoine Jacoutot wrote:

> On Fri, Jan 17, 2020 at 07:46:23PM -0700, [hidden email] wrote:
> >
> > On 1/17/20 7:25 PM, Jordan Geoghegan wrote:
> > >
> > >
> > > On 2020-01-17 18:10, [hidden email] wrote:
> > > > HI,
> > > >
> > > >
> > > > I downloaded the install66.fs snapshot today, 20200117, and did a fresh
> > > > install.  Even though I got the full install set, i used http from
> > > > ftp.openbsd.org as the install source.
> > > >
> > > > Installation went fine but when I tried to install packages I get the
> > > > above error.
> > > >
> > > > "# pkg_add -vn pftop
> > > > quirks-3.216 signed on 2020-01-17T19:15:00Z
> > > > quirks-3.216: ok
> > > > Can't load quirk: Can't locate OpenBSD/Quirks.pm in @INC (you may need
> > > > to install the OpenBSD::Quirks module) (@INC contains:
> > > > /usr/local/libdata/perl5/site_perl/amd64-openbsd
> > > > /usr/local/libdata/perl5/site_perl /usr/libdata/perl5/amd64-openbsd
> > > > /usr/libdata/perl5) at /usr/libdata/perl5/OpenBSD/AddDelete.pm line 350.
> > > >
> > > > pftop-0.7p19: ok
> > > > Merging manpages in /usr/local/man: /usr/local/man/man8/pftop.8
> > > > Extracted 252817 from 253475"
> > > >
> > > [snip]
> > >
> > > I believe quirks gets automatically installed when you install your
> > > first package.
> >
> >
> > AH HA, that seems to be the case.
> >
> >  pkg_add -v pftop
> > quirks-3.216 signed on 2020-01-17T19:15:00Z
> > quirks-3.216: ok
> > pftop-0.7p19: ok
> > Extracted 252817 from 253475
> >
> >
> > I was just initially trying to see what would be installed without
> > actually installing.  I've run into issues before where the base system
> > packages and the userland stuff, if they aren't labeled the same date
> > have library issues.  I was trying to make sure i'd avoid that.
> >
> >
> > Thanks for the quick answer!
>  
> That is still a pkg_add bug though...

Known bug, it's on my list (need a clean machine to reproduce, because
I most often have so many packages installed it's not even funny)

Reply | Threaded
Open this post in threaded view
|

Re: Can't locate OpenBSD/Quirks.pm in @INC

Marc Espie-2
In reply to this post by Antoine Jacoutot-7
On Sat, Jan 18, 2020 at 01:41:20PM +0100, Antoine Jacoutot wrote:

> On Fri, Jan 17, 2020 at 07:46:23PM -0700, [hidden email] wrote:
> >
> > On 1/17/20 7:25 PM, Jordan Geoghegan wrote:
> > >
> > >
> > > On 2020-01-17 18:10, [hidden email] wrote:
> > > > HI,
> > > >
> > > >
> > > > I downloaded the install66.fs snapshot today, 20200117, and did a fresh
> > > > install.  Even though I got the full install set, i used http from
> > > > ftp.openbsd.org as the install source.
> > > >
> > > > Installation went fine but when I tried to install packages I get the
> > > > above error.
> > > >
> > > > "# pkg_add -vn pftop
> > > > quirks-3.216 signed on 2020-01-17T19:15:00Z
> > > > quirks-3.216: ok
> > > > Can't load quirk: Can't locate OpenBSD/Quirks.pm in @INC (you may need
> > > > to install the OpenBSD::Quirks module) (@INC contains:
> > > > /usr/local/libdata/perl5/site_perl/amd64-openbsd
> > > > /usr/local/libdata/perl5/site_perl /usr/libdata/perl5/amd64-openbsd
> > > > /usr/libdata/perl5) at /usr/libdata/perl5/OpenBSD/AddDelete.pm line 350.
> > > >
> > > > pftop-0.7p19: ok
> > > > Merging manpages in /usr/local/man: /usr/local/man/man8/pftop.8
> > > > Extracted 252817 from 253475"
> > > >
> > > [snip]
> > >
> > > I believe quirks gets automatically installed when you install your
> > > first package.
> >
> >
> > AH HA, that seems to be the case.
> >
> >  pkg_add -v pftop
> > quirks-3.216 signed on 2020-01-17T19:15:00Z
> > quirks-3.216: ok
> > pftop-0.7p19: ok
> > Extracted 252817 from 253475
> >
> >
> > I was just initially trying to see what would be installed without
> > actually installing.  I've run into issues before where the base system
> > packages and the userland stuff, if they aren't labeled the same date
> > have library issues.  I was trying to make sure i'd avoid that.
> >
> >
> > Thanks for the quick answer!
>  
> That is still a pkg_add bug though...

Thinking some more about it, I'm not sure about the right solution.
- I can easily suppress the quirks warning if -n is given.

- but then, quirks is kind-of part of pkg_add proper, so maybe it would be
more appropriate to install quirks anyway.   This is a bit unexpected, though.

Reply | Threaded
Open this post in threaded view
|

Re: Can't locate OpenBSD/Quirks.pm in @INC

Antoine Jacoutot-7
On Sun, Jan 19, 2020 at 12:19:31PM +0100, Marc Espie wrote:

> On Sat, Jan 18, 2020 at 01:41:20PM +0100, Antoine Jacoutot wrote:
> > On Fri, Jan 17, 2020 at 07:46:23PM -0700, [hidden email] wrote:
> > >
> > > On 1/17/20 7:25 PM, Jordan Geoghegan wrote:
> > > >
> > > >
> > > > On 2020-01-17 18:10, [hidden email] wrote:
> > > > > HI,
> > > > >
> > > > >
> > > > > I downloaded the install66.fs snapshot today, 20200117, and did a fresh
> > > > > install.  Even though I got the full install set, i used http from
> > > > > ftp.openbsd.org as the install source.
> > > > >
> > > > > Installation went fine but when I tried to install packages I get the
> > > > > above error.
> > > > >
> > > > > "# pkg_add -vn pftop
> > > > > quirks-3.216 signed on 2020-01-17T19:15:00Z
> > > > > quirks-3.216: ok
> > > > > Can't load quirk: Can't locate OpenBSD/Quirks.pm in @INC (you may need
> > > > > to install the OpenBSD::Quirks module) (@INC contains:
> > > > > /usr/local/libdata/perl5/site_perl/amd64-openbsd
> > > > > /usr/local/libdata/perl5/site_perl /usr/libdata/perl5/amd64-openbsd
> > > > > /usr/libdata/perl5) at /usr/libdata/perl5/OpenBSD/AddDelete.pm line 350.
> > > > >
> > > > > pftop-0.7p19: ok
> > > > > Merging manpages in /usr/local/man: /usr/local/man/man8/pftop.8
> > > > > Extracted 252817 from 253475"
> > > > >
> > > > [snip]
> > > >
> > > > I believe quirks gets automatically installed when you install your
> > > > first package.
> > >
> > >
> > > AH HA, that seems to be the case.
> > >
> > >  pkg_add -v pftop
> > > quirks-3.216 signed on 2020-01-17T19:15:00Z
> > > quirks-3.216: ok
> > > pftop-0.7p19: ok
> > > Extracted 252817 from 253475
> > >
> > >
> > > I was just initially trying to see what would be installed without
> > > actually installing.  I've run into issues before where the base system
> > > packages and the userland stuff, if they aren't labeled the same date
> > > have library issues.  I was trying to make sure i'd avoid that.
> > >
> > >
> > > Thanks for the quick answer!
> >  
> > That is still a pkg_add bug though...
>
> Thinking some more about it, I'm not sure about the right solution.
> - I can easily suppress the quirks warning if -n is given.

The problem is that you may get a different output compared to if quirks was
instaled (e.g. cve).

> - but then, quirks is kind-of part of pkg_add proper, so maybe it would be
> more appropriate to install quirks anyway.   This is a bit unexpected, though.

It would be unexpected yes.
Maybe quirks has become too quirky and we need a better solution?

--
Antoine