Can't get gettext installed via package on 3.9.

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Can't get gettext installed via package on 3.9.

Allie Daneman
I already tried to submit a bug report on a package with new dependendencies so I'll
just post to ports and see if I can get some guidance. It seems like a few packages
depend on gettext and I'm having issues installing it's new version. I get this:

Can't install gettext-0.14.5p1 because of conflicts (.libs-gettext-0.10.40p3)
/usr/sbin/pkg_add: gettext-0.14.5p1:Fatal error

So I perused CVSweb hoping to track down where to look for the cruft in my
filesystem...I didn't find anything. I did a 3.9 upgrade on an i386 box and am fumbling
through the package upgrades. I actually just removed them all and started over...which
may have made it worse ;) Any help would be greatly appreciated...I can't even install
php without gettext.

Allie Daneman



Reply | Threaded
Open this post in threaded view
|

Re: Can't get gettext installed via package on 3.9.

Nikolay Sturm-2
* [hidden email] [2006-05-02]:
> Can't install gettext-0.14.5p1 because of conflicts (.libs-gettext-0.10.40p3)
> /usr/sbin/pkg_add: gettext-0.14.5p1:Fatal error
>
> So I perused CVSweb hoping to track down where to look for the cruft in my
> filesystem...

Dear user,

error messages are messages of the program you are trying to use,
intended to inform you about some issue the program is having. In order
for this mechanism to work, both parties need to do their job:

1) the program needs to provide a reasonable error message
2) the user has to read and think about it

Please follow step 2 and be a lucky user.

Yours,

The OpenBSD User Satisfaction Team

PS: As today is May 3rd, User Satisfaction Day, let me give you a hint:

   .libs-gettext-0.10.40p3 is a package name.