Boot attempt: SolidRun CuBox-i2

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Boot attempt: SolidRun CuBox-i2

Brian Conway
Obviously not supported hardware, but wanted to throw this out in case
it's of use to anyone. I picked up the mid-level CuBox-i2eX
(dual-core, serial over USB,
http://www.solid-run.com/products/cubox-i-mini-computer/cubox-i-specifications/)
model and attempted to load the 12/14/2014 IMX snapshot (via tftp
using SolidRun's Ignition image as the U-Boot source). Logs are below,
let me know if there's any assistance I can in the future. Thanks.

U-Boot SPL 2013.10-rc4 (Oct 27 2014 - 18:17:31)
Boot Device: SD1
spl: error reading image u-boot.img, err - -1
Load image from RAW...


U-Boot 2013.10-rc4 (Oct 27 2014 - 18:17:31)

CPU:   Freescale i.MX6Q rev1.5 at 792 MHz
Reset cause: WDOG
Board: MX6-CuBox-i
DRAM:  1 GiB
MMC:   FSL_SDHC: 0
*** Warning - bad CRC, using default environment

In:    serial
Out:   vga
Err:   vga
Net:   FEC [PRIME]
(Re)start USB...
USB0:   USB EHCI 1.00
scanning bus 0 for devices... 1 USB Device(s) found
       scanning usb for storage devices... 0 Storage Device(s) found
       scanning usb for ethernet devices... 0 Ethernet Device(s) found
Hit any key to stop autoboot:  0
CuBox-i U-Boot > dhcp
BOOTP broadcast 1
DHCP client bound to address 10.X.Y.113
Using FEC device
TFTP from server 10.X.Y.1; our IP address is 10.X.Y.113
Filename 'pxelinux.0'.
Load address: 0x10800000
Loading: ####
1.2 MiB/s
done
Bytes transferred = 46909 (b73d hex)
CuBox-i U-Boot > tftpboot ${loadaddr} openbsd/bsd.rd.IMX.umg
Using FEC device
TFTP from server 10.X.Y.1; our IP address is 10.X.Y.113
Filename 'openbsd/bsd.rd.IMX.umg'.
Load address: 0x10800000
Loading: #################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
######################################################
1.4 MiB/s
done
Bytes transferred = 7461152 (71d920 hex)
CuBox-i U-Boot > bootm
## Booting kernel from Legacy Image at 10800000 ...
   Image Name:   boot
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    7461088 Bytes = 7.1 MiB
   Load Address: 10800000
   Entry Point:  10800000
   Verifying Checksum ... OK
   XIP Kernel Image ... OK

Starting kernel ...

undefined instruction
pc : [<10800008>]   lr : [<4ff723b9>]
sp : 4f770d70  ip : 0000001e fp : 00000000
r10: 00000000  r9 : 4f770f38 r8 : 4ff724e9
r7 : 00000000  r6 : 10800000 r5 : 4ffa1c6c  r4 : 00000000
r3 : 4f770fe0  r2 : 10000100 r1 : 000012d5  r0 : 4f770fe0
Flags: nZCv  IRQs off  FIQs off  Mode SVC_32
Resetting CPU ...

resetting ...

Brian Conway

Reply | Threaded
Open this post in threaded view
|

Re: Boot attempt: SolidRun CuBox-i2

Patrick Wildt-2
The i.MX version is definitely the wrong one.  You gotta try the SUNXI version.

\Patrick

> Am 23.12.2014 um 21:43 schrieb Brian Conway <[hidden email]>:
>
> Obviously not supported hardware, but wanted to throw this out in case
> it's of use to anyone. I picked up the mid-level CuBox-i2eX
> (dual-core, serial over USB,
> http://www.solid-run.com/products/cubox-i-mini-computer/cubox-i-specifications/)
> model and attempted to load the 12/14/2014 IMX snapshot (via tftp
> using SolidRun's Ignition image as the U-Boot source). Logs are below,
> let me know if there's any assistance I can in the future. Thanks.
>
> U-Boot SPL 2013.10-rc4 (Oct 27 2014 - 18:17:31)
> Boot Device: SD1
> spl: error reading image u-boot.img, err - -1
> Load image from RAW...
>
>
> U-Boot 2013.10-rc4 (Oct 27 2014 - 18:17:31)
>
> CPU:   Freescale i.MX6Q rev1.5 at 792 MHz
> Reset cause: WDOG
> Board: MX6-CuBox-i
> DRAM:  1 GiB
> MMC:   FSL_SDHC: 0
> *** Warning - bad CRC, using default environment
>
> In:    serial
> Out:   vga
> Err:   vga
> Net:   FEC [PRIME]
> (Re)start USB...
> USB0:   USB EHCI 1.00
> scanning bus 0 for devices... 1 USB Device(s) found
>       scanning usb for storage devices... 0 Storage Device(s) found
>       scanning usb for ethernet devices... 0 Ethernet Device(s) found
> Hit any key to stop autoboot:  0
> CuBox-i U-Boot > dhcp
> BOOTP broadcast 1
> DHCP client bound to address 10.X.Y.113
> Using FEC device
> TFTP from server 10.X.Y.1; our IP address is 10.X.Y.113
> Filename 'pxelinux.0'.
> Load address: 0x10800000
> Loading: ####
> 1.2 MiB/s
> done
> Bytes transferred = 46909 (b73d hex)
> CuBox-i U-Boot > tftpboot ${loadaddr} openbsd/bsd.rd.IMX.umg
> Using FEC device
> TFTP from server 10.X.Y.1; our IP address is 10.X.Y.113
> Filename 'openbsd/bsd.rd.IMX.umg'.
> Load address: 0x10800000
> Loading: #################################################################
> #################################################################
> #################################################################
> #################################################################
> #################################################################
> #################################################################
> #################################################################
> ######################################################
> 1.4 MiB/s
> done
> Bytes transferred = 7461152 (71d920 hex)
> CuBox-i U-Boot > bootm
> ## Booting kernel from Legacy Image at 10800000 ...
>   Image Name:   boot
>   Image Type:   ARM Linux Kernel Image (uncompressed)
>   Data Size:    7461088 Bytes = 7.1 MiB
>   Load Address: 10800000
>   Entry Point:  10800000
>   Verifying Checksum ... OK
>   XIP Kernel Image ... OK
>
> Starting kernel ...
>
> undefined instruction
> pc : [<10800008>]   lr : [<4ff723b9>]
> sp : 4f770d70  ip : 0000001e fp : 00000000
> r10: 00000000  r9 : 4f770f38 r8 : 4ff724e9
> r7 : 00000000  r6 : 10800000 r5 : 4ffa1c6c  r4 : 00000000
> r3 : 4f770fe0  r2 : 10000100 r1 : 000012d5  r0 : 4f770fe0
> Flags: nZCv  IRQs off  FIQs off  Mode SVC_32
> Resetting CPU ...
>
> resetting ...
>
> Brian Conway
>


Reply | Threaded
Open this post in threaded view
|

Re: Boot attempt: SolidRun CuBox-i2

Patrick Wildt-2
In reply to this post by Brian Conway
Whoops, I must be very very tired.  I worked a but on the CubieBoard
and misread it.

Yeah, it’s a Cubox, so it’s i.MX.  My fault. :(


> Am 23.12.2014 um 22:25 schrieb Brian Conway <[hidden email]>:
>
> Interesting, even though it's an i.MX6 SoC and not an Allwinner?
> Thanks for the tip, I'll give it a look.
>
> Brian Conway
> Founder, Owner
> RCE Software, LLC
>
>
> On Tue, Dec 23, 2014 at 3:22 PM, Patrick Wildt <[hidden email]> wrote:
>> The i.MX version is definitely the wrong one.  You gotta try the SUNXI version.
>>
>> \Patrick
>>
>>> Am 23.12.2014 um 21:43 schrieb Brian Conway <[hidden email]>:
>>>
>>> Obviously not supported hardware, but wanted to throw this out in case
>>> it's of use to anyone. I picked up the mid-level CuBox-i2eX
>>> (dual-core, serial over USB,
>>> http://www.solid-run.com/products/cubox-i-mini-computer/cubox-i-specifications/)
>>> model and attempted to load the 12/14/2014 IMX snapshot (via tftp
>>> using SolidRun's Ignition image as the U-Boot source). Logs are below,
>>> let me know if there's any assistance I can in the future. Thanks.
>>>
>>> U-Boot SPL 2013.10-rc4 (Oct 27 2014 - 18:17:31)
>>> Boot Device: SD1
>>> spl: error reading image u-boot.img, err - -1
>>> Load image from RAW...
>>>
>>>
>>> U-Boot 2013.10-rc4 (Oct 27 2014 - 18:17:31)
>>>
>>> CPU:   Freescale i.MX6Q rev1.5 at 792 MHz
>>> Reset cause: WDOG
>>> Board: MX6-CuBox-i
>>> DRAM:  1 GiB
>>> MMC:   FSL_SDHC: 0
>>> *** Warning - bad CRC, using default environment
>>>
>>> In:    serial
>>> Out:   vga
>>> Err:   vga
>>> Net:   FEC [PRIME]
>>> (Re)start USB...
>>> USB0:   USB EHCI 1.00
>>> scanning bus 0 for devices... 1 USB Device(s) found
>>>      scanning usb for storage devices... 0 Storage Device(s) found
>>>      scanning usb for ethernet devices... 0 Ethernet Device(s) found
>>> Hit any key to stop autoboot:  0
>>> CuBox-i U-Boot > dhcp
>>> BOOTP broadcast 1
>>> DHCP client bound to address 10.X.Y.113
>>> Using FEC device
>>> TFTP from server 10.X.Y.1; our IP address is 10.X.Y.113
>>> Filename 'pxelinux.0'.
>>> Load address: 0x10800000
>>> Loading: ####
>>> 1.2 MiB/s
>>> done
>>> Bytes transferred = 46909 (b73d hex)
>>> CuBox-i U-Boot > tftpboot ${loadaddr} openbsd/bsd.rd.IMX.umg
>>> Using FEC device
>>> TFTP from server 10.X.Y.1; our IP address is 10.X.Y.113
>>> Filename 'openbsd/bsd.rd.IMX.umg'.
>>> Load address: 0x10800000
>>> Loading: #################################################################
>>> #################################################################
>>> #################################################################
>>> #################################################################
>>> #################################################################
>>> #################################################################
>>> #################################################################
>>> ######################################################
>>> 1.4 MiB/s
>>> done
>>> Bytes transferred = 7461152 (71d920 hex)
>>> CuBox-i U-Boot > bootm
>>> ## Booting kernel from Legacy Image at 10800000 ...
>>>  Image Name:   boot
>>>  Image Type:   ARM Linux Kernel Image (uncompressed)
>>>  Data Size:    7461088 Bytes = 7.1 MiB
>>>  Load Address: 10800000
>>>  Entry Point:  10800000
>>>  Verifying Checksum ... OK
>>>  XIP Kernel Image ... OK
>>>
>>> Starting kernel ...
>>>
>>> undefined instruction
>>> pc : [<10800008>]   lr : [<4ff723b9>]
>>> sp : 4f770d70  ip : 0000001e fp : 00000000
>>> r10: 00000000  r9 : 4f770f38 r8 : 4ff724e9
>>> r7 : 00000000  r6 : 10800000 r5 : 4ffa1c6c  r4 : 00000000
>>> r3 : 4f770fe0  r2 : 10000100 r1 : 000012d5  r0 : 4f770fe0
>>> Flags: nZCv  IRQs off  FIQs off  Mode SVC_32
>>> Resetting CPU ...
>>>
>>> resetting ...
>>>
>>> Brian Conway
>>>
>>